• 0

    posted a message on XNet: an efficient and scalable networking mod

    what is the limit for copy/pasting? i have the newest version and tried to copy/paste channels and it told me "clipboard too large", which doesn't surprise me since i have 440 machines im trying to copy/paste settngs for. it takes at least 40 minutes of doing it all manually. just wondering what the max amount is and if it could be changed at all before i think of a workaround.

    Posted in: Minecraft Mods
  • 0

    posted a message on Bounding Box Outline Reloaded Mod for Minecraft

    I really like this mod, i use the forge version but i am having trouble getting it to work loading the dat files for my server. Is the correct folder path config/BBOutlineReloaded/ip/port ? I have my dat files in the port folder but it doesn't work. Using cache works fine but I'd prefer using the dat files themselves.


    Also when I put the mod on my personal server, it doesn't crash me or the server but I can't join and I get this error in the server console.


    [Server thread/ERROR] [FML]: Exception caught during firing event net.mine[email protected]46a656d9:
    java.lang.NullPointerException
    at com.irtimaled.bbor.forge.ForgeCommonProxy.sendToPlayer(ForgeCommonProxy.java:112) ~[ForgeCommonProxy.class:?]
    at com.irtimaled.bbor.forge.ForgeCommonProxy.playerLoggedInEvent(ForgeCommonProxy.java:80) ~[ForgeCommonProxy.class:?]


    Really good mod though, love using it for farms in vanilla.

    Posted in: Minecraft Mods
  • 0

    posted a message on Semi transparent and opaque textures

    Oh I see now, I misread it earlier. Thanks for the help. I'll try to figure it out when I can but in the mean time I'll stick with a separate class for the beams since I'm not ready to release it yet. I'll come back if I run into problems.

    Posted in: Modification Development
  • 0

    posted a message on Semi transparent and opaque textures

    All of that only goes in my TESR right?


    Do guis work differently for metadata blocks? I have the normal beacon onBlockActivated in my file and I just noticed it wasn't opening the gui.

    Posted in: Modification Development
  • 0

    posted a message on Semi transparent and opaque textures

    I have one beam class now, I only had so many because I wasn't sure how to do it differently. Turns out I forgot some of my registers in my proxies and main, the normal beam shows up on all blocks now.


    Can you explain a bit more on how to get the beam color?

    Posted in: Modification Development
  • 0

    posted a message on Semi transparent and opaque textures

    http://pastebin.com/gpd5H4pL


    This is my metadata block file. Before I converted my blocks to use metadata, all I had to do to get my beacon beam showing was just return new TileEntityColorBeam. It doesn't show up when I do that now. If I add TileEntityBeacon or just remove it all together, it shows a regular beam on all 16 blocks. What I want to accomplish is to have each different metadata block return its own beam color.

    Posted in: Modification Development
  • 0

    posted a message on Semi transparent and opaque textures

    Bumping this for a new question. Instead of having a block file for each block, I'm making them use metadata now since I want to neaten up my code. However, when I try to put my custom beam entity on the default block(white) to make sure it works, it doesn't show up. It only works when I use the regular beacon tile Is there a different method of getting multiple tile entities on a block with metadata?

    Posted in: Modification Development
  • 0

    posted a message on Semi transparent and opaque textures

    Thanks, I got it now. Everything is working the way I want it to.


    Except a crash when I load it onto my personal server which I'm looking into now. Edit: fixed myself.

    Posted in: Modification Development
  • 0

    posted a message on Semi transparent and opaque textures

    Ok, so after some trial and error, and admittedly some copy-pasting, I have a colored beam working. The only problem now is when I get real close and look up at the beam, it disappears. This happened before I even got to the colored beam stage. I've googled and isGlobalRenderer is set to true in my file that extends tesr.myentity. Am I missing anything else?

    Posted in: Modification Development
  • 0

    posted a message on Semi transparent and opaque textures

    I'll take a few more shots at it and if I still crash, I'll upload everything to Gist. I'm still in the learning process of modding so this seems a bit intimidating to get right.

    Posted in: Modification Development
  • 0

    posted a message on Semi transparent and opaque textures

    Thanks for the help. I've registered my new tileentity but I'm still getting the same crash. TileEntities seem too advanced for me at this stage,, nothing I do works. Are there any guides on them that work with 1.9? I don't know how much they changed with previous versions.

    Posted in: Modification Development
  • 0

    posted a message on Semi transparent and opaque textures

    I appear to be doing something right since I'm crashing instead of getting a white beam lol. I made a new entity class, imported that into my block class, attempted the change the color of the beam and when I use createNewTileEntity, the game crashes when I place the block. When I comment it out, it goes to the normal white beam, don't know if my new attempt changed the color. The crash says I'm missing a mapping. That's a registry error right? Is registering a tile entity different from a block or item?

    Posted in: Modification Development
  • 0

    posted a message on Semi transparent and opaque textures

    Thanks for the help, I don't have much experience using float yet, it's pretty confusing to me so I'll have to learn about them. In TileEntityBeacon under updateSegmentColors, I see it uses sheep dye to make it start white. I don't need a custom color, I'd be ok with just changing the color of the beam using EnumDyeColor.color. Would that be possible in my case or is the float array necessary?

    Posted in: Modification Development
  • 0

    posted a message on Semi transparent and opaque textures

    This is stumping me. I tried a few things and the beam always came back the default color. I don't want to be spoonfed but do you have any other pointers besides what you've told me?

    Posted in: Modification Development
  • 0

    posted a message on Semi transparent and opaque textures

    Thanks, I got a beam on my custom block. Do you, or anyone, know how to make the beam start off with a different color?

    Posted in: Modification Development
  • To post a comment, please or register a new account.