• 1

    posted a message on [Launcher] Magic Launcher 1.3.4 (mods, options, profiles, news)
    Minor bug: Since the website minecraft.net moved from http to https three days ago, the website keeps showing up offline with the little redstone status lamps.

    https://twitter.com/StatusMinecraft/status/393398680973504512
    Posted in: Minecraft Tools
  • 0

    posted a message on OptiFine HD (FPS Boost, Dynamic Lights, Shaders and much more)
    only <10% increase, guess my pc is too powerful. ~85fps @ 1600x1200 w/ everything enabled and Far distance. (Was ~80fps) When I fly far above dense woods, the increase becomes much more noticable.

    I can't work without this mod anymore. Switching texture packs without disconnecting and the extra options (especially zoom, hd textures and fog) are indispensable!
    Posted in: Minecraft Mods
  • 0

    posted a message on How to install WorldEdit on a Feed The Beast server?
    Feed the beast is really weird, but depending on which modpack, IT IS POSSIBLE!

    WorldEdit works with Bukkit, FTB works with Forge, the solution is BukkitForge.

    I tried it on three of their modpacks, and two worked.
    Direwolf20 - Medium
    MindCrack - Hard, because it is weird
    FTB Beta A - Failed, but I don't like this pack anyway because there's no RedPower2.

    Step by step:
    1. Put the jar file of BukkitForge (I used 1.4.7-30) into the %serverroot%\coremods folder.
    2. Make a folder %serverroot%\plugins and put there the jar files of Worldedit (I used 5.5) and bPermissions (I used 2.10.1)
    3. Start the server.

    For MindCrack, there are a few additional steps, because the server is weird:
    3.1 After starting, it will crash, so start it again.
    3.2 It will crash again, so start it a third time.
    3.3 If it crashes yet again (happens sometimes) start it some more times.
    (Because it is weird, every time you start, more files will be downloaded to the %serverroot%\lib folder, until there are 12 files. And did I mention it's weird?)
    End of MindCrack steps.

    4. Type /permissions examplefiles
    5. Go to folder %serverroot%\plugins\bPermissions
    6. Edit file groups.yml with WORDPAD! (more advanced editors might change spaces to tabs!)
    7. Add the following line to the file:

    8. Copy file groups.yml to the folder %serverroot%\plugins\bPermissions\0 (or whatever your world is called)
    9. Restart the server.
    Posted in: Server Support and Administration
  • 0

    posted a message on [Launcher] Magic Launcher 1.3.4 (mods, options, profiles, news)
    Is there an option to make the launcher window stay alive when you run Minecraft? Starting the launcher after each quit takes quite some time, compared to the original launcher. Usually I just use the "Test" button in the setup window because it does just that, but that only works fine for single player, not multiplayer.
    Posted in: Minecraft Tools
  • 0

    posted a message on Client starts lagging after about 10 minutes
    EDIT: I take this back. This only happens when the FPS is constantly low, and happens suddenly (and only when I have distance on Far or higher). On other times it is reasonably fast, but placing and destroying blocks makes the game freeze for a part of a second and no errors occur in the log.

    I just found out that Magic Launcher has a log window (found in setup), and when it gets slow it floods with OpenGL out of memory errors:

    ########## GL ERROR ##########
    @ Post render
    1285: Out of memory
    Posted in: Java Edition Support
  • 0

    posted a message on [1.4.x/13w07a] [16X] Cartoonism [V1.6.1]
    Voted 3/5. I made a slight change to it that made it instantly better imho. I added a 10% darker 1px border around the Stone, Sandstone-top and Clay textures which are otherwise completely uniform (skipped Snow on purpose). This way I can see and count individual blocks again.

    Edit: I forgot to change grass which is still uniform.

    Posted in: Resource Packs
  • 0

    posted a message on Client starts lagging after about 10 minutes
    Yep, all different kinds, new worlds, 1.8 worlds, 12w36a worlds, nothing matters, all the same.
    Posted in: Java Edition Support
  • 0

    posted a message on Client starts lagging after about 10 minutes
    I tried Optifine, and am amazed at the new features it brings. It doesn't make it faster one bit though even though they claim a 2x speedup isn't unusual.

    I did find out that simply changing texture packs when it its slow will make it smooth again.
    Posted in: Java Edition Support
  • 0

    posted a message on Client starts lagging after about 10 minutes
    I haven't played minecraft in 9 months due to circumstances and updated straight from beta 1.8 to 1.3.2.

    I noticed that when I start playing it is smooth (100+fps), but it gradually gets slower until it's about 10fps after 10 minutes and after 15 minutes it's completely unplayable because every placed/broken block makes the game freeze for a whole second and clicks will be registered twice, music+sound skipping furiously, etc. (I'm using the latest LWJGL). Making the screen small doesn't solve it as seen in this image:



    Whenever it gets slow, I see in the pie graph that the gamerenderer.level.updatechunks.rebuild is the most dominant (which is always highest even if smooth). Sometimes though, the most dominant is root.tick.level.entities.regular.tick.unspecified (like in an NPC village).

    Setting the view distance, quality and stuff lower makes it a little more playable but it still slows down to the point of unplayability.

    I also noticed that sometimes, placing a torch (while in a cave) makes the game a little faster temporarily, but it doesn't evade the fate of the session. I noticed that staying still makes it go faster, for example 20fps, but as soon as I start moving the mouse around it becomes slow again (and the C number "Number of chunks rendered over total number of chunks" will spike during movement but as soon as I stop the mouse the number becomes low again. This also happens just as much when it is still smooth so it's not the reason).

    I tried to do a search on which past version introduced this behavior, but it turned out all the way back to 1.8rc2 the behavior persists. Then I downloaded the beta 1.8 jar and it still persists. I was like wtf? I dug into my backups and replaced the entire .minecraft folder with an old 1.8 and tried that. Even that one starts getting slower after like 5-10 minutes, but every time just after it becomes borderline unplayable, it resets and becomes smooth again, just to repeat the same slowdown over and over. The only thing I can think of that changed is that I re-installed Windows XP in march (from the same CD as always). I don't have any problem in any other Java application (I'm a Java programmer) or other OpenGL game.

    Well, this turned out to be just a rant because I don't see a solution coming up soon.
    Posted in: Java Edition Support
  • 0

    posted a message on MCEdit: Minecraft World Editor (Now open source!)
    WTF since when does the edit function create a new reply? I'm not kidding, I pressed edit and I just changed one word. replying would imply that the original text would be inside quote tags right? Ignore this post or delete it.
    Posted in: Minecraft Tools
  • 0

    posted a message on MCEdit: Minecraft World Editor (Now open source!)
    How can I topple a region?

    I have a horizontal piston display and want to rotate around the X or Z axis to a vertical display.
    Posted in: Minecraft Tools
  • 0

    posted a message on Video Recording Program
    I'm also searching for a good application for recording video.

    I've tried Fraps, but regardless of the compression scheme, it drops like 90% of the frames, while only using 5% CPU. Why doesn't it just use a bit more CPU in favor of more frames?!?! (tried on two different PC's with different OSs)

    I've tried camstudio, but apart from that it records only at ~11fps, the videos come put pitch black or come out totally crappy (despite my 10000kbps setting).
    Posted in: Computer Science and Technology
  • 0

    posted a message on SMP Slime killing bug
    I didn't find any either, until I left and came back a minecraft day later.
    Posted in: Legacy Support
  • 0

    posted a message on SMP Slime killing bug
    In an SMP server, I found a slime-spawning chunk, built a slime-farm with three floor levels at y=4, 7 and 10. When I came back I found a few big slimes. I was on the top floor and they were on the middle. I immediately noticed they were jittering up and down, and even pushing me on the level above (known bug). I've had this happen with skeletons too. When I went to the middle level, hey were still jittering, and meanwhile cornering me so I could barely move.

    At this point, I tried to kill them, but I spent an entire iron sword, half an iron shovel and half an iron pickaxe on one of them and it still didn't die!

    Then I went to the bottom level, let them follow me, and there I could finally hit them. Just one blow of any iron weapon and they split up. Even hitting them from below while they were on the middle floor reached a hit. They were also hurting me this time.


    Forgive me if this isn't the right place to post, but I couldn't find a bug forum.
    Posted in: Legacy Support
  • 0

    posted a message on Change .minecraft Location
    Hmm, I looked in the source, and it isn't possible yet. It's hardcoded:
            case OS.windows:
                workingDirectory = new File(userHome, "." + applicationName + "/");
                break;
    Mojang, please implement it.

    Ideally, I'd like it to be a portable version.
    Posted in: Legacy Support
  • To post a comment, please or register a new account.