• 0

    posted a message on EvilCraft (Open Source) - v0.10.12

    Nope, I don't. You can find me on Discord and IRC though, do you think a standalone server would be beneficial?

    Posted in: WIP Mods
  • 0

    posted a message on EvilCraft (Open Source) - v0.10.12
    Quote from Unfamous»

    How do you gather blood from the undead tree?


    You can only do this using Forestry's squeezer
    Posted in: WIP Mods
  • 0

    posted a message on EvilCraft (Open Source) - v0.10.12

    Please report any issues you have here: https://github.com/CyclopsMC/EvilCraft

    Posted in: WIP Mods
  • 0

    posted a message on EvilCraft (Open Source) - v0.10.12
    Quote from FSMAcolyte»

    The purifier, how do I get it to work?


    full of blood, blook in, item in, nothing happens.


    Item in, no blook, nothing happens.


    Your item must be enchanted, just tested it, works fine for me.
    Posted in: WIP Mods
  • 0

    posted a message on EvilCraft (Open Source) - v0.10.12

    Ugh, that's unfortunate. Not likely I can convince the other players to go through the trouble of upgrading, given that a bunch of the mods haven't/won't be moving to 1.10.

    Ah well, guess I'm out of luck. Thanks for the clarification!

    Also, do these issues extend to the bound blood drop? I was having difficulty getting that to work as well.


    Yes, since the bound blood drop also uses fluids internally.

    I strongly encourage you to update to, because it's very likely that this won't be the only problem you'll encounter, and there's no one around anymore to fix them.
    Posted in: WIP Mods
  • 0

    posted a message on EvilCraft (Open Source) - v0.10.12
    Quote from undefined »

    That's the problem, 1.8.9 is not supported anymore.
    Between 1.8 and 1.10, some fluid changes were done, what caused fluid incompatibilities between mods.
    These have all been resolved now in 1.10(.2).

    So update your pack, everything will work better ;-)
    Posted in: WIP Mods
  • 0

    posted a message on EvilCraft (Open Source) - v0.10.12
    Quote from TomWolf»

    Since I'm not able to submit an issue on github for some reason I'll post it here instead:

    I'm stupid, didn't set a title....issue on github now.

    -------------------------------------------------------

    Werewolves not attacking.

    First noticed in a village with several werewolves every night and none attacked.

    Reproduced by using only:
    cyclops core 0.7.7
    EvilCraft 0.10.11
    Forge: different versions between 2053 and 2076

    To reproduce I spawned a werewolf in at night with an egg. Had gamemode 0 (survival) on when I spawned it in.

    Tested in different biomes and also by going to village and setting time to night. Doesn't help to attack the werewolf. Other mobs, including the poison one from EC works correctly.


    Thanks :-)
    Posted in: WIP Mods
  • 0

    posted a message on EvilCraft (Open Source) - v0.10.12
    Quote from TomWolf»

    Playing in 1.10.2 with evilcraft 0.10.11 and forge 12.18.1.2076

    I found a village and it had several werewolvians and they turn to werewolves every night but they don't attack me. Is this a feature or a bug? If it's a bug I'll report it properly.


    They should attack you, so that must be a bug :-)
    Posted in: WIP Mods
  • 0

    posted a message on EvilCraft (Open Source) - v0.10.12
    Quote from MentalMouse42»

    Thanks. BTW, I seem to have picked up Vengeance II on my diamond boots....


    While enchanting? Or by using the Blood Chest?
    That enchanment should not be able to occur when using the Enchantment Table... (If it does occur, you can report it as a bug ;-) )
    Posted in: WIP Mods
  • 1

    posted a message on EvilCraft (Open Source) - v0.10.12
    Quote from MentalMouse42»

    Is there a general way to get at the changelog for a given version?

    Yes, the changelogs are available in the description of each curseforge file, or on github: https://github.com/CyclopsMC/EvilCraft/tree/master-1.10/resources/changelog
    Posted in: WIP Mods
  • 0

    posted a message on EvilCraft (Open Source) - v0.10.12
    Quote from MentalMouse42»

    Come to think of it, where is the changelog? The download page only gives a few lines that don't seem to pertain, and I can't find it offhand on github.


    Here is the one for 0.10.9: https://minecraft.curseforge.com/projects/evilcraft/files/2325842
    Posted in: WIP Mods
  • 0

    posted a message on EvilCraft (Open Source) - v0.10.12
    Quote from MentalMouse42»

    Hmm. Since upgrading to 0.10.10, I'm not actually seeing Vengance spirits from the Pickaxe. This can't be intentional....


    Have a look at the (0.10.9) changelog. Vengeance Pickaxes crafted before that update will indeed not produce spirits anymore.
    Posted in: WIP Mods
  • 1

    posted a message on EvilCraft (Open Source) - v0.10.12
    Quote from Unsomniaque»

    Hello


    Parameter tests


    System Windows 10. The mouse control is standard (no specific function). The keyboard setting is standard (no specific function).
    Minecraft loader MultiMC 0.4.11
    Minecraft version 1.10.2

    Minecraft Controls
    - RIGHTCLICK = use item/place block
    - LSHIFT = sneak
    Minecraft Mods
    - Forge (2046 or 2073)
    - EvilCraft-1.10.2-0.10.8 or EvilCraft-1.10.2-0.10.8
    - CyclopsCore-1.9.4-0.7.5 or CyclopsCore-1.9.4-0.7.6


    Tests


    Forge 2046 + EvilCraft-1.10.2-0.10.8 + CyclopsCore-1.9.4-0.7.5 :
    a1)RIGHTCLICK or LSHIFT+RIGHTCLICK on the dark tank with hand = self-supply switch
    b1)RIGHTCLICK on the dark tank with empty bucket = take a liquid bucket
    c1)RIGHTCLICK on the dark tank with liquid bucket = give a liquid bucket
    d1)LSHIFT+RIGHTCLICK on the dark tank with empty bucket = take a liquid bucket
    e1)LSHIFT+RIGHTCLICK on the dark tank with liquid bucket = liquid on the ground

    Forge 2073 + EvilCraft-1.10.2-0.10.8 + CyclopsCore-1.9.4-0.7.5 :
    a2)RIGHTCLICK or LSHIFT+RIGHTCLICK on the dark tank with hand = self-supply switch
    b2)RIGHTCLICK on the dark tank with empty bucket = take a liquid bucket
    c2)RIGHTCLICK on the dark tank with liquid bucket = give a liquid bucket
    d2)LSHIFT+RIGHTCLICK on the dark tank with empty bucket = not working
    e2)LSHIFT+RIGHTCLICK on the dark tank with liquid bucket = liquid on the ground

    Please note the difference in operation between (d1 & d2)

    Forge 2046 + EvilCraft-1.10.2-0.10.10 + CyclopsCore-1.9.4-0.7.6 :
    a3)RIGHTCLICK or LSHIFT+RIGHTCLICK on the dark tank with hand = self-supply switch
    b3)RIGHTCLICK on the dark tank with empty bucket = self-supply switch
    c3)RIGHTCLICK on the dark tank with liquid bucket = give a liquid bucket
    d3)LSHIFT+RIGHTCLICK on the dark tank with empty bucket = take a liquid bucket
    e3)LSHIFT+RIGHTCLICK on the dark tank with liquid bucket = liquid on the ground

    Forge 2073 + EvilCraft-1.10.2-0.10.10 + CyclopsCore-1.9.4-0.7.6 :
    a4)RIGHTCLICK or LSHIFT+RIGHTCLICK on the dark tank with hand = self-supply switch
    b4)RIGHTCLICK on the dark tank with empty bucket = not working
    c4)RIGHTCLICK on the dark tank with liquid bucket = give a liquid bucket
    d4)LSHIFT+RIGHTCLICK on the dark tank with empty bucket = not working
    e4)LSHIFT+RIGHTCLICK on the dark tank with liquid bucket = liquid on the ground

    Please note the difference in operation between (b1;b2) and (b3 & b4)
    Please note the similarities in operation between (d1 & d2) and (d3 & d4)


    Conclusion


    friendly and good luck ;)


    Thanks for the detailed tests ;-)
    So it looks like something has changed in Forge between versions 2046 and 2073. The behaviour with 2046 is the intented one (I used 2049 to test).
    I'll look into it.
    (Follow up on the issue here: https://github.com/CyclopsMC/EvilCraft/issues/470)
    Posted in: WIP Mods
  • 0

    posted a message on EvilCraft (Open Source) - v0.10.12
    Quote from Unsomniaque»

    1) Since I installed the "1.10.2-0.10.10" I can not take the liquid in the tank with a bucket: it activates self-supply (shift or not does not change). I can always fill with a bucket but not empty. I tested only with evilcraft in several version of Forge of 2011 to 2073. I returned to "1.10.2-0.10.8" and everything works again as before.


    I just tested this myself, and everything seems to work just fine.
    Right-clicking with a filled bucket on a non-full tank will move that fluid to the tank (if the tank has at least 1000mB of free space).
    Shift+right-clicking with an empty bucket on a non-empty tank will move the fluid from the tank to the bucket (if the tank has at least 1000mB).

    I tested this with only EvilCraft and CyclopsCore installed.
    If you still encounter this problem, then it might be another mod breaking it. Try it with only EC and CC installed, and iteratively add mods to see when it breaks again, then you'll know what mod causes the issue.
    Posted in: WIP Mods
  • 0

    posted a message on EvilCraft (Open Source) - v0.10.12
    Quote from Unsomniaque»

    Hello

    Thank you for this mod!

    1) Since I installed the "1.10.2-0.10.10" I can not take the liquid in the tank with a bucket: it activates self-supply (shift or not does not change). I can always fill with a bucket but not empty. I tested only with evilcraft in several version of Forge of 2011 to 2073. I returned to "1.10.2-0.10.8" and everything works again as before.

    2) I have not managed to make the blood Tinker (2.3.3a and 2.4.0) fully compatible with evilcraft blood. Is there a trick?

    postscript: I do not speak English, this message is a google translation.


    1) Last time I checked, this worked fine, I'll look into it.

    2) You should be able to pump tinker's blood into any EC machine, if this is not possible, please let me know, because that would be a bug :). EC blood that is pumped into a TCon smeltery doesn't automatically transform into TCon blood though.
    Posted in: WIP Mods
  • To post a comment, please or register a new account.