• 0

    posted a message on Ars Magica v5.52.014 (Updated August 2) (1.5.2)
    Hmm. I think i found a bug but i'm not sure what to do in terms of posting it.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.5.1]ID Resolver (Finally updated!)
    Quote from walkerjonny

    I have the same error but it doesn't cause a crash anyway.
    So I'm ignoring it at the moment.
    Maybe ShaRose would fix it in one of his future updates.


    ah. thank you very much. So it was just a bug.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.5.1]ID Resolver (Finally updated!)
    hmmm... I need a little help with this. Every time I'm at the Minecraft home menu it says Sprite IDs Left: ERROR. It tells me how many Block and Item ids i have left. and when I went to the IDResolver text file in the .minecraft folder i found this


    java.lang.NoSuchFieldException: itemSpritesLeft
    at java.lang.Class.getDeclaredField(Class.java:1899)
    at mod_IDResolver.<clinit>(mod_IDResolver.java:22)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:525)
    at java.lang.Class.newInstance0(Class.java:372)
    at java.lang.Class.newInstance(Class.java:325)
    at cpw.mods.fml.common.modloader.ModLoaderModContainer.preInit(ModLoaderModContainer.java:107)
    at cpw.mods.fml.common.Loader.preModInit(Loader.java:235)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:593)
    at cpw.mods.fml.client.FMLClientHandler.onPreLoad(FMLClientHandler.java:193)
    at net.minecraft.client.Minecraft.a(Minecraft.java:383)
    at net.minecraft.client.Minecraft.run(Minecraft.java:735)
    at java.lang.Thread.run(Thread.java:722)

    I'm sorry, but i have tried installing it several times and it always shows up with the error in the sprite ids. i have ID Resolver update 1 RAW, Forge 3.3.3.152, GuiAPI 0.14.3 - 1.2.5, and ShaRose's Forge-4096 Fix.

    If someone can help i would be grateful.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.5.1]ID Resolver (Finally updated!)
    Quote from DaviePatriots

    Ok, I've been trying to get this mod to work, but it always ends up crashing after I select the "Save and Continue Loading" option after I select an empty ID slot, or it crashes after selecting "Automatically assign an ID to all from this mod".

    Before I post my crash reports...what do I need to install. I have Forge 3.1.2.90 and ModLoader (latest version for Minecraft 1.2.5). And what order should I install everything, in terms of before/after certain mods.

    Thanks for the help in advance :)


    isn't the recommended build 3.1.3.105?Also, I seem to be having problems... here is the error i keep on getting.


    --- BEGIN ERROR REPORT b55daaa6 --------
    Generated 5/24/12 6:30 PM

    Minecraft: Minecraft 1.2.5
    OS: Windows 7 (x86) version 6.1
    Java: 1.7.0_03, Oracle Corporation
    VM: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation
    LWJGL: 2.4.2
    OpenGL: AMD M880G with ATI Mobility Radeon HD 4250 version 3.3.10179 Compatibility Profile Context, ATI Technologies Inc.

    java.lang.RuntimeException: RedPowerCore: BlockID 140 occupied by ic2.common.BlockScaffold, autoAssign is disabled.
    at forge.MinecraftForge.killMinecraft(MinecraftForge.java:483)
    at eloraam.core.Config.getBlockID(Config.java:114)
    at RedPowerWorld.initialize(RedPowerWorld.java:479)
    at mod_RedPowerWorld.initialize(mod_RedPowerWorld.java:37)
    at mod_RedPowerMachine.initialize(mod_RedPowerMachine.java:57)
    at mod_RedPowerMachine.modsLoaded(mod_RedPowerMachine.java:25)
    at ModLoader.init(ModLoader.java:899)
    at ModLoader.addAllRenderers(ModLoader.java:189)
    at ahu.<init>(RenderManager.java:86)
    at ahu.<clinit>(RenderManager.java:14)
    at net.minecraft.client.Minecraft.a(Minecraft.java:394)
    at net.minecraft.client.Minecraft.run(Minecraft.java:732)
    at java.lang.Thread.run(Thread.java:722)
    --- END ERROR REPORT cfcdfbce ----------

    I've tried changing the block id manually to something else but i still get this error. Any help would be greatly appreciated.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.6.4]TerraFirmaCraft - Survival mode as it should've been.
    so you just restarted your computer? or minecraft?
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.6.4]TerraFirmaCraft - Survival mode as it should've been.
    hmm I don't know if this is a normal minecraft bug, but for some reason my sound won't work once I install TFC? Does anyone know the reason for this?
    Posted in: Minecraft Mods
  • 0

    posted a message on Mrsal511's Modding Tutorials (With Video)
    Nvm of couse you would have it. Well in there you should have the public int idDropped. where it says return you just put return blockID and that makes it return itself. so pretty much

    public int idDropped(int i, Random random, int j)
    {
    return blockID;
    }

    that should make it return the HellStone.
    Posted in: Tutorials
  • 0

    posted a message on Mrsal511's Modding Tutorials (With Video)
    Quote from Malikai2121

    How can I make my block drop itself? Like Gold ore does?

    java.lang.ExceptionInInitializerError
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at java.lang.Class.newInstance0(Unknown Source)
    at java.lang.Class.newInstance(Unknown Source)
    at net.minecraft.src.ModLoader.addMod(ModLoader.java:284)
    at net.minecraft.src.ModLoader.readFromClassPath(ModLoader.java:1290)
    at net.minecraft.src.ModLoader.init(ModLoader.java:846)
    at net.minecraft.src.ModLoader.addAllRenderers(ModLoader.java:154)
    at net.minecraft.src.RenderManager.<init>(RenderManager.java:85)
    at net.minecraft.src.RenderManager.<clinit>(RenderManager.java:12)
    at net.minecraft.client.Minecraft.startGame(Minecraft.java:423)
    at net.minecraft.client.Minecraft.run(Minecraft.java:784)
    at java.lang.Thread.run(Unknown Source)
    Caused by: java.lang.IllegalArgumentException: Slot 124 is already occupied by [email protected] when adding [email protected]
    at net.minecraft.src.Block.<init>(Block.java:273)
    at net.minecraft.src.Block.<init>(Block.java:308)
    at net.minecraft.src.BlockStone.<init>(BlockStone.java:9)
    at net.minecraft.src.BlockHellStone.<init>(BlockHellStone.java:9)
    at net.minecraft.src.mod_HellStone.<clinit>(mod_HellStone.java:12)
    ... 15 more

    By the way thats the error im getting when starting up. HellStone is my block name



    package net.minecraft.src;
    import java.util.Random;


    public class mod_HellStone extends BaseMod
    {

    public static final Block HellStone;

    static
    {
    HellStone = (new BlockHellStone(124, ModLoader.addOverride("/terrain.png", "/mods/HellStone.png"))).setHardness(3F).setResistance(4F).setStepSound(Block.soundMetalFootstep).setBlockName("HellStone Block");
    }

    public mod_HellStone()
    {



    }

    public void GenerateSurface(World world, Random rand, int chunkx, int chunkz)
    {
    //HellStone

    for (int l = 0; l<45; l++);
    {
    int i1 = chunkx +rand.nextInt(16);
    int j1 = rand.nextInt (64);
    int k1 = chunkz +rand.nextInt (16);

    (new WorldGenMinable(HellStone.blockID, 20)).generate(world, rand, i1 ,j1 ,k1 );

    }

    //end HellStone
    }


    public void load()
    {

    }


    public String getVersion()
    {
    return "HellStone 2.1.3";
    }

    }

    Theres my code for mod_HellStone.java

    Yo dude do you have a HellStone.class File?
    Posted in: Tutorials
  • 0

    posted a message on Mrsal511's Modding Tutorials (With Video)
    Quote from Stormister

    Thank you so much! Really appreciate it!

    You're welcome Now if only i could figure out my problem.
    Posted in: Tutorials
  • 0

    posted a message on Mrsal511's Modding Tutorials (With Video)
    Yo Stormister the part of your code right here.
    Quiver = (new ItemArmor(130, EnumArmorMaterial.CLOTH, 3, 1)).setIconIndex(ModLoader.addOverride("/gui/items.png", "/mods/Quiver.png")).setItemName("Quiver");
    }
    The 3 is whats causing your armor to look like diamond. just add your own texture to the armor folder (make sure you have both the Quiver_1 and Quiver_2 in there.) and then do the ModLoader.addArmor("Quiver") and replace the 3 with a 5.
    Posted in: Tutorials
  • 0

    posted a message on Mrsal511's Modding Tutorials (With Video)
    OK. I would really appreciate some help here because this error has been bothering me. Eclipse says there are no errors but when i try running it the error appears. Here it is. (Im making a practice mod that i will reference to when making a bigger mod.)

    java.lang.NullPointerException
    at net.minecraft.src.ModLoader.addName(ModLoader.java:341)
    at net.minecraft.src.ModLoader.addName(ModLoader.java:304)
    at net.minecraft.src.mod_Practice.<init>(mod_Practice.java:88)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at java.lang.Class.newInstance0(Unknown Source)
    at java.lang.Class.newInstance(Unknown Source)
    at net.minecraft.src.ModLoader.addMod(ModLoader.java:284)
    at net.minecraft.src.ModLoader.readFromClassPath(ModLoader.java:1290)
    at net.minecraft.src.ModLoader.init(ModLoader.java:846)
    at net.minecraft.src.ModLoader.addAllRenderers(ModLoader.java:154)
    at net.minecraft.src.RenderManager.<init>(RenderManager.java:85)
    at net.minecraft.src.RenderManager.<clinit>(RenderManager.java:12)
    at net.minecraft.client.Minecraft.startGame(Minecraft.java:423)
    at net.minecraft.client.Minecraft.run(Minecraft.java:784)
    at java.lang.Thread.run(Unknown Source)

    Thx for the help!
    Posted in: Tutorials
  • 0

    posted a message on Smart Moving
    Found out how to post screenshots so here is the pic.
    Posted in: Minecraft Mods
  • 0

    posted a message on CraftGuide v1.7.1.1
    Figured out how to post Screenshots via youtube. so here it is//i.imgur.com/UG0Zy.png" width="" height="" alt="" />[/URL]" width="" height="" alt="" />//i.imgur.com/UG0Zy.png" width="" height="" alt="" />[/URL]" width="" height="" alt="" />
    Posted in: Minecraft Mods
  • 0

    posted a message on Smart Moving
    I ran into a problem when using your mod with Uristqwerty's CraftGuide mod. Im not sure which mod is causing this problem so i'm posting this on both of your forum pages. The problem I ran into was that the Done button was covering another button that changes how I open the crafting guide of Uristqwerty's mod. Ill add a screenshot once I figure out how. I hope you guys are able to resolve this problem.
    Posted in: Minecraft Mods
  • 0

    posted a message on CraftGuide v1.7.1.1
    Uh I ran into a problem when I was using your mod with Divisor's Smart Moving mod. I was unable to change the button that opens the crafting guide because the Done button was in the way. I will also post this on Divisor's forum page, so one of you can fix this problem. I will also add a screenshot of it once I figure out how.
    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.