• 0

    posted a message on 1.18 Dungeons harder to find

    I am on windows10 so playing bedrock and I have yet to see a single dungeon below level 0 and I have mine a pretty large area at Y=-54 and explore a few massive caves.


    I found a few connected to mineshafts above level 0. I tried to used an xray ressource pack to look them up but it does not look through the new blocks so cant see anything below level 0.


    For some reason chunkbase does not report dungeon locations in 1.18 , so no luck this way.

    Posted in: Recent Updates and Snapshots
  • 0

    posted a message on How to spawn a loot chest in PE with a command block?

    Java : /setblock ~ ~1 ~ chest{LootTable:"chests/simple_dungeon"}

    PE : ?????

    Posted in: Discussion
  • 0

    posted a message on Since today all of my world backup wont save

    Ok the log wont paste on this site. I tried with a sample test and it gave me an url. The log has 50 000 + lines, its too big imo


    Here is the first part of it.


    https://paste.ubuntu.com/p/xHR3dZvns9/


    Wow ok, here is the log after I installed back the Dungeon Crawl mod:


    https://paste.ubuntu.com/p/TgwCPsJqV8/


    It looks like that mod breaks the world if its uninstalled....

    Posted in: Java Edition Support
  • 0

    posted a message on Since today all of my world backup wont save
    Quote from ConorGarland»

    Post the "latest.log" file using paste.ubuntu.com


    Not sure how this site works, after I do it either nothing happens or I get a Bad Gateway error.

    How am I suppose to link the log to the forums?

    Posted in: Java Edition Support
  • 0

    posted a message on Is there any tools to copy a structure on MCPE 1.16.1

    Beside the /clone command?

    Or to cut the structure and then just paste it with the destination coordinates.


    I would also like a tool to paste a .schem into the world.

    Posted in: MCPE: Mod / Tool Discussion
  • 0

    posted a message on Since today all of my world backup wont save

    Well the deletion of cluster did not work, the gave save changes on delete clusters but not on old clusters. Minecraft if such a piece of junk.

    Posted in: Java Edition Support
  • 0

    posted a message on Since today all of my world backup wont save

    I make the world in Java because of mods that help me like world edit and Dungeon crawl.

    After that I convert it to Bedrock.


    I was able to fix my world in java with MCASelector after deleting chunks until I found the ones causing the problem. Once the chunks were identified, I used I backup the world and only deleted those chunks. Worked and no conversion needed.

    Posted in: Java Edition Support
  • 0

    posted a message on Since today all of my world backup wont save

    I solved it by converting the world to bedrock with Mcc tools chest PE then converting it back to Java. Lost some things in the process but since I am doing this map in Java for bedrock its acceptable. When I am done I will play this map in bedrock anyway.


    At least now the optimize world ran correclty and didnt crash and the world can be saved again.


    imo Mojan needs to develop an utility tool to fix corrupted worlds.


    Update : after further inspection of the world, it looks like the corruption was caused by mod Dungeon Crawl. I am missing small parts of the structures generated by this mod.

    Posted in: Java Edition Support
  • 0

    posted a message on Since today all of my world backup wont save

    I have 4 backups of my world done one the last week.

    The world were modified with world edit but since today I cant save anything.

    I am loading the backups with forge 1.16.1 or vanilla 1.16.1 and nothing works, I change something and when I go back its not there anymore...

    I removed world edit 1.16.1 from the mod folder problem remains.

    Tried going into 1.16.2 vanilla and same problem.


    Tried creating a new world, it worked...

    Posted in: Java Edition Support
  • 0

    posted a message on Cannot interact with anything....

    The problem was cause by control settings. I have reset all 3 controls to default and it worked.


    So, in settings, I have reset to default the following:

    - Keyboard and Mouse

    - Controller

    - Touch


    after that, everything worked.

    Posted in: Minecraft (Bedrock) Support
  • 0

    posted a message on Cannot interact with anything....

    Create a new world and cannot interact with anything....


    Minecraft Windows 10, no textures, no skins, no mods.

    Posted in: Minecraft (Bedrock) Support
  • 0

    posted a message on Where's the Super Duper Graphics?

    Would like to see some news about it. I own an Xbox one X and I am not touching Minecraft until shaders are in.

    Posted in: Discussion
  • 0

    posted a message on How to make a function to add players auto join an empty team?

    Well it worked.


    To check if there is no player in a specific team: (this function will be called only if there are no players in team HouseAqua)

    function Herbapou:Teams/JoinHouseAqua unless @a[team=HouseAqua]

    In function Herbapou:Teams/JoinHouseAqua, assign the team HouseAqua if a player with no team is standing at the serverspawn:

    execute @e[type=armor_stand,name=ServerSpawn] ~ ~ ~ scoreboard teams join HouseAqua @a[r=1,team=]
    Posted in: Commands, Command Blocks and Functions
  • 0

    posted a message on How to make a function to add players auto join an empty team?

    Thanks, I will check it out tonight.


    To code testfor in a function you use IF. Example:

    function JoinTeamBlue if @a[team=TeamRed]


    I wonder if I can use unless instead of if

    function JoinTeamBlue unless @a[team=TeamBlue]


    If I understand this correctly, this <@a[team=TeamBlue]> is true if there is at least one player in TeamBlue?


    Execute commands are tricky because it resets the location of the command. Once you used it with an armor stand you cant use another until youre a done doing what you are doing at that armor stand, unless you are doing another execute on that armor stand.

    Posted in: Commands, Command Blocks and Functions
  • 0

    posted a message on How to make a function to add players auto join an empty team?

    Thanks, It should work.


    The only thing I am missing is to check for an empty team. I want to assign the player to the next available empty team.


    The logic would be this:


    Fonction AssignPlayersToEmptyTeam:

    If <TeamBlue is empty> then call function JoinTeamBlue

    If <TeamRed is empty> then call function JoinTeamRed


    In the JoinTeamBlue function, then I can code:

    execute @e[type=armor_stand,name=JoinTeam] ~ ~ ~ scoreboard teams join TeamBlue @a[r=1,team=]


    ....


    Function works pretty much like command blocks except for the way to call them.


    What I do is make a GameLoop function that I set up with the /gamerule gameLoopFunction <path:name>


    The GameLoop function is like a giant repeating command block where you can put multiple commands and call other functions.


    So far I trigger special actions using invisible armor stands. Example:

    • I have door<Teamcolor> armor stands to have players of a team go through an iron door and not let players of other teams access (team house, mines, ...)
    • I have a NaturalSpawn function that replace natural spawning mobs like zombies, skeleton, ... to custom mobs and custom loot.
    • I have an armor stands for the ServerSpawn that give bacic gear, food and a guide book.
    • I have multiple armor stands name SpawnPoint that do like the ServerSpawn and let players set there spawnpoint here if they stand on it.
    • I also use armor stands to define gamemode zones. For example, around a TeamRed armor stand, I set all players of that team to survival and all other players to adventure. Around the serverspawn, everyone is set to adventure, ...

    ...


    I am sure we could trigger an function with a button click for example but I havent got to this yet.

    Posted in: Commands, Command Blocks and Functions
  • To post a comment, please .