• 0

    posted a message on [Software][Plugin][Bukkit] Runecraft [use bukkit page for download]
    Quote from frederikdoktor »
    Hey i have a litle problem, when i try to put the Runcraft files in the Minecraft_server.exe ( Openede with winrar ) i says ( Minecraft_server.exe:The archive file is corrupt ) Why is that ??? please help


    You have to use the java files in order to modify them!
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software][Plugin][Bukkit] Runecraft [use bukkit page for download]
    Quote from Zeerix »
    Quote from bebblebrox »
    Nothing crashes with right clicking or "chicken casting spells", whatever those are. It crashes with no one on.

    Therefore I did not see this as a solution, I'm not sure why I would replace my truck tires when my TV went out.

    How do you know that no chicken tried casting a spell if you weren't on?

    java.lang.ClassCastException: be cannot be cast to ep

    no-animals=true!


    so that error is a chicken casting a spell?

    interesting....

    I think I'll try putting the Runecraft into the hMod also
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software][Plugin][Bukkit] Runecraft [use bukkit page for download]
    Quote from Club559 »


    Quote from DHowett »
    My merged jq (hmod125+runecraft) previously exhibited the same issue that hMod 125 unofficial beta did when right-clicking without an item selected.

    I've updated the aforementioned jq.class (here, same URL as before) to be on-par with hMod 125. It no longer causes crashes if you right-click with no item selected!

    Place it in Minecraft_Mod.jar, or higher (on your classpath) and revel in full compatibility with hMod tool-using plugins and Runecraft!
    This doesn't fix the "chickens casting spells" issue (the previous ClassCastException from q), however. Setting no-animals=true does! :Sheep:


    Read posts.


    Nothing crashes with right clicking or "chicken casting spells", whatever those are. It crashes with no one on.

    Therefore I did not see this as a solution, I'm not sure why I would replace my truck tires when my TV went out.
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software][Plugin][Bukkit] Runecraft [use bukkit page for download]
    Quote from bebblebrox »
    Quote from Zeerix »
    Just remove jq.class from hMod's .jar file. Tell me if any plugin doesn't work.


    It still doesn't work for me

    Runs for a bit and then crashes and won't stop crashing

    2010-11-16 12:31:50 [INFO] Done! For help, type "help" or "?"
    2010-11-16 12:31:50 [INFO] Antigrief : sucessfuly loaded
    java.lang.ClassCastException: be cannot be cast to ep
    at q.<init>(q.java:17)
    at gs.a(SourceFile:120)
    at gr.a(SourceFile:65)
    at net.minecraft.server.MinecraftServer.h(SourceFile:269)
    at net.minecraft.server.MinecraftServer.run(SourceFile:208)
    at bw.run(SourceFile:482)
    2010-11-16 12:31:51 [SEVERE] Unexpected exception
    java.lang.ClassCastException: be cannot be cast to ep
    at q.<init>(q.java:17)
    at gs.a(SourceFile:120)
    at gr.a(SourceFile:65)
    at net.minecraft.server.MinecraftServer.h(SourceFile:269)
    at net.minecraft.server.MinecraftServer.run(SourceFile:208)
    at bw.run(SourceFile:482)


    Only plugin I have is AntiGrief, but am running hMod and llamacraft integrated into the server .jar file


    Does anyone have a solution? We're going into 15 days without having a working Runecraft installation
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software][Plugin][Bukkit] Runecraft [use bukkit page for download]
    Quote from Zeerix »
    Quote from Tjalling »
    Quote from bebblebrox »
    Wait, what works now? It now works properly with hMod?

    Just remove jq.class from hMod's .jar file. Tell me if any plugin doesn't work.


    It still doesn't work for me

    Runs for a bit and then crashes and won't stop crashing

    2010-11-16 12:31:50 [INFO] Done! For help, type "help" or "?"
    2010-11-16 12:31:50 [INFO] Antigrief : sucessfuly loaded
    java.lang.ClassCastException: be cannot be cast to ep
    at q.<init>(q.java:17)
    at gs.a(SourceFile:120)
    at gr.a(SourceFile:65)
    at net.minecraft.server.MinecraftServer.h(SourceFile:269)
    at net.minecraft.server.MinecraftServer.run(SourceFile:208)
    at bw.run(SourceFile:482)
    2010-11-16 12:31:51 [SEVERE] Unexpected exception
    java.lang.ClassCastException: be cannot be cast to ep
    at q.<init>(q.java:17)
    at gs.a(SourceFile:120)
    at gr.a(SourceFile:65)
    at net.minecraft.server.MinecraftServer.h(SourceFile:269)
    at net.minecraft.server.MinecraftServer.run(SourceFile:208)
    at bw.run(SourceFile:482)


    Only plugin I have is AntiGrief, but am running hMod and llamacraft integrated into the server .jar file
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software][Plugin][Bukkit] Runecraft [use bukkit page for download]
    Wait, what works now? It now works properly with hMod?
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software][Plugin][Bukkit] Runecraft [use bukkit page for download]
    I can't get it to work no matter what I try

    Doesn't work stock, doesn't work with the class replacement

    ah well...have some stranded users

    lol
    Posted in: Minecraft Tools
  • 0

    posted a message on URGENT: Ubuntu server restore problems
    I did not, and after realizing that some form of open files was the only thing that could be happening, I went back to the 6am backup, because server logs showed no one was on from around 4:30am through 6am

    In that time, I reasoned, the server should have done it's own automatic write, as well as writing when everyone had logged out of the chunks they were in

    On the bright side, there is no on-going corruption detected by the server, as in it isn't spamming those messages about bad chunks and trying to relocate them. People will just have to repair, and I'll modify my .sh script to make the proper calls to screen and do a save-all, turn off save, etc.

    /shrug

    just want to get this fixed before survival is patched multiplayer, because people will flip their lids if it crashes then, lol
    Posted in: Server Support and Administration
  • 0

    posted a message on URGENT: Ubuntu server restore problems
    No one has seen anything like this?

    Has anyone else even tried a restore?
    Posted in: Server Support and Administration
  • 0

    posted a message on URGENT: Ubuntu server restore problems
    Finally got around to making sure backups were working properly on my Ubuntu server.

    Using 7z to compress the whole world folder, every hour.

    Server corrupted today, maxed out RAM and had to be kill stopped.

    On restart, world corruption was visible, chunks misplaced, etc

    No problem I have backups. Removed corrupt world directory, replaced with backup I had where people were on and everything was fine. Restart server, CORRPUPTION IS THERE! As in, it went BACK in time, and infected my backup! This cannot happen, it doesn't make sense.

    Ok, maybe the server only saves chunks when people leave the, I think. So I look back through my logs, 6am it would appear no one was on. I use THAT backup, and restart the server, and get the EXACT SAME CORRUPTION

    Can someone PLEASE clue me in here?

    I just had a smart idea and tried a drop_caches command, I'll see if that does anything. If not, this is defying computers as I know them.
    Posted in: Server Support and Administration
  • 0

    posted a message on Who is your host?
    Thought I'd do an update here

    We settled in over at 2host with a 2gb/4 burst VPS

    We have only had 1 interruption, and someone was launching a DDOS against the whole node

    Running the server on Ubuntu, keep VNC turned off unless I need to get in, and I rarely see RAM usage go above 1500

    ONLY complaint I have is their host OS doesn't seem to be able to allow the control panel to monitor RAM usage or bandwidth
    Posted in: Server Support and Administration
  • 0

    posted a message on Massive Mining lag after patch Llama, Runecraft
    No one was on when I woke up this morning so I decided to patch everything up

    Downloaded posted server .jar file.

    Latest llama, runecraft, and Hey0

    Hey0 was borked, crashed on people talking, so rolled back to last known workingwrapper server file and src directory

    So I have the latest server .jar with llama and runecraft dumped into it, and I'm running like 1.01 i think of Hey0's wrapper/launcher

    everything is dandy, runes work, llama appears to be working fine

    But there's some MASSIVE lag when mining, as in if you don't keep hitting the stone it's liable to re-appear. On my end, it appears to be one hit AFTER it should disappear, and if you don't hit it that one time you have to re-mine it from scratch just like you never started

    Server's not out of ram, and nothing else is lagging like we would see if there was something massive going on at the host node

    Ideas??
    Posted in: Server Support and Administration
  • 0

    posted a message on Who is your host?
    All right after a week straight of nothing but problems I'm going to have to suggest NO ONE go with Haze

    The node we were on kept having problems. They didn't offer to move us to another one until I demanded to know why they weren't simply switching us off the problem node to a working one while they figured out the problem.

    When they went to migrate us, I get an email at 9am on Saturday saying they were starting the migration, it would be quick, and I'd get an email when they were done.

    No email, no move, for NINE HOURS. I had the server down, figuring they were moving it "any time"

    The move the server, and forget to hook my console up so I can't do anything. They hook it up, works for a bit, this morning I again have no access to either the web management page nor console.

    Bad, bad form.
    Posted in: Server Support and Administration
  • 0

    posted a message on Who is your host?
    Holy crap how much is that going to cost?

    Fazed does NOT have that kind of following

    I think I have...30ish? people on the whitelist
    Posted in: Server Support and Administration
  • 0

    posted a message on Who is your host?
    That's interesting, because I've had nothing but problems with haze

    Nice price for the ram

    but my node is seriously unstable. 6ish crashes in under 2.5 days. And I mean total server crashes, with rollback and everything because no time to issue a save-all
    Posted in: Server Support and Administration
  • To post a comment, please or register a new account.