• 0

    posted a message on RFTools Control: advanced visual automation system (1.3.0)

    How am I supposed to format the tag argument of the NBT Equivalence opcode?


    Specifically, I am trying to compare the size of an Astral Sorcery crystal to a fully-grown sample. According to MineTweaker, the sample has the tag {astralsorcery: {crystalProperties: {collectiveCapability: 100, size: 900, fract: 0, purity: 100, sizeOverride: -1}}}, and the only bit I'm interested in is the size. In my test world, I have a sample crystal being read on top of the processor itself, and two different nodes, each with a chest on one side and a lamp on the other. In the first, I have an exact duplicate of the crystal; in the second, one which I've ground down a few times so that its size is reduced (specifically, the tooltip and MT both reflect a size of 856).


    I've tried putting in "{astralsorcery: {crystalProperties: {size:}}}" (with and without the spaces) and the program happily runs, so long as there is in fact a crystal in each chest to look at - but it evaluates as True (turning on the lamp) in all cases. ETA: also tried "{astralsorcery: {crystalProperties: {size" with exactly the same result. Also tried "astralsorcery[crystalProperties[size]]" in case it used array syntax. I have no idea at this point what it's even looking at.

    Posted in: Minecraft Mods
  • 1

    posted a message on [TC4+5 Addon] Automagy - Automation and Logistics (v2.0.3 - Thirsty Tanks for Thaumcraft 5)

    ...oh, there it is.


    False alarm, sorry. I just hadn't noticed the extra tabs waaaaay over on the far right of my screen.

    Posted in: WIP Mods
  • 0

    posted a message on [TC4+5 Addon] Automagy - Automation and Logistics (v2.0.3 - Thirsty Tanks for Thaumcraft 5)

    Uh, am I missing some ultra-important thing on 1.8.9? I don't currently have any access to the Automagy research - what do I need to scan or research to change that? It's not redstone, I tried that... as I did redstone torches, repeaters, and comparators (all of these things both as loose items and when placed), and the basic Automagy hourglass. I even tried the redstone inversion torch (and some leftover Order slivers from making it). I've researched the Arcane Ear and Redstone Relay from the core Artifice tab, as well, and made some progress in Golemancy.

    Posted in: WIP Mods
  • 0

    posted a message on Simple Condensers - Basic Condensers for EE3

    I can't use the condensers to make end stone. I have the transmutation researched and can pull it out of a tablet, but shift-click at a condenser puts it in the "stuff" section rather than the target slot, and even if manually put in the target slot, it doesn't work.


    In general they seem to be awfully finicky for me. Also nonfunctional are diamond blocks and the upper tiers of compressed cobblestone, despite having seen such cobblestone and even nether stars used in a Let's Play. Using minium condensers in all cases.


    Mod versions: EE3 0.3.507, LomLib 3.2.0, SC 1.2.0. This is in the FTB Horizons Daybreaker modpack.


    Ed: Never mind. Stung by an out-of-sync, apparently; works properly on reloading the world.

    Posted in: Minecraft Mods
  • 0

    posted a message on Compact Machines v1.21
    Is there a trick of some kind to the AE2 integration? I tried with a Large machine and it seemed to work - I could use an ME crafting terminal inside the cube and it linked to my main network. But I needed to move it before I actually installed anything serious (no nether stars yet), and now I can't get any AE2 connection to happen at all.

    Edit: Okay, as long as I'm connecting directly to the controller (no tunnels, don't know about quantum bridges) and I'm going in through a SIDE, I get a connection. The top doesn't seem to work at all. Don't know about the bottom.
    Posted in: WIP Mods
  • 0

    posted a message on [0.0.5d] Fluxed-Crystals - The Fixenning!
    I like what you're doing here, but the mod is in serious need of some user feedback. Using the version in the latest Material Energy ^4 pack (which I think is actually newer than the download here), first off, the farm managers won't auto-place powered soil when the buttons are pushed. That's a relatively minor thing in itself, but since they NEED that button to have been pushed to recognize the soil at all, it's a frustrating one - especially since the UI gives no information about why it's not growing things.



    Further, the machine UIs could really use information on what goes in what slot, and on the progress of any actions. It's sometimes hard to tell if a machine is not working, or just working slowly - a visual indicator that it's operating, ideally with a progress bar, would help this greatly.



    Finally, if it's going to accept item-transport connections, some clarity in what side does what would be immensely valuable.
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Derp. I looked for "ethereal", glanced over the other Thaumcraft-related options, missed that one. Apologies.

    Still having trouble navigating the Chromic Lexicon - it looks like I should be able to scroll to the right, as there's a sub-box inside the Constructs box which I can just see the edge of. But I'll keep trying to gather info fragments.

    I do rather wish the most expedient way to get the things wasn't putting a bed near a pylon and corpserunning repeatedly, but so it goes; I'll keep hunting for dungeon chests.
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    The changelog for Dye Trees mentions an option for generating Thaumcraft's ethereal bloom, but I'm not seeing it in ChromatiCraft's config. Would it be possible to put in a flag for that, maybe even an option for its density? As it is, what's normally a relatively rare and precious crafted thing in stock Thaumcraft is now ubiquitous if you happen to find a rainbow forest. As of recent versions, you don't even need shears to pick it up intact - it was made more expensive to compensate - so this seems potentially a trifle unbalancing.
    Posted in: Minecraft Mods
  • 0

    posted a message on Enhanced Portals 3
    Quote from sexydexydoo»

    Hey Shurhaian,

    The Redstone Interface outputs a signal to a surrounding block but does not output directly from itself. Not sure how your set up is but here are some screenshots to help you out.

    Awesome, that was exactly what I needed! Thank you so much, I'm getting a signal now!
    Posted in: Minecraft Mods
  • 0

    posted a message on Enhanced Portals 3
    I'm having issues with the Redstone Interface. I'm trying to use Output - Portal Created to trip a timer (well, an Automagy hourglass) so that the portal shuts down some time after it's created. The other interface, set to shut the portal off on pulse, works fine; I've got a button on the other side of it for manual shutoff. However, the Output interface is never outputting a signal.

    I've tried on Portal Created and Portal Active. I've tried with the hourglass right next to the interface, and I've tried with ProjectRed red alloy wire, Automagy redcrystal, and vanilla redstone, as intermediaries. Nothing.

    The portal uses a dialing device, and I've tried dialing both another portal in the overworld, and one in the Nether. I even tried creating the portal from the other end in case it was somehow triggering only on a remote dial-in. Nothing yields even a single unit of redstone signal.

    I'm on 3.0.7, but the changelog since doesn't seem to refer to the redstone interface that I can see. Getting the server to update would be nontrivial, unfortunately - it's running the latest Resonant Rise - but I can try pushing for it if this is a thing that's since been fixed.

    Am I missing some ultra-important thing about how the redstone interface works?
    Posted in: Minecraft Mods
  • 0

    posted a message on Applied Energistics 2 - Open Source
    Quote from Nicholai194»
    I just found a way to use an export bus with a crafting card and a chest with an import card to make automated crafting without tying up any of my molecular assembly chambers. What a neat mod this is!

    I honestly doubt this. The crafting card works by allowing the export bus to request a crafting job, not by doing the crafting itself.
    Posted in: Minecraft Mods
  • 0

    posted a message on AOBD 2 - Process all the ores!
    Yeah, on further work, I too am convinced that the sorter is the problem. SFM can shove things into the machines just fine. I found THAT out after noting that if I took e.g. a yellorium clump and put it into the crusher by hand, the sorter would wake up and send other yellorium clumps there... so long as it still had one in the machine when the part in question wound up in the input chest, the sorter would send it to join its brethren. But even if there were only vanilla-Mekanism ore bits in there - osmium and copper chunks, iron dust - it wouldn't work unless I moved the first one myself.

    Bizarre that it processed the iron and gold just fine, and MOST of the ores, before it gave up. And it's a shame, because those filters are conceptually delightful; much nicer than needing to encode every. single. metal by hand. (The biggest downside of a pack with Metallurgy...)

    I've brought it up in the Mekanism thread, at least. Hopefully it'll get seen there.

    Thanks for your response.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mekanism v9.4.0 - Industrial Turbines, Thermoelectric Boilers, Fusion Reactors!
    Well, drat. That's a nuisance.

    How about logistical sorters? My crafting chain got badly jammed up when the sorter just... refused to continue processing. I have AOBD installed, and it processed all ores just fine through the purification chamber... except yellorite. But except for the iron and gold, it wouldn't do any of the subsequent stages, unless I moved at least one of the clumps/dirty dusts/dusts into the appropriate machine by hand. And after an indeterminate length of time, it also processed the yellorite ore into clumps. Some of the metals stuck in the chain were ones that come with Mekanism (osmium, copper, and tin), and it refused to work even if I took out all the AOBD pieces. Is there some way to nudge them into working again? I really like the oredict flags, especially being able to put wildcards in, and that they can be moved elsewhere while retaining settings is also a plus (not looking forward to trying to move a SFM inventory manager after setting a whole bunch of different commands to move a whole bunch of different metals...).
    Posted in: Minecraft Mods
  • 0

    posted a message on Mekanism v9.4.0 - Industrial Turbines, Thermoelectric Boilers, Fusion Reactors!
    Is there a way to dump gas from a gas-burning generator? I was trying to hook up ethylene production, and inadvertently got oxygen in the conduits before managing to disconnect that side of the separator and set it to dump. Now I've got a generator that has gas in it, pretends to run, but produces no power and doesn't actually burn the gas - and it keeps that gas whether broken with pick or retrieved with a wrench.
    Posted in: Minecraft Mods
  • 0

    posted a message on AOBD 2 - Process all the ores!
    I'm having some trouble using this mod with a Mekanism processing chain (3x, so far). The machines seem to process AOBD materials just fine - but the logistical transporter doesn't seem to know that they do.

    I have an input chest with a logistical sorter on it, with an oredict filter set to send ore* to the purification chamber, clump* to the crusher, dustDirty* to the enrichment chamber, and dust* to the energized smelter. All machines send their output back to the input chest in between, so that if I want to dump anything into the chain that doesn't quite follow the standard process (e.g. silk-touched nether quartz ore), it doesn't gum things up. This works fine for vanilla metals, copper, and tin - the ones that Mekanism supports natively.

    However, AOBD materials don't seem to register quite right. IC2 uranium, Electric Age tungsten, and Metallurgy manganese all go to the purification chamber just fine - but their clumps then don't get sent to the crusher. If I move them there by hand, the crusher happily crushes them up, but then the dirty dusts don't move along on their own. Yellorite ore won't even go into the purification chamber unless I do it by hand (at which the machine processes it but the clumps, again, get stuck in the sorting chest).

    As far as I can tell, the oredict filters are fine - I see what looks like the AOBD clumps flashing by in the clump* filter preview, for instance (although since they don't have tooltips on that preview it's hard to be 100% sure).

    Edit to add: ...actually now I'm not sure. It cooooould just be the logistical sorter being glitchy, I just saw it move yellorite ore after refusing to do anything for minutes at a time.
    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.