• 0

    posted a message on TerraFirmaPunk: Render bug and game breaking bug: GL Error : 1283: Stack overflow
    Quote from tclproject»

    Try seeing if any other keybind is set to 'E', except for the original inventory.


    No, there are no conflicting keybinds.

    Posted in: Mods Discussion
  • 0

    posted a message on TerraFirmaPunk: Render bug and game breaking bug: GL Error : 1283: Stack overflow

    Here is an image showing how the inventory gets cut off.

    The inventory still exists, it just doesn't render.

    Posted in: Mods Discussion
  • 0

    posted a message on TerraFirmaPunk: Render bug and game breaking bug: GL Error : 1283: Stack overflow

    Hi. I am here to hopefully get help on a notoriously difficult bug to track down and fix. The bug is very strange. Randomly while exploring, sometimes you will get a rendering bug where a nearby mob is rendered upside-down and above your head. Sometimes this will interfere with your inventory and remove everything but your in-inventory crafting table. This issue happens across multiple different worlds as well. I only use the default amount of ram being 3228m. The console is also spammed like crazy with this:



    ########## GL ERROR ##########

    @ Post render

    1283: Stack overflow


    From what I have been able to dig up is this seems to only happen near naturally generated structures. I haven't been able to find any solutions so far.


    I am using the latest version of the TerraFirmaPunk modpack on curse and I have not added any extra mods such as Optifine. I have tried to remove BetterFoliage, SmartMoving, SmartRender, and PlayerAPI, however, removing these does not fix the bug.


    This issue happened on my old PC when I was using a light version of the modpack, but I have a much more powerful PC now. All of my drivers are up to date as well so that shouldn't be the problem.


    My PC specs are below:


    Intel(R) Core(TM) i3-9100F CPU @3.60GHz 3.60 GHz

    8.00 GB

    64-bit operating system, x64-based processor

    NVIDIA GeForce GTX 1650

    Windows 10 Home


    Anyway, I hope this post can spark discussion about this bug and help others who have this issue.

    Thanks for reading!

    Posted in: Mods Discussion
  • 0

    posted a message on Could someone help me with this impossible math problem? (Read description)
    Quote from Hexalobular»

    69 minus 19 = 50 but 19 to 69 is 51 since you're counting both ends.


    Suppose you wanted a fence that was 1 block long, it would only take up 1 block so both "ends" would be on the same block, lets say X=0, 0 minus 0 = 0 so that doesn't work, you need to add one to get the length.


    The X / Z coordinates are for one corner of the block, NW I think

    Say your fence goes from left to right and the coordinates point to the left edge of a block, the coordinates of the block the left end of the fence is standing on will point to the end of the fence but the coordinates of the block at the right end will point to the left edge of that block even though the fence continues to the right edge so you will be missing a block by just subtracting the coordinates.



    ...I actually see what you mean now... My friend had to show me what you meant. This whole thing really is just a big mind bender. Thanks all who helped me out! :)

    Posted in: Discussion
  • 0

    posted a message on Could someone help me with this impossible math problem? (Read description)
    Quote from Hexalobular»

    69 minus 19 = 50 but 19 to 69 is 51 since you're counting both ends.


    Suppose you wanted a fence that was 1 block long, it would only take up 1 block so both "ends" would be on the same block, lets say X=0, 0 minus 0 = 0 so that doesn't work, you need to add one to get the length.


    The X / Z coordinates are for one corner of the block, NW I think

    Say your fence goes from left to right and the coordinates point to the left edge of a block, the coordinates of the block the left end of the fence is standing on will point to the end of the fence but the coordinates of the block at the right end will point to the left edge of that block even though the fence continues to the right edge so you will be missing a block by just subtracting the coordinates.


    That math does not add up. What I am trying to say is that when I count the blocks that the fence are adjacent with I get 51, but when I use the coordinates to count, I get 50.
    Quote from ScotsMiser»

    This particular error is so common it even has names; one of which is a "Fence Post error" see https://en.wikipedia.org/wiki/Off-by-one_error#Fencepost_error


    Like I just said, I am not talking about fences. I am talking about how long they are. This has nothing to do with fences. Its the math that I get when counting the blocks. I counted the blocks adjacent to the fences, and it gives me 51, but when I use the coordinates to count, I get 50.

    Posted in: Discussion
  • 0

    posted a message on Could someone help me with this impossible math problem? (Read description)

    So recently, I have been playing on a server in 1.13. I made an area that I plan to put an iron farm and a mob farm in the center. When I made my walls (the fences), I used my X cords coordinates to measure how long one fence wall needed to be. When measuring from end to end with coordinates, the wall measured to be 50 blocks long as seen from the 1st and 2nd image. However, when measuring manually, the wall turns out to be 51 blocks long as seen from the 3rd image. What is troubling me is that these two methods of measuring things that should work, completely contradict each other.


    Could someone shed some light on this situation? (No, I do not need the center point calculated.)

    Posted in: Discussion
  • 0

    posted a message on I need help with this math issue.
    Quote from JoQsh»

    If I'm understanding you correctly, each craft costs 4 of item A, 16 of item B, and 16 of item C. Each craft gives 5-20 XP and you want to fill a 1250 XP bar.


    1250/5 = 250, so you will need a maximum of 250 crafts.

    1250/20 = 62.5, so you will need a minimum of 63 crafts.

    On average, you will need 157 crafts.


    For the maximum, 250 crafts, you would need 1000 of item A, 4000 of item B, and 4000 of item C.

    For the minimum, 63 crafts, you would need 252 of item A, 1008 of item B, and 1008 of item C.

    On average, you will need 628 of item A, 2512 of item B, and 2512 of item C.


    So you need 252-1000 of the one item and 1108-4000 of the other 2 items.


    Does that answer your question, or did I misunderstand something?


    Thank you! This answers my question flawlessly!
    Posted in: General Off Topic
  • 0

    posted a message on I need help with this math issue.

    So I've been playing a mmo, and I need to know how many of a certain item I need to make something.

    Each craft requires 4 of one item, and 16 of two items, and each craft increases a exp bar from about

    5 - 20 to a total of 1250. I need to know the minimum and maximum amount of these items I will need

    total to completely fill up the 0/1250 exp bar. Sorry if this is difficult to understand, Im never good at

    explaining things well, and for those who can help me, thank you.

    Posted in: General Off Topic
  • 1

    posted a message on Custom Map?

    Yes. WorldPainter is a very powerful and easy map creator tool. I use it a lot when I get creative, and since im lazy as hell, that's saying something. :P

    Posted in: Maps Discussion
  • 0

    posted a message on [THREAD CLOSED] Unexplained performance drop when loading minimum mods with forge. Can I fix this?
    Quote from Henrieta»

    So your PC is better than my old one.


    Just to go sure, you know how to allocate more RAM to minecraft?

    2GB should be.


    I never tried terrain control, however, assuming you'd like a more interesting world generation, try mc version 1.7.10, install forge on it, then realistic world generation (RWG) + Biomes o'Plenty.

    And important: add fastcraft to the mods!

    On the mc forum page of RWG it is explained how to make them work together.

    You won't need the BoP world type, but the RWG world type.

    These 2 together create a very wonderful terrain and I guess, with 2GB allocated, they should run well.


    Okay, thanks for the support. I might just not bother with mods in the future since my computer is "complicated".
    I do in fact know how to allocate ram to minecraft, as do I know how to run and manage servers. Biome Bundle
    can also be ran on a server with plugin managers such as Spigot or Bukkit. So if i really wanted to, I could buy a
    server hosting service and have Biome Bundle work as a plugin instead of a mod, allowing me to join the server
    without need of the mod itself. Anyway, i guess ill close this thread since i am no longer in need of support. So
    thanks again for all who helped! :D
    Posted in: Mods Discussion
  • 0

    posted a message on [THREAD CLOSED] Unexplained performance drop when loading minimum mods with forge. Can I fix this?
    Quote from Henrieta»

    how much ram does your pc have?

    If you have 4gb you can add 2gb to parameters, but only on a 64bit system.

    If your PC runs on 32bit java (and windows), you can only add up to 1gb.


    If you can't add ram at all, try using mc version 1.6.4, as it is before the update with the added world gen and should help.


    Also, which mods are you most interested in using?

    Just til few months ago I also had to deal with an old PC and a 32bit system, so maybe we can work out some alternatives.


    My pc actually has exactly 4 gigabytes of ram, and is a 64bit system. The only mod I planned on using in regards to this topic is TerrainControl with the Biome Bundle addon. (If you search biome bundle on youtube or google you should get a easy example of the mod)
    Also, i am seriously thinking on giving up trying to understand this freaking weird Pc. I can run Vanilla with maxed video settings on almost any server with 70fps-120fps, while before hand, i was giving estimates with mid-low settings. I don't even know what to think anymore.
    Posted in: Mods Discussion
  • 0

    posted a message on [THREAD CLOSED] Unexplained performance drop when loading minimum mods with forge. Can I fix this?
    Quote from Thyriel27»

    Have you set the JVM Parameters so Minecraft can use more RAM ?

    If yes, try OptiFine

    If that doesn't help too, what mods are you using ? There are some that have a huge impact on perfomance, especially those that add a lot of stuff to the generated world


    I currently don't have enough ram to add to my minecraft, although I have never noticed any increase of FPS when adding ram. I always use optifine, so that is out of the way, and the mod I was using was TerrainControl with Biome Bundle. That may be some of the cause, but since the Biome Bundle addon only uses vanilla blocks, I can probably run a pre-generated world from Biome Bundle in vanilla just fine.
    Posted in: Mods Discussion
  • 0

    posted a message on [THREAD CLOSED] Unexplained performance drop when loading minimum mods with forge. Can I fix this?
    Quote from majestyc2k1»

    You didn't state what version of MC your using.



    Quote from Henrieta»

    If available for your MC version, install fastcraft, this should help!


    All minecraft versions. Although I am focusing on 1.10.2, all versions I play have this issue.
    Posted in: Mods Discussion
  • 0

    posted a message on [THREAD CLOSED] Unexplained performance drop when loading minimum mods with forge. Can I fix this?

    For some reason, when ever I load just 1 or 2 mods, my FPS and performance drop drastically. However when I play on vanilla, It runs great with at least 70 FPS on minimum average. This only happens with Minecraft as well. With only a few mods, I get around 20-50 FPS that fluctuate quite a lot, but I can run games such as Blade and Soul, a highly intensive and graphic game surprisingly well considering my PC isn't built for gaming that intense.

    My question is this: Can I fix this bizarre performance issue? I need this resolved because I can't record gameplay with very low FPS.

    Thanks.

    EDIT: For those that need a specific minecraft version that I am getting this issue on, all minecraft versions give me this issue with forge installed.

    Posted in: Mods Discussion
  • To post a comment, please or register a new account.