• 0

    posted a message on Minecraft ModLoader 1.5.1 generateSurface Won't Work
    Howdy,

    I was having the same issue as you and have posted my fix here: http://www.minecraftforum.net/topic/1743743-151-ore-generation-code-with-modloader-help/page__st__20#entry21701819

    Hope it helps :)
    Posted in: Modification Development
  • 0

    posted a message on [1.0.0] The Node Pack

    does this mod still have the lasers featured in this video?



    Yup. They are in the Mechanics Pack
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.0.0] The Node Pack
    Quote from Glace1221

    I would like to download some of this stuff, but I feel they need a description so I'll know what I'm getting.

    I'll wait.



    They have descriptions now. They are very basic descriptions but I feel they cover the everything.
    If I can be bothered I might update the Node Pack Wiki which has everything from recipes to in depth descriptions on each block and item in this mod. That will take time though, so we shall see.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.0.0] The Node Pack
    Quote from Rothyn

    ok so i finally found the cause of the bug mentioned earlier apparently its the "Too many items" mod that was causing it, is there a way to work around it?


    I've been using too many items with my mod pack since I installed it and I haven't come across this problem. However I have the full pack installed.
    I do believe there is an error in the current version of the Mechanics Pack that causes it to rely on the Structures pack for rendering the teleporter node block. I have fixed it already, but just haven't released the fix yet.
    This is most likely what's causing your problem. As a temporary work around, if you install the node structures pack then it should be fine. I'll release the fix so that the mechanics pack works by itself soon.

    Alternatively, if you don't want the structures pack at all, then set the teleporter block id in the options file to -1 and that might fix it.

    Hope that helps :smile.gif:
    Quote from Polar_Roku

    I have an idea. This would be done mostly for smp, but could be implemented int survival mode. Could you make something thats like a telegraph node? You would right click it, then type in a message of about 64 characters, the it would be sent to the nearest node in a large number of blocks. For single player, there could be randomly generated telegraph towers in the map that would randomly send out telegraphs with various messages. What do you say? To difficult?


    Sounds interesting. I'm undecided if I'll look into this mod for SMP again, but if I do I'll definitely give it a go.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.0.0] The Node Pack
    Quote from Gamestar1313

    I just plonked the whole Structures pack in my jar.


    Awesome, nice work. you'll get the node structures too now, added bonus. :smile.gif:

    I've resolved the issue in my code base. It was a bit more wide spread than what I thought, I think you'll find teleporters don't work with gems (from the Magic pack) like they should. I've fixed it all up now and it'll be a part of the next release.
    Quote from BotheBull

    can you put in a jet pack? im sorry if there is one in already but i didnt read it because i skimmed through it ... i do that a lot :tongue.gif:


    Do you mean as an alternative to something like the chicken suit pack? Where as long as you have space held (and enough fuel) you are propelled upwards.
    It'd be possible, I'll think about it. :wink.gif:
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.0.0] The Node Pack
    Quote from Gamestar1313

    I opened Minecraft, after installing the Mechanics pack (after all of the prerequisites), and when I opened my inventory it went to the Saving Chunks screen and this came up:
    Mods loaded: 48
    ModLoader 1.0.0
    mod_Arrows 1.0.0
    mod_ModLoaderMp 1.0.0
    mod_Somnia v17 [1.0.0]
    mod_SinglePlayerCommands 2.1 for SPC 3.0.1
    mod_SmartMoving 5.10
    mod_NotEnoughItems 1.0.2
    mod_Node_PackLoader 3.0 for Minecraft 1.0.0
    mod_Node_Mechanics 3.0 for Minecraft 1.0.0
    mod_airship Airships V2.5.1 for 1.0.0
    mod_BuildCraftCore 2.2.7
    mod_BuildCraftBuilders 2.2.7
    mod_BuildCraftEnergy 2.2.7
    mod_BuildCraftFactory 2.2.7
    mod_BuildCraftTransport 2.2.7
    mod_zAdditionalPipes Rev31.4
    mod_LogisticsPipes 0.1.2 (for Minecraft 1.0.0, Buildcraft 2.2.8, Forge 1.2.2)
    mod_Console 1.1
    mod_CraftGuide 1.3.0
    mod_Clevercraft 1.4.2
    mod_crystalWing Minecraft 1.0.0
    mod_EE EEv5.7.3
    mod_IC2 v1.42
    mod_InvTweaks 1.34b (1.0.0)
    mod_ItemDescriptions 1.1
    mod_PigbearLaser Laser 1.1
    mod_MineFactory 1.0.0R1.4.0
    mod_MineFactoryCompat_Grass 1.0.0R1.4.0
    mod_WeaponMod 1.0.0 v8.1.0 Forge Edition
    mod_tome 1.0.0
    mod_Zeppelin 1.0.0.0.22
    mod_NetherOres 1.0.0R1.1.0
    mod_Railcraft 2.1.1
    mod_RecipeHelper r4
    mod_RedPowerArray 2.0pr4
    mod_RedPowerCore 2.0pr4
    mod_RedPowerLighting 2.0pr4
    mod_RedPowerLogic 2.0pr4
    mod_RedPowerMachine 2.0pr4
    mod_RedPowerWiring 2.0pr4
    mod_RedPowerWorld 2.0pr4
    mod_RedstoneRemote 1.0.0R1.1.0
    mod_startingInventory 1.0.0
    mod_HeroesGuild 1.2.1
    mod_ThaumCraft 1.0.2
    mod_treecapitator 1.0.0
    mod_WirelessRedstone 1.4
    mod_XieClient Xie's Mod SMP v0.2.1

    Minecraft has crashed!
    ----------------------

    Minecraft has stopped running because it encountered a problem.

    If you wish to report this, please copy this entire text and email it to [email protected]
    Please include a description of what you did when the error occured.



    --- BEGIN ERROR REPORT aa829aff --------
    Generated 27/12/11 04:15

    Minecraft: Minecraft 1.0.0
    OS: Windows 7 (x86) version 6.1
    Java: 1.6.0_24, Sun Microsystems Inc.
    VM: Java HotSpot(TM) Client VM (mixed mode), Sun Microsystems Inc.
    LWJGL: 2.4.2
    OpenGL: ATI Radeon HD 5570 version 4.1.10524 Compatibility Profile Context, ATI Technologies Inc.

    java.lang.NoClassDefFoundError: mod_Node_Structures
    at NodePack.Mechanics.Node_ItemTeleporter.a(Node_ItemTeleporter.java:23)
    at acy.h(Item.java:225)
    at codechicken.nei.NEIUtils.loadItems(NEIUtils.java:150)
    at codechicken.nei.NEIController.<init>(NEIController.java:30)
    at mg.tmiConstructor(GuiContainer.java:52)
    at mg.<init>(GuiContainer.java:46)
    at hw.<init>(SourceFile:20)
    at net.minecraft.client.Minecraft.k(SourceFile:1517)
    at net.minecraft.client.Minecraft.x(SourceFile:705)
    at net.minecraft.client.Minecraft.run(SourceFile:658)
    at java.lang.Thread.run(Unknown Source)
    Caused by: java.lang.ClassNotFoundException: mod_Node_Structures
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 11 more
    --- END ERROR REPORT 242ed19e ----------

    Why is the Structures pack necessary for Mechanics?

    EDIT: To clarify, it seems that a class file from the Structures pack not being there is causing Minecraft to not work, even though I Only installed Mechanics.


    The files are not corrupt. This is just a mistake on my end. I will fix it up as soon as I can.
    In the meantime if you can figure out what class is needed then extract just that file from the structures pack that will fix it.
    Sorry for the inconvenience.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.0.0] The Node Pack
    Quote from Typhonragewind

    I've done that and now everytime i try to open my inventory the game starts to endlessly save chunks and then crashes....sigh...i've got to find courage and do a fresh install....your mod is too awesome not to use.


    If the fresh install doesn't work let me know which pack you're using and what ids you've changed and ill look into it.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.0.0] The Node Pack
    Quote from razer

    and i was there every step of the way. :tongue.gif:
    thanks for the late present.

    No Worries mate. :biggrin.gif:

    Quote from Lfty

    How many IDs I want for this Modpack? :biggrin.gif:

    If you're going for the full pack it uses:
    26 block id's
    54 item id's

    However any blocks and items you don't want to load with the Node Pack you can just set the ID to -1 in the options file. This hasn't been fully tested, but works in theory. If you choose to do this and encounter problems, let me know.

    Quote from Typhonragewind

    Just so you know the item IDs (at least for the mechanic pack) are conflictiong with those of the Buildcraft mod (factory pack).

    I can post the full error log if you wish.


    @razer is right, the ID's used by the Node Pack are completely configurable. The options files used can be found in
    {start of path here}/.minecraft/mods/NodePack/

    Quote from Polar_Roku

    OM FRICKIN G! THANK YOU! I've been checking every single day since minecraft 1.0.0 has come out for this to update, and It finally has! YES! THANK YOU!

    No worries mate. :biggrin.gif:
    If you have any ideas for improvements just let me know. :smile.gif:
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.0.0] The Node Pack
    Hi everyone,

    After (about) 6 long months the Node Pack has finally been updated.
    If you find issues let me know and I'll fix them ASAP.

    A lot of work has gone into the update this time to ensure that next time it should be MUCH easier and MUCH quicker.

    Enjoy!

    ~ Node Reaver
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.0.0] The Node Pack
    Quote from Rothyn

    Do you think he'll update the laser bridge mod soon too... ive got the perfect base built for it but untill he release it all i can do is just sitt and twiddle my thumbs


    I reckon he'll update it really soon. I know he's updated pretty much everything except for the crystals, which he's working on now. (Yeah that's right I'm working on my mods on Christmas Eve.)

    Looks like I wont have all the mods tested by Christmas Day, however if I get a chance I will upload the ones that have been tested.

    If not then boxing day seems like a goer. :biggrin.gif:
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.0.0] The Node Pack
    Quote from razer

    care to enlighten us on what you plan for the next update. (not the port to 1.7 mind you unless that will be the update.)


    Umm.. the plan at the moment is that the next version will probably be only small. It will hopefully fix some of the bugs that have been reported and will also port the mods to 1.7_02. Which will be out as soon as I can get it out!

    I'm putting off building anything new in at the moment because I simply am too busy with Turret Tactix.
    Avcon is less than a month away and we'd really like to release the beta soon.

    But once the beta is out, or after avcon, whenever I get the most time. You can bet your bottom dollar that I'll be having a go at getting a lot of the content mentioned into the node pack. :biggrin.gif:
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.0.0] The Node Pack
    Quote from Dragon3d

    I'm having trouble getting Illumination Tube to load. When I couldn't get the whole pack to work I went back and tried installing individual mods. I have so far been able to load all but Illumination Tube. Below is the Minecraft crash report and Node Pack log from my test run of the Illumination Tube mod:

    code

    And from NodePack_log:

    code



    The problem seems to be occurring in: mod_IDList Beta 1.6.6.1
    It could be completely possible that the illumination tube and ID List are not compatible. And that could be because both illumination tube and illumination tube roof have the same block name. As in two block's, two block Id's one name. I'm not sure how much changing that name would stuff up now but I will change the roof illumination tube's block name to a different one for the next release and test it. If it works fine then next release should fix your bug.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.0.0] The Node Pack
    Quote from Taygon

    Oh good. Glad to help.

    Also, I don't know if it's been fixed recently or not, but when I was using it in 1.5_01, the Illumination Tube caused an instant game crash if it appeared in the game's Statistics. I haven't re-installed that part with 1.66 because of that bug.


    I just had a look at my stats in 1.6_6 then and the illumination tube was there. No crash or anything bad. So it should be all good.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.0.0] The Node Pack
    Quote from Tim1994

    Could I get some help modding my server with this? I've never modded a server before but I followed the instructions on the first page and the mod is on there but when I try to craft something it doesn't let me craft it and just stays in the crafting table (client-sided rather than server?). Do I need anything like bukkit? I'm just running it from the .jar.

    Thanks


    usually when it shows that you can craft something in the client but doesn't actually let you craft it it means that item isn't available on the server. The node server pack does not include the entire node pack, only certain bits. this could be the problem. Or maybe the server isn't installed correctly. Are you certain it's working. An easy way to check is to connect, it should say welcome to the node server or something like that. Or you could try typing /score which will show you your current score.

    Quote from NetherTrey

    Nice mods. Unfortunately I also use Industrialcraft and Buildcraft, and run an smp server, so theres a lot of issues with too many sprites and conflicts. The node server pack in particular is giving me problems. It works fine on its own but in conjunction with the other two mods it doesn't. I'm most interested in the laser bridge mod, which works with IC and BC fine in ssp on its own. On smp however i'm stuck. Is there a way to only implement parts of the node server pack?

    I've been playing around with it and found that if my installation order (in the server jar) is NodeServerPack-->ModloaderMP Server-->IC-->BC then everything seems to work, except for one interesting bug. Jumping on a bed crashes the server with this error:

    [WARNING] Failed to handle packet: java.lang.NullPointerException
    java.lang.NullPointerException
    at lm.c(SourceFile:466)
    at gx.a(SourceFile:217)
    at fk.a(SourceFile:126)
    at ji.b(SourceFile:279)
    at gx.a(SourceFile:69)
    at cs.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(Unknown Source)
    at net.minecraft.server.MinecraftServer.run(Unknown Source)
    at bo.run(SourceFile:422)

    Is the server mod compatible with ModloaderMP? What would be nice are seperate downloads for the mods server side, but you've done so much already i really hate to ask :smile.gif:


    I've come across this bed bug also. As well as a lot of other server related errors. I'm not sure why they are happening.
    To be honest I had no idea a multiplayer version of Mod Loader existed. Which is why I've just edited the default minecraft files. This means the node server mod is incompatible with almost any other server mod. Now that I know that multiplayer mod loader exists I will use it. You'll have to wait till next release for it though, sorry. Also when i actually get round to implementing more of the node pack as part of the server mod I will release it separately, the same way I have for the single player mods.

    Quote from Taygon

    Bug report:
    Crossbow bolts turn into normal arrows when recovered.

    This piece of the mod worked fine in 1.5_01, but I just updated to 1.66, and it doesn't work anymore.


    Thanks for that mate. It's noted and will be fixed for next release.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.0.0] The Node Pack
    Quote from RiderofDark

    Ahh, I see, I see. Got it working now, thanks. :smile.gif:

    Followup question: I noticed that redstone wires (or levers) have to be on the same plane as the top of the GravLift Control to switch direction, but Redstone Torches only have to be near; is it supposed to work like that?


    To be honest I'm not sure. I'm pretty sure I remember when I first wrote the code for the grav-lift just copy-pasting the red stone activation code for the dispenser. Having said that I have modified it a bit since then and that could be what is making it that way. If you think that it needs fixing/tweaking then let me know and I'll get onto it. :biggrin.gif:
    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.