• 0

    posted a message on Minecraft 1.8.9 crashes with Forge
    Quote from CJMinecraft01»

    After looking at your log file I have noticed that it says "exoticbirds:" which makes me think that there are mods. In your mods folder is there any mods? I recommend making a backup of your .minecraft folder and then deleting everything in there. Then try to reinstall minecraft and then forge


    After reading this, I deleted the whole .minecraft folder, made a new one and ran Minecraft. Then I installed Forge with the installer on the fresh copy of the game. Sadly same error. Thanks a bunch for the help though. I do appreciate the effort.
    Posted in: Modification Development
  • 0

    posted a message on Minecraft 1.8.9 crashes with Forge

    I've installed an older version of Java (8 Update 73) with no improvement. I also tried something I hadn't thought to try before. I tried running older installations of Minecraft Forge, which worked in the past. They don't work, instead of crashing to launcher like 1.8.9 has been, they don't even seem to try to boot up. I'm really at a loss with this issue so far.

    Posted in: Modification Development
  • 0

    posted a message on Minecraft 1.8.9 crashes with Forge

    BTW, I'm using:

    Windows 7 - 64 bit

    Java 8 Update 92


    I'm using a Toshiba Satellite laptop, ATI Mobility Radeon HD 4200 graphics card.

    In the System Variables my JAVA_HOME is set to C:\Program Files\Java\jre1.8.0_92


    I don't know if any of that is helpful for figuring it out.

    I read here: http://www.minemum.com/troubleshooting-forge

    To try using a different version of Java, but I'm hesitant to try that if it's just something simple that I'm overlooking having to do with the Forge install.


    Does anyone know why Minecraft works for me but Forge does not?

    Posted in: Modification Development
  • 0

    posted a message on Minecraft 1.8.9 crashes with Forge

    Yes, I'm making a mod.

    I made alot of progress with it for MC 1.8, then I've set it aside for awhile.

    Now I'm going to be working on it for MC 1.8.9, but I can't even get Forge to run.

    Posted in: Modification Development
  • 0

    posted a message on Minecraft 1.8.9 crashes with Forge

    I deleted most of the contents of my .minecraft folder and restarted the launcher to download the necessary game files in order to do a fresh install. After successfully starting the vanilla minecraft 1.8.9, I reinstalled Forge using the windows installer.


    I get a crash to the launcher, but it's not generating a logs/fml-{client/server}-latest.log file.(forge crash log)


    This is the error inside the minecraft launcher Game Output tab:

    Exception in thread "main" java.lang.UnsatisfiedLinkError: Could not load library. Reasons: [no jansi in java.library.path, C:\Users\Mythra\AppData\Local\Temp\jansi-64-1351080000637047122.dll: Access is denied]
    at org.fusesource.hawtjni.runtime.Library.doLoad(Library.java:182)
    at org.fusesource.hawtjni.runtime.Library.load(Library.java:140)
    at org.fusesource.jansi.internal.Kernel32.<clinit>(Kernel32.java:37)
    at org.fusesource.jansi.WindowsAnsiOutputStream.<clinit>(WindowsAnsiOutputStream.java:52)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at org.apache.logging.log4j.core.appender.ConsoleAppender.getOutputStream(ConsoleAppender.java:128)
    at org.apache.logging.log4j.core.appender.ConsoleAppender.getManager(ConsoleAppender.java:104)
    at org.apache.logging.log4j.core.appender.ConsoleAppender.createAppender(ConsoleAppender.java:99)
    at org.apache.logging.log4j.core.config.DefaultConfiguration.<init>(DefaultConfiguration.java:53)
    at org.apache.logging.log4j.core.LoggerContext.<init>(LoggerContext.java:63)
    at org.apache.logging.log4j.core.selector.ClassLoaderContextSelector.locateContext(ClassLoaderContextSelector.java:217)
    at org.apache.logging.log4j.core.selector.ClassLoaderContextSelector.getContext(ClassLoaderContextSelector.java:114)
    at org.apache.logging.log4j.core.selector.ClassLoaderContextSelector.getContext(ClassLoaderContextSelector.java:81)
    at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:83)
    at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:34)
    at org.apache.logging.log4j.LogManager.getLogger(LogManager.java:387)
    at net.minecraft.launchwrapper.LogWrapper.configureLogging(LogWrapper.java:14)
    at net.minecraft.launchwrapper.LogWrapper.log(LogWrapper.java:28)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:94)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release

    Launcher log Exception:

    java.io.FileNotFoundException: File 'C:\Users\Mythra\AppData\Roaming\.minecraft\assets\indexes\legacy.json' does not exist
    at org.apache.commons.io.FileUtils.openInputStream(FileUtils.java:299) ~[launcher.jar:1.6.61]
    at org.apache.commons.io.FileUtils.readFileToString(FileUtils.java:1711) ~[launcher.jar:1.6.61]
    at net.minecraft.launcher.Launcher.cleanupOrphanedAssets(Launcher.java:254) ~[launcher.jar:1.6.61]
    at net.minecraft.launcher.Launcher.performCleanups(Launcher.java:496) ~[launcher.jar:1.6.61]
    at net.minecraft.launcher.game.MinecraftGameRunner.launchGame(MinecraftGameRunner.java:231) ~[launcher.jar:1.6.61]
    at com.mojang.launcher.game.runner.AbstractGameRunner.onDownloadJobFinished(AbstractGameRunner.java:186) [launcher.jar:1.6.61]
    at com.mojang.launcher.updater.download.DownloadJob.popAndDownload(DownloadJob.java:122) [launcher.jar:1.6.61]
    at com.mojang.launcher.updater.download.DownloadJob.access$000(DownloadJob.java:12) [launcher.jar:1.6.61]
    at com.mojang.launcher.updater.download.DownloadJob$1.run(DownloadJob.java:86) [launcher.jar:1.6.61]
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.8.0_92]
    at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_92]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:1.8.0_92]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:1.8.0_92]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_92]

    I don't understand what I could be doing wrong with a fresh install of the game and only using the Forge installer after that (with no mods in coremods & mods folders).

    Posted in: Modification Development
  • 0

    posted a message on [16x] Qtpie's Cheerful Pack - 1.13a

    Version 1.9a - TOO MANY CHANGES. Seriously though, if you haven't checked it out before, it's a good time to do it. I might upload some pictures of what is new and different if I get around to it. :)

    Posted in: Resource Packs
  • 0

    posted a message on GotoLink updates: Formivore's options (2015/08/01)...

    I asked the developer of Steamcraft 2 somewhat recently, and this was his/her response:


    "This mod is not really related to the original Steamcraft except by name. It's a bit late to change the name of this mod now however.

    There are no current plans to 'upgrade' to 1.8. I might consider 1.9, we will see how things look when that gets going."


    Because of that, I think there is good reason to maintain the original Steamcraft mod.

    Posted in: Minecraft Mods
  • 0

    posted a message on GotoLink updates: Formivore's options (2015/08/01)...
    Quote from GotoLink»

    All the mods are in progress of being updated to 1.8.


    Thank you. :)
    Posted in: Minecraft Mods
  • 0

    posted a message on Setting up multiple versions of Minecraft Forge

    Thank you so much, both of you, for the help. :)

    +Rep

    Posted in: Modification Development
  • 0

    posted a message on Setting up multiple versions of Minecraft Forge

    I'm curious if it is possible to have multiple game versions of the game set up to use their own set of mods, without getting in and moving mods in and out of the "mods" folder. If I was to create a folder within the minecraft\versions\1.8-Forge11.14.1.1334 folder called "mods." Can the game find the mods that I have in that location so that when I use it they are functioning?

    If this doesn't work is there an alternative so that I wouldn't have to change mods in and out whenever I want to use a different version of the game.

    Posted in: Modification Development
  • 0

    posted a message on GotoLink updates: Formivore's options (2015/08/01)...

    Are you working on the update to 1.8 for SteamCraft? I've always been a fan of that mod.

    Posted in: Minecraft Mods
  • 0

    posted a message on Wallpaper

    Great mod, I really like what you did here. I can see this being useful in alot of adventure maps.

    Posted in: Minecraft Mods
  • 0

    posted a message on Setting "DECAYABLE" tag on custom leaves

    Wow, it seems so obvious now. I can only imagine how much easier this kind of thing will be after I've learned Java better. Thanks for walking me through this, Choonster. :)

    Posted in: Modification Development
  • 0

    posted a message on Setting "DECAYABLE" tag on custom leaves
    Quote from Choonster»

    This code should go wherever you need to grow a willow tree, e.g. where you register your willow trees to generate in the world or in your sapling class where you grow your willow tree.


    I've placed it in the CustomSapling class, where I grow my willow tree.



    the problem I have is that wherever I've tried to place the code it does one of two things. It either prevents my sapling from growing into a tree at all, or it doesn't change the decaying of the leaves. When placed here where I have it in the screenshot, it stops the sapling from becoming a tree. But that is the exact place in my sapling class where I grow the tree. Gist

    Posted in: Modification Development
  • 0

    posted a message on Setting "DECAYABLE" tag on custom leaves
    Quote from Choonster»

    Don't put those methods in your worldgen class.


    When instantiating your worldgen class, use the following code:


    IBlockState leavesState = MythAdventure.Myth_Leaves.getDefaultState().withProperty(CustomLeaves.VARIANT, CustomPlanks.EnumType.WILLOW).withProperty(BlockLeaves.DECAYABLE, false);
    int leavesMeta = MythAdventure.Myth_Leaves.getMetaFromState(leavesState);
    WorldGenWillowTree treeGen = new WorldGenWillowTree(MythAdventure.Myth_Log, MythAdventure.MythLeaves, CustomPlanks.EnumType.WILLOW.getMetadata(), leavesMeta);

    This is suitable for initial world gen, but for your sapling you'll want to use the other WorldGenWillowTree constructor to set doBlockNotify to true.


    I hate to be a pest, but I've tried inserting that code you so kindly provided in areas of the CommonProxy, Main (MythAdventure.class) and even WorldGenWillowTree.class. I had no problem setting doBlockNotify to true in my CustomSapling class, and I get trees to generate just fine. The problem is that I really don't understand where to put that bit of code. I'm not sure if you mean for me to use it after I create a class that I don't have yet dealing with world gen, or if I'm stupidly overlooking how to use it in the classes I already have.

    I had planned to get around to getting the trees to generate in the world eventually. I had just thought I could get them to generate looking the exact way I wanted to before that step.

    Posted in: Modification Development
  • To post a comment, please or register a new account.