• 0

    posted a message on [Help] 1.4.5: JavaVM WARNING: JAWT_GetAWT must be called after loading a JVM
    I don't know how to downgrade to java 6. I've looked everywhere, my only hope is to wait for java 7 support. Which'll take a while...
    Posted in: Modification Development
  • 0

    posted a message on [Help] 1.4.5: JavaVM WARNING: JAWT_GetAWT must be called after loading a JVM
    Quote from thesbros

    Do you have Java 7?


    Yeah, one of the most recent mac osx software updates forced java 7. So I do have it..
    Posted in: Modification Development
  • 0

    posted a message on [Help] 1.4.5: JavaVM WARNING: JAWT_GetAWT must be called after loading a JVM
    Ever since 1.4.4 came out this problem has occurred:



    27 achievements
    208 recipes
    Setting user: Player550, -
    Client asked for parameter: server
    LWJGL Version: 2.4.2
    JavaVM WARNING: JAWT_GetAWT must be called after loading a JVM
    org.lwjgl.LWJGLException: Could not get the JAWT interface
    at org.lwjgl.opengl.AWTSurfaceLock.lockAndInitHandle(Native Method)
    at org.lwjgl.opengl.AWTSurfaceLock.access$100(AWTSurfaceLock.java:49)
    at org.lwjgl.opengl.AWTSurfaceLock$1.run(AWTSurfaceLock.java:89)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.lwjgl.opengl.AWTSurfaceLock.privilegedLockAndInitHandle(AWTSurfaceLock.java:86)
    at org.lwjgl.opengl.AWTSurfaceLock.lockAndGetHandle(AWTSurfaceLock.java:64)
    at org.lwjgl.opengl.MacOSXCanvasPeerInfo.initHandle(MacOSXCanvasPeerInfo.java:53)
    at org.lwjgl.opengl.MacOSXDisplayPeerInfo.doLockAndInitHandle(MacOSXDisplayPeerInfo.java:56)
    at org.lwjgl.opengl.PeerInfo.lockAndGetHandle(PeerInfo.java:85)
    at org.lwjgl.opengl.MacOSXContextImplementation.create(MacOSXContextImplementation.java:47)
    at org.lwjgl.opengl.Context.<init>(Context.java:120)
    at org.lwjgl.opengl.Display.create(Display.java:858)
    at org.lwjgl.opengl.Display.create(Display.java:784)
    at net.minecraft.client.Minecraft.startGame(Minecraft.java:382)
    at net.minecraft.client.Minecraft.run(Minecraft.java:741)
    at java.lang.Thread.run(Thread.java:722)
    Pastebin available here: http://pastebin.com/ZJjCa5Lx

    Does anyone know how to fix this? I can't seem to find any other thread that has this problem.

    Thanks.
    Posted in: Modification Development
  • 0

    posted a message on [Help] 1.4.4 LWJGL Problems? JavaVM WARNING: JAWT_GetAWT must be called after loading a JVM
    Quote from Anglican

    Hm... If this is still problematic, try going into Applications/Utilities and running Java Preferences. You want to make sure 1.6 comes BEFORE 1.7


    Yeah, Mac OSX had some update where they did something with oracle and there is no longer a "Java Preferences" thing.
    Quote from lockNload147

    http://lwjgl.org/for...hp?topic=4326.0
    The problem seems to be Java 7 on Mac OS with LWJGL. So I would try using Java 6 instead just like Anglican said.


    Ok.
    Posted in: Modification Development
  • 0

    posted a message on [Help] 1.4.4 LWJGL Problems? JavaVM WARNING: JAWT_GetAWT must be called after loading a JVM
    Quote from Anglican

    I got this problem before, what you have to do is change your Eclipse JVM version from 1.7 to 1.6. To do that, go into preferences(Or the windows equivalent), select "Java" and then "Build Path" I think, then select 1.6


    I actually already did that, and I still get the same error.
    Posted in: Modification Development
  • 0

    posted a message on Set display location of text to screen?
    Height + 10 instead of Height - 10?
    Posted in: Modification Development
  • 0

    posted a message on [Help] 1.4.4 LWJGL Problems? JavaVM WARNING: JAWT_GetAWT must be called after loading a JVM
    Please take the time to read this and help me.

    I'm totally stumped on this problem. It just started to occur since 1.4.4.

    When I try to start up minecraft in eclipse I get this error in the console:



    JavaVM WARNING: JAWT_GetAWT must be called after loading a JVM
    org.lwjgl.LWJGLException: Could not get the JAWT interface
    at org.lwjgl.opengl.AWTSurfaceLock.lockAndInitHandle(Native Method)
    at org.lwjgl.opengl.AWTSurfaceLock.access$100(AWTSurfaceLock.java:49)
    at org.lwjgl.opengl.AWTSurfaceLock$1.run(AWTSurfaceLock.java:89)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.lwjgl.opengl.AWTSurfaceLock.privilegedLockAndInitHandle(AWTSurfaceLock.java:86)
    at org.lwjgl.opengl.AWTSurfaceLock.lockAndGetHandle(AWTSurfaceLock.java:64)
    at org.lwjgl.opengl.MacOSXCanvasPeerInfo.initHandle(MacOSXCanvasPeerInfo.java:53)
    at org.lwjgl.opengl.MacOSXDisplayPeerInfo.doLockAndInitHandle(MacOSXDisplayPeerInfo.java:56)
    at org.lwjgl.opengl.PeerInfo.lockAndGetHandle(PeerInfo.java:85)
    at org.lwjgl.opengl.MacOSXContextImplementation.create(MacOSXContextImplementation.java:47)
    at org.lwjgl.opengl.Context.<init>(Context.java:120)
    at org.lwjgl.opengl.Display.create(Display.java:858)
    at org.lwjgl.opengl.Display.create(Display.java:784)
    at net.minecraft.client.Minecraft.startGame(Minecraft.java:382)
    at net.minecraft.client.Minecraft.run(Minecraft.java:741)
    at java.lang.Thread.run(Thread.java:722)
    JavaVM WARNING: JAWT_GetAWT must be called after loading a JVM
    org.lwjgl.LWJGLException: Could not get the JAWT interface
    at org.lwjgl.opengl.AWTSurfaceLock.lockAndInitHandle(Native Method)
    at org.lwjgl.opengl.AWTSurfaceLock.access$100(AWTSurfaceLock.java:49)
    at org.lwjgl.opengl.AWTSurfaceLock$1.run(AWTSurfaceLock.java:89)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.lwjgl.opengl.AWTSurfaceLock.privilegedLockAndInitHandle(AWTSurfaceLock.java:86)
    at org.lwjgl.opengl.AWTSurfaceLock.lockAndGetHandle(AWTSurfaceLock.java:64)
    at org.lwjgl.opengl.MacOSXCanvasPeerInfo.initHandle(MacOSXCanvasPeerInfo.java:53)
    at org.lwjgl.opengl.MacOSXDisplayPeerInfo.doLockAndInitHandle(MacOSXDisplayPeerInfo.java:56)
    at org.lwjgl.opengl.PeerInfo.lockAndGetHandle(PeerInfo.java:85)
    at org.lwjgl.opengl.MacOSXContextImplementation.create(MacOSXContextImplementation.java:47)
    at org.lwjgl.opengl.Context.<init>(Context.java:120)
    at org.lwjgl.opengl.Display.create(Display.java:858)
    at org.lwjgl.opengl.Display.create(Display.java:784)
    at org.lwjgl.opengl.Display.create(Display.java:765)
    at net.minecraft.client.Minecraft.startGame(Minecraft.java:397)
    at net.minecraft.client.Minecraft.run(Minecraft.java:741)
    at java.lang.Thread.run(Thread.java:722)

    It's really pissing me off. I don't know how to fix this.

    Can someone please help me?
    Thanks so much. I want to update my mod(s) to 1.4.4 but I cannot due to this crazy error.
    Posted in: Modification Development
  • 0

    posted a message on [Help] This just started happening because of 1.4.4 (Eclipse Error)
    I did. It's in the "jars" folder.
    Inside the bin folder is the lwjgl.jar
    I copied over "resources" too.

    Even in the referenced libraries in eclipse it shows lwjgl.jar
    (Along with lwjgl_util.jar, and the other ones)

    I don't believe the problem has to do with that.
    Unless it relates to the problem of "Build path specifies execution environment JavaSE-1.6. There are no JREs installed in the workspace that are strictly compatible with this environment."
    Posted in: Modification Development
  • 0

    posted a message on [Help] This just started happening because of 1.4.4 (Eclipse Error)
    I could mod completely fine with eclipse back in 1.4.2 and earlier versions. But when I got the new version of mcp, installed and decompiled, (It all worked out fine - no errors or anything) when I go into eclipse, I get this warning for both the client and the server projects:

    Build path specifies execution environment JavaSE-1.6. There are no JREs installed in the workspace that are strictly compatible with this environment.


    I have Java 1.6
    I don't understand what's wrong here.


    Can anyone please help me?
    I have no edited any code at all. Even if I did, it wouldn't do anything, because when I start up minecraft in eclipse I get this error in the console:

    Exception in thread "main" java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1860)
    at java.lang.Runtime.loadLibrary0(Runtime.java:845)
    at java.lang.System.loadLibrary(System.java:1084)
    at org.lwjgl.Sys$1.run(Sys.java:72)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.lwjgl.Sys.doLoadLibrary(Sys.java:65)
    at org.lwjgl.Sys.loadLibrary(Sys.java:81)
    at org.lwjgl.Sys.<clinit>(Sys.java:98)
    at net.minecraft.client.Minecraft.getSystemTime(Minecraft.java:2583)
    at net.minecraft.client.Minecraft.main(Minecraft.java:2189)
    at Start.main(Start.java:22)

    I notice that the first line of that is "no lwjgl in java.library.path"
    Uh, there is.

    Sorry if I screwed anything up, I have just never encountered this weird problem before and I can't do any modding until it's fixed.

    Please help
    -Thanks.
    Posted in: Modification Development
  • 0

    posted a message on [Help, 1.3.2] GL ERROR @ Post render 1280: Invalid enum
    I fixed it.

    So can a mod or admin please close the thread.

    Thanks :)
    Posted in: Modification Development
  • 0

    posted a message on [Help, 1.3.2] GL ERROR @ Post render 1280: Invalid enum
    Minecraft v1.3.2.
    The file I've edited to most is GuiIngame.
    I've changed a bunch of code and I'm playing around with GUI.
    I'm not having this issue with an unedited version, I've edited it quite a lot.
    I don't go around random classes changing things, the main class I've been playing around in is GuiIngame.

    If you need more info tell me.
    Thanks for your effort so far.
    Posted in: Modification Development
  • 0

    posted a message on [Help, 1.3.2] GL ERROR @ Post render 1280: Invalid enum
    The problem is I don't know the code that's causing this problem. I don't know how/when this occurred.

    The only thing I can think of is that OpenGL's depth mask feature is causing me to see the clouds through blocks when I mouse over one.
    Posted in: Modification Development
  • 0

    posted a message on [Help, 1.3.2] GL ERROR @ Post render 1280: Invalid enum
    C'mon, someone. Please help me here.
    Posted in: Modification Development
  • To post a comment, please or register a new account.