• 0

    posted a message on [SOLVED] Biome specific ore generation

    Can you mark your Topic as [SOLVED] so other users who have the same issue can see what worked for you?

    Posted in: Modification Development
  • 0

    posted a message on Minecraft modded item texture and name issues

    What version are you programming in?


    Have you checked:


    1. if you have a autist_block.png in your assets/yourmodid/textures/blocks? (not block)

    2. if your model references your texture file in assets/yourmodid/models/block? (not blocks)

    3. if you registered your block in your block class?

    4. if your block class is registered in your main mod file?

    Posted in: Modification Development
  • 0

    posted a message on (1.7.10) Is there a way to change the texture of modded items?

    As far as I know, there is not. Not with out the original creators permission.

    Posted in: Modification Development
  • 0

    posted a message on Minecraft Modding Forge textures

    JSON files look correct.


    I don't understand why your registering your block items the way you are. I do it a bit differently.



    public static final RegistryObject<BlockItem> SILVER_BLOCK = ITEMS.register("silver_block",
    			() -> new BlockItem(ModBlocks.SILVER_BLOCK.get(),
    					new Item.Properties().group(ItemGroup.BUILDING_BLOCKS)));


    Posted in: Modification Development
  • 0

    posted a message on Minecraft Modding Forge textures

    Have you made the appropriate JSON files?

    Posted in: Modification Development
  • 0

    posted a message on Minecraft Modding Forge textures

    Can you provide what version of Minecraft you are modding in and, using spoilers and code block, your Block Class? Providing these will help the rest of us to understand your problem.

    Posted in: Modification Development
  • 0

    posted a message on Help

    In your Tile Entity class for interactive items, such as crafting tables/ chests/ furnaces, there is a readFromNBT/ writeToNBT method that remembers when items are put in, and taken out.

    Posted in: Modification Development
  • 0

    posted a message on Help

    Sounds like you forgot your read/ write NBT methods in your TileEntity* class.


    * Updated due to wrong class containing read/ write NBT.

    Posted in: Modification Development
  • 0

    posted a message on Help With Creative Menu

    Not that I'm aware of. Most mod items appear at the bottom of the page they're assigned to.

    Posted in: Modification Development
  • 0

    posted a message on The constructor ArmorItem(ItemTier, EquipmentSlotType, Item.Properties) is undefined

    I think what is going on is, MC is using the default ArmorItem, and not your custom ArmorItem. Maybe change ArmorItem in your ItemInit to something more custom to your mod, even if it's IncognitoArmorItem. Don't forget to create a class that defines your custom ArmorItem in your objects directory, extending ArmorItem.


    Just a guess, hope it helps. It's what I did with my mod.

    Posted in: Modification Development
  • 0

    posted a message on Help with Biome generation!

    Have you looked at the biome classes in minecraft to see what is different from your biome class?


    You should define the type of biome (hieght, rainfall, etc) in your Biome initialization class (in your case BiomeList). Then in your Biome class, customize it with formation, features, entities, etc.


    For example:



    public static final RegistryObject<Biome> CatIslandBiome = BIOMES.register("cat_island", () -> 
    		new CatIslandBiome(new Biome.Builder().precipitation(RainType.RAIN).scale(0.05F).temperature(0.8F).waterColor(4159204).waterFogColor(329011)
    				.surfaceBuilder(SurfaceBuilder.DEFAULT, 
    						new SurfaceBuilderConfig(Blocks.GRASS_BLOCK.getDefaultState(), 
    								
    				.category(Category.PLAINS)
    				.downfall(0.3F)
    				.depth(0.125F)
    				.parent(null)));





    Then in your Cat Island Biome Class


    public CatIslandBiome(Builder biomeBuilder)
    {
     super(biomeBuilder);
    
     //add stuff here. Features, ores, carvers, enitites, etc.
    }

    Dont forget to Register your BiomeList in your main mod class


    //In your main method
    
    BiomeList.BIOMES.register(modEventBus);
    
    //Just before setup method
    
    @SubscribeEvent
        public static void onRegisterBiomes(final RegistryEvent.Register<Biome> event)
        {
        	BiomeList.registerBiomes();
        	
        }


    Posted in: Modification Development
  • 0

    posted a message on Does anybody know how to port mods?
    Quote from theonebeing118»

    So basically, Forge underwent a large rewrite after 1.12.2, causing most mods to stick to that version. I was wondering if anybody could give me a simple, straight to the point, short, not complicated tutorial on how to port mods for 1.12.2 and older to the latest version? This is going into a personal, private, passion project I’ve been wanting to do for a very long time, so if anybody could do that for me that would be great!


    Like you just said, Forge did a complete rewrite of their source code. You will have to adapt as well. I've been making mods since 1.7.2, and have adapted to all the current versions.

    Posted in: Modification Development
  • 0

    posted a message on [1.7.10] Custom armor not rendering

    In your AmethystArmour Class, the super uses 3 arguments (material, id, slot). When you registered your pieces, there is no ID for them to use as, they are all set to 0.


    Do the item icons for your Armour render? I imagine the armour is not rendering when put on, yes?

    Posted in: Modification Development
  • 0

    posted a message on Need help to make layers of blocks to a Geology Mod (Geoimmersion 1.15.2)

    You could effectively determine which block will be your top few blocks in SurfaceBuilderConfig in your SurfaceBuilder method, in a custom Biome class. After that, you could specify at which depths, and how frequent, other blocks spawn in an custom OreGen class.

    Posted in: Modification Development
  • 0

    posted a message on help me pls i don't understand!

    This line:



    private void doClientStuff (final InterModEnqueueEvent event)



    Should actually be:


    private void doClientStuff (final FMLClientSetupEvent event)



    Start with that.

    Posted in: Modification Development
  • To post a comment, please .