• 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from AnrDaemon»

    For modpack creators, this IS a problem.


    How would it be aproblem?
    As a pack creator it's your job to know your way around the mods you're using - dependencies are pretty trivial compared to techtrees and crafting/progress paths...
    Also curse is a pretty unreliable source for dependency/compatability/version related info if you don't double-check all of the file details in my experience.
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from TimDual»

    I'm pretty sure I posted it here too after somebody told me to, but maybe I didn't. And do you know how to fix the problem?


    Not really - as I said the problem doesn't occur on my instances and is caused either by a faulty ASM modification to EntityLivingBase or someone setting the activePotionMap to null using reflection...
    (Possibly/Most likely a case of two mods messing too much with the same system)
    Try finding the mod(s) responsible with binary search and start with GoG3 and Aether2 - both of them are known to cause various issues...
    Once you know the minimum setup required to reproduce the crash report back as it should be traceable then.
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from TimDual»

    oops, thaumic exploration, not thaumic horizons. and i posted a crash report here sometime ago but he never replied to it.


    Assuming you refer to this (which you didn't post, but referenced [pointing to the wrong thread btw] here), it looks like a reflection/asm conflict related crash. Funny thing about it is: I'm running all mods you mentioned in your minmal setup without a hitch...
    Posted in: Minecraft Mods
  • 1

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from TimDual»

    Reika, can you please fix the issue that arises when thaumic tinkerer, thaumic horizons, and one of your mods are installed at the same time?



    You'll need to specify what issue would need a fix first.

    So you'd be required to provide information like a crash report...


    (Judging from the mods you named you might also want to check if the 'issue' you have is an ID conflict... there are configs... ; Also: Thaumic Horizons is kinda dead and was left in quite a buggy state - you'll find it has many bugs and none of them is likely to ever get fixed)
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    Thaumic Infusions is known to be incompatible with most mods that apply ASM changes to the Block class - it also has been declared both incomplete and unsupported for 1.7 by its' developer. (see https://github.com/ReikaKalseki/Reika_Mods_Issues/issues/895)

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from illara»

    I agree to follow all rules regarding public packs and will send a message informing Reika of the config changes once the pack is actually finished.


    You obviously didn't read them (completely)...

    (Please read the whole page linked above if you are confused by my statement ;))

    Posted in: Minecraft Mods
  • 1

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from Trellinane»
    Also, I seem to be having an issue with the RF transfer cables in Revolution 3.4.4. When I attempt to set the transfer limit on the cable network it will only allow me to set it to 2.130 GRF/tick. If I try to go over this it resets to 0. Anything under this amount seems fine. Not really an issue for most applications but the particular cable involved is coming from the turbine generator to an RF Battery. Is this according to design intent or is there an issue here?


    2.1 GRF/t is the maximum due to how the RF API works - the internal calculations are based on (signed) Integers and Doubles, both of which have maximum absolute values of 2^31 - 1. As a result the highest possible transfer rate is exactly 2.147.483.647 RF per Tick ;)

    (Some storages can go above this value by using different data types (longs, BigInts, etc) or storing energy in thousands (kRF))



    To put it simple: There are technical reasons for it and 'fixing' that behaviour could cause serious issues when interacting with other RF-based systems.

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    Okay... that recipe is... interesting...

    But that config looks absolutely great ^^

    Posted in: Minecraft Mods
  • 1

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from Zimbalza»

    Installed Forge 1614, another crash just as before. This has been quite a challenge so far.


    I really don't get it anymore... something like that should be impossible without any (poorly coded) Coremod interfering... Forestry is failing internally, when noone else seems to have that problem (judging from a quick search through some Forums).
    You absolutely sure this only happens when ExtraUtillities, Forestry and DragonAPI are loaded together? (Because that combination is running perfectly fine for me with about 250 mods on top of it).
    As I'm running out of ideas, the only thing I can suggest is trying to find the minimum setup required for it to happen and search from there... (aka pinpointing the cause by removing mods until the crash stops or rebuilding the currently crashing setup until it starts crashing again to find the mod responsible). If you are willing to go that route, just a few tips: First try removing mods in packets of ~5 a time (NOT the 'core', 'api' and 'lib' ones and of course also none of the mods already known to be involved) until it stops happening (then re-add mods from the last packet until you find the offender) or you're down to only the libraries/base-mods, then start removing those one at a time until the 'bad' one is found...
    [Personally I suspect it to be one of the 'less-known' mods as otherwise someone else should have already run into this crash...]

    Sorry that I can't be of much help in this case... :(

    Posted in: Minecraft Mods
  • 1

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    Quote from Zimbalza >>

    Looking at the Gendustry downloads on curse shows the up-to-date file is 1.6.3.132-mc1.7.10 and should be the one I am using. Is there another one elsewhere?



    Nah, forget what I said there... *derp* [Note to self: stop trying to help people with crashes at 2am]
    Could you update Forge to .1614 (latest; instead of recommended) and see if that does anything?
    What's really strange about this is that the JVM seems to be unable to find one of Forestrys nested classes... one that's definitely there...

    @Reika
    Elite Artefact/Thargoid Mechanics in CC? Count me in! :D

    ...

    Everyone! The Chromaticraft v17 Hypetrain leaves the station right now! ^.^
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    Okay I'm slowly becoming confused... can you chack that all your Forestry Addons are up-to-date? (just noticed at least gendustry isn't).

    Still though the main error is caused by binnies which is running perfectly fine for me using the same Versions...

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    That one is already a lot more workable with :D

    First things first: did you disable any Module of Forestry in its' config? If so, which?

    Also please update Forestry to the latest Version (4.2.16) - if I recall correctly something was off with the .15 builds...

    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)

    That crash does seem to be caused by InventoryTools...

    (The NPE is thrown in line 46 here: https://github.com/AnimeniacYuuto/InventoryTools/blob/master/src/main/scala/yuuto/inventorytools/client/InputHandler.scala - seems like someone forgot a not-null check...)

    Try opening the options.txt in your minecraft dir and changing key.inventorytools.dollymode:<something> to key.inventorytools.dollymode:0

    Doing so will disable the dolly switching, but should prevent that line from being called.

    (As the Author seems to be inactive I don't think there will be a 'clean' fix to that)


    Hope that helps :)

    Posted in: Minecraft Mods
  • 2

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from Flabort»
    *snip*

    Reika stated some time ago, that he is not really willing to update at the moment. Also when (or if) he does, he will not rewrite his mods (which he would have to do under normal curcumstances considering the magnitude of the changes made to MC), but instead change DragonAPI to double as a compat layer between the games updated code and his mods'.
    Posted in: Minecraft Mods
  • 0

    posted a message on Reika's Mods (Tech, WorldGen, Civilization, and more)
    Quote from IronYacker»

    *snip*


    When removing DragonAPI you have to run the game once with an FMLPatch to revert some things (link).
    Regarding your crash... could you check if your Firewall allows java to use the network? (or if 'localhost' is declared unsafe somewhere?)
    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.