• 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from Magician_DC

    Hi there,

    Its been a while since I played with this mod. I love it, however, I have a problem. Ever since the old Mo Creatures mod, I have been able to instaspawn mobs. With this new edition, I am not able to instaspawn any mobs at all. As an OP on the server, I do make sure that both CONFIGS on client and server have the option to instaspawn set to "true". If anyone is also experiencing this problem or know a solution, please share what I am doing wrong so I can correct my mistake. Maybe its because I set all configs in the mo creatures folder to default leaving all the others blank as I do not understand them. Can it be that I must somehow enable all biomes in the Biomes config to be able to instaspawn? To not confuse people any further, please some one answer my question. My problem is server-sided as I do not play SSP. I am using the latest FORGE and GUIAPI, and CMS.

    @ EndermanIsAwesome

    It seems ur Dimensional ID does not match his or the SERVER. Make sure both CONFIGS are the same on the SERVER and CLIENT to avoid this crash.

    have you tried deleting the config files and letting them be regenerated to the new version?
    Posted in: Minecraft Mods
  • 0

    posted a message on The Twilight Forest (v2.3.5: Wrecking Block)
    Quote from Hageri


    Minecraft has crashed!
    ----------------------

    Minecraft has stopped running because it encountered a problem; Failed to start game

    A full error report has been saved to C:\Users\Becker\AppData\Roaming\.minecraft\crash-reports\crash-2013-06-12_18.49.49-client.txt - Please include a copy of that file (Not this screen!) if you report this crash to anyone; without it, they will not be able to help fix the crash :(



    --- BEGIN ERROR REPORT 7d92546 --------
    Full report at:
    C:\Users\Becker\AppData\Roaming\.minecraft\crash-reports\crash-2013-06-12_18.49.49-client.txt
    Please show that file to Mojang, NOT just this screen!

    Generated 12.06.13 18:49

    -- System Details --
    Details:
    Minecraft Version: 1.5.2
    Operating System: Windows 7 (amd64) version 6.1
    Java Version: 1.6.0_24, Sun Microsystems Inc.
    Java VM Version: Java HotSpot™ 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
    Memory: 350367920 bytes (334 MB) / 648740864 bytes (618 MB) up to 954466304 bytes (910 MB)
    JVM Flags: 2 total; -Xms512m -Xmx1024m
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Suspicious classes: FML and Forge are installed
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP v7.51 FML v5.2.2.684 Minecraft Forge 7.8.0.684 5 mods loaded, 5 mods active
    mcp{7.44} [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized
    FML{5.2.2.684} [Forge Mod Loader] (coremods) Unloaded->Constructed->Pre-initialized
    Forge{7.8.0.684} [Minecraft Forge] (coremods) Unloaded->Constructed->Pre-initialized
    mod_TooManyItems{1.5.2 2013-04-25} [mod_TooManyItems] (minecraft.jar) Unloaded->Constructed->Pre-initialized
    TwilightForest{1.18.1} [The Twilight Forest] (twilightforest-1.18.1.zip) Unloaded->Constructed->Errored
    LWJGL: 2.4.2
    OpenGL: GeForce GT 520/PCIe/SSE2 GL version 4.3.0, NVIDIA Corporation
    Is Modded: Definitely; Client brand changed to 'fml,forge'
    Type: Client (map_client.txt)
    Texture Pack: Default
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: ~~ERROR~~ NullPointerException: null

    java.lang.IllegalArgumentException: Slot 133 is already occupied by net.minecraft.block.BlockOreStorage@404fe94c when adding twilightforest.block.BlockTFLog@3e5d9d90
    at net.minecraft.block.Block.<init>(Block.java:340)
    at net.minecraft.block.BlockLog.<init>(BlockLog.java:26)
    at twilightforest.block.BlockTFLog.<init>(BlockTFLog.java:28)
    at twilightforest.block.TFBlocks.<init>(TFBlocks.java:40)
    at twilightforest.TwilightForestMod.preInit(TwilightForestMod.java:283)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at cpw.mods.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:494)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:165)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:98)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:514)
    at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:160)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:410)
    at net.minecraft.client.MinecraftAppletImpl.func_71384_a(SourceFile:56)
    at net.minecraft.client.Minecraft.run(Minecraft.java:732)
    at java.lang.Thread.run(Unknown Source)
    --- END ERROR REPORT 782d3b4b ----------
    :(

    1. spoiler tags
    2. simple ID conflict, change the ID for either one of the conflicting blocks, you may have to repeat this with any other blocks
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from TaeoG

    This is a long shot, but is anyone else getting lockups? I have nearly 100 mods going, so trying to find out which ones are causing problems is hard. All I know is the game locks up in less than a minute the moment I add Mo'Creatures. The error always starts with an "out of memory" error, even though its using maybe 1GB of the 4 I give it.

    I can never get an error log because it never completely crashes... just locks up. IE



    look at the FML-client-0.log file.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from Cloud_Kitty

    Okay, I'm trying to get onto the official server and I've gotten all the mods downloaded, correct versions, put them in the right place; all that good stuff. The thing is, when I try to join the server, it says "Forge Mod Loader has found ID mismatches. Complete details are in the log file. ID 171 from Mod BiomesOPlently is missing. You cannot connect to this server." Can anyone help me? I'm not sure if I should do something to one of the files in BiomesOPlently or change my Forge version(Using version 7.8.0.684 of FML). I am using MultiMC.

    delete the BOP config file.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from minecraftnut

    I know, but I wondered if this is possible without using a server. For 2 reasons.
    1. I am testing our new client atm and we have not decided on which mods to keep, so at this point we dont want to create a server yet. This would only double our work with removing and adding mods at this point. Also, for some reason the GUI resets the changes everytime I load the world in SSP. So a detailed config would help a lot and with all the changes since last time we had Mo'Creatures, I can't find one. I want to keep the mob spawning relatively low for performance reasons and disable some entirely (the votes were no on maggots and flies lol), because some of our players are still stuck with 32bit java and large mods can be very demanding.

    2. When we are ready with our client and want to create a server, we would already have the right config file.

    messing with the configs in game with the GUI shouldn't do that.
    I'm still in the 1.4.7 version, but, MOC is creating several config files, one for each mod that adds mobs. IDK if it puts them in a subfolder now or they are all in the main config folder
    all the server config files are the same as the client ones for MOC. You can just copy your client config files onto the server when you are ready
    Quote from shaelandrys

    Thanks for giving it a go, XanderGryphon. Being heard and acknowledged is at least half the battle. -smiles-

    On a whim and a hunch, I tried to see if merely creating a new "instance" (I forget what a new mods set is called) in MultiMC might help. It did! So, for the time being, all is well. Some of "the workings" in the old instance must have gotten corrupted, as the game did not shut down properly, and then would not reload. Could be something with memory allocation for game use, perhaps.

    I'd love to know if there is a way to "fix" my first "instance", which has crash reports in prior threads, since I had a very nice setup, if anyone else has insights to the crash.

    try deleting your config files for that instance, save a backup just in case that does not fix the problem
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from minecraftnut

    Is there a way to create a config file with individual mob spawn settings, like on a server? As if you wouldn't have GUIAPI?

    server creates the config files just like the client. You can either manually edit these files or use the line commands if you are a server OP
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from j4bber

    Ok I am in single player mode and want to turn down the spawn a little on some of the creatures. I keep seeing that you can do this with the ingame gui, but for the life of me I cant find the gui that does this. Is thre a key combination or something??

    global mod options button.
    Posted in: Minecraft Mods
  • 0

    posted a message on The Twilight Forest (v2.3.5: Wrecking Block)
    Quote from Master_Aricitic


    I thought that tree leafs prevented mobs from spawning on them. If that is the case then it should (theoretically) be possible to designate a block as a 'no spawn' zone. Problem with that, of course, is modifying said block, and naturally preventing ANY mob from spawning. (Water also prevents hostile mobs from spawning-how, exactly, this is done, I am unsure. But Water vs Leaf is likely a biome thing.)


    AFAIK, mobs can not spawn on half blocks and transparent blocks: water, glass, and lava (unsure of RS lamps). BTW, RS counts as a half block so they won't spawn on top of RS lined blocks.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from geckogeek6

    Is there a way to specifically edit spawn rates of wither skeletons? they seem to no be able to spawn. or would increasing regular skeleton spawn rate affect them too?

    skelly eggs used in nether will spawn wither skellys
    so you'll have to up the skelly rate.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from iAdam____

    Crash on server, not seen this crash before :P (Btw I'm using 1.5.1)
    ---- Minecraft Crash Report ----
    // You're mean.

    Time: 10/06/13 18:47
    Description: Exception in server tick loop

    cpw.mods.fml.common.LoaderException: java.lang.NoSuchMethodError: drzhark.customspawner.CustomSpawner.setMaxMonsters(I)V
    at cpw.mods.fml.common.LoadController.transition(LoadController.java:142)
    at cpw.mods.fml.common.Loader.initializeMods(Loader.java:696)
    at cpw.mods.fml.server.FMLServerHandler.finishServerLoading(FMLServerHandler.java:93)
    at cpw.mods.fml.common.FMLCommonHandler.onServerStarted(FMLCommonHandler.java:355)
    at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:140)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:429)
    at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:573)
    Caused by: java.lang.NoSuchMethodError: drzhark.customspawner.CustomSpawner.setMaxMonsters(I)V
    at drzhark.mocreatures.MoCreatures.updateSpawnSettings(MoCreatures.java:1346)
    at drzhark.mocreatures.MoCreatures.updateSettings(MoCreatures.java:1337)
    at drzhark.mocreatures.MoCreatures.postInit(MoCreatures.java:481)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at cpw.mods.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:494)
    at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:165)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
    at com.google.common.eventbus.EventBus.post(EventBus.java:267)
    at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:98)
    at cpw.mods.fml.common.Loader.initializeMods(Loader.java:695)
    ... 5 more


    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- System Details --
    Details:
    Minecraft Version: 1.5.1
    Operating System: Windows 7 (amd64) version 6.1
    Java Version: 1.7.0_21, Oracle Corporation
    Java VM Version: Java HotSpot™ 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 363410688 bytes (346 MB) / 456785920 bytes (435 MB) up to 3802857472 bytes (3626 MB)
    JVM Flags: 0 total;
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Suspicious classes: FML and Forge are installed
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP v7.44 FML v5.1.43.682 Minecraft Forge 7.7.2.682 11 mods loaded, 11 mods active
    mcp{7.44} [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized
    FML{5.1.43.682} [Forge Mod Loader] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized
    Forge{7.7.2.682} [Minecraft Forge] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized
    Aether II{Alpha v1.0.1} [Aether II] (AetherII_Alpha_v1.0.2_MC1.5.1.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized
    MainMenuAPI{1.0.0} [Main Menu API] (AetherII_Alpha_v1.0.2_MC1.5.1.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized
    CustomSpawner{1.12.5} [DrZhark's CustomSpawner] (CustomMobSpawner 1.12.5.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized
    MagicCarpet{1.1} [DrZhark's Magic Carpet Mod] (DrZharks MagicCarpet Mod v1.1.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized
    MoCreatures{5.2.3} [DrZhark's Mo'Creatures Mod] (DrZharks MoCreatures Mod v5.2.3.zip) Unloaded->Constructed->Pre-initialized->Initialized->Errored
    Hats{1.3.2} [Hats] (Hats1.3.2.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized
    HatStand{1.2.1} [HatStand] (HatStand1.2.1.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized
    Thaumcraft{3.0.4c} [Thaumcraft] (Thaumcraft3.0.4c.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized
    Profiler Position: N/A (disabled)
    Is Modded: Definitely; Server brand changed to 'fml,forge'
    Type: Dedicated Server (map_server.txt)

    you are using MOC for MC 1.5.2 on MC 1.5.1. it won't work.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from BarbiieDolly

    When I open to where I found bin there is no 'coremods' What is going on?

    coremods is not inside the bin folder, it is inside the main .minecraft folder
    will only appear after you have successfully run MC with forge installed
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from XanderGryphon

    Same thing, except you'll have to upload the config file from your client to the server or manually edit the config file that's stored on the server.

    not anymore, if you are OP on the server you can use commands to modify the server's config file
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from Noahshiloh

    Thank you for adding the BWG4 thingy. I tried the newest version and it crashed :[

    need the FML-client-0.log file to really help you out.
    Posted in: Minecraft Mods
  • 0

    posted a message on The Twilight Forest (v2.3.5: Wrecking Block)
    Quote from FSMAcolyte

    What's with all the glass?? http://i.imgur.com/6x9MBPg.jpg

    temp place holder for a magic forcefield block
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from ZenVolta

    Hey guys, does anyone know the best way to slow down mob spawns? Like what settings and everthing I should use? I love Mo Creatures but a lot of the time I feel like my world is over populated. Any help would be appreciated thanks

    up the spawn tick rate
    Posted in: Minecraft Mods
  • To post a comment, please .