• 1

    posted a message on VoxelMap [1.16.1 to 1.7.10] - a minimap and worldmap

    Just a note to anyone who may be getting this error: Unknown World!
    VoxelMap is one of my essential mods and I love it, but I'd been having a nagging issue with "Unknown world" errors in chat whenever I'd change worlds. I tried multiple server plugins as suggested in this thread to manage the world names, but no matter how many times I'd chosen the world in the map UI it never saved.

    I just found out it's because I was using our world names with colons. Our worlds always follow a naming convention of "Destinos:WorldName" and I was using that convention in VoxelMap.

    When I just on a whim, thought to try "Destonos_Worldname" it started working fine :) So if you're having this problem, try eliminiating :'s (and maybe other special characters?) from your names in VoxelMap.

    Posted in: Minecraft Mods
  • 0

    posted a message on VoxelMap [1.16.1 to 1.7.10] - a minimap and worldmap

    EDIT: Currently talking with the Rift dev on Discord. Says it should be fixed in a few hours.
    ==

    Thanks for the link to Rift for 1.13.2. Been frothing at the mouth for days waiting for a 1.13.2 version :)

    I know you're not the dev of Rift, and it's out of your way for me to ask you, but just in case you can shed some light on it:
    After installing that version of Rift (from your link), I get the success message, but when I try to launch the game and get this error:


    The file it's trying to download upon launching the game is not at that path. (Or anywhere on that server, I went searching.)

    Is it normal for a mods to go searching for a download? I never paid attention before and don't know much about how mods work, but I thought all the files needed were in the .jar that was installed. Anyway, it might be that they just removed the thing and that version doesn't work anymore :(

    Posted in: Minecraft Mods
  • 0

    posted a message on Dynmap - Dynamic web-based maps for Minecraft

    I love dynmap. I've used it for years, but now I'm having a small problem maybe someone can help with.


    1. I just added custom maps to the template for the first time. Everything is fine, except the new map icons (the ones you click to change views on the map) are black.

    2. I did some reading and found out how to specify them in the map settings, here: https://github.com/webbukkit/dynmap/wiki/HD-Map-Configuration

    under "Additional HDMap settings". Specify icon: images/filename.png. Well it didn't quite work:

    Problem #1 and work-around: In my "Surface" maps, of which I've created SW, SE, NW, NE variations, I have specified "images/block_surface.png". It wasn't working because dynmap was for some reason, adding "_Southwest" or "_Southeast" etc, to the file URI. I fixed this with a work around, creating copies of the desired image, with that file name. (Ending up with 4 of the same icon, named things like "block_surface_Southwest.png". This works, although I'd rather it work properly, but that's not so important, since I can work around it. :P

    Problem #2 That worked, but when I got to the cave map icons, the same thing did not work. For some reason, even though I've specified "images/block_skylands.png" in my template file. (I like that one better than the cave one :P) when I check the source code of the page, the icon paths are pointed to "images/block_cave_Southeast.png" (etc) instead. So in addition to tacking on the extra custom view name, it's ignoring the file that I specified altogether.


    This doesn't make any sense to me, so maybe I've just made a dumb mistake and need a second pair of eyes to look over my stuff. I can't find it. Thanks in advance for any help!


    Template file:


    --- 
    templates: 
      normal-hires: 
        enabled: true
        extrazoomout: 5
        maps: 
          - 
            class: org.dynmap.hdmap.HDMap
            lighting: shadows
            mapzoomin: 3
            name: flat
            perspective: iso_S_90_lowres
            prefix: flat
            shader: stdtexture
            title: Flat
          - 
            boostzoom: 5
            class: org.dynmap.hdmap.HDMap
            icon: images/block_surface.png
            lighting: shadows
            mapzoomin: 3
            name: surface_Southeast
            perspective: iso_SE_30_hires
            prefix: t
            shader: stdtexture
            title: "Surface SE"
          - 
            boostzoom: 2
            class: org.dynmap.hdmap.HDMap
            icon: images/block_surface.png
            lighting: shadows
            mapzoomin: 3
            name: surface_Southwest
            perspective: iso_SW_30_hires
            prefix: SW
            shader: stdtexture
            title: "Surface SW"
          - 
            class: org.dynmap.hdmap.HDMap
            icon: images/block_skylands.png
            lighting: default
            mapzoomin: 3
            name: cave_Southeast
            perspective: iso_SE_60_hires
            prefix: ct
            shader: cave
            title: "Cave SE"
          - 
            class: org.dynmap.hdmap.HDMap
            icon: images/block_skylands.png
            lighting: default
            mapzoomin: 5
            name: cave_Southwest
            perspective: iso_SW_60_hires
            prefix: cSW
            shader: cave
            title: "Cave SW"
    version: 0.2


    Source code of the dynmap menu:



    Files in my /dynmap/web/images folder:


    Posted in: Minecraft Mods
  • 0

    posted a message on New Mob Suggestion: Giant Ants.

    I also agree that the ant's "building" behavior should be limited to a variant of what we see from endermen so far. At most just taking random blocks and stacking them into a pilar, I think that would still be amusing and close enough to "ant like". (Limited to dirt, sand, and derivatives of those) Perhaps colonies could, instead of building their own tunnels, just simply be found commonly in existing caves nearby the surface entrances.


    I definitely think taming and riding have to be a part of it. If one doesn't understand why, they should go watch the movie "Honey I Shrunk the Kids" :)

    Posted in: Suggestions
  • 0

    posted a message on New Mob Suggestion: Giant Ants.

    In most places, you put sugar on the ground, you get ants. That's why I chose sugar. Of course, they do like other things, peanut butter especially.


    Quote from Wolftopia»

    This has a lot of potential, but I think some of it should be changed:

    1. The legs on the ant should be shorter so it looks less like the spider.

    2. You shouldn't be able to tame the ants.

    3. The colonies should be much larger (20-30 ants), but only a few should be above ground; the rest should be in the underground tunnels, even if there is an ant hill. The underground ants should be in "infested sand," and only come out when you enter their tunnel. (When an ant comes out of an infested sand block, the block does not get destroyed.)

    4. The ants should only be able to build or dig on podzol, dirt, sand, and red sand.

    5. The queen ant should drop something that allows you to control the ants to an extent, where they can build for you, but of course only out of sand, red sand, or dirt.

    6. Ants of different colonies should attack each other.


    The design is not mine, nor really a recommendation - I swiped it from an existing mod. I just thought it was cute.

    Posted in: Suggestions
  • 0

    posted a message on New Mob Suggestion: Giant Ants.

    New Mob Suggestion: Giant Ants.


    Behavior:
    Found in sandy and podzol areas. Colonies of 5 or 6. The ants work together to stack blocks, and dig tunnels. They drop venom sacks which could be used for various things including poison arrows. Neutral unless attacked. Can climb vertically, and often follow each other in a caravan like Llamas.


    Tamable:

    Can be fed sugar to be tamed. Tamed giant ants can be ridden with a saddle and named with a tag. Can still climb vertical faces while ridden.They lay eggs to reproduce.


    1 in 100 spawned ants is a "queen", which does nothing all day but supervise. Armies protect her but she drops something very special.


    Photo from Mod: Dark Menagerie

    Posted in: Suggestions
  • 0

    posted a message on Dynmap - Dynamic web-based maps for Minecraft

    I love dynmap. I've used it for years, but now I'm having a small problem maybe someone can help with.


    1. I just added custom maps to the template for the first time. Everything is fine, except the new map icons (the ones you click to change views on the map) are black.

    2. I did some reading and found out how to specify them in the map settings, here: https://github.com/webbukkit/dynmap/wiki/HD-Map-Configuration

    under "Additional HDMap settings". Specify icon: images/filename.png. Well it didn't quite work:

    Problem #1 and work-around: In my "Surface" maps, of which I've created SW, SE, NW, NE variations, I have specified "images/block_surface.png". It wasn't working because dynmap was for some reason, adding "_Southwest" or "_Southeast" etc, to the file URI. I fixed this with a work around, creating copies of the desired image, with that file name. (Ending up with 4 of the same icon, named things like "block_surface_Southwest.png". This works, although I'd rather it work properly, but that's not so important, since I can work around it. :P

    Problem #2 That worked, but when I got to the cave map icons, the same thing did not work. For some reason, even though I've specified "images/block_skylands.png" in my template file. (I like that one better than the cave one :P) when I check the source code of the page, the icon paths are pointed to "images/block_cave_Southeast.png" (etc) instead. So in addition to tacking on the extra custom view name, it's ignoring the file that I specified altogether.


    This doesn't make any sense to me, so maybe I've just made a dumb mistake and need a second pair of eyes to look over my stuff. I can't find it. Thanks in advance for any help!


    Template file:


    --- 
    templates: 
      normal-hires: 
        enabled: true
        extrazoomout: 5
        maps: 
          - 
            class: org.dynmap.hdmap.HDMap
            lighting: shadows
            mapzoomin: 3
            name: flat
            perspective: iso_S_90_lowres
            prefix: flat
            shader: stdtexture
            title: Flat
          - 
            boostzoom: 5
            class: org.dynmap.hdmap.HDMap
            icon: images/block_surface.png
            lighting: shadows
            mapzoomin: 3
            name: surface_Southeast
            perspective: iso_SE_30_hires
            prefix: t
            shader: stdtexture
            title: "Surface SE"
          - 
            boostzoom: 2
            class: org.dynmap.hdmap.HDMap
            icon: images/block_surface.png
            lighting: shadows
            mapzoomin: 3
            name: surface_Southwest
            perspective: iso_SW_30_hires
            prefix: SW
            shader: stdtexture
            title: "Surface SW"
          - 
            class: org.dynmap.hdmap.HDMap
            icon: images/block_skylands.png
            lighting: default
            mapzoomin: 3
            name: cave_Southeast
            perspective: iso_SE_60_hires
            prefix: ct
            shader: cave
            title: "Cave SE"
          - 
            class: org.dynmap.hdmap.HDMap
            icon: images/block_skylands.png
            lighting: default
            mapzoomin: 5
            name: cave_Southwest
            perspective: iso_SW_60_hires
            prefix: cSW
            shader: cave
            title: "Cave SW"
    version: 0.2


    Source code of the dynmap menu:



    Files in my /dynmap/web/images folder:


    Posted in: Minecraft Mods
  • 0

    posted a message on Need help getting the Nether to generate in a secondary world?

    I've tried everything I can think of, but it hasn't worked. Here's the scenario:


    We started a new server with Multiverse, with one old world, and a new world. What we did to get this was:


    We started a multiplayer server and the new world is fine.

    We'll call that:

    Mainworld

    Mainworld_nether

    Mainworld_the_end


    The world folders generated on the server like normal...


    The we copied all the data from the Secondary World (Old) that we played on before into a new world folder on the server "Secondaryworld". That works fine. We're playing on Secondaryworld like crazy and everythings good, except there's no nether or end. Nobody had gone to the end or the nether on this world yet, so I thought that the worlds would generate when they finally did build a portal in the overworld... but the portal doesn't do anything. It lights up purple and makes the spooky sounds but standing in it just goes no where.


    There are no files in the DIM1 and DIM-1 folders on the old world file. I tried copying those folders into folders that I manually made called "Secondaryworld_nether" and "Secondaryworld_the_end" but still no luck... the nether portal goes nowhere.


    I've tried to create the nether and end via Multiverse commands, but it says that Secondaryworld already exists. Any thoughts.

    Posted in: Server Support and Administration
  • 3

    posted a message on VoxelMap [1.16.1 to 1.7.10] - a minimap and worldmap
    Quote from MamiyaOtaru»

    it should "just work", so there's no settings to fiddle with. It can go a bit wonky though. It can tell which world it is in by comparing the stored data for each world with the area around you when you portal in. If you happen to portal in to a part of the world you have never visited, it won't have anything to match up.


    You could also be running into some cached data being mixed up from the transition from single world to multiworld. Usually wiping the cached map data will fix that, though that's not always a happy solution.


    As you are the admin though, there's another possibility :) The reason I compare stored data to figure out which world you are in is that Minecraft doesn't send any identifying info about the current world. Unless you use a server plugin, like https://journeymap.info/JourneyMapServer or https://dev.bukkit.org/projects/worldinfo


    Having either of those installed on the server will cause the server to send an ID packet to each client when they join a world. You can configure it to be a specific name for each world, or just install it and let it run and it'll pick some gibberish (but distinguishable) name, and automatically keep each world's cached map data separate


    Thank you for your reply! Yet another reason VoxelMap is a recommended mod on our server :)

    Installing WorldInfo totally fixed the issue for me! Thank you so much for the tip!
    Posted in: Minecraft Mods
  • 0

    posted a message on VoxelMap [1.16.1 to 1.7.10] - a minimap and worldmap

    WE LOVE VOXELMAP AT MADMINERS! :P We've used it for years!


    But, does VoxelMap support multiverse worlds? We went from a single-world server to a multiverse server with 2 overworlds and I seem to be having a bit of trouble (But other players are not, so I think this is maybe a local issue.)

    VoxelMaps remembers one world (World A) but when I switch over to World B, it almost always says "Unknown world! Please select your current world in the Multiworld screen."


    And I do go and select the current world, but it doesn't remember it. It will be fine until I change worlds again. Usually it will remember World A, but when I come back to World B it gives the error again. And any waypoints saved before are missing.


    I have also noticed that somewhere along the way the world that "takes" has changed. For the first few days of our multi-world setup it was World A that always was saved and World B that was forgotten. Now World B is always remembered and World A is forgotten.


    I am the admin of our server and no other players have complained of this yet. (We have multiple players using VoxelMap as it is in our "recommended mods" list.


    Is there maybe a setting I'm missing?

    Posted in: Minecraft Mods
  • 0

    posted a message on MAtmos - Environmental sound atmosphere simulator
    Quote from soccerguy3»

    the controls are opened by F7 by default from there turn down effects

    Thank you so much :) <3
    Posted in: Minecraft Mods
  • 0

    posted a message on MAtmos - Environmental sound atmosphere simulator

    I love this mod, but I was wondering if there's settings somewhere? The wind is too constant and loud for me, and it sounds like something's wrong with it. Its very harsh instead of the soft pleasant wind sound in the video at the top of this thread. It sounds like a jet engine constantly flying over my head.


    However, I hear the birds and other stuff just fine. Thank you for all the work. It's awesome.

    Posted in: Minecraft Mods
  • 1

    posted a message on A question about weight in loot tables

    I'm experimenting with my server's loot tables and want to clarify how the "weight" entries work.


    I understand that if I have a roll with four entries listed, all with weights of 1, 2, 3, and 4, respectively, that the entry with 4 will drop most often and the entry with 1 will drop least often.


    My question is whether the drop chances of weight values of 1, 2, 3 and 4 would equal to drop chances of weights of 3, 4, 7 and 79, respectively, or if the integers increase exponentially. For example. a 2 drops twice as often as a 1, but a 10 drops ten times as often as a 1, regardless of the chronological order of the weights?


    I hope I haven't made this question too confusing. I struggled with how to word it clearly. Basically, I'm just wondering if


    it acts as a chronology or if it's literally a multiplier. I can give some examples of code to clarify if needed.

    Posted in: Discussion
  • 0

    posted a message on Tinkering with loot tables, but can't change bat's loot.

    Hello,


    I have been tinkering with the loot tables for various monsters on my server, and I generally am successful. However I have trouble with the Bat.json file. It's blank by default, but whenever I put anything into it, and then restart the server, the console complains with an error saying it couldn't load the bat.json file from the related folder.

    It's not a syntax error. I've validated the code and also simply copied and pasted the loot code from a working monster into the bat's file and it still fails to load, even though the other monster loads fine and they have identical code.


    Is the bat disabled from loot in the game or something? What else could I be doing wrong?


    EDIT: Nevermind, I guess. I found an online loot table generator and the code it produced seemed to work. As sure as I was there was no syntax error, I must have been wrong. Mods may delete this thread if they feel like it.

    Posted in: Recent Updates and Snapshots
  • 0

    posted a message on Can't get hopper to transfer ore to furnace?
    Wow! I was unaware that side hoppers would do fuel but not materials. Is that by design or a bug?
    Posted in: Discussion
  • To post a comment, please .