• 0

    posted a message on PhoenixTerrainMod Code sharing thread
    Hello everyone i am author bukkit version PTM.
    I can explain some config changes:
    1)In bukkit version hell variables deleted - this is not supported now, sorry
    2)All old settings (except hell variables) work in bukkit version as it was
    3)Also bukkit version have another block repalce format.
    4)Lines look like "<...>" - ignored, it is only for better view.
    5)Bukkit version also add some new settings
    disableNotchHeightControl:false
    CustomHeightControl:0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0

    and etc
    Posted in: Mods Discussion
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    Quote from Rebelj12a

    Isolating the problems

    Hmm besides that not sure


    Wait new release ..
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    R-T-B make new release from SVN please...
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    Quote from Luxander

    Right now, we're more worried about R-T-B making a version of Phoenix Terrain Mod that works with Cubic Chunks.


    For Cubic Chunks we need new chunk generator. You cant easy migrate from PTM to this ...
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    Quote from Wessexstock

    I hate to burst everyones' collective bubbles but BiomeTerrainMod's code was written by Bucyruss, not R-T-B.

    Not to say that R-T-B isn't my *****, because he is, but he just picked up the code where Bucyruss left it and kept up with obfuscation and debugging busted features.

    I'm not sure that anyone besides Bucyruss really has a solid grasp on how the code works exactly.

    Bukkit code rewrote by me because Bucyruss was terrible ... imho
    So maybe better blend with Bukkit code.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    Quote from AH1684

    0 to 128. I changed it to 0 to 64 and to 0 to 0, both failed. I'm trying to make a flying islands map, which I made in single player. No bob objects.





    Fix will be in new release.
    Now you can run with waterSourceDepositMinAltitude > 0 and lavaSourceDepositMinAltitude > 0
    caveMinAltitude > 0
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    Quote from Vikman

    Can you please make a bukkit compatible PLUGIN if possible (i know that you have released a bukkit version, but not as a plugin)? Would be way easier to set up like that.


    It is not possible now.
    In Bukkit you cant generate biomes with custom setting as plugin. Also it still not have event for growing tree from sapling.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    Quote from Deserves2live

    So...anyone?


    Hmm corrupted world .. try to generate new ...
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    Quote from Boreeas

    Thanks for that.
    I get this error now when starting the start.cmd:
    http://pastebin.com/A76NVF5P


    Settings file please.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    Quote from AH1684

    0 to 128. I changed it to 0 to 64 and to 0 to 0, both failed. I'm trying to make a flying islands map, which I made in single player. No bob objects.


    Post your full settings file please.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    Quote from AH1684

    Whenever I change the ini. settings, I get this. HELP! I'm using the bukkit version.


    Hmm, what caveMinAltitude and caveMaxAltitude you have in config ?
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    Quote from XzeaLL

    We want to use ptm on our linux server (bukkit) but we can't get the .bat to work.
    This is the normal command to start the server without ptm:

    java -server -Xmx768M -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:ParallelGCThreads=2 -XX:+AggressiveOpts -jar craftbukkit.jar nogui

    But what do we have to add/change to start it with ptm? (the included start.sh/cmd/bat doesnt work)

    thx :smile.gif:

    Something like this:

    java -server (JMV config options as you like) -cp BiomeBukkit.jar:craftbukkit.jar org.bukkit.craftbukkit.Main nogui
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    Quote from SadCrow

    I can confirm, this ini crash on my server too..
    Complains about the line "ReplacedBlocks:None", but removing this line will still result in a crash.

    However, reseting the sea level back to the default value of 64, and the server starts without errors!

    Going to try a different PTM release now, I believe my server might be running R16B1.

    Edit: Also confirmed using PTM R16B2 and craftbukkit build 953.
    Crash when using this ini, unmodified.
    Works when edit sea level to default!


    Yeap bug found, new version on SVN... R-T-B update site please :smile.gif:
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    Quote from themushyman

    Urhh.. I'm having a slight problem. When I set the BiomeTerrainModSettings.ini for our default world - when I tried generating it I got these awful errors... :L Anything I can do?

    I am using Bukkit for Minecraft 1.7.2 (build 935) and PTM 16B2. Help!


    Post your config here please.

    Also you know latest recommended version is 953 ?
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.7.3] PhoenixTerrainMod (New status update 11/03/12)
    Quote from SadCrow


    Two more funny bugs that most probably is related to the custom trees. The .bo2 ones this time...

    I just noticed there are now growing tree trunks inside caves, with nothing but solid rock over and below it.

    And when trying a new "Floating Islands" config, I noticed tall pillars of grass/dirt and tree trunks all the way from lower ground/sea level to the higher ground. Usually with a custom tree at the top, like in this screenshot..


    This two is in BO2 object settings:
    1) collisionPercentage = 100 or about it, this allow spawn objects in any place, but if dig = false it is spawn parts in blank places only.
    2) underFill = true
    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.