• 0

    posted a message on [1.11] EntityThrowables and Mobs

    Hi all, I've just recently got into modding and I've run into a few issues that I haven't found tutorials for.


    So I have an item that acts basically just like an egg: it's thrown and a mob spawns upon contact. The issues I'm having with it right now:


    1) The item is being thrown, but it isn't rendering. How do I render/register/etc. entity objects?


    2) I've been trying to find Techne all over to make mobs, but all the links seem to be dead. Is there a place I can still download it, or another tool that does the same things?


    Thanks!

    Posted in: Modification Development
  • 0

    posted a message on Pikmin Mod

    Hi everyone! I've been playing Minecraft for a few years now, and I've also been studying programming in college for three years. Oddly enough, I never thought to put the two together and make a mod until this week, and with Hey! Pikmin just released, I've had Pikmin on the brain.

    I've been going through various modding tutorials, and quickly finding that everything I want to do is way too much for one person to handle, so I'll open this project up to you guys! I've made a GitHub repository that you can dig around and possibly help me out with, whether it's by pushing code directly or by showing me how various things are done in code. Hopefully the readme file in the repo has enough information that you can figure out what I'm trying to make with this mod, but you can certainly ask me questions if you're confused. If you've played the actual games before, most of the mechanics should be familiar to you.


    SCREENSHOTS:


    Red Pikmin item and Red Pikmin crops

    Red Pikmin throwable item and Red Pikmin crops.

    Posted in: WIP Mods
  • 0

    posted a message on Strange server happenings...please help!
    The java version solved the Log and Chat problem, but when I direct connect on the Windows 8 laptop (the one not hosting):

    java.net.ConnectExcepton: Connection timed out: no further information: /[insert my server ip and port here]
    Posted in: Java Edition Support
  • 0

    posted a message on Strange server happenings...please help!
    Ok, so we've been playing Minecraft on LAN for quite a while, and then I decide to throw on some more mods to the game, and all of a sudden the LAN doesn't work, servers between us don't work (but those outside of our house do, go figure).

    I've since removed Minecraft from both of our computers and reinstalled it. I've installed the latest version of Java and downloaded the 1.7.2 server.exe file, and we are both connected to the same networks in Hamachi. There's some weird stuff happening...

    1) When I open the server.exe, the Java box opens as usual, but the stats only show the Memory Use and Average Tick, the rest of the box is blank. Also, the Log and Chat box is completely empty. However,

    2) When I input the IP for the server on Minecraft Multiplayer, I myself can get in without any issues. The world loads fine, everything. I'm currently slaying an Ender Dragon I spawned in the overworld. Despite this,

    3) The other laptop in the house cannot connect to the server. It pings for a very long time (which, to me, means it knows it's there) and then it claims there's no connection. Again, we are both connected to Hamachi networks.

    The laptops are a Windows 7 and a Windows 8, but this didn't have any problems in the past. Thanks for the help! :)
    Posted in: Java Edition Support
  • 0

    posted a message on LAN not working right
    I have similar issues in my household, we are both connected to Hamachi, but the server on Minecraft times out before it can connect. I'm pretty sure that my game knows the server is there (since, if I put in a bogus IP address, it automatically goes red as opposed to the time it takes for the real IP address), but there's something stopping it before it can connect.
    Posted in: Java Edition Support
  • 0

    posted a message on Server problems with mods (and HDMI/Ethernet cable questions)
    I downloaded a 1.6.4 server, threw on a 1.6.4 Forge clint AND server in Minecraft, and updated my mods to 1.6.4. I get this when I try to connect to my own server:

    Time: 10/15/13 6:18 PM
    Description: Ticking screen

    java.lang.NoClassDefFoundError: net/minecraft/world/chunk/EmptyChunk
    at net.minecraft.client.multiplayer.WorldClient.func_72970_h(WorldClient.java:118)
    at net.minecraft.world.World.finishSetup(World.java:253)
    at net.minecraft.client.multiplayer.WorldClient.<init>(WorldClient.java:67)
    at net.minecraft.client.multiplayer.NetClientHandler.func_72455_a(NetClientHandler.java:349)
    at net.minecraft.network.packet.Packet1Login.func_73279_a(Packet1Login.java:119)
    at net.minecraft.network.TcpConnection.func_74428_b(TcpConnection.java:462)
    at net.minecraft.client.multiplayer.NetClientHandler.func_72551_d(NetClientHandler.java:281)
    at net.minecraft.client.multiplayer.GuiConnecting.func_73876_c(GuiConnecting.java:51)
    at net.minecraft.client.Minecraft.func_71407_l(Minecraft.java:1579)
    at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:909)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:837)
    at net.minecraft.client.main.Main.main(SourceFile:101)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:27)
    Caused by: java.lang.ClassNotFoundException: net.minecraft.world.chunk.EmptyChunk
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:186)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 18 more
    Caused by: java.lang.NullPointerException
    at net.aetherteam.threadedlighting.asm.TLTransformer.transform(TLTransformer.java:103)
    at net.minecraft.launchwrapper.LaunchClassLoader.runTransformers(LaunchClassLoader.java:274)
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:172)
    ... 20 more


    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- Head --
    Stacktrace:
    at net.minecraft.client.multiplayer.WorldClient.func_72970_h(WorldClient.java:118)
    at net.minecraft.world.World.finishSetup(World.java:253)
    at net.minecraft.client.multiplayer.WorldClient.<init>(WorldClient.java:67)
    at net.minecraft.client.multiplayer.NetClientHandler.func_72455_a(NetClientHandler.java:349)
    at net.minecraft.network.packet.Packet1Login.func_73279_a(Packet1Login.java:119)
    at net.minecraft.network.TcpConnection.func_74428_b(TcpConnection.java:462)
    at net.minecraft.client.multiplayer.NetClientHandler.func_72551_d(NetClientHandler.java:281)
    at net.minecraft.client.multiplayer.GuiConnecting.func_73876_c(GuiConnecting.java:51)

    -- Affected screen --
    Details:
    Screen name: net.minecraft.client.multiplayer.GuiConnecting
    Stacktrace:
    at net.minecraft.client.Minecraft.func_71407_l(Minecraft.java:1579)
    at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:909)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:837)
    at net.minecraft.client.main.Main.main(SourceFile:101)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

    Are there extra steps I need to take, other than directing the Forge Server files to the server folder?
    Posted in: Java Edition Support
  • 0

    posted a message on Server problems with mods (and HDMI/Ethernet cable questions)
    ok then, how do I set up a forge server?
    Posted in: Java Edition Support
  • 0

    posted a message on Server problems with mods (and HDMI/Ethernet cable questions)
    My brother and I have been playing LAN minecraft for a while now. But I decided to add a mod to both of our games and now the LAN servers can't see each other. He'd host the game and I can't connect when I type in the IP numbers and LAN port.

    So I completely removed both our Minecrafts and rebuilt. The vanilla versions (latest snapshot and 1.6.4) both worked with LAN, but as soon as I decided to throw the mods back on, the LAN didn't work (the extra mod I added (ExtraDimensional) was not added in this second adding) and I have reason to believe the LAN doesn't work anymore even in vanilla versions, its as if the mods kill LAN.

    We have Forge 9.10.1.871 (for 1.6.2, yes)

    The mods I currently have are:

    Aether II for 1.6.2
    ExtraBiomesXL 1.6.2-3.14.1
    Barrels 3.3-1.6.4
    BILLUND 1.0
    Plants vs. Zombies 2.2
    Flowercraft 1.6-1.6.2
    WildCaves3-0.4.3

    Also, we have an HDMI Ethernet cable, is it possible to connect this to each other and bypass any wireless server issues? If so, how can we set it up?
    Posted in: Java Edition Support
  • 0

    posted a message on [1.7.2][1.6.4][FORGE] Plants Vs Zombies Mod
    Issue: The 2.2 version for Minecraft 1.6.2 doesn't work for multiplayer LAN servers...is this supposed to be?
    (I downloaded 2.2, since crafting recipes in 2.3 don't seem to work)

    We both downloaded the same version (2.2) and I host. On the other computer, it states that the various item ID's (791, 777, etc) are missing from mod CountryGamer etc. and they can't join in. But they have the same exact mod.

    How can I fix this?
    Posted in: Minecraft Mods
  • 0

    posted a message on Mod item ID number change?
    "java.lang.ArrayIndexOutOfBoundsException: 10015"

    What is this?
    Posted in: Mods Discussion
  • 0

    posted a message on Mod item ID number change?
    Thanks! Now time for tons of trial-and-error...yay... :P
    Posted in: Mods Discussion
  • 0

    posted a message on Mod item ID number change?
    Hey guys, me again.

    I posted a while ago about adding mods, and I've since added 15 or so to Minecraft, but now I'm running into an issue...new mods I install can't coexist with others.

    Some of the items' decimal/hex/binary numbers match with other items' numbers, which, obviously, can't happen, and the game follows suit and crashes on startup.

    Is there any way I can edit certain items' numbers so that they won't clash with others and would result in them both being in the game? I believe the numbers are stored somewhere in the .class files, but I could be wrong.

    Thanks! :)
    Posted in: Mods Discussion
  • 0

    posted a message on Failing at adding mods...
    Ok, so like I said, I have the Miner's dream mod. I also have the Herobrine mod, however there's a problem with it...

    I make the totem thing for Herobrine, summon him, and the chaos ensues. But a few seconds in, the game crashes. Is there anything I can do with graphic adjustment or anything to keep the mod from crashing?
    Posted in: Discussion
  • 0

    posted a message on Failing at adding mods...
    So what I'm reading from this:

    I'm gonna install a 1.6.2 Forge for 1.6.x mods, and Aether II is not updated to a 1.6.x mod yet, right? So I have to wait for them to update it? But I've seen on YouTube a bunch of titles that say the current Aether works with this Minecraft version...


    I have gotten Miner's Dream to work on it. Can I mix mods together into one file without having to worry about any overwriting?
    Posted in: Discussion
  • 0

    posted a message on Failing at adding mods...
    Hey guys.

    I've been on and off trying to add mods on my Minecraft (1.6.2) for a month or so and I have decided that I want the Aether II mod.

    The problem is, every tutorial I follow makes me want to pull my hair out at the end when it crashes. I download Forge, I put it in, etc., and it won't work. So this is why I'm coming here.

    I've "reset" my .minecraft folder to its original state. Now I need somebody (or somebodies) to help me in a VERY DETAILED, STEP-BY-STEP tutorial on how to install Forge and ultimately get the Aether II mod (a general overview on how to get other Forge mods afterwards would be nice, too, lol!)

    ALSO: I would like to know how to make an Aether server. I think that downloading the Forge server is the same as the client.
    Posted in: Discussion
  • To post a comment, please or register a new account.