• 0

    posted a message on Davincis Vessels (Previously Archimedes Ships Plus) - Move Your World | 1.12 Released!

    Accidental Double Post. Crappy internet.

    Posted in: Minecraft Mods
  • 0

    posted a message on Davincis Vessels (Previously Archimedes Ships Plus) - Move Your World | 1.12 Released!
    Quote from darkevilmac»

    I've been looking a little bit at some CoFH libraries and they seem to have some things for rotation values. I can only hope that in a future version of minecraft rotation will be a little less metadata based but I doubt that would happen. At this point it's really a matter of having to sit down and get all the metadata values for each rotation (long, painful, and can change with each version). I would like to automate this to some extent with CoFH mods if possible but I don't want to have too many dependencies.

    I haven't yet spent much time learning how minecraft's code works, much less regarding rotation of blocks, but I had an idea of a way to automate the process a bit for Archimedes' Ships that might not require manual mrot lists.


    During the assembly phase of making a ship, I assume the script has to run a check of each block, and identifies ones on the vanilla mrot list to keep track of their initial rotation, and adjust it on the dis-assembly phase to match a change in the ship's rotation (correct me if I'm wrong).


    If this is the case, might it be possible to have the assembly code flag any blocks that aren't vanilla, and then check to see if meta-data variations for it exist. This is of course assuming that standard blocks that are the same on all sides don't have rotation data, since regardless of what angle they're placed at they all lay in the same direction. If the difference between blocks with meta-data and those without can be detected, then the code can automatically add mod-added blocks with mrot data to the list.


    The only remaining hurdle then would be if the mrot data needs to be set up in a certain order, but I would 'assume' that if say, turning it 90 degrees clockwise turned the mrot from 2 to 1 in a vanilla block, then in a mod-added block the same change would follow similar rules.


    This all of course assumes that there's a way to check for said data in the first place, so if this is impossible then by all means let me know, and I may be able to think of other possible ways. I just don't have the time yet to learn minecraft or Forge's code limitations while learning C# for college projects. ^_^;

    Posted in: Minecraft Mods
  • 0

    posted a message on ChickenBones Mods
    Quick question, which may likely be answered and I'll keep looking myself, through these 946 pages of this thread (x_x), but on the off chance that someone knows, I'm asking.

    Versions: Minecraft 1.6.4, Wireless Redstone1.4.0.7:

    Problem: After restarting the server, none of my receivers activate. They've all retained their frequency number and names, but unless I manually change their freq. and then back, they don't work. Possibly have way too many in one area, but I'm not sure what's gone wrong here.

    Background: I set up a complex 7x7 map table system using wireless transmitters and receivers that allows players to select a row and column. Each has a transmitter on it's own frequency, which with the help of some Project:Red AND gates, the receivers will illuminate the appropriate map section, then with some more AND gates, pressure pad, command blocks, and some more wireless wonderfulness, the players can teleport to any section of the world map in increments of 512 blocks.

    Upon setup and testing, everything worked perfectly. The server's got a scheduled restart every 4 hours. After the server restarts, the receivers no longer function, despite having all their frequency numbers and names visibly fine. If I adjust them up and back 1 point, they work again, but I have to do it manually, and there are 15 transmitters going to 196 receivers in a small hidden area under the map..

    Considering replacing it all with Rednet if I have to, but it took hours to set it up the first time... ~_~;
    Posted in: Minecraft Mods
  • 0

    posted a message on [Forge Multipart] ProjectRed - v4.7.0pre12.95 - 02/08/2016
    Also getting the same crashes.
    Troubleshot by selectively removing all other mods I had running and parts of Project Red. Only Base, World, and Lighting run together.
    -1.6.4 with just forge 9.11.1.965
    -Multipart installed by PR.
    -Code Chicken Core 0.9.0.7
    Soon as you add Mechanical, Integration, or Compat it crashes in various ways during initialization.
    Rolling back to V4.2.0.14 for the time being, but looking forward to more from you guys though. ^_^
    Take your time and keep up the good work!
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.6.2][SP/SMP] Marcopolo's Mods: Better Ore Distribution(v2.7.1 beta), Trap Friendly Cactus, and Practical TNT
    Quote from LordBlackHole

    Yea I've thought about that. The problem is that I couldn't just backport Geocraft, I'd have to do the same for Chemcraft Core, and then I'd have to do it for Snowfall also, and so on. Maybe.


    Understood. I don't yet know all the work it takes to make a mod backwards compatable, but I'm sure it can be quite taxing depending on the degree of change between MC versions' code if just updating mods is as difficult as it is. Regardless, my server's mainly waiting on Thaumcraft to update, which from what I've seen will break/reconfigure most of its current functions anyway, so working toward 1.6.2 now may be in my best interest anyway. :P

    I'll give it a shot, see how it runs alone and with as many of the updated mods as I care to use, and let you know what I find.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.6.2][SP/SMP] Marcopolo's Mods: Better Ore Distribution(v2.7.1 beta), Trap Friendly Cactus, and Practical TNT
    Quote from LordBlackHole

    Alright, my rewrite is ready for testing.

    Geocraft is my own mod that adds three new kinds of stone, but that was it. I decided to just write my own Better Ore Distribution style gen code there, using some of what I wrote for BOD, but mostly doing it all myself.

    You can think of it sort of like BOD 3.


    Great! I would love to give it a test and you the thorough feed-back I'm sure you're looking for, should any issues arrise. ^_^

    Although, having checked your pages for download versions, is there any chance you might retro compile it for 1.5.2? Most of the major Mods I run on my server haven't yet updated to 1.6.2, which is disheartening with 1.7 on the horrizon, so we've been stuck with 1.5.2 till they catch up.

    If not I'll still give it a good run through so I have it ready for when we do update the world to a newer Minecraft.
    Posted in: Minecraft Mods
  • 0

    posted a message on [1.6.2][SP/SMP] Marcopolo's Mods: Better Ore Distribution(v2.7.1 beta), Trap Friendly Cactus, and Practical TNT
    Hello LordBlackHole and Marcopolo!

    I've been doing some testing to try to help hammer this issue out, as I'd -REALLY- like to use this mod. (FYI I'm not yet versed in code, so I won't pretend to be.) I'm using the following:

    - Minecraft 1.5.2 + Forge 737
    - BOD 2.7.1 Legacy Version (Downloaded as .jar.zip, removed .zip and put in the Coremods folder as instructed)
    - Optifine and a couple UI Mods + an X-ray mod to tune the BOD Config. (nothing that effects terrain generation)

    When a new world is generated with this setup:
    - the BOD folder and configs generate in the Config folder as expected.
    - Worlds generated on Default or Large Biomes have no trees.
    - Default Ores are nowhere in sight, even after extensive searching the biomes they're set to generate in (according to the BOD-biomes-mine[1.1].txt) -EXCEPT- emerald, which appears to spawn by default Minecraft in evenly dispersed veins of 1 or 2 below height 35.

    The default rarities of mines seemed ridiculously high (50 for Dirt, Gravel, and Silverfish blocks, 75 - 160 for all else) in comparison to the "How to edit the Config" guide on the OP, which quotes the effects of 1 - 10. So, I closed the game, adjusted Lapiz(ID 21) rarity in both configs to 2, saved, restarted Minecraft and re-created the same world. Exploring the nearby ocean yielded no change, and no Lapiz.

    Next I built a Nether Protal, keeping above constant. Within 200 blocks or so exploring with the X-ray I found a few veins of Quartz formed as I would expect from BOD, suggesting it's working in the Nether. Exploring the Nether BOD-Mine[1.1].txt versus the Overworld version, the only differences were that UseMarcoVeins was true by default for Quartz in the Nether, and not for the Overworld, and BOD-Overrides.txt was generated in the Nether, but not the Overworld Folder.

    Closed MC, set all UseMarcoVeins to true in Overworld BOD-Mine.txt except SilverFish blocks, and no change. Still no ores, no trees in sight, save Emerald which is still generating in default MC manner. A quick trip to the Nether, the Quartz is still spawning fine in BOD style.

    Finally, just for S&Gs, I added Biomes O' Plenty. To my surprise, all ores were generating in BoP biomes as they should by BOD rules, and BoP trees were generating without issue. But in any Default minecraft biome in a BoP world, still no ores or trees. Go figure.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from Harushimo

    I have an exceedingly simple question I can't for the life of me find the answer to:

    -Where do I find the Forge, GUIApi, and Custom Mob Spawner version requirements for previous versions of Mo Creatures? (Specifically I'm trying to get MoC 5.1.5 working on Minecraft 1.5.1)

    It's not on the Wiki, not in the Readme of previous Versions, and I've already spent a few hours backtracking through the couple thousand replies on this thread. Any help would be GREATLY appreciated, especially if some fabled requirements history exists and I'm merely lost.


    Well, I finally found an Installation video for Mo Creatures on MC 1.5.1. Thanks to that, I now know that on Minecraft v1.5.1, Mo Creatures v5.1.5 will work if you have:
    - Forge v7.7.1.611
    - Custom Mob Spawner v1.12.5
    - GUIApi v0.15.4
    I'll check with newer versions of Forge if the other mods I run need an updated version, but I couldn't get Mo Creatures 5.1.5 working with the last Forge build for MC 1.5.1 for several hours, and now I'm back on Forge 7.7.1.611.

    On that note, maybe something as simple as "Last known working builds" under the previous versions listing for Mo Creatures would be VERY useful.

    [EDIT: Tested with Forge v7.7.2.682 and Working. Seems any other Custom Mob Spawner version will cause a crash and/or freeze at "Building Terrain" upon world generation, depending on which version combinations you try.]
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    I have an exceedingly simple question I can't for the life of me find the answer to:

    -Where do I find the Forge, GUIApi, and Custom Mob Spawner version requirements for previous versions of Mo Creatures? (Specifically I'm trying to get MoC 5.1.5 working on Minecraft 1.5.1)

    It's not on the Wiki, not in the Readme of previous Versions, and I've already spent a few hours backtracking through the couple thousand replies on this thread. Any help would be GREATLY appreciated, especially if some fabled requirements history exists and I'm merely lost.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from bloodshot45

    Yes, I made a mistake regarding CustomMobSpawner. By default, all custom entities other than mocreatures will spawn via vanilla spawner. The moment you assign a biome group to a custom entity in MoCProperties.cfg, CMS will take over and remove the spawn list entry from vanilla.

    As for the bug with Twilight Forest, there were a few things on our end preventing spawns. This has been fixed and will be included in next update. I have also added a new biome group "UNDEFINED" which will now contain any biome that is not added by us.

    MoCBiomeGroups use the "biomeName" var which is assigned by the mod authors. The new UNDEFINED group will be populated with the names you need to use.


    Thanks for the info. I'll be looking forward to the new version then, but by all means, take your time. I know how stressful it can be to have hundreds of random people on the internet rushing you to get the next the version out of something you do for free in your spare time. ^_^

    Keep up the great work, very much appreciate the responce, and no rush. It's not game-breaking.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mo' Creatures - v12.0.0 for Minecraft 1.12.1!! Now Opensource!!
    Quote from bloodshot45

    ...For the time being, you will need to create a new biome group in MoCBiomeGroups.cfg with the Twilight Forest biomes then add this group to the TF entities in MoCProperties.cfg.

    Since this is obviously a tedious way of customizing non-moc entities, I have altered how this works in my current dev version...


    Hello Bloodshot45,

    I run a Server with KasumiNaito, to whom you replied about the issue with Twilight Forest, and I just wanted to clarify the problem. All creatures that should spawn in the Twilight Forest mod do so normally, as though no other mob-adding mods are active.

    The issue we're having is Mo' Creatures entities will not spawn in the Twilight Forest. The normal creatures for Twilight Forest spawn there fine, but nothing else (from Mo'C. or other mob-adding mods), and we were wondering if there was a way to get Mo' Creatures entities to spawn in the Twilight Forest?

    We've added THETWILIGHTFOREST as a group in the MoCBiomesGroups.cfg, and added each of the Twilight Forest biomes (As shown in the Twilight Forest Config biomes secion) to each of the closest biome groups (Lake added to River group, TwilightForest added to Forest Group, etc.).

    We've also gone through the MoCProperties.cfg and added THETWILIGHTFOREST group to each entity we wanted to show up in the Twilight Forest. Unfortunately, it doesn't seem to have worked.

    If you have any suggestions, I'm all ears. I'll keep messing with it untill then. :P


    Edit: Additional question: Will the biomes groups accept # biome ids? Example:
    TwilightForest.cfg

    Biome {
    I:biome.id.Clearing=79
    I:biome.id.ClearingBorder=80
    ....

    Should we use "Clearing" or "79" under Biome Group NORMAL in the MoCBiomeGroups.cfg?
    Posted in: Minecraft Mods
  • To post a comment, please .