All users will need to merge their Minecraft Forum account with a new or existing Twitch account starting October 23rd. You can merge your accounts by clicking here. Have questions? Learn more here.
Dismiss
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from wiiareonfire »
    Nobody can connect through the ipconfig address... Either way... here are the two Simpleserver property files.

    The console output would be nice too, but SimpleServer is configured fine. Did you open the ports on your software firewall?
    http://devfluid.com/simpleserver/index. ... _server.3F
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from wiiareonfire »
    I've stopped Hamachi, forwarded the two ports (rather, 25000 to 26000) between my firewall and my IP that's found in "ipconfig."
    Double and triple checked settings, but nobody can join without using the Hamachi address.
    I "RTFM", and all readmes, and just about every scrap of data there is, but nothing is going through.

    Can you connect to the server using your "IP that's found in "ipconfig""? If so, you have a router/networking issue and not a SimpleServer issue. Otherwise, you still need to post the information requested in the FAQ...
    http://devfluid.com/simpleserver/index. ... _errors.3F
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from dalek42 »
    In a working dedicated simpleserver/minecraft server (CentOS/linux, dedicated IP), the new GI .jar has problems when a user attempts to login. The console displays the connecting IP, and then nothing.. no errors, no log entries, no disconnect... The client just sees a long wait until a timeout occurs.

    Please pastebin the full console output. You appear to be describing a vanilla server login bug. The problem is that SimpleServer exacerbates the issue by giving the client 30 seconds to timeout. While the client is timing out, it can't reconnect and the server can't be shutdown.

    I am not sure of the best way to fix it, so please take a look if you have a chance. :-)
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from raffletime »
    Alright, so I've got a problem.
    ...
    >> Starting SimpleServer 7.0-stable-fc75711

    This version is not compatible with Minecraft Beta 1.3. You need the development version.

    A summary of changes since 7.0 is available here.
    https://github.com/GICodeWarrior/Simple ... er/CHANGES
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from Server557 »
    Currently SimpleServer Wrapper 7.2-dev-4c78333, isn't working with CraftBukkit (CraftBukkit - Development Snapshot (21 February 2011, 20:10GMT) )

    Commands aren't being entered into the console whilst typing, after everything is started up and running (seemingly fine, with no errors). When hitting enter, I get the error that the command that I typed isn't recognised (incase it was some issue that hides the entered commands).

    EDIT: (using the right pastebin URL this this...)
    Pastebin: http://pastebin.com/feAUcUse


    It looks like they added an interactive console.
    https://github.com/Bukkit/CraftBukkit/c ... 2aa119d42f

    This completely breaks integration with any console wrapper, including SimpleServer. I left a note on the commit to see if they intend to provide standard unix-type fallback behavior, but I won't hold my breath.

    SimpleServer is abstracted enough that someone could write a handler for the new CraftBukkit interactive terminal without changing much of the existing code, but it still won't be trivial.

    I don't have enough time in the near future to work on this, but if someone else is interested, I can certainly help you get going.
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from Pathia »
    For some reason, for the last few versions in fact, when I type in the window, there's no sign of the input. I have to type blind essentially. It lets me enter commands, but it never shows up in the window until I hit enter.

    This is a known issue with SimpleServer on Windows since Minecraft Beta. I have looked into it a bit, but I haven't been able to track down the issue yet. If anyone is up for the challenge, we would be glad to have a patch that fixes this. :-)
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from shadow386 »
    Quote from GICodeWarrior »
    I have uploaded a new development version that includes all the contributions and fixes necessary to get going again (if you aren't already).
    https://github.com/downloads/GICodeWarr ... Server.jar

    Tis the working version for 1.3_1?

    The latest Minecraft server version is 1.3 AFAIK, but if there is a 1.3_1 I am unaware of, it probably works with that too.
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Thank you for your patience everyone. In addition, thank you those who have stepped in to help out. :-)

    I have uploaded a new development version that includes all the contributions and fixes necessary to get going again (if you aren't already).
    https://github.com/downloads/GICodeWarr ... Server.jar

    I haven't had a chance to go through and verify all of the commands and features on an individual basis, but most things should work. If you find that something isn't working, please read the FAQ on the wiki first, before posting here. If your questions are not answered by following the FAQ, please include all of the information described in the FAQ with your question here.

    Sorry for the delay, but thank you for sticking with it!
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from iBotPeaches »
    I started looking at way the instant block didn't work, and I caught onto this code quicker than I thought.

    Minecraft 1.2 and prior destroyed blocks after a certain number of hits. I heard another developer say 1.3 does it based on time-elapsed (thus making idbehod useless), but I have not tested it.

    You can run SimpleServer from Eclipse and use the Eclipse debugger. Also, "!rcon restart" restarts the minecraft server, not the wrapper.

    I am not available to work on this until Monday, but I have not abandoned the project. Thank you everyone who has stepped in to help out!
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from SirH3nry »
    So what happens when the minecraft client and/or server client are updated? (For example the MC Beta 1.3 is coming out soon) Will simple server be updated ever? Does it even NEED to be updated?

    Every time the network protocol is updated, SimpleServer needs to be updated. Not every release has protocol changes, but the next release probably will.
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from wicax »
    one question how come the lock feature doesnt work my friends can take the stuff and how do i boosts someones rank because the set rank command doesnt work

    Looks like two questions to me. :-P

    Stand on top of your locked chest and use the !gps command to get your location. Compare that location to the one in chest-list.txt. If they aren't close, that isn't your locked chest. Also note that you can only lock a single-wide chest.

    You can !setgroup players as high as 1 group level below you. (ie. Admins can create Mods and Owners can create Admins) If you want more than that, you can edit member-list.txt and use the !reload command to activate your changes.
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from gladi099 »
    i run it in screen? so thats the server log

    edit: found the log directory - what log do you want? admin or all of the 3?

    You have to copy the console output or tell screen to log the console output.
    http://www.gnu.org/software/screen/manu ... ml#Logging
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from gladi099 »
    Server Log: http://pastebin.com/rkkyqyEp - from line 1240 to line 1323 pastebin for that part of the log: http://pastebin.com/kDpzPdPv

    These do not contain the messages from SimpleServer. You have to copy the console output.
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from Jandalf »
    1. when i type in the console the text appears only when i press enter...

    This is a known issue on Windows. I haven't managed to figure out how to fix it yet.
    Posted in: Minecraft Tools
  • 0

    posted a message on [Software] SimpleServer Wrapper RC 7.0 [1.2]
    Quote from Blobftw »
    How do you use a backup?
    Server got massively destroyed (by me D:) and need to use one. How do i do it?

    EDIT: I'm on a VPS, does that make a difference? I am currently guessing and right now I have moved a backup to my pc, extracted it and now putting it back up. Thing is its estimated time is 4 hours because the map is so big... am I doing it right?

    If you have SSH you can unzip it on the server.
    $ mkdir restored-world
    $ cd restored-world
    $ unzip ../backups/<backup-name>.zip
    $ cd ..
    $ echo levelName=restored-world >> simpleserver.properties
    $ ./launch.sh


    If you don't have SSH, or don't understand what I am saying, what you are doing now should work.
    Posted in: Minecraft Tools
  • To post a comment, please or register a new account.