• 0

    posted a message on My kids are begging for mods

    Basic question: Is version 1.8.9 too new for mods my kids are asking for?


    My kids are begging for minecraft mods. They asked for pixelmon and some other stuff. I installed Forge. I tried to test a mod by downloading the mocreatures mod and then downloaded the recommended links with it. It didn't work. I tried another API and it gave me a crash report. So I am not sure what I'm doing, but I want to help them out. It seems the version of minecraft we have is very new and it might just be that this version is too new vs something like 1.7whatever had 1200+ mods on the mod list.

    Posted in: Mods Discussion
  • To post a comment, please or register a new account.