• 0

    posted a message on Legend of Argon - by Draco Rogue
    Quote from SuchParadoxon»

    The only issue I had with the final area was that the boss spawned in again after some time.By the end of the battle there were 3 copies of the boss, plus the original. I did manage to kill it, then grab the wool and run but it was a pretty damn intense.


    Dang, didn't seem like it worked then.


    What version were you playing on if I may ask?

    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue
    Quote from coolfool8888»

    Will the next map be sky islands or caves? Either way very hyped to play it :)


    It will be a cave area so I can use natural spawns which in LoA I can barely use due to no space for darkness in skylands. There will be new area gameplay concepts and items using command blocks (I will be using a wide variety of spellbooks too ;) ).

    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue
    Quote from Ceie»

    I think it is a mac - issue. For some reason apparently mac really likes java 1.6. After doing a lot of internet research I FINALLY found a site that shows me how to find the actual location of Java 1.8. So - so far - the solution to the problem seems to be this - (in case someone is having the same problem of minecraft on mac defaulting to java 1.6)


    1. Go to system preferences

    2. Find the Java folder

    3. Click where it says "Java" (for me it is between "update" and "security")

    4. It should say "View and manage Java runtime versions.. etc.." Click "View")

    5. It shows you the path of the 1.8 java version - copy that - manually if you have to.

    6. Open the minecraft launcher and the profile editor.

    7. Click the "executables" box and replace the current path (for wrong java version) with the one you just copied.

    8. Run minecraft. It should work if you copied the path correctly.


    Anyway - it seems I am now running an updated Java version and indeed the map does not seem as laggy as before. I did die 2 times as a result of silly lag - and me rushing in to try to secure my items before things respawned around the orange wool box. Anyway. This seems difficult so I doubt the current death count of 4 will stand for long.. But at least now I might actually be able to play the map as intended. And I really would like to give it a shot as it looks dam awesome :D


    Awesome! Hope you enjoy the map, good luck :)

    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue

    I love the map!! God job!!


    Quote from smuggle»

    Really really really good map, you killed me 3 times ;) one of my favorite maps. Thank so much Mr Draco !!!


    Quote from SuchParadoxon»

    Ello everyone, just finished the map, took me about 24 hours in total and I died a total amount of 2 times( 1. Getting killed by tree guards in Ruins of Wonder, 2. Getting absolutely rekt by Marble Guardians in Temple of Legend) The map was fantastic gameplay wise, aesthetically stunning and well balanced.Loved all the costum items, especially the knockback sticks.Plus because most of the map was over void it kept me on edge 24/7 especially near the ending areas. Really looking for whatever map you make next Draco :D

    Also victory pic:



    Thanks guys! Congratulations for completing it :) How did you find the last wool, did it work properly in your playthroughs?


    By the way, I have indeed made a few areas in the next upcoming CTM [5 areas made so far], here's a few screenshots:



    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue
    Quote from MrBusaa»

    I've just finished Legends of Argon, is there another map? It says "Maps" and "Vault of Adventures, a series of combat-intensive maps!" insinuating there are more than one? Are there more?


    I'm planning a new map which will introduce new mechanics, have better aesthetic features. However, before Legends of Argon, I did release a (severely outdated) CTM named 'Lands of Desire II' for Minecraft 1.5.2.

    Quote from Ceie»

    Hmm I may have a idea what is wrong. This is the screenshot:

    http://imgur.com/NuZNwL0

    It says I am still using Java 1.6. I did install 1.8 but it seems that the minecraft launcher defaults to the 1.6 version that is still on my mac. I tried deleting 1.6 but then I couldn't run the launcher at all. I checked ways to force the launcher to use the 1.8 java version, but I just don't get it - or the things I have tried just don't work.


    It's definitely not the map as it's not causing many chunk updates. On the note of Java, my launcher is using v1.8.0_51, so I'm not sure why it only works for the old version. You uninstalled 1.6 completely and the launcher wouldn't work?

    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue
    Quote from Ceie»

    I updated java to 8 and installed Optifine too. And assigned 4G ram to minecraft. Still having a lot of lag. Rubberband type where suddenly everything freezes and next thing time is sped up by 3-400%. Or I mine blocks and am "teleported" back in time. I don't get it. I could play even the final areas of Ragecraft 2 without this kind of lag. Anything else I can do to help this? Or does it clear up as I get further away from the spawn chunks?



    Huh, can you get a screenshot of the f3 bar when all the chunks have been loaded?

    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue
    Quote from UnknownBnm»

    Thanks... but this made it even more unplayable. In the file I sent you, I was fully geared in I2. I ended up in the hub in creative mode with no items. I went to I2 and the lag was so bad I had to force quit MC. It's fine.... I'm just too lazy to restart the map. i'm sure it's an awesome map, and I loved the gameplay up to I2. Unfortunately, the map ended up having too much lag for me, so I'm gonna do a fly-through. Thanks for the effort though.


    Damn, that's a shame. I'm really sorry for the lag, this time I don't know what it is. Also it is my mistake that I must have deleted the inventory. It seems like this map has a lot of mistakes and I will need to move on to the next map, and learn from this.

    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue

    https://drive.google.com/file/d/0B-6sZKyYG85RSkZCbjZ4eFBjU3c/view?usp=sharing

    Here you go. I'll remove the link after you've downloaded it. Hopefully nothing goes wrong with this file :P

    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue
    Quote from TheEpic5MC»

    How do I download the map using the google drive link?


    If you access the page, you will see a download icon (arrow pointing down at the line) at the top. Click on it, and it will bring you to a new page. Press 'download anyway'.


    @UnknownBnm

    I will send it to you when I have the time. However it might (?) not be today.

    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue
    Quote from UnknownBnm»

    :( I guess I'm done playing then. Already spoiled so much of the map that it would be a bore to play again. @Draco What can i do to fix that in my version?


    Perhaps I can input your equipment into the updated map, send me screenshots of your wool, emeralds, equipment etc. Tell me what areas you've finished.

    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue

    If anyone is playing from version 1.0 to version 1.1, give yourself one emerald piece. One of them is not in the map if I remember correctly. The fix is here, 1.2.0 (and if you do manage to find it; let's say it's an extra piece ;) )


    https://drive.google.com/file/d/0B-6sZKyYG85RMXgtbVplb1ltVEU/view?usp=sharing

    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue
    Quote from 1darklight1»

    Well. I played new version and found out something unexpected. And found cause of lag in my pc. After i got lag again and looked at what was eating most of CPU i found weird thing. There was two of jawaw.exe, both of them was greedy for cpu. O_O So i found which one was for minecraft and closed another. Done. No lags in your map, because cpu got free from overworking. Why there was second jawaw.exe i have no idea.

    Anyway. Thanks for help and sorry for inconvenience. Case solved for me. Now i can enjoy this map :D But I wonder what was the cause of lag was for other guys.


    I still think that the main reason for the lag was the amount of chunk updates in the spawn chunks. That chunk is always loaded and there's a problematic redstone clock that updates the light level constantly. That causes most of the lag.

    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue
    Quote from csarpaul»

    I can confirm it was notRAM usage I looked at, it was the C* option in my f3 screen.



    Quote from 1darklight1»

    Well. I dunno. Here is picture where i check chunk updates. You have another screen while use f3?


    I hopefully fixed the command block lag, from ~100 chunk updates every second to ~0 (if rendered chunks are already loaded). I added a new chunk spawn and compacted the redstone. If you are able to, please open the map to test if the lag is still there?

    V1.1.0 - https://drive.google.com/file/d/0B-6sZKyYG85RSVBKUEJJT0F3NTQ/view?usp=sharing or

    http://www.mediafire.com/download/ga4g3efdz0falec/[CTM-2] Legends of Argon v1.1.0.zip

    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue
    Quote from 1darklight1»

    Well. I join you guys. I also have lag. CPU is loaded up to 99-100%. probably too much of command blocks for my pc. (i dunno if it could be that some command block is broken and eats up all cpu)



    Quote from csarpaul»

    Exactly! At least I'm not alone. ;-; I tried gm1 to fly through and load surrounding areas and landing in them testing the lag there and it's everywhere for me.


    Alright, I think I have discovered the main problem. If you open up f3, do you get a lot of chunk updates?

    Posted in: Maps
  • 0

    posted a message on Legend of Argon - by Draco Rogue
    Quote from UnknownBnm»

    Yeah, I'm getting lag too. Say there's a skelly. Game stops: I hit the skeleton and then 5 seconds later it goes flying.... OR: Game stops 5 creepers and 2 zombies around me: 10 seconds later: I die.


    Does this happen everywhere in the map or in some select areas?

    Posted in: Maps
  • To post a comment, please or register a new account.