• 0

    posted a message on [HELP] Scoreboard commands

    So the problem is fairly simple. (In Minecraft version 1.11.2) I'm typing the following command into a chain of command blocks: "/scoreboard players add @a[score_zhonya_min=1] bset 1" (With zhonya and bset both being dummy objectives.) However it says: "Selector '@a[score_zhonya_min=1]' found nothing" even though my zhonya is indeed set to 1. Any help is appreciated.


    (Edit: Nevermind I've solved the issue, if anyone could delete this post I'd appreciate it.)

    Posted in: Commands, Command Blocks and Functions
  • 0

    posted a message on [HELP] Testfor Tamed Wolf's Owner?

    So I'm making this contraption that uses a wolf as an input. Basically I want to test if a mob is near a wolf (that is tamed) and send an output (e.g. a noise using /playsound) to ONLY the owner of the wolf. I've gotten the mob and wolf detection part down but I don't know if it's even possible to testfor and send an output to the wolf's owner. Help is very appreciated. Thank you!

    Posted in: Commands, Command Blocks and Functions
  • 0

    posted a message on [Help] Detecting and Killing Entities in a Certain Radius.

    I'm trying to kill any arrows in a certain radius of the player. Is there any way to do this? (in 1.10+)

    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on Testfor Player with Enchanted and Named Armor.
    Quote from Skylinerw»


    You don't need to change anything. Any data you don't specify will just not be looked at.



    Hmmmm weird. Whenever I dye the leather boots cyan (or any color for that matter) it stops working.


    Edit: Nevermind. I dyed my boots and it still worked. Weird, It didn't work before. But now everything works so thank you so much for the help!

    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on Testfor Player with Enchanted and Named Armor.

    Another question: I want the leather boots to work with any color but whenever I dye the boots it doesn't work. Is there anyway to specify in the command that the boots can be any color?

    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on Testfor Player with Enchanted and Named Armor.
    Quote from Skylinerw»

    Under normal circumstances (enchanting), the "id" and "lvl" tag for enchantments are saved as a short, while you've specified them as an integer. If they were created by enchanting, you'll need to specify the correct datatypes:

    /scoreboard players set @a Swimming 1 {Inventory:[{Slot:100b,id:"minecraft:leather_boots",tag:{display:{Name:"Swimming Shoes"},ench:[{id:8s,lvl:3s}]}}]}


    Keep in mind that if you provided the item with commands, the datatype won't be corrected to short and will remain as whatever datatype you specified.


    Thank You!
    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on Testfor Player with Enchanted and Named Armor.

    I'm making a swimming concept in minecraft and I wanted to add a score of 'Swimming' 1 to the player if they are wearing leather boots named: 'Swimming Shoes' and with the enchantment: Depth Strider 3. So I put this command: /scoreboard players set @a Swimming 1 {Inventory:[{Slot:100b,id:"minecraft:leather_boots",tag:{display:{Name:"Swimming Shoes"},ench:[{id:8,lvl:3}]}}]} Whenever I wear my leather boots (named: 'Swimming Shoes' and with the enchantment: Depth Strider 3) however the command block output says: The dataTag does not match for bankflame. Am I doing something wrong?

    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on [Help] /replaceitem bug?

    I have tried to use the /replaceitem and use it on a player with a certain scoreboard objective (e.g. /replaceitem entity @a[score_Swim=1] slot.armor.chest minecraft:elytra) Unfortunately this doesn't work for me. It keeps giving me an elytra even if my score of 'Swim' is 0. Am I doing something wrong or is this a bug? Please Help.

    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on [Help] Clear Offhand
    Quote from jtpetch»

    Using /replaceitem with slot.weapon.offhand should work. Or, yes, Sylis is right, it's id is -106


    I have tried /replaceitem but I'm trying to clear the slot rather than replacing the slot with an item.
    Quote from shtnvs»

    /replaceitem entity @p slot.weapon.offhand minecraft:air


    I don't mean to sound rude, but I don't understand why everyone thinks minecraft:air is an item. Air is a block not an item.
    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on [Help] Clear Offhand

    I want to clear the offhand slot of a certain item (in this case a porkchop) with a command(s). I have tried the /clear command but it doesn't detect items in the offhand slot. I've also tried /replaceitem but I haven't found a way of replacing the offhand item with nothing. I've also tried both of them combined but none of that has worked. Thank you in advance for all the help!

    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on Need Help With a Time Detector

    Ok this works fine, but is there any way to make it more compact? If not this design works ok too.

    Posted in: Redstone Creations
  • 0

    posted a message on Need Help With a Time Detector

    So I was trying to find a time detector on YouTube to make a compact time detector that will send a signal when it is midnight (or time 18000 in Minecraft) but I couldn't find any. I wanted to know if there was a compact way of doing this that anyone knows or has a video of. All help is much appreciated!

    Posted in: Redstone Creations
  • 0

    posted a message on Minecraft Won't Load Data (Can't think of anyway better to describe it)

    So recently today I wanted to copy a build from one Minecraft world to another so I opened two games at once and started copying my build. Once I successfully did and exited Minecraft I came back to improve my build and I spawned somewhere else. I improved my build slightly and shrugged the spawning problem off as a "It will probably go away next time I log back on." But the next time I did log back on It spawned me in the same place with all my improvements gone. Also sometimes (50% of the time) I log on it gives me lag spikes every couple seconds. Another thing is that whenever I try to delete a file or move a file into the .minecraft folder it gives me to error 'Invalid MS-DOS function' (this only happens when I do an action in the .minecraft folder.) One last thing is when I load my world and then exit out of it the world doesn't move up to the top in the singleplayer world list as it usually does. I don't know if all these problems are associated with each other but they ARE definitely a problem that I need help fixing. I Thank everyone in advance for taking their time to help me.

    Posted in: Java Edition Support
  • 0

    posted a message on Testfor Players In The Air?

    I was wondering if you could testfor a player that was in the air or using the new Elytra using a tag or a testfor or a scoreboard or something else. If this is possible in the 1.9 snapshots could you tell me the command? Help much appreciated!

    Posted in: Redstone Discussion and Mechanisms
  • To post a comment, please or register a new account.