• 0

    posted a message on OptiFine HD (FPS Boost, Dynamic Lights, Shaders and much more)
    Having a major problem with OF HD_U_D4 that doesn't occur in the previous version. If I change any setting that re-renders chunks, the chunks don't re-render properly, instead they appear invisible. The only things visible are entities and particles. I can still walk fine, so it's not the more serious type of chunk error where world chunk data doesn't load at all.

    Two examples on how to reproduce it are, changing certain graphical detail settings, or changing the texture pack through the in game menu.



    Motherboard: ASRock Z77 Extreme4
    CPU: Intel Core i5 3570K, 4 GHz
    RAM: G.Skill Ripjaws X 8GB (2x4GB) , 1.6 GHz
    GPU: XFX Radeon HD 7870 Black Edition, 1.05 GHz core, 1.25 GHz memory (5 GHz effective)
    OS: Windows 8 Pro x64
    Java: version 7 update 9
    LWJGL: 2.8.4
    Posted in: Minecraft Mods
  • 0

    posted a message on Understanding a Minecraft Computer!
    Quote from DarkVegito

    Ain't I building the HACK ALU, I thought Ralath0n said that this was the HACK ALU Architecture.

    Hm, I never remembered Ralath0n recommending you build a HACK ALU... *goes looking through all the pages again*
    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on Speedtest.net Results and General Internet connection and ISP Discussion
    Mines pretty bad. I do however have access to 100Mbps speeds at the TAFE college I study at. It's amazing how fast it is compared to my home connection.

    Posted in: Computer Science and Technology
  • 0

    posted a message on Understanding a Minecraft Computer!
    Quote from DarkVegito

    @AlphaHusky: I haven't made any other ALU, so do you mean that other ALU designs are much more complicated and messy?


    No, he means that that there are ALU architectures superior to the ALU design you're building (like the HACK ALU architecture). To me though, hardware architecture doesn't matter when you're learning. I'm learning quite a bit from this topic also. I created an ALU with most logical functions, although it has messy wiring. :P
    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on Handling Negative Answers in a Calculator
    *sigh*

    I watched some of Poroperinglish's tutorials on negative numbers, and I still feel confused. :(

    I feel stupid not knowing now still even though Proper's videos go into good detail. :(

    World save:
    http://www.mediafire.com/?5z5xb1bej2wyond
    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on Handling Negative Answers in a Calculator
    I'm kinda confused about using the first bit as an indicator of negative answers: what if I do a calculation that makes use of the first bit (like 5-3, 5 = 0101) and gives a non-negative answer? Sounds like it would cause problems and accidentally convert non-negatives.

    I also just recently spoke to someone on the RDF and they said the problem occurs when using the two's complement method of subtraction (which I am). He said something along the lines of "add (either 1 or 2, kinda forgot) to and then invert the outputs". I managed to solve the inversion part by creating a multiplexer in which the B inputs are inverted from the A inputs. I'm a bit confused with the adding part though. It looks like I won't be able to throw in some adders after the MUX, since at this stage the answer has been converted to BCD... Do I need to put the MUX before the double dabble BCD conversion or what?
    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on Handling Negative Answers in a Calculator
    Recently I've been working on a 16-bit calculator that is capable of addition and subtraction. Addition seems to work fine, and subtractions works fine only when the answers aren't negative numbers. If I enter, say 2048 - 4096 into my calculator it gives me an answer of 63488. Whereas something like 4096 - 1024 gives me a correct answer of 3072.

    How do I fix this?
    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on How Terrible is My (And Your) Computer?
    My laptop from 2008. Less than an hour ago I had this laptop running with 4GB of RAM but was hitting around 97% memory usage quite frequently, so I upgraded.

    OS: Windows 7 Home Premium x64, SP1
    CPU: Intel Mobile Core 2 Duo @ 2.3 GHz (2 cores, 2 threads)
    RAM: 8GB Crucial DDR2-800 (2x4GB)
    GPU: AMD Mobility Radeon 3650, 512MB DDR2
    Disk: Corsair Force 3 240GB SATA III SSD

    Runs Minecraft quite well despite the ancient GPU. I get about 50-70 FPS when the render distance is set to far, but I usually play on normal or short for >100 framerates.

    As for slow computers, I have an old one sitting somewhere which has only around 894MB of RAM, a Core 2 Duo (I think), and an old nVidia GPU with 128MB of video memory. It doesn't run Minecraft well, plus it's difficult to work with machines with less than 1GB of RAM. :(
    Posted in: Computer Science and Technology
  • 0

    posted a message on ChickenBones Mods
    Thanks for updating to 1.3.2. However, I can't get NEI to show up ingame. I have Forge 4.0.0, and both CodeChickenCore and the NEI jars are in the coremods folder. Was working fine in 1.2.5.

    I tried deleting all the associated config files too, to no avail. I went into the 'Mods' area of the main menu, and it listed all the loaded mods. Forge and FML, as well as CodeChickenCore and NEI, and a few other mods like OptiFine. I disabled OptiFine and all other potentially conficting mods but it's still not showing up. :(



    *** Starting Minecraft ***
    Minecraft version: 1.3.2
    Minecraft.jar: minecraftv.jar
    Mods:
      minecraftforge-universal-4.0.0.200.zip
    Java path: C:\Program Files\Java\jre6\bin\javaw.exe
    Memory: 768 MB
    LauncherPath: /C:/Users/Daniel/Downloads/MagicLauncher_0.9.9.exe
    *** MagicMinecraftLauncher 0.9.9 ***
    Disable inactive mods
    2012-09-02 15:12:19 [INFO] [ForgeModLoader] Forge Mod Loader version 3.0.71.289 for Minecraft client:1.3.2, server:1.3.2 loading
    2012-09-02 15:12:19 [INFO] [STDOUT] Adding Accesstransformer map: codechickencore_at.cfg
    2012-09-02 15:12:19 [INFO] [STDOUT] Adding Accesstransformer map: nei_at.cfg
    2012-09-02 15:12:19 [INFO] [STDOUT] Inserted super call into aqu.c
    2012-09-02 15:12:20 [INFO] [STDOUT] aqh was overriden from NotEnoughItems 1.4.0.0.jar
    2012-09-02 15:12:21 [INFO] [STDOUT] Generated BlockMobSpawner helper method.
    2012-09-02 15:12:22 [INFO] [STDOUT] 27 achievements
    2012-09-02 15:12:22 [INFO] [STDOUT] 195 recipes
    2012-09-02 15:12:22 [INFO] [STDERR] Client asked for parameter: server
    2012-09-02 15:12:22 [INFO] [STDOUT] LWJGL Version: 2.8.4
    2012-09-02 15:12:24 [INFO] [ForgeModLoader] Attempting early MinecraftForge initialization
    2012-09-02 15:12:24 [INFO] [ForgeModLoader] Completed early MinecraftForge initialization
    2012-09-02 15:12:24 [INFO] [ForgeModLoader] Searching C:\Users\Daniel\AppData\Roaming\.minecraft\mods for mods
    2012-09-02 15:12:24 [INFO] [ForgeModLoader] Forge Mod Loader has identified 4 mods to load
    2012-09-02 15:12:25 [INFO] [STDOUT] Removing TMI Uninstaller
    2012-09-02 15:12:25 [INFO] [ForgeModLoader] Forge Mod Loader has successfully loaded 4 mods
    2012-09-02 15:12:33 [INFO] [STDOUT] Inserted super call into aqn.c
    Posted in: Minecraft Mods
  • 0

    posted a message on A Texture Artist's Guide to MCPatcher's Features
    I can't get CTM to use unique top log textures for each type of wood (oak, birch, spruce, jungle). This is my block17.properties file:

    source=/ctm/top.png
    method=top
    tiles=0-2
    metadata=0


    the '/ctm/' folder exists and so does the 'top.png' file.
    Posted in: Resource Pack Discussion
  • 0

    posted a message on 12w34a Snapshot Available for Testing!
    Looks awesome. I'm pleased with the content that Mojang are adding to the game so far. :)

    But yeah... you forgot to link to the snapshot. Going to have to download it from mojang.com for the time being.
    Posted in: Minecraft News
  • 0

    posted a message on Smallest Random Number Generator
    Quote from Magix

    Do you really need a save for that? Just look at the picture

    Yes. I suck at copying from ingame pictures. Especially if what I'm trying to copy is compact in size. A few weeks ago I tried copying a very small, pistonless full adder design someone posted, with no success.

    Quote from emeraldfyr3


    Oops! My bad! I just fixed it, try it now! ;)


    Thanks. :)
    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on Smallest Random Number Generator
    Looks very compact, but...

    Invalid or Deleted File.

    The key you provided for file download was invalid. This is usually caused because the file is no longer stored on Mediafire. This occurs when the file is removed by the originating user or Mediafire.

    If you believe you have reached this page in error, please submit a ticket.


    Someone should reupload the world save.
    Posted in: Redstone Discussion and Mechanisms
  • 0

    posted a message on [1.8.7 / 1.7.10 and earlier][update 4/23] MCPatcher HD fix 5.0.3
    Quote from dubca7

    With the latest patch I get this

    Exception in thread "Thread-5" java.lang.NoClassDefFoundError: com/pclewis/mcpat
    cher/TexturePackAPI$ChangeHandler
    	 at ji.b(SourceFile:155)
    	 at ji.<clinit>(SourceFile:17)
    	 at sr.<clinit>(SourceFile:65)
    	 at rh.<clinit>(SourceFile:116)
    	 at aig.<clinit>(SourceFile:287)
    	 at axk.<init>(SourceFile:14)
    	 at net.minecraft.client.Minecraft.<init>(SourceFile:128)
    	 at anw.<init>(SourceFile:36)
    	 at net.minecraft.client.MinecraftApplet.init(SourceFile:36)
    	 at net.minecraft.Launcher.replace(Launcher.java:143)
    	 at net.minecraft.Launcher$1.run(Launcher.java:87)
    Caused by: java.lang.ClassNotFoundException: com.pclewis.mcpatcher.TexturePackAP
    I$ChangeHandler
    	 at java.net.URLClassLoader$1.run(Unknown Source)
    	 at java.net.URLClassLoader$1.run(Unknown Source)
    	 at java.security.AccessController.doPrivileged(Native Method)
    	 at java.net.URLClassLoader.findClass(Unknown Source)
    	 at java.lang.ClassLoader.loadClass(Unknown Source)
    	 at java.lang.ClassLoader.loadClass(Unknown Source)
    	 ... 11 more



    Same here... :(
    Posted in: Resource Packs
  • 0

    posted a message on [Launcher] Magic Launcher 1.3.4 (mods, options, profiles, news)
    The launcher no longer connects ("Error connecting to server" in red text)... Other launchers seem to work fine though, plus there are already exceptions in my firewall.

    I click the 'Details' button and all it displays is:
    MagicLauncher 0.9.8
    java.home: C:\Program Files\Java\jre7
    java.runtime.name: Java(TM) SE Runtime Environment
    java.runtime.version: 1.7.0_05-b06
    os.name: Windows 7
    os.version: 6.1
    os.arch: amd64
    sun.arch.data.model: 64


    Yup, that's it... no exceptions or anything...
    Posted in: Minecraft Tools
  • To post a comment, please .