• 0

    posted a message on Good RF Cable "Standalone" Mod That Actually WORKS?

    1. I think Fun Ores or maybe interaction between Fun Ores and Progressive Automation, but I'm not sure. I'm not familiar with the code for either mod as a mod dev would be; I'm just looking up the classes referred to in the stacktrace.


    2. There's a difference between meat ores, which the pig ore is one, and the mob ores, which include the enderman ore.



    3. Fun Ores:


    Problems? Feature suggestions? Click the "Issues" button above to go to the issue tracker!Or just leave a comment if you REALLY don't want to...

    Issue tracker is on github. Progressive Automation:


    And bugs should be reported to my issue tracker on github.


    Also, you wanted to use it to get ender pearls? Take a look at lines 555-557 of the Fun Ores config. It appears as if they won't drop ender pearls.

    Posted in: Mods Discussion
  • 0

    posted a message on Good RF Cable "Standalone" Mod That Actually WORKS?

    I do think it is a bug. If you look at the stacktrace (and Progressive Automation's and Fun Ores' Githubs), this is what you find.

    The stacktrace refers to line 77 and line 223 in class com.vanhal.progressiveautomation.entities.miner.TileMiner. Line 77 merely calls function mine(), which line 223 is a line of. This is line 223:

    List<ItemStack> items = currentBlock.getDrops(worldObj, currentPosition,
    worldObj.getBlockState(currentPosition), fortuneLevel);


    The stacktrace also refers to line 163 in class net.silentchaos512.funores.block.BlockOreMob. Line 163 returns a List<ItemStack> which is getting the drops of the mob ore. Near the end of the method getDrops(WorlServer world, int fortune, ILootTableDrops ore, int tryCount, ConfigOptionOreGenBonus config) in the class net.silentchaos512.funores.util.OreLootHelper, line 59 calls the addBonusDrops. These are lines 71-78 of the same class:

    if (config.pick != 0) {
          dropsToTry = new ConfigItemDrop[config.pick];
          for (int i = 0; i < config.pick; ++i) {
            dropsToTry[i] = config.bonusDrops.get(rand.nextInt(config.bonusDrops.size()));
          }
        } else {
          dropsToTry = config.bonusDrops.toArray(new ConfigItemDrop[] {});
    }


    config.pick is the number of drops from the bonus drops list to attempt to drop when mining the ore. Line 74 is the line inside the for loop. So the crash is an IllegalArgumentException. One thing that might be causing the exception is that rand.nextInt(config.bonusDrops.size()) is negative.


    Does any of that make the remotest sense? I'll still look into it, but it does seem to be something out of your control. A crash involving Fun Ores and Progressive Automation. I'd submit a bug report to both mod devs, and in the meantime try one of the hotfixes. I hope this helps!


    EDIT: Another possibility to temporarily fix the issue would be to restore the server to an earlier backup. It would only need to be before the Miner attempted to mine the mob ore.

    Posted in: Mods Discussion
  • 0

    posted a message on Good RF Cable "Standalone" Mod That Actually WORKS?

    Have you changed any configs for Fun Ores from the default? If you want a hotfix for your server, I think one would be to disable mob ores, or another to use MCEdit to remove Progressive Automation's Miner.

    Posted in: Mods Discussion
  • 0

    posted a message on How do Skyblock Modpacks Load Faster?

    I should have specified, and I'll edit the post to reflect this, but I didn't mean world loading time. I meant the load time when launching the game from the launcher (whichever you use) to the main menu of the game.

    Posted in: Mod Packs
  • 0

    posted a message on Good RF Cable "Standalone" Mod That Actually WORKS?

    What version of Fun Ores are you using? Have you mined any of Fun Ore's mob ores with Progressive Automation's miner yet? It seems as if that's the problem, but I'm still looking at it.


    EDIT: Also, can I see Fun Ores config file, and while you are at it, Progressive Automation's?

    Posted in: Mods Discussion
  • 0

    posted a message on Good RF Cable "Standalone" Mod That Actually WORKS?

    What is your modlist with the versions of mods you are using, crash report, latest.log, and fml log (on client it's fml-client-latest.log and server fml-server-latest.log)? I think you should probably give us those. Please don't forget to use spoilers.


    EDIT: In regards to creating another account on github, in my opinion it would not be a waste, since many mods use Github for bug submission. Extra Utilities has a Github purely for submitting bugs for example; its source is not on Github. But that's just my own opinion

    Posted in: Mods Discussion
  • 0

    posted a message on Bloodmoon only(read before commenting)

    Well, while you might not get a crash report everytime you crash, you do have two other logs, latest.log and fml-client-latest.log, you could give us that could point to the problem of the crash, albeit you probably should create another post in maybe modified client support section. Also, did you check you installed Random Things for 1.7.10? If you downloaded it from the website, I think it'd default to the latest version, period, which would be for 1.10.2, not 1.7.10. And I know this isn't related to the request for a bloodmoon mod, but such a feature really doesn't even warrant a whole mod in my opinion.


    EDIT: I found a mod called Bloodmoon by Lumien, albeit, it's on 1.8+, not on 1.7.10

    Posted in: Java Edition Support
  • 0

    posted a message on How do Skyblock Modpacks Load Faster?

    Hello,


    On my computer most decent sized modpacks such as FTB Infinity Evolved or DesignTech take between 5-10 minutes, usually closer to the middle of the range or the higher end of it. However, in some of the Skyblock type modpacks I've noticed that they take about 5 minutes, sometimes more, sometimes less. I've only seen this in SkyFactory 2.5 and Project Ozone 2, since they are the only two I've booted up thus far. How do they optimize the modpacks to boot up so fast? Is it just due to the modlist, or are they tweaking or using mods to improve performance? I'd love to optimize my modpacks for a nice snappy load time. Thanks!


    EDIT: I should have specified this, but I don't mean world loading time. I mean the load time for launching the game, i.e. for pressing play or doing whatever you need to do in whichever launcher you are using to the main menu of the game appearing.

    Posted in: Mod Packs
  • 0

    posted a message on Good RF Cable "Standalone" Mod That Actually WORKS?

    From the way you describe it, it sounds like maybe a bug. Try using both the latest and latest stable version of EnderIO, probably also with just EnderIO. If it works then, start adding mods into your instance that were in the other instance, and try to figure out what was causing the problem. If not, fill out a bug report however EnderIO's dev wants you to.

    Posted in: Mods Discussion
  • 0

    posted a message on Good RF Cable "Standalone" Mod That Actually WORKS?

    Please elaborate, since EnderIO's energy conduits for one work perfectly fine. Another mod that adds some power cabling and some ok power gen (which is an understatement in regards to its fusion reactor) is Mekanism. Also, standalone as in doesn't add anything else besides power transport, power gen, and power storage?

    Posted in: Mods Discussion
  • 0

    posted a message on Need help with optifine crashing on 1.10.2 - openGl problem?

    What version of Optifine are you using? In regards to other mods on 1.10.2, many of them are in alpha or beta. Several are still unstable, and some major mods from 1.7.10 have yet to be ported. For example, railcraft was just ported a week or two ago. Right now it's in beta, so there might still be some nasty bugs and crashes yet to work out. You could always post to the forums with the crash report and logs in spoilers, and we can help you fix it if possible, or if not we can tell you that you need to report it. All in all, 1.10.2 is not yet stable. It's getting much more stable, but for now, 1.7.10 is the latest stable version for modded Minecraft.

    Posted in: Java Edition Support
  • 0

    posted a message on Forge 1.10.2 Gradually Rising RAM Usage

    Sounds like a memory leak alright. In which case you'll have to wait until Forge fixes it. The only question is why hasn't everyone had this problem then?

    Posted in: Java Edition Support
  • 0

    posted a message on Project Ozone v1.7 Crashes on Load, Please Help

    Are the first few lines of the crash report this:

    java.lang.NullPointerException: Initializing game
    at net.blay09.mods.eiramoticons.addon.pack.TwitchTurboPack.<init>(TwitchTurboPack.java:54)
    at net.blay09.mods.eiramoticons.ClientProxy.reloadEmoticons(ClientProxy.java:98)

    If so, then the same information I gave ipie4fun applies to you. If not, then do post your crash report with spoilers.

    Posted in: Mods Discussion
  • 0

    posted a message on Custom bosses or preset world mods?

    After many google searches, I managed to find out about a mod called Lockdown. Lockdown allows you to make a default world, lock the gamemode, disable the more world options button, and remove the multiplayer button. It is the answer to the latter part of my question, and hopefully this thread will be easily found by the next person looking for a mod like this.

    Posted in: Mods Discussion
  • 0

    posted a message on Modpack crashing

    Sounds kinda like a corrupted download of Forge.

    Posted in: Mod Packs
  • To post a comment, please or register a new account.