• 0

    posted a message on Custom Painting Mod and 1.6
    Hello everyone! I'm in need of some help, or perhaps advice here. I recently installed the CustomPaintingMod based on ModLoaderMP for a school project, but when 1.6.1 went live and the maps were added to the game, I lost every custom painting in the mine I'd made for the project. It seems I can't go back far enough to get them back (that I've been able to find) so I was wondering if anyone knows how to go back to 1.5 or how to make custom paintings work on 1.6. Any advice would be most helpful.
    Posted in: Mods Discussion
  • 0

    posted a message on Custom Painting Mod
    Friends, I come to you tonight very frustrated. I've been trying (for a day and a half now) everything I can think of to get the Custom Paintings mod for ModLoaderMP working, but it keeps crashing my game. I load them into the bin folder in this order on a Windows 7 machine:

    ModLoader
    AudioMod
    ModLoaderMP
    Improved ModLoaderMP
    CustomPaintingMod

    And I can't figure out exactly where I'm going wrong. Has anyone else run into similar issues? The first two dozen or so times I followed the tutorials to the letter and still came up with nothing but a black screen and a crashed game. Maybe someone can help me here? The files go in this order:

    ModLoader
    BaseMod.class
    bu.class
    cn.class
    EntityRendererProxy.class
    gz.class
    jz.class
    kb.class
    MLProp.class
    ModLoader.class
    ModTexture.class
    rg.class
    sd.class
    uj.class
    wg.class
    xl.class

    AudioMod
    Folder "ibxm" which contains:
    Channel.class
    Envelope.class
    FastTracker2.class
    IBXM.class
    Instrument.class
    LogTable.class
    Module.class
    Pattern.class
    Player$1.class
    Player$Driver.class
    Player.class
    ProTracker.class
    Sample.class
    ScreamTracker3.class

    Folder "paulscode" which contains:
    Folder "sound" which contains:
    Folder "codecs" which contains:
    CodecIBXM.class

    xe.class

    SDK's ModLoaderMP 1.4 01v3
    BaseModMP.class
    dw.class (determined later to be broken)
    ko.class (determined later to be broken)
    ModLoaderMP.class
    Packet200ModLoader.class

    Improved ModLoaderMP v1.1
    Folder "Client" which contains:
    Folder Class which contains:
    BaseModMP.class
    ModLoaderMP.class
    jo.class ("Real name" Packet)
    mg.class ("Real name" NetClientHandler)
    Packet231EntitySpawn.class
    Folder "Source" which contains:
    BaseModMp.java
    ModLoaderMP.java
    NetClientHandler.java
    Packet.java
    Packet231EntitySpawn.java

    Folder "Server" which contains
    Folder "Class" which contains:
    BaseModMp.class
    es.class
    gc.class
    ModLoaderMP.class
    Packet231EntitySpawn.class
    Folder "Source" which contains:
    BaseModMp.java
    ModLoaderMP.java
    NetClientHandler.java
    Packet.java
    Packet231EntitySpawn.java
    I don't run a server, so I haven't been loading the "Server" files into the mod.

    CustomPainting v1.3
    Folder "Client" which contains:
    EntityCustomPainting.class
    GuiCustomPaintingMenu.class
    ItemCustomPainting.class
    mod_CustomPainting.class
    Packet500EntityCustomPainting.class
    RenderCustomPainting.class

    Folder "CustomPaintingSprites" which contains:
    painting.png

    Folder "Server" which contains:
    EntityCustomPainting.class
    ItemCustomPainting.class
    mod_CustomPainting.class
    Packet500EntityCustomPainting.class

    I load the files in this exact order, without loading the "Server" files because I don't run a server and I wouldn't have the slightest idea where to put them. I test it one mod at a time as I go and it's fine until I get to loading the CustomPaintingMod itself. Then my game blackscreens and crashes. Any advice would be most helpful, and before anyone says it yes I deleted the META-INF folder every time.

    This is my modloader.txt file:


    May 23, 2011 8:53:12 PM ModLoader init
    FINE: ModLoader Beta 1.5_01v4 Initializing...
    May 23, 2011 8:53:12 PM ModLoader readFromClassPath
    FINER: Adding mods from C:\Users\Compaq\AppData\Roaming\.minecraft\bin\minecraft.jar
    May 23, 2011 8:53:12 PM ModLoader readFromClassPath
    FINER: Zip found.
    May 23, 2011 8:53:12 PM ModLoader addMod
    FINE: Failed to load mod from "mod_CustomPainting.class"
    May 23, 2011 8:53:12 PM ModLoader addMod
    FINER: THROW
    java.lang.NoClassDefFoundError: Packet230ModLoader
    at mod_CustomPainting.<init>(Unknown Source)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at java.lang.Class.newInstance0(Unknown Source)
    at java.lang.Class.newInstance(Unknown Source)
    at ModLoader.addMod(ModLoader.java:207)
    at ModLoader.readFromClassPath(ModLoader.java:1135)
    at ModLoader.init(ModLoader.java:815)
    at ModLoader.AddAllRenderers(ModLoader.java:124)
    at sd.<init>(sd.java:58)
    at sd.<clinit>(sd.java:8)
    at net.minecraft.client.Minecraft.a(SourceFile:282)
    at net.minecraft.client.Minecraft.run(SourceFile:658)
    at java.lang.Thread.run(Unknown Source)
    Caused by: java.lang.ClassNotFoundException: Packet230ModLoader
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 16 more
    May 23, 2011 8:53:22 PM ModLoader AddAllRenderers
    FINE: Initialized
    Posted in: Mods Discussion
  • 0

    posted a message on Custom Painting Mod
    Quote from mattcactusrocks

    Please go into your .minecraft and post your modloader.txt, if you do that, we can help you. By the way, this is the wrong section. This section is only about posting mods. This would belong in the modding discussion section.


    This is my modloader.txt file:


    May 23, 2011 8:53:12 PM ModLoader init
    FINE: ModLoader Beta 1.5_01v4 Initializing...
    May 23, 2011 8:53:12 PM ModLoader readFromClassPath
    FINER: Adding mods from C:\Users\Compaq\AppData\Roaming\.minecraft\bin\minecraft.jar
    May 23, 2011 8:53:12 PM ModLoader readFromClassPath
    FINER: Zip found.
    May 23, 2011 8:53:12 PM ModLoader addMod
    FINE: Failed to load mod from "mod_CustomPainting.class"
    May 23, 2011 8:53:12 PM ModLoader addMod
    FINER: THROW
    java.lang.NoClassDefFoundError: Packet230ModLoader
    at mod_CustomPainting.<init>(Unknown Source)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at java.lang.Class.newInstance0(Unknown Source)
    at java.lang.Class.newInstance(Unknown Source)
    at ModLoader.addMod(ModLoader.java:207)
    at ModLoader.readFromClassPath(ModLoader.java:1135)
    at ModLoader.init(ModLoader.java:815)
    at ModLoader.AddAllRenderers(ModLoader.java:124)
    at sd.<init>(sd.java:58)
    at sd.<clinit>(sd.java:8)
    at net.minecraft.client.Minecraft.a(SourceFile:282)
    at net.minecraft.client.Minecraft.run(SourceFile:658)
    at java.lang.Thread.run(Unknown Source)
    Caused by: java.lang.ClassNotFoundException: Packet230ModLoader
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 16 more
    May 23, 2011 8:53:22 PM ModLoader AddAllRenderers
    FINE: Initialized
    Posted in: Minecraft Mods
  • 0

    posted a message on Custom Painting Mod
    Friends, I come to you tonight very frustrated. I've been trying (for a day and a half now) everything I can think of to get the Custom Paintings mod for ModLoaderMP working, but it keeps crashing my game. I load them into the bin folder in this order on a Windows 7 machine:

    ModLoader
    AudioMod
    ModLoaderMP
    Improved ModLoaderMP
    CustomPaintingMod

    And I can't figure out exactly where I'm going wrong. Has anyone else run into similar issues? The first two dozen or so times I followed the tutorials to the letter and still came up with nothing but a black screen and a crashed game. Maybe someone can help me here? The files go in this order:

    ModLoader
    BaseMod.class
    bu.class
    cn.class
    EntityRendererProxy.class
    gz.class
    jz.class
    kb.class
    MLProp.class
    ModLoader.class
    ModTexture.class
    rg.class
    sd.class
    uj.class
    wg.class
    xl.class

    AudioMod
    Folder "ibxm" which contains:
    Channel.class
    Envelope.class
    FastTracker2.class
    IBXM.class
    Instrument.class
    LogTable.class
    Module.class
    Pattern.class
    Player$1.class
    Player$Driver.class
    Player.class
    ProTracker.class
    Sample.class
    ScreamTracker3.class

    Folder "paulscode" which contains:
    Folder "sound" which contains:
    Folder "codecs" which contains:
    CodecIBXM.class

    xe.class

    SDK's ModLoaderMP 1.4 01v3
    BaseModMP.class
    dw.class (determined later to be broken)
    ko.class (determined later to be broken)
    ModLoaderMP.class
    Packet200ModLoader.class

    Improved ModLoaderMP v1.1
    Folder "Client" which contains:
    Folder Class which contains:
    BaseModMP.class
    ModLoaderMP.class
    jo.class ("Real name" Packet)
    mg.class ("Real name" NetClientHandler)
    Packet231EntitySpawn.class
    Folder "Source" which contains:
    BaseModMp.java
    ModLoaderMP.java
    NetClientHandler.java
    Packet.java
    Packet231EntitySpawn.java

    Folder "Server" which contains
    Folder "Class" which contains:
    BaseModMp.class
    es.class
    gc.class
    ModLoaderMP.class
    Packet231EntitySpawn.class
    Folder "Source" which contains:
    BaseModMp.java
    ModLoaderMP.java
    NetClientHandler.java
    Packet.java
    Packet231EntitySpawn.java
    I don't run a server, so I haven't been loading the "Server" files into the mod.

    CustomPainting v1.3
    Folder "Client" which contains:
    EntityCustomPainting.class
    GuiCustomPaintingMenu.class
    ItemCustomPainting.class
    mod_CustomPainting.class
    Packet500EntityCustomPainting.class
    RenderCustomPainting.class

    Folder "CustomPaintingSprites" which contains:
    painting.png

    Folder "Server" which contains:
    EntityCustomPainting.class
    ItemCustomPainting.class
    mod_CustomPainting.class
    Packet500EntityCustomPainting.class

    I load the files in this exact order, without loading the "Server" files because I don't run a server and I wouldn't have the slightest idea where to put them. I test it one mod at a time as I go and it's fine until I get to loading the CustomPaintingMod itself. Then my game blackscreens and crashes. Any advice would be most helpful, and before anyone says it yes I deleted the META-INF folder every time.
    Posted in: Minecraft Mods
  • To post a comment, please .