Mods Discussion

Information about specific Minecraft mods and technical assistance for using and installing modifications.
Thread Latest Post Replies Views
1.8.9 I need help! >>
by l1f3l1ne
3 179
1.8.9 Forge Pixelmon won't completely load. >>
by Kleask10
3 553
1.8.9 Shaders W/ Mods >>
by ATalkingDuck
3 313
1.8.9 When i try to download optifine it downloads as a intenet explore file >>
by NonStopSkillz
3 413
1.8.9 Please help me fix my mods/find a mod pack? >>
by Carmlapples
3 1,240
1.8.9 Shaders for 1.8.9 with other mods. need HELP! >>
by LeonelSaberTooth
3 549
1.8.9 NPCs Entity ID issue! >>
by Karagra
3 1,105
1.7.10 1.8 +1 More Animation mods >>
by EnderSlainer
3 513
1.8.9 Forge Why can't forge find optifine >>
by Potatuh
4 854
1.8.9 Optifine With Forge >>
by Potatuh
4 575
1.8.9 Need help looking for a TreeCapitator mod for 1.8.9 >>
by WhoStoleMyWaffle
4 20,350
1.8.9 Skin converter from 1.7 to 1.8 that can convert multiple skins >>
by Triliton
4 1,140
1.8.9 Modded Team UHC >>
by GalaxyGamer14
4 248
Forge 1.8.9 +1 More Problem Installing mods on my mac >>
by futhead_omardanniel1
4 310
1.8.9 NEI Help Plz >>
by AwesomeAlex2710
4 354
1.8.9 Help! I can't find a good mod that shows crafting recipes for MC version 1.8.9! >>
by Haisu_Hline
4 914
1.8.9 It is possible mods 1.8/1.7.10 work in 1.8.9? >>
by ReiDaTecnologia
4 693
1.8.9 Mods "lagging" 1.8.9, however work fine in 1.7.10. Please Help. >>
by FenriskollJarred
4 1,161
1.8.9 Modded Launcher Crash Please Help >>
by Destroyer998
4 483
1.8.9 Modding Crashes >>
by Owenn
4 281
1.8.9 Shape Shifter for Mac 1.8.9 >>
by IRDavies
4 1,932
1.8.9 Help with Weather2 mod! >>
by AuthenticElle
5 660
Forge 1.8.9 Can't Install Too Many Items Mod >>
by BrennanSB
5 467
1.8.9 1.11 +2 More X-Ray Help! >>
by Doctor_Chad
5 303
1.8.9 Pixelmon mod freezing while loading >>
by EmperourPenguin
5 699
1.8 1.8.9 +1 More Ultimate Minecraft! Lots of random mods needed! >>
by CubedHero
5 377
1.9 1.8.9 Loading Mods ( . jar file resets ) >>
by DaRealTrinnexx
5 528
1.8.9 Searching for mod >>
by norzqq
5 306
1.8.9 Pixelmon requires Java 1.8, you are using 1.6.0_65. >>
by willybilly
6 347
1.8.9 Forge Serious Forge mismatch IDs problem, world ruined (Please help me fix it!) >:( >>
by drybones967
6 270