Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Minecraft not using my AMD video card


  • Please log in to reply
8 replies to this topic

#1

M4A8
    M4A8

    Out of the Water

  • Members
  • 3 posts

Posted 02 February 2012 - 03:39 PM

For some reason Minecraft will not use my video card at all. This is dragging me down to about 40-50 fps on default minecraft, and if I try to run any graphical mods it drops down to the single digits. I also have VERY slow chunk loading (it takes around 2 minutes just to load up the visible chunks on far visibility), and my CPU gets very hot having to take all the load. I am running an AMD 6870 card, with 64 bit windows 7 and 64 bit java and extended memory for minecraft. Also running a Phenom II X4 965 BE OC'd to 4.2 GHZ (I need to have it OC'd just to play). All of my onboard graphics are disabled. I know of other people with the exact same setup pulling around 200 fps. Is there some way to force minecraft to use my video card or is there some kind of work around?

Edit: All my drivers are up to date. I tried the new lwjgl but it didn't change a thing. I know there's nothing wrong with the card itself as I can pull 80+ in skyrim on ultra and the card is showing about 80% load there.

Register or log in to remove.

#2

gerbil
    gerbil

    Support Guru

  • Members
  • 4915 posts

Posted 02 February 2012 - 07:32 PM

Minecraft does not choose which GPU to use.  Your system does.
Try configuring Catalyst to associate java with the High Performance GPU

#3

M4A8
    M4A8

    Out of the Water

  • Members
  • 3 posts

Posted 02 February 2012 - 08:36 PM

View Postgerbil, on 02 February 2012 - 07:32 PM, said:

Minecraft does not choose which GPU to use.  Your system does.
Try configuring Catalyst to associate java with the High Performance GPU

I've tried that but I can't find where in the CCC I can associate programs :S

#4

MrCai
    MrCai

    Gold Miner

  • Members
  • 468 posts

Posted 02 February 2012 - 10:26 PM

Let me know if you get an answer to this one, i've got a work around for nvidia cards, but i've got friends in need of this AMD (ATi) fix.
Posted Image

#5

Buckwheat15

Posted 04 February 2012 - 11:16 PM

View Postgerbil, on 02 February 2012 - 07:32 PM, said:

Minecraft does not choose which GPU to use.  Your system does.
Try configuring Catalyst to associate java with the High Performance GPU

Same I have looked everywhere in the CCC and there is nothing. Amd's CCC doesn't have any features based on the switchable graphics. I play on a Acer Aspire laptop with a AMD A6 cpu a 6520g integraded card, and a 6650m dedicated card with 1gb of ram. When I set Minecraft and Java in the CCC to high performace, nothing happens. Minecraft runs at 30 fps when it should be at 60 - 80 fps. But when I play a game with DirectX graphics, it switches over fine. Here is an example with Opengl (Minecraft) and Directx.

I start up the Heaven DX11 benchmark. Set to DirectX it runs the dedicated card fine. In the Amd System Monitor its using the dedicated 6650m GPU. Switch to OpenGl mode. Uses all of the integraded card and none of the dedicated card. There was a significant drop in fps from the dedicated GPU.

So for you, me, and alot of other people, Amd wont switch over for some reason. Depending if you have a desktop or laptop there might be a way to change it in the Bios. But for now Im just going to wait and see if AMD will fix this problem, or pray that someone will have the fix. Because its been bugging be since I got this computer.  :(

#6

Ujelly?
    Ujelly?

    Redstone Miner

  • Members
  • 523 posts

Posted 18 March 2012 - 12:33 PM

Well this appears to but a dampner on me playing on my new laptop :(
Beta Players, Beta players everywhere!

#7

gerbil
    gerbil

    Support Guru

  • Members
  • 4915 posts

Posted 18 March 2012 - 03:38 PM

Different brands of laptops have different issues.
HP for example has a host of system updates (BIOS and video drivers) to fix the crap that they shipped so that the switchable graphics kind of function, sort of, maybe if the stars align.
Toshiba's ship with two sets of video drivers installed, one for a video card that isn't installed in most of the laptops and thus doesn't work.

My son's Dell XPS and my Alienware don't seem to have any problems with their switchable graphics.

#8

Redstone PrO
  • Location: Germany
  • Minecraft: knexfan0011

Posted 12 May 2012 - 03:29 PM

I have the same problem with my HD6850 Posted Image
MSI Afterburner says my GPU is at 33% max usage when playing minecraft with Optifine 16xAA and 16xAF with the OCD pack and my framerate is around 60. I'd love to install the dynamic shader mod, but its waaaaay too laggy :/ (CPU: AMD Phenom IIX4 955 @3.6GHZ)
Have a wonderful day ^-^v
Sorry for any typos/gramatical errors, english isn't my primary language ;)

#9

captainskyhawk

Posted 10 October 2012 - 08:20 PM

I had this same issue when using the Catalyst 12 drivers -- try downgrading to the Catalyst 11.9 ones.  When I did that Minecraft started using my GPU again, and it showed when using a tool like GPU-Z (as well as just having my framerate be twice as much without).