Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

MCP Decompiler Fatal Error! HELP!


  • Please log in to reply
18 replies to this topic

#1

chrishall

Posted 26 January 2012 - 08:28 AM

I try to decompile but i get these errors:

== ERRORS FOUND ==

Unrecoverable error during obfuscation, see log file for details.
RetroGuard error: COM.rl.obf.classfile.ClassFileException: ClassNotFound com/sk8
9q/worldedit/LocalPlayer
==================

FATAL ERROR
Traceback (most recent call last):
  File "runtime\decompile.py", line 49, in decompile
    commands.applyrg(CLIENT)
  File "C:\Users\Chris\Desktop\MCP\runtime\commands.py", line 619, in applyrg
    self.runcmd(forkcmd)
  File "C:\Users\Chris\Desktop\MCP\runtime\commands.py", line 779, in runcmd
    raise CalledProcessError(returncode, forkcmd, output)
CalledProcessError: Command '"C:\Program Files\Java\jdk1.7.0_01\bin\java.exe" -c
p "runtime\bin\retroguard.jar;lib;lib\*;jars\bin\minecraft.jar;jars\bin\jinput.j
ar;jars\bin\lwjgl.jar;jars\bin\lwjgl_util.jar" RetroGuard -searge temp\client_rg
.cfg' returned non-zero exit status 1

Anyone can help? that would be great i have updated mcp re installed jdk but nothing seems to fix it i have even reinstalled a whole new MCP :(

Register or log in to remove.

#2

Wethospu

Posted 26 January 2012 - 08:37 AM

Do you have .minecraft/bin in the mcp/jars?

#3

chrishall

Posted 26 January 2012 - 08:45 AM

View PostWethospu, on 26 January 2012 - 08:37 AM, said:

Do you have .minecraft/bin in the mcp/jars?
yes

#4

Wethospu

Posted 26 January 2012 - 09:13 AM

Hmm, is it unmodded too?

#5

chrishall

Posted 26 January 2012 - 09:43 AM

View PostWethospu, on 26 January 2012 - 09:13 AM, said:

Hmm, is it unmodded too?
no it is modded but i deleted the bin folder and i am going to replace it with an unmodded bin see if that helps

#6

chrishall

Posted 26 January 2012 - 09:50 AM

ok so i Replaced it with an clean unmodded bin/jar and no errors! thanks for the help

#7

ottoguy2
    ottoguy2

    Void Walker

  • Members
  • 1857 posts

Posted 26 January 2012 - 06:52 PM

Reinstall everything. Including java.
Posted Image
This picture will not do the above.

#8

zXTechnoWolf
  • Location: United States
  • Minecraft: zXTechnoWolf
  • Xbox:xXTacticalCatXx
  • PSN:zXTechnoWolfX

Posted 26 January 2012 - 06:53 PM

View Postchrishall, on 26 January 2012 - 09:50 AM, said:

ok so i Replaced it with an clean unmodded bin/jar and no errors! thanks for the help
It said that a certain class file is missing. Don't listen to the guy above me, if your going to use ModLoader to make mods, then before you decompile the jar delete META-INF and install ModLoader. Nothing else. Then decompile.
When luck becomes habit, it turns into skill.
Posted Image

#9

RyRyBoyer1999

Posted 15 August 2012 - 01:34 AM

View PostzXTechnoWolf, on 26 January 2012 - 06:53 PM, said:

It said that a certain class file is missing. Don't listen to the guy above me, if your going to use ModLoader to make mods, then before you decompile the jar delete META-INF and install ModLoader. Nothing else. Then decompile.
Ok well i have a similar problem, however i need to keep ModLoader installed. For some reason, I get this error report
Spoiler:
At this time 1.3.1 is released but when I try to get MCP7.0 to work with 1.3.1 It gives me this error
Spoiler:
PLEASE HELP!

#10

tomtomg99

Posted 23 August 2012 - 06:53 PM

Quote

Ok well i have a similar problem, however i need to keep ModLoader installed. For some reason, I get this error report
Spoiler
At this time 1.3.1 is released but when I try to get MCP7.0 to work with 1.3.1 It gives me this error
Spoiler
PLEASE HELP!
i had the same error i found out i was using the wrong version of minecraft try deleting all the files and updating

#11

Rumikarimu
  • Location: British Columbia, Canada
  • Minecraft: Rikorualex

Posted 29 September 2012 - 11:26 PM

16:26:13 -
16:26:13 - RetroGuard error: COM.rl.obf.classfile.ClassFileException: ClassNotFound BaseMod
16:26:13 - '"C:\Program Files\Java\jdk1.7.0_07\bin\java" -cp "runtime\bin\retroguard.jar;lib;lib\*;jars\bin\mine...' failed : 1
16:26:13 -
16:26:13 - == ERRORS FOUND ==
16:26:13 -
16:26:13 - Unrecoverable error during obfuscation, see log file for details.
16:26:13 - RetroGuard error: COM.rl.obf.classfile.ClassFileException: ClassNotFound BaseMod
16:26:13 - ==================
16:26:13 -
16:26:13 - Decompile failed

   WUT NOW?
Posted Image

#12

SpitefulFox
  • Location: California
  • Minecraft: SpitefulFox

Posted 30 September 2012 - 05:10 AM

Are you using the latest version of MCP and a minecraft.jar with ONLY modloader installed in it?

#13

bigfish101

Posted 08 October 2012 - 01:26 AM

how long does the decompil take to do?

#14

ariel13443
  • Location: Lithuania
  • Minecraft: ariel134

Posted 26 February 2013 - 05:54 PM

Hey, Ive got the same error with retroguard. Im using MCP for 1.4.7, bin contains minecraft.jar with Minecraft Forge and other stuff for minecraft. MCP version is 726a

#15

CppMinecraft
  • Minecraft: CppMinecraft

Posted 27 February 2013 - 11:41 PM

I'm having the same problem. I looked in the minecraft.jar with ModLoader, and I noticed that it has _aux.class instead of aux.class, but when I try to change it, it says "The specified device name is invalid.". Here's the more detailed log:

# Unrecoverable error during obfuscation:
# COM.rl.obf.classfile.ClassFileException: ClassNotFound com/google/common/base/Supplier
#  at COM.rl.obf.Cl$ExtNameListUp.<init>(Cl.java:1539)
#  at COM.rl.obf.Cl.getExtNameListUp(Cl.java:1510)
#  at COM.rl.obf.Cl.resolveThis(Cl.java:902)
#  at COM.rl.obf.Cl.resolveNameSpaceExcept(Cl.java:852)
#  at COM.rl.obf.Cl.resolveOptimally(Cl.java:645)
#  at COM.rl.obf.ClassTree$6.classAction(ClassTree.java:682)
#  at COM.rl.obf.ClassTree.walkTree(ClassTree.java:1483)
#  at COM.rl.obf.ClassTree.walkTree(ClassTree.java:1475)
#  at COM.rl.obf.ClassTree.walkTree(ClassTree.java:1475)
#  at COM.rl.obf.ClassTree.walkTree(ClassTree.java:1466)
#  at COM.rl.obf.ClassTree.walkTree(ClassTree.java:1466)
#  at COM.rl.obf.ClassTree.walkTree(ClassTree.java:1466)
#  at COM.rl.obf.ClassTree.walkTree(ClassTree.java:1466)
#  at COM.rl.obf.ClassTree.walkTree(ClassTree.java:1466)
#  at COM.rl.obf.ClassTree.walkTree(ClassTree.java:1447)
#  at COM.rl.obf.ClassTree.resolveClasses(ClassTree.java:677)
#  at COM.rl.obf.GuardDB.createMap(GuardDB.java:437)
#  at COM.rl.obf.GuardDB.remapTo(GuardDB.java:464)
#  at COM.rl.obf.RetroGuardImpl.run(RetroGuardImpl.java:182)
#  at COM.rl.obf.RetroGuardImpl.obfuscate(RetroGuardImpl.java:131)
#  at COM.rl.obf.RetroGuardImpl.obfuscate(RetroGuardImpl.java:113)
#  at RetroGuard.main(RetroGuard.java:90)

#16

CppMinecraft
  • Minecraft: CppMinecraft

Posted 28 February 2013 - 03:02 PM

I've figured it out! You need to install forge into your minecraft.jar (in .minecraft/bin), then run minecraft, then copy over the bin and resources folder to mcp. (Just copying the .jar works, too.)
When you first run MC after installing forge, it does that installing thing or whatever that's for. I think that somehow make the .jar useable. I was just using a freshly created .jar that hadn't been run. Hope this helps!

#17

CppMinecraft
  • Minecraft: CppMinecraft

Posted 28 February 2013 - 03:21 PM

Nevermind, that was an unmodified .jar. It didn't have forge. :(

#18

ariel13443
  • Location: Lithuania
  • Minecraft: ariel134

Posted 01 March 2013 - 04:45 PM

Nope! Sorry about that! I installed forge wrong. U need to get src files from forge official forum and put (which in forge src archive)forge folder into MCP and open it. Then click install.bat file and than will auto decompile + forge installation. :(

#19

CppMinecraft
  • Minecraft: CppMinecraft

Posted 07 March 2013 - 11:49 PM

When I download forge, it just installs the .zip with all the classes but no install.bat. Am I clicking the right download link?
I click the Universal Direct link on http://www.minecraft...pic,4804.0.html.