Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[1.6.2] Single Player Commands [V4.9] - Official Download [SPC] [+NoClip]

spc single player single player commands mod commands command mod simo_415 noclip fly

  • Please log in to reply
30068 replies to this topic

#11601

SH4D0WS1N
  • Location: My room(s) 23/7
  • Minecraft: SH4D0WS1N

Posted 20 July 2011 - 12:28 AM

View PostKingdb707, on 19 July 2011 - 09:04 PM, said:

I am using zombe's fly mod. It warns me that it's noclip is deactivated because SPC has one. I was fine with that. But when I try to noclip with SPC, I get teleported to the bottom of my map, and the noclip still doesn't work. Does anyone have a fix to this, because I can't find one.
This is the only thing preventing me from keeping SPC.
Zombe's fly mod fits my needs way more with it's speed modifier.
And ever since it came out with noclip it's made me love it even more.
Did I stop responding to this thread? If it's because I was arguing, I most likely cbf to argue. If I was trying to help you, try PMing me.
Posted Image

Register or log in to remove.

#11602

bomberJV36
  • Location: USA
  • Minecraft: bomberJV36

Posted 20 July 2011 - 02:34 AM

I love this mod

#11603

zomb69
    zomb69

    Nether Resident

  • Members
  • 2052 posts
  • Location: cyberspace
  • Minecraft: zomb69

Posted 20 July 2011 - 02:45 AM

is there a command to make stuff glow? what if i want to make 1 piece of red wool glow but only that one? if not you should make a 'glow wand' so an area or cube can be selected to glow?

Official VDC server: vdc.zomb69server.co.vu

Posted Image

including 1.7.4-1.8 updates - mirror: https://drive.google...bjA&usp=sharing


#11604

Binkleplease

Posted 20 July 2011 - 03:36 AM

Forgive me for being a tech noob, but how do you run a stack trace on a mac?
Please help me I have the saving chunks error after the world flashes for about 0.5 sec, but don't want to report anything yet as I will be asked for a stack trace.

HELP US!
:iapprove:
  :VV:
:iapprove:
:VV:

#11605

simo_415
    simo_415

    Glowstone Miner

  • Members
  • 3046 posts

Posted 20 July 2011 - 04:25 AM

View Postzomb69, on 20 July 2011 - 02:45 AM, said:

is there a command to make stuff glow? what if i want to make 1 piece of red wool glow but only that one? if not you should make a 'glow wand' so an area or cube can be selected to glow?

Nah there isn't and it isn't currently possible to make one block glow and another block of the same type not glow.

View PostBinkleplease, on 20 July 2011 - 03:36 AM, said:

Forgive me for being a tech noob, but how do you run a stack trace on a mac?
Please help me I have the saving chunks error after the world flashes for about 0.5 sec, but don't want to report anything yet as I will be asked for a stack trace.

HELP US!
:iapprove:
  :VV:
:iapprove:
:VV:

Run Minecraft from the console - read the sticky thread on the released mod forum about modding tips and tricks.

#11606

AwashOrphan4060
  • Location: Missouri,USA
  • Minecraft: AwashOrphan4060
  • Xbox:PhD Orphan

Posted 20 July 2011 - 04:56 AM

Is it possible to change the wand to sponge or any other item? because i dont use spc on all my world so when i hit a tree with a wooden axe first always sets just wondering

Posted Image


#11607

Papsern
    Papsern

    Carpenter

  • Members
  • 55 posts

Posted 20 July 2011 - 05:11 AM

I got singleplayer commands in 1.7_01 and when minecraft updated to 1.7.3 i just reinstalled my 1.7_01 version of singleplayer commands and it worked fine except that when i did any command that teleports the player i just got teleported to like 3000 blocks above sea level and nowhere near where i wanted to go. Is that just normal if you use an old version or was mine stuffed up. Im gonna get the new version anyhow.  :mellow:
Posted Image

#11608

Jbt91
    Jbt91

    Carpenter

  • Members
  • 46 posts

Posted 20 July 2011 - 05:25 AM

View PostPapsern, on 20 July 2011 - 05:11 AM, said:

I got singleplayer commands in 1.7_01 and when minecraft updated to 1.7.3 i just reinstalled my 1.7_01 version of singleplayer commands and it worked fine except that when i did any command that teleports the player i just got teleported to like 3000 blocks above sea level and nowhere near where i wanted to go. Is that just normal if you use an old version or was mine stuffed up. Im gonna get the new version anyhow.  :mellow:

The 1.7.01 and the 1.7.2 versions of SinglePlayerCommands were known to be buggy when installed on 1.7.3. Teleportation issues, jump height issues, and noclip issues were among the problems reported.

#11609

zomb69
    zomb69

    Nether Resident

  • Members
  • 2052 posts
  • Location: cyberspace
  • Minecraft: zomb69

Posted 20 July 2011 - 05:29 AM

View Postsimo_415, on 20 July 2011 - 04:25 AM, said:

Nah there isn't and it isn't currently possible to make one block glow and another block of the same type not glow.


damn thanks for the reply but and thanks for the awesome mod it helps me building this (not quite finished but certainly more than half done(with working cannons)):

Posted Image
Posted Image
Posted Image

this is where i started 2weeks ago:

Posted Image

Official VDC server: vdc.zomb69server.co.vu

Posted Image

including 1.7.4-1.8 updates - mirror: https://drive.google...bjA&usp=sharing


#11610

Binkleplease

Posted 20 July 2011 - 06:00 AM

View Postsimo_415, on 20 July 2011 - 04:25 AM, said:

Run Minecraft from the console - read the sticky thread on the released mod forum about modding tips and tricks.

ON A MAC...

#11611

simo_415
    simo_415

    Glowstone Miner

  • Members
  • 3046 posts

Posted 20 July 2011 - 06:17 AM

View PostBinkleplease, on 20 July 2011 - 06:00 AM, said:

ON A MAC...

That's why I said run it from the console, MAC is based off ux OS's therefore how to run it on ux should work:

cd ~/.minecraft/bin; java -Xms512M -Xmx1024M  -Xincgc -cp "minecraft.jar:jinput.jar:lwjgl.jar:lwjgl_util.jar" -Dorg.lwjgl.librarypath="$(pwd)/natives" -Dnet.java.games.input.librarypath="$(pwd)/natives" net.minecraft.client.Minecraft


#11612

simo_415
    simo_415

    Glowstone Miner

  • Members
  • 3046 posts

Posted 20 July 2011 - 06:31 AM

I plan to spend a few hours tonight fixing bugs and writing a few enhancements as well as releasing an installer for the mod - which should solve 95% of the installation problems. I dont have time these days to respond to posts on the forums, so if you guys would help others out when they have issues, that would be great.

Here is a brief answer to most common questions:

Q. Installation problems.
A. Refer to OP troubleshooting section

Q. Noclip doesn't work with Zombes
A. A mod conflict caused by a bug in SPC - will be fixed by the next release

Q. Minecraft Extended compatability?
A. Semi... MCE changes block ids and many of the things in Minecraft which are hard to account for. There are issues with MCE and block/item related commands.

Q. Drops command
A. I haven't used it more than 2 minutes in 1.7.3 and didn't have an issue, it sounds like people have had issues - I will investigate

Q. Teleport commands
A. No idea why you would be going thousands of blocks from where you should be - but it sounds like you have the wrong SPC version installed this was a problem with V2.10_1 on Minecraft 1.7.3 (which is not supported) if you install this combination you ARE going to have problems

Q. I PMed you but you didn't respond...
A. No offense intended, it isn't just you it is everyone, I have over 200 PMs in my inbox which are unanswered (unopened) - I dont have the time. All my PMs go to my email I read them all there and unless it is something which requires specifically my attention I haven't replied. The best way to get my attention is still PM - make sure it is something which is specifically regarding me.

Q. I have a problem with *insert command here*
A. Go to http://youtube.com/user/spcmod and lookup the command to see how it should be used

---

If I missed something I appologise this is a rushed message.

#11613

Turtally
    Turtally

    Out of the Water

  • Members
  • 2 posts

Posted 20 July 2011 - 07:21 AM

I need help, whenever I use noclip it works fine until I turn it on and then I skyrocket to the sky and fall down. Is there any way for me to fix this?

#11614

fireballcreeper
  • Minecraft: darknessking2011

Posted 20 July 2011 - 07:32 AM

what do you do to get the other dyes? i dont know how to write the small number

#11615

Godsblade :)

Posted 20 July 2011 - 09:08 AM

Good work on this, it really shows how to push the limits of creativity to another level. :D

#11616

Binkleplease

Posted 20 July 2011 - 09:15 AM

View Postsimo_415, on 20 July 2011 - 06:17 AM, said:

That's why I said run it from the console, MAC is based off ux OS's therefore how to run it on ux should work:

cd ~/.minecraft/bin; java -Xms512M -Xmx1024M  -Xincgc -cp "minecraft.jar:jinput.jar:lwjgl.jar:lwjgl_util.jar" -Dorg.lwjgl.librarypath="$(pwd)/natives" -Dnet.java.games.input.librarypath="$(pwd)/natives" net.minecraft.client.Minecraft

I feel stupid now. But like I said, I'm a tech noob.

#11617

simo_415
    simo_415

    Glowstone Miner

  • Members
  • 3046 posts

Posted 20 July 2011 - 11:20 AM

View PostBinkleplease, on 20 July 2011 - 09:15 AM, said:

I feel stupid now. But like I said, I'm a tech noob.

That's ok - not everyone has to know everything. Would you like to try a demo of the new installer for SPC? I haven't had anyone test it on a MAC or ux based machine yet, it should theoretically work - but yeah hasn't been tested. It is still in development, but it will install the classes fine.

#11618

simo_415
    simo_415

    Glowstone Miner

  • Members
  • 3046 posts

Posted 20 July 2011 - 11:32 AM

I need help working out why some of these things occur. If you can help out by reproducing any of these issues please let me know! Fixing problems at the moment and cant reproduce most of these.

View Postsimo_415, on 20 July 2011 - 06:31 AM, said:

I plan to spend a few hours tonight fixing bugs and writing a few enhancements as well as releasing an installer for the mod - which should solve 95% of the installation problems. I dont have time these days to respond to posts on the forums, so if you guys would help others out when they have issues, that would be great.

Here is a brief answer to most common questions:

Q. Installation problems.
A. Refer to OP troubleshooting section

Q. Noclip doesn't work with Zombes
A. A mod conflict caused by a bug in SPC - will be fixed by the next release

Q. Minecraft Extended compatability?
A. Semi... MCE changes block ids and many of the things in Minecraft which are hard to account for. There are issues with MCE and block/item related commands.

Q. Drops command
A. I haven't used it more than 2 minutes in 1.7.3 and didn't have an issue, it sounds like people have had issues - I will investigate

Q. Teleport commands
A. No idea why you would be going thousands of blocks from where you should be - but it sounds like you have the wrong SPC version installed this was a problem with V2.10_1 on Minecraft 1.7.3 (which is not supported) if you install this combination you ARE going to have problems

Q. I PMed you but you didn't respond...
A. No offense intended, it isn't just you it is everyone, I have over 200 PMs in my inbox which are unanswered (unopened) - I dont have the time. All my PMs go to my email I read them all there and unless it is something which requires specifically my attention I haven't replied. The best way to get my attention is still PM - make sure it is something which is specifically regarding me.

Q. I have a problem with *insert command here*
A. Go to http://youtube.com/user/spcmod and lookup the command to see how it should be used

---

If I missed something I appologise this is a rushed message.


#11619

simo_415
    simo_415

    Glowstone Miner

  • Members
  • 3046 posts

Posted 20 July 2011 - 11:57 AM

Freezecam implemented, buggy though =(... it's really weird to be walking around and have control over your player without the camera moving with the player...

#11620

Singular9

Posted 20 July 2011 - 12:22 PM

ok when i ran minecraft it started fine loaded my world and then stopped and froze and it didn't respond so i exited then i tried it without tmi mod, it worked fine, a bit of lag at the beginning, i think tmi stops it from working.