Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[Launcher] Magic Launcher 1.2.5 (mods, options, profiles, news)


  • Please log in to reply
9321 replies to this topic

#7421

MinerLouizer1112

Posted 21 July 2013 - 02:25 AM

im having a problem, once i added damage indicators, my minecraft would run, show the mojan logo for about 15 secs, then crash with no error or crash log, it just closes o.o before this mod, it worked fine. list of my mods include:
Rei's minimap
Optifine
Damage indicators
TMI
Endercraft
the Mists of Riov

Register or log in to remove.

#7422

Nornwen
    Nornwen

    Tree Puncher

  • Members
  • 10 posts

Posted 21 July 2013 - 05:51 AM

I have the newest version of magic launcher but I am having problems:

1) I do have 1.6.2 and have already launched it on its own.

2) I have set the environment to 1.6.2

3) However, if I go to options instead of setup it says I am in 1.5.2 and gives me no option to change.

4) Everything says "OK" and checks out in that way.

Here is what it says:

Spoiler:


#7423

Alper_Kaan

Posted 21 July 2013 - 06:43 AM

i have a problem,if i open the magic launcher and click login the game don't start please help me

#7424

Saiyan1337
  • Location: Texas
  • Minecraft: Saiyan1337

Posted 21 July 2013 - 08:00 AM

View PostNornwen, on 21 July 2013 - 05:58 AM, said:

This is exactly my problem, does anyone have the answer?
Check to see if your using the right environment. and everything is installed correctly.

View PostTSHock, on 20 July 2013 - 04:56 PM, said:

AH! THAT SUCKS! HELP ME IN THIS ERROR:
Spoiler:
I think i see a 1.4.7. idk... make sure that those are all updated to 1.6.2 and you are using the right environment.

View PostJJMAN64883, on 20 July 2013 - 11:39 PM, said:

Help:
*** MagicMinecraftLauncher 1.1.7 ***
  LCP: ;C:\Users\VVJS\Desktop\Aether\bin\minecraft.jar;bin/jinput.jar;bin/lwjgl.jar;bin/lwjgl_util.jar
  InactiveExtMods: 1.6.2 DamageIndicators v2.8.5.1.zip;AetherII_Alpha_v1.0.2_MC1.5.1.zip;Damage-Indicators-Mod-1.5.1.zip
  MainClass: net.minecraft.client.Minecraft
java.lang.NoClassDefFoundError: org/lwjgl/LWJGLException
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
at java.lang.Class.getMethod0(Unknown Source)
at java.lang.Class.getMethod(Unknown Source)
at magic.launcher.Launcher.main(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.lwjgl.LWJGLException
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 5 more

Pro tip: Update that to 1.6.2... that may solve the issue...
Posted Image

#7425

TheHazification
  • Minecraft: KingCaliente

Posted 21 July 2013 - 10:17 AM

How do allocate more ram.

#7426

Danzel
    Danzel

    Tree Puncher

  • Members
  • 32 posts
  • Location: Odense, Denmark
  • Minecraft: danzel89

Posted 21 July 2013 - 12:01 PM

I only have sounds for like a few seconds then it disappears and I have to log out, close MagicLauncher and open it all again.

What am I doing wrong?

#7427

adrianmelinswe5454

Posted 21 July 2013 - 12:31 PM

I can not play! Help need!


*** MagicMinecraftLauncher 1.1.6 ***
  LCP: C:\Users\Adrian\Desktop\OptiFine_1.6.2_HD_U_B4 (1).zip;C:\Users\Adrian\AppData\Roaming\.minecraft\bin\1.6.2.jar;bin/jinput.jar;bin/lwjgl.jar;bin/lwjgl_util.jar
  MainClass: net.minecraft.client.Minecraft
java.lang.ClassNotFoundException: net.minecraft.client.Minecraft
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at magic.launcher.Launcher.main(Unknown Source)

#7428

BeardedKirklander

Posted 21 July 2013 - 01:27 PM

View PostTheHazification, on 21 July 2013 - 10:17 AM, said:

How do allocate more ram.

Start Magic Launcher
Click Setup Button
Click Advanced tab (next to Mods)
Enter amount you want to allocate in the Memory field
   (I use 2048 on most machine, sometimes 1024)

Hope that helps.

View PostDanzel, on 21 July 2013 - 12:01 PM, said:

I only have sounds for like a few seconds then it disappears and I have to log out, close MagicLauncher and open it all again.

What am I doing wrong?

Try these that I paste from another post someone made:

Option #1:  (Suggested before)  Go into the menu, and go where you can choose resource packs.  Click on your resource pack (if you're not using one just click on the DEFAULT one) and your sound should start up.

Option #2:  Hold down F3 and his S.  This will restart the sound in-game.  Super Simple.

#7429

MinerLouizer1112

Posted 21 July 2013 - 03:27 PM

View PostMinerLouizer1112, on 21 July 2013 - 03:05 PM, said:

please can someone help me with this problem ^^^ Posted Image
ACTUALY i found a crash report in my .minecraft folder
Spoiler:


#7430

Phoenix1Falcon2MC3

Posted 21 July 2013 - 03:42 PM

This is great, just how do i change my minecraft jar to 1.6.2? I wanna use the shaders mod while playing on my favorite servers on 1.6.2, but i need to load up the minecraft jar. help!? (unless i have to delete the 1.5.2 jar file and replace it with a 1.6.2 jar file. but if this is true, how do i reach the jar file to delete it? i run windows.)
Im surprised if i have Iron/Gold armor to survive this many days :Pand with No fences 0_0
Posted Image

#7431

snake302
    snake302

    Tree Puncher

  • Members
  • 19 posts

Posted 21 July 2013 - 04:03 PM

How change font???

#7432

MinerLouizer1112

Posted 21 July 2013 - 04:19 PM

View PostMinerLouizer1112, on 21 July 2013 - 03:27 PM, said:

ACTUALY i found a crash report in my .minecraft folder
Spoiler:
i asked the damage indicator mod thread and they said it is most likely a ML problem, so someone please help :/

#7433

Acies
    Acies

    Newly Spawned

  • Members
  • 1 posts

Posted 21 July 2013 - 05:20 PM

I have a serious issue, I cant log in with my username, (this appears when I log in: "Error connecting to server") and when I try to log in with my email a log pop up appears.
Help please

#7434

RayMan225

Posted 21 July 2013 - 05:25 PM

I really need some help because I ran out of things to try. I updated everything to 1.6.2, all my mods, Forge, and followed the instruction to select the specific environment in the setup menu. But still, no matter what I do, I get the same error message, a long stream of words with a bunch of codes below it. If I look in the options menu it says that I'm running 1.5.2, even though I just updated it, if it means anything (now it says that it's modified because I tried deleting the META Inf folder).

If it helps, this is the error message:
\*** MagicMinecraftLauncher 1.1.7 ***
  LCP: C:\Users\Home PC\Desktop\Optifine\OptiFine_1.6.2_HD_U_B4.zip;C:\Users\Home PC\AppData\Roaming\.minecraft\versions\1.6.2-Forge9.10.0.789\1.6.2-Forge9.10.0.789.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\net\minecraftforge\minecraftforge\9.10.0.789\minecraftforge-9.10.0.789.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\net\minecraft\launchwrapper\1.3\launchwrapper-1.3.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\org\scala-lang\scala-library\2.10.2\scala-library-2.10.2.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\org\scala-lang\scala-compiler\2.10.2\scala-compiler-2.10.2.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\org\ow2\asm\asm-all\4.1\asm-all-4.1.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\net\sf\jopt-simple\jopt-simple\4.5\jopt-simple-4.5.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\lzma\lzma\0.0.1\lzma-0.0.1.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\com\paulscode\codecjorbis\20101023\codecjorbis-20101023.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\com\paulscode\codecwav\20101023\codecwav-20101023.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\com\paulscode\libraryjavasound\20101123\libraryjavasound-20101123.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\com\paulscode\librarylwjglopenal\20100824\librarylwjglopenal-20100824.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\com\paulscode\soundsystem\20120107\soundsystem-20120107.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\org\lwjgl\lwjgl\lwjgl\2.9.0\lwjgl-2.9.0.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\org\lwjgl\lwjgl\lwjgl_util\2.9.0\lwjgl_util-2.9.0.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\argo\argo\2.25_fixed\argo-2.25_fixed.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\org\bouncycastle\bcprov-jdk15on\1.47\bcprov-jdk15on-1.47.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\com\google\guava\guava\14.0\guava-14.0.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\org\apache\commons\commons-lang3\3.1\commons-lang3-3.1.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\commons-io\commons-io\2.4\commons-io-2.4.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\net\java\jinput\jinput\2.0.5\jinput-2.0.5.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\net\java\jutils\jutils\1.0.0\jutils-1.0.0.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\com\google\code\gson\gson\2.2.2\gson-2.2.2.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\org\lwjgl\lwjgl\lwjgl-platform\2.9.0\lwjgl-platform-2.9.0-natives-windows.jar;C:\Users\Home PC\AppData\Roaming\.minecraft\libraries\net\java\jinput\jinput-platform\2.0.5\jinput-platform-2.0.5-natives-windows.jar
  MainClass: net.minecraft.launchwrapper.Launch
java.lang.ClassNotFoundException: net.minecraft.launchwrapper.Launch
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at magic.launcher.Launcher.main(Unknown Source)

#7435

Nornwen
    Nornwen

    Tree Puncher

  • Members
  • 10 posts

Posted 21 July 2013 - 05:33 PM

View PostNornwen, on 21 July 2013 - 05:51 AM, said:

I have the newest version of magic launcher but I am having problems:

1) I do have 1.6.2 and have already launched it on its own.

2) I have set the environment to 1.6.2

3) However, if I go to options instead of setup it says I am in 1.5.2 and gives me no option to change.

4) Everything says "OK" and checks out in that way.

Here is what it says:

Spoiler:
In response to the person who responded to me. (LOL) I did change my environment. ^^^^

I have the same problem as the person above, it seems there are a few people with this problem. Maybe it is a bug?

#7436

ebennett365

Posted 21 July 2013 - 06:17 PM

SOMEBODY TELL ME HOW TO GET FORGE WORKING SO I CAN USE OPTIFINE WITH THE BACKPACKS MOD!!!

This stupid editor sucks it wont let me put my pic here!!!!!


#7437

Curver_21

Posted 21 July 2013 - 06:38 PM

This is a great tool for installing mods, but unfortunately for me it causes some problems. I cannot get the sound to work when launching with magic launcher, regardless of how much memory I allocate or what mods I have activated. When launching normally (no magic launcher), I do have sound. Any tips?

Edit:

It's actually modloader that's causing the problems. Great. Do I need modloader to be active under 'mods'? How should I activate modloader now?

#7438

BeardedKirklander

Posted 21 July 2013 - 07:19 PM

View PostCurver_21, on 21 July 2013 - 06:38 PM, said:

This is a great tool for installing mods, but unfortunately for me it causes some problems. I cannot get the sound to work when launching with magic launcher, regardless of how much memory I allocate or what mods I have activated. When launching normally (no magic launcher), I do have sound. Any tips?

Edit:

It's actually modloader that's causing the problems. Great. Do I need modloader to be active under 'mods'? How should I activate modloader now?

Option #1:  (Suggested before)  Go into the menu, and go where you can choose resource packs.  Click on your resource pack (if you're not using one just click on the DEFAULT one) and your sound should start up.

Option #2:  Hold down F3 and his S.  This will restart the sound in-game.  Super Simple.

#7439

krissness

Posted 21 July 2013 - 09:02 PM

View Postkrissness, on 19 July 2013 - 03:07 AM, said:

Hi! I've been through the past few pages, but nothing seems to adequately describe my problem.

I've been using ML for a while; went to go update the launcher, Minecraft, and the mods - did all successfully. All my mods say 'ok' in the setup, and when I test it, it works fine.
When I go to actually login, however, it will not connect to the server. Under options, it says it's running Version 1.5.2.
I've re-downloaded everything - from MagicLauncher itself to the mods to Minecraft - the original launcher and the new update. I'm a little stumped. Any help would be appreciated. Thank you!

Alrighty, so I took screen caps and documented the details of my problem, for a bit more technical clarity. :C

My (few) Mods: (Note: I've always used just these 3, I simply updated them all to their most current versions.)
Posted Image


My Options:
Posted Image


My Problem:
Posted Image


My Error Details:

Spoiler:


#7440

Breaking Ice

Posted 21 July 2013 - 09:02 PM

Hey guys, I've been having a problem getting this new version to work. I have all my mods added, and its all OK, and my environment is the forge one, but when I try to test I get this error message.

*** MagicMinecraftLauncher 1.1.7 ***
  LCP: C:\Users\Donny V2\Desktop\Minecraft\downloaded mods\Too Many Items\TooManyItems2013_07_09_1.6.2_Forge.jar;C:\Users\Donny V2\Desktop\Minecraft\downloaded mods\Rei Minimap\[1.6.2]ReiMinimap_v3.4_01.zip;C:\Users\Donny V2\Desktop\Minecraft\downloaded mods\OptiFine\OptiFine_1.6.2_HD_U_B3.zip;C:\Users\Donny V2\Desktop\Minecraft\downloaded mods\Inv Tweaks\InventoryTweaks-MC1.6.2-1.55-b56.jar;C:\Users\Donny V2\Desktop\Minecraft\downloaded mods\bspkrs mods\Status Effect HUD\[1.6.2]StatusEffectHUDv1.14.zip;C:\Users\Donny V2\Desktop\Minecraft\downloaded mods\bspkrs mods\Ingame Info\[1.6.2]IngameInfo.ML.1.6.2.r02.zip;C:\Users\Donny V2\Desktop\Minecraft\downloaded mods\bspkrs mods\Armor Effect HUD\[1.6.2]ArmorStatusHUDv1.12.zip;C:\Users\Donny V2\Desktop\Minecraft\downloaded mods\bspkrs mods\[1.6.2]bspkrsCorev3.03.zip;C:\Users\Donny V2\Desktop\Minecraft\downloaded mods\Forge\minecraftforge-universal-1.6.2-9.10.0.789.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\versions\1.6.2-Forge9.10.0.789\1.6.2-Forge9.10.0.789.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\net\minecraftforge\minecraftforge\9.10.0.789\minecraftforge-9.10.0.789.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\net\minecraft\launchwrapper\1.3\launchwrapper-1.3.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\org\scala-lang\scala-library\2.10.2\scala-library-2.10.2.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\org\scala-lang\scala-compiler\2.10.2\scala-compiler-2.10.2.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\org\ow2\asm\asm-all\4.1\asm-all-4.1.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\net\sf\jopt-simple\jopt-simple\4.5\jopt-simple-4.5.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\lzma\lzma\0.0.1\lzma-0.0.1.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\com\paulscode\codecjorbis\20101023\codecjorbis-20101023.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\com\paulscode\codecwav\20101023\codecwav-20101023.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\com\paulscode\libraryjavasound\20101123\libraryjavasound-20101123.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\com\paulscode\librarylwjglopenal\20100824\librarylwjglopenal-20100824.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\com\paulscode\soundsystem\20120107\soundsystem-20120107.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\org\lwjgl\lwjgl\lwjgl\2.9.0\lwjgl-2.9.0.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\org\lwjgl\lwjgl\lwjgl_util\2.9.0\lwjgl_util-2.9.0.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\argo\argo\2.25_fixed\argo-2.25_fixed.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\org\bouncycastle\bcprov-jdk15on\1.47\bcprov-jdk15on-1.47.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\com\google\guava\guava\14.0\guava-14.0.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\org\apache\commons\commons-lang3\3.1\commons-lang3-3.1.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\commons-io\commons-io\2.4\commons-io-2.4.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\net\java\jinput\jinput\2.0.5\jinput-2.0.5.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\net\java\jutils\jutils\1.0.0\jutils-1.0.0.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\com\google\code\gson\gson\2.2.2\gson-2.2.2.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\org\lwjgl\lwjgl\lwjgl-platform\2.9.0\lwjgl-platform-2.9.0-natives-windows.jar;C:\Users\Donny V2\AppData\Roaming\.minecraft\libraries\net\java\jinput\jinput-platform\2.0.5\jinput-platform-2.0.5-natives-windows.jar
  MainClass: net.minecraft.launchwrapper.Launch
java.lang.ClassNotFoundException: net.minecraft.launchwrapper.Launch
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at magic.launcher.Launcher.main(Unknown Source)

I believe this has something to do with Forge because it will work if I don't use the Forge environment and turn all the Forge-required mods off.

I noticed at the top is gives the location of the first active mod that it encounters from the bottom up. In the error report above it says too many items, but if I go and disable that, then it will just say Raiesminimap, then if I disable that it will say optifine. (Which doesn't even require forge) and so on.

I have this screenshot of my setup screen, in case that helps.

http://prntscr.com/1gqtwh

Anyone's help on this would be tremendously appreciated, as I can't pvp well without these mods xD