Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[Launcher] Magic Launcher 1.2.5 (mods, options, profiles, news)


  • Please log in to reply
9314 replies to this topic

#1861

TheLima
    TheLima

    Carpenter

  • Members
  • 54 posts
  • Minecraft: TheLima

Posted 24 April 2012 - 12:35 AM

View Postjjokcerr, on 23 April 2012 - 10:50 PM, said:

All the mods? interesting idea mate Posted Image
any performance affects? ( positive / negative )


@ag25
i clicked the up arrow bottom right corner of your replay :3
i approve of that message Posted Image

@iiiHuman...Well, most of the mods that require modloader are coded to load from it will actually have a high risk of getting something wrong if they are put into the jar.
By the same token, some other mods will require you to put them into the jar to work right, due to incompatibility with modloader, or some other dark-side-of-the-force reason...
In the end, it's all about reading the instructions and doing what it says...The mod's author knows best, afterall.

@jjockcerr...It's all loaded in your RAM memory or a buffer-like range of memory allocated in your HD. Either way, it's moved (actually copied) from the general place to one that has an easier access to the files, and, in theory, both loading methods will lead the data to the same place, thus having (once loaded...the same cannot be told about loading-times) the same performance.
Digging straight down while forgetting I have no Ladders at all...

Register or log in to remove.

#1862

KBKevin
    KBKevin

    Out of the Water

  • Members
  • 4 posts

Posted 24 April 2012 - 05:43 AM

I'm having a problem with installing IC2 and TC2 and I get this error report


=====================================
Error Report
Spoiler:

=====================================



I'm aware "CodeChickenCore" comes up twice but I only installed it once.
I tried a fresh install but no avail. :/
Can anyone help?


*ERROR LOG*


Spoiler:

Edited by KBKevin, 24 April 2012 - 05:59 AM.


#1863

EmberQuill

Posted 24 April 2012 - 06:37 AM

View PostKBKevin, on 24 April 2012 - 05:43 AM, said:

Spoiler:

CodeChickenCore isn't the only one listed twice.  Forge, ModLoaderMP, NEI, and Rei's Minimap are all doubled.  You should check and make sure you aren't somehow loading both of them twice.

I'm not sure exactly what's causing your error, although I do know that ModLoaderMP and Forge are no longer compatible.  Forge incorporated a lot of MLMP's functionality and improved on it but now that means that MLMP and Forge can't coexist.

#1864

ThreeEye
    ThreeEye

    Void Walker

  • Members
  • 1841 posts
  • Minecraft: iiiHuman

Posted 24 April 2012 - 12:18 PM

View Postjjokcerr, on 23 April 2012 - 10:50 PM, said:

All the mods? interesting idea mate Posted Image
any performance affects? ( positive / negative )



There would be NO detrimental performance affects nor any other differences since, either loading them externally from that mods sub-folder OR listing them internally instead, Magic Launcher would be loading them the same way either method.



Posted Image




View PostTheLima, on 24 April 2012 - 12:35 AM, said:

@iiiHuman...Well, most of the mods that require modloader are coded to load from it will actually have a high risk of getting something wrong if they are put into the jar.



We're NOT talking about putting them into the jar.  We're talking about whether to place a ModLoader-Dependent mod in the mods sub-folder or to just select it for the internal mods list instead.

ModLoader-Dependent mods can either be dropped into that mods sub-folder as normal in which case they will automatically be seen as an external mod but still loaded as long as you have ModLoader itself in the internal mods list.  HOWEVER, you do NOT have to do that.  You can instead leave them out of, or remove them from, that mods sub-folder and add them to the list of internal mods just like you do with ModLoader itself and also just like you do with mods that do NOT require ModLoader.  You just need to have them listed after ModLoader since mod order matters.

The point is, that it works either way.  And, there are benefits to loading them internally (listed in the internal mods list in Magic Launcher) instead of externally (dropping them into that mods sub-folder as normal).

Loading them "internally" does NOT mean putting them into the minecraft.jar file itself.

Also, you only want to load them either internally (preferred) or externally (optional) but not both.  Otherwise, you will get errors about the mods trying to be loaded more than once.

To also be perfectly clear, do NOT have a mod in that mods folder if you're loading it internally instead.  Have it in some different location.


Posted Image




View PostTheLima, on 24 April 2012 - 12:35 AM, said:

By the same token, some other mods will require you to put them into the jar to work right, due to incompatibility with modloader, or some other dark-side-of-the-force reason...
In the end, it's all about reading the instructions and doing what it says...The mod's author knows best, afterall.


There is really currently only one known mod that requires still being installed manually into the minecraft.jar file instead.  And, that is GuiAPI.  As mentioned earlier in the thread, it is not really a compatibility issue between GuiAPI and Magic Launcher but rather a limitation of GuiAPI itself due to issues with the specific set of programming library files that was used to make it.  It is also mentioned in the GuiAPI thread.

However, some mods will still require extra steps to be taken such as removing one or more files and manually placing them in your minecraft installation's bin folder (not the minecraft.jar file).  Or, first extracting the correct edition of a mod from the larger zip package you downloaded (since the mods files aren't actually in the root of the package you initially downloaded).



Posted Image




View PostKBKevin, on 24 April 2012 - 05:43 AM, said:

I'm having a problem with installing IC2 and TC2 and I get this error report ...

< snip >

I'm aware "CodeChickenCore" comes up twice but I only installed it once.
I tried a fresh install but no avail. :/
Can anyone help?




First off, you only want to load mods EITHER internally (preferred) OR externally (optional) BUT NOT BOTH.  Otherwise, you will get errors about the mods trying to be loaded more than once.

Second, I don't know about the conflict between the latest Forge and ModLoaderMP but that would also cause problems.

Third, mod order matters.  ModLoader normally goes first if needed.  Then, ModLoaderMP if needed.  Then/Or, Forge if needed.  Try to put OptiFine last after other mods as desired.  There is at least one exception to that rule too.



Posted Image

#1865

conchclaq

Posted 24 April 2012 - 01:00 PM

You, sir, are the savior of Minecraft and Mojang.Posted Image Posted Image Posted Image Posted Image Posted Image Posted Image

#1866

Murdath
    Murdath

    Tree Puncher

  • Members
  • 24 posts
  • Location: Avandoned Mine Shaft
  • Minecraft: Murdath

Posted 24 April 2012 - 04:37 PM

How do I change the Mods block ID's ?

TC2 and IC2 conflict with eachother, and when I modify the config files with new block ID's, Magic Launcher rewrites those files back to the starting point.

#1867

stertingen
  • Location: Germany
  • Minecraft: stertingen

Posted 24 April 2012 - 05:38 PM

it world be much easier to install external mods for different versions if you can make different mods-folders, for each minecraft.jar one mods-folder.
Sorry for my bad english, I'm german.
Best Mod ever: RedPower2 by Eloraam

#1868

Johnny__Alpha

Posted 24 April 2012 - 07:13 PM

Having a problem logging in. I just changed my password to one a bit more secure and I can no longer long in via Magic Launcher. I can still log in perfectly fine using the default launcher, and have never had any problems logging in with Magic Launcher before changing my password. Are there any characters that Magic Launcher won't accept in a password that Minecraft.net will? I do not wish to change my password again just to use the launcher.

I noticed this in the error log:

Quote

Invalid byte 1 of 1-byte UTF-8 sequence.
Here is the full log:
MagicLauncher 0.9.7
java.home: C:\Program Files\Java\jre8
java.runtime.name: Java(TM) SE Runtime Environment
java.runtime.version: 1.8.0-ea-b27
os.name: Windows 7
os.version: 6.1
os.arch: x86
sun.arch.data.model: 32
com.sun.org.apache.xerces.internal.impl.io.MalformedByteSequenceException: Invalid byte 1 of 1-byte UTF-8 sequence.
	at com.sun.org.apache.xerces.internal.impl.io.UTF8Reader.invalidByte(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.io.UTF8Reader.read(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.load(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.scanData(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanCDATASection(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl.parse(Unknown Source)
	at javax.xml.parsers.SAXParser.parse(Unknown Source)
	at magic.launcher.af.run(Unknown Source)

Any help appreciated.

Posted Image

I hope your dragon dies


#1869

Bonedragon1300
  • Minecraft: Bonedragon1300

Posted 24 April 2012 - 08:45 PM

Is there a reason that any mod with sound dosn't work? can some one tell me whats going on.
Posted Image

#1870

Cjslayer16

Posted 25 April 2012 - 03:50 AM

Anyone know particularly what this error is? :S
Spoiler:

I had this working earlier, but had a slight issue detailed here, so I attempted to use the magic launcher as advised by my friend, however I then got this error. As far as I know I have done as directed and such, GUI API is installed manually into the Jar as I read reading down this page.

Any help would be mighty appreciated!

#1871

Nachorandell
  • Minecraft: Nachorandell

Posted 25 April 2012 - 04:06 AM

For some reason, when I try to reroute my .minecraft folder, I press the browse button next to "location", and it pulls up my standard file browser and I am unable to select a different .minecraft folder. Please help!
Mess with the best, die like the rest.
Clan: Ranger Mercenaries Rank: Owner

#1872

tomeoftom

Posted 25 April 2012 - 09:07 AM

Just signed up to tell you how amazing this utility is. It's saved me so, so much time. Beautifully made, sir.

#1873

ThreeEye
    ThreeEye

    Void Walker

  • Members
  • 1841 posts
  • Minecraft: iiiHuman

Posted 25 April 2012 - 01:07 PM

View Poststertingen, on 24 April 2012 - 05:38 PM, said:

it world be much easier to install external mods for different versions if you can make different mods-folders, for each minecraft.jar one mods-folder.



Did you even glance at the last page or the few posts at the top of this one?

Just put those mods in the internal mods list instead of that mods sub-folder.



Posted Image




View PostCjslayer16, on 25 April 2012 - 03:50 AM, said:

Anyone know particularly what this error is? :S
Spoiler:

I had this working earlier, but had a slight issue detailed here, so I attempted to use the magic launcher as advised by my friend, however I then got this error. As far as I know I have done as directed and such, GUI API is installed manually into the Jar as I read reading down this page.

Any help would be mighty appreciated!



Bottom portion of the sixth post up from yours on this same page.

You're loading mods twice.  Try loading them all internally only (preferred).



Posted Image

#1874

Cjslayer16

Posted 25 April 2012 - 02:14 PM

Its weird, every time I change anything I get several Different error reports. I'm going to try one last time doing them all internally and see what happens.

Edit: I was attempting this last night, and I logged in this morning in an attempt to fix it, but the magic launcher actually deleted a bunch of my mod Zip files -.- Now I need to re download a few. Is that because of something I've done or some weird glitch? Nevermind, lol I see how it works, thats pretty nifty. Then I dont have to move stuff around. Was quite a shock for me though. I even went in once and Didnt see them as zip files so I ignored their presence entirely. Ahh I'm too tired for this.

As someone else said, it Overwrote my config files too, so now all the ID clashes I had before are there again. Sigh, this is a pain.  Good thing I have a wordpad file saved just for instances like this.
Seems it was only the armor stand mod and Shelf mod. Might be why people find it easier to just delete them.

Edit two: I don't understand, It just keeps adding the mods twice. I put them all internally and then X'd off the list. Do I need to do something else that I am forgetting?

Edit three:This is very annoying, this is all I have put on , and it still duplicates. They are only internally, Externally was turned off. I didn't put them in there twice either. :/


This is the full log
Spoiler:
From what I seen, there is one particular line, that tells me , It knows I don't want certain mods on twice but it loads them anyways saying it cannot disable both.
The main question I think I actually have now, am I forgetting a step that is obvious? I looked over the main post a couple times and I don't notice anything ...

They are all the mods that are internally, but they are still in the external list ( they are disabled in the external list), is there a way to remove them and have them still internal or does it require them in that spot to work right? I'm just not sure how this works. -.-' I feel dumb too, because All these mods do work together, I had the game running earlier. As I noted in the thread I linked to my original problem post. But it had caused errors with furnaces somewhere. So I did not even load Extra Furnaces.

#1875

Cjslayer16

Posted 25 April 2012 - 05:51 PM

Ahh I fixed it guys, I'm not sure exactly what went wrong but I just did it all by hand and It worked out better then before. I dont get the original error I used to, and now It all works fine and dandy :3 Thanks for the replies anyways guys!

#1876

ThreeEye
    ThreeEye

    Void Walker

  • Members
  • 1841 posts
  • Minecraft: iiiHuman

Posted 25 April 2012 - 06:00 PM

View PostCjslayer16, on 25 April 2012 - 05:51 PM, said:

Ahh I fixed it guys, I'm not sure exactly what went wrong but I just did it all by hand and It worked out better then before. I dont get the original error I used to, and now It all works fine and dandy :3 Thanks for the replies anyways guys!



When loading all of your mods internally (preferred), make sure that mods folder is EMPTY.  Load all of your mods from a DIFFERENT location.  And, mod order matters.

It would be nice to see a screenshot of your mod setup screen.



Posted Image

#1877

CannonFoddr
  • Location: Inside your PC, watching you !!!!!
  • Minecraft: CannonFoddr

Posted 25 April 2012 - 07:37 PM

View PostRycr, on 24 April 2012 - 06:37 AM, said:

CodeChickenCore isn't the only one listed twice.  Forge, ModLoaderMP, NEI, and Rei's Minimap are all doubled.  You should check and make sure you aren't somehow loading both of them twice.

I'm not sure exactly what's causing your error, although I do know that ModLoaderMP and Forge are no longer compatible.  Forge incorporated a lot of MLMP's functionality and improved on it but now that means that MLMP and Forge can't coexist.
I had something similar.....

Have you 'stored' the MOD's you're loading via 'Magic' in /.minecraft/mods/ folder by any chance (& not in a sub folder like '/.minecraft/mods/1.2.5 mods/')??

What MIGHT be happening is that 'modloader' is being installed - which then 'looks' for compatible MOD's in that /mods/ folder & you are ALSO asking magic to load in those self same MOD's - so you're loading those MOD's twice
Posted Image

#1878

Hydro3000

Posted 25 April 2012 - 07:56 PM

Ummm I have a problem. When I try to install forge it says not compatible even though its for minecraft 1.2.5?
This means I cant use the Backpack mod and Balkons Weapons mod!!!! Please help me I will try to figure it out myself as well
Posted Image

#1879

geobiscuits

Posted 25 April 2012 - 08:43 PM

can someone help me. i'm trying to delete the magic launcher and reinstall it again because i fiddled around with it but an error appears. it says " the action can't be completed because the file is open in java™ Platform SE binary. close the file and try again". i have closed everything but i still can't delete it. someone help me please.
Posted Image

#1880

CannonFoddr
  • Location: Inside your PC, watching you !!!!!
  • Minecraft: CannonFoddr

Posted 25 April 2012 - 09:04 PM

View Postgeobiscuits, on 25 April 2012 - 08:43 PM, said:

can someone help me. i'm trying to delete the magic launcher and reinstall it again because i fiddled around with it but an error appears. it says " the action can't be completed because the file is open in java™ Platform SE binary. close the file and try again". i have closed everything but i still can't delete it. someone help me please.
Are you using Windows ??

If so use [ctrl] [alt] and [del] together to call up the windows task manager & select the tab labelled 'processes'

look for 'Java.exe' (it may be 'javaw.exe' or similar) - highlight it & click on the 'end process' button, select [yes] when asked & that 'should' stop Java from attempting to run 'magic' allowing you to uninstall etc

If not - you could try booting up into windows 'safe' mode & try to uninstall magic that way
Posted Image