Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[1.7.2] [SSP/SMP/LAN] Minecraft Comes Alive v4.0.1 (Two Million Downloads!)

villager npc children marriage kids babies family

  • Please log in to reply
11898 replies to this topic

#5101

Jakestarz
  • Location: The void between bedrock and the nether spawning creepers.
  • Xbox:SYCOGLUESNIFFER

Posted 30 September 2012 - 04:56 PM

View Postglorissa, on 30 September 2012 - 03:40 PM, said:

is this for 1.3.2 or still Beta Posted Image  i need 1.3.2
if anyone sends me the link to 1.3.2
ill give them Posted Image  Posted Image  Posted Image  Posted Image  Posted Image  Posted Image  Posted Image
This is 1.3.2
The Mod is in beta
"It's not what your country can do for you, it's what you can do for this country."

Register or log in to remove.

#5102

Emilie
    Emilie

    Iron Miner

  • Members
  • 290 posts
  • Location: Nordland in Norway
  • Minecraft: Emilielol123lal

Posted 30 September 2012 - 05:13 PM

How do you chat to them because it is grey over the button and how do you migrate and make them follow you How please answer!

#5103

630tiger
    630tiger

    Obsidian Miner

  • Members
  • 1479 posts

Posted 30 September 2012 - 05:27 PM

I'm having a rather odd problem at the moment. I have two villagers together that I just spawned from eggs, and I gifted one (I tried several times and it doesn't matter who I give it to first) an arranger's ring. They accepted it and a name thing came up over their head and in their GUI that said they had the ring. But when I give it to the other person, though the ring disappears and the chat says the villagers are married, the original person still has the ring and the game doesn't recognize that they're married. In fact, I can give a ring to the other person and the game will think that I'm going to find a partner for them, even though their intended spouse still has a ring. Also, when I try to take the ring back after a failed marriage, two ring items drop, but I can only pick up one.
"I realized I just liked making them move."
"Look at me still talking when there's science to do. When I look out there it makes me glad I'm not you."

#5104

WildBamaBoy

Posted 30 September 2012 - 05:30 PM

View PostTheLordDwarf, on 30 September 2012 - 08:08 AM, said:

i gave a women with 100 hearts a regular gold ring made minecraft crash please fix

i tried to have a baby i had a boy i named him and i didn't get him i heared a POP noise but no baby came out

i tried to migrate but it crashed

You were right with a lot of bugs

Did you update at all?? These are verified fixed.

View PostLadyofthedrgns, on 30 September 2012 - 09:13 AM, said:

My virus scanner is currently going nuts over the beta download and has currently quarantined all files. So when i went to check the mod file. WinRAR stated that the mod_MCA.zip did not exist.

i have tried shutting down my virus scanner briefly to see if that helped. Tried installing again. As soon as i turned my virus program back on, it immediately attacked the files again. I'm at a lose as to what to do now.

Wow..That's definitely a false positive. What antivirus program do you use? Maybe somewhere you could add an exception for the mod_MCA file.

View PostSuperburns, on 30 September 2012 - 02:16 PM, said:

so i followed you advice,  and we had liftoff!
but for some reason, and i think it's forge's fault on this one, when i used a seed,
or tried to build a superflat,(to get to villages faster) it locked up on the "buliding terrain".

so i said F it, and just made a basic world. tried lookin for a village till i gave up, so i decided i would
build my own. i switched to creative, attempted to lay down a female village egg,
And....
Spoiler:

so i guess i should give up the whole forge thing, untill your official 3.0 pops out.
hope this helps.

Definitely a forge issue. Intentional? Who knows. Nothing I can do about it. :\

View PostEmilie, on 30 September 2012 - 05:13 PM, said:

How do you chat to them because it is grey over the button and how do you migrate and make them follow you How please answer!

Read Bugs and Fixes. They are disabled on purpose.

View Post630tiger, on 30 September 2012 - 05:27 PM, said:

I'm having a rather odd problem at the moment. I have two villagers together that I just spawned from eggs, and I gifted one (I tried several times and it doesn't matter who I give it to first) an arranger's ring. They accepted it and a name thing came up over their head and in their GUI that said they had the ring. But when I give it to the other person, though the ring disappears and the chat says the villagers are married, the original person still has the ring and the game doesn't recognize that they're married. In fact, I can give a ring to the other person and the game will think that I'm going to find a partner for them, even though their intended spouse still has a ring. Also, when I try to take the ring back after a failed marriage, two ring items drop, but I can only pick up one.

This is odd. Try spawning the villagers then reloading the world. Then try to get them married. Does it work?

Posted Image


#5105

630tiger
    630tiger

    Obsidian Miner

  • Members
  • 1479 posts

Posted 30 September 2012 - 05:37 PM

I'll try that, but right now I'm stuck on the "name your child" screen with a greyed-out "Done" button. I have no idea what to do but close Minecraft, since escape isn't working.

EDIT: Tried going back on that world and the game crashed. I tried going back to the world again to copy the crash log, and now it works, and I have a baby boy.

EDIT 2: Those villagers I tried marrying earlier like five times are now magically married. I'm very confused.

EDIT 3: And now those villagers have mysteriously vanished. There's no caves or anything around like that. I've heard other people having similar problems. I don't know, but I suspect they're de-spawning or something like that.
"I realized I just liked making them move."
"Look at me still talking when there's science to do. When I look out there it makes me glad I'm not you."

#5106

Jconn3r
    Jconn3r

    Tree Puncher

  • Members
  • 25 posts

Posted 30 September 2012 - 05:45 PM

Yay its not as buggy anymore :) I still want the hardcore secret though

#5107

630tiger
    630tiger

    Obsidian Miner

  • Members
  • 1479 posts

Posted 30 September 2012 - 06:10 PM

Yay, new problems! This time I tried starting two new worlds, but this time they were both in creative mode (I have cheats on for the other world, so I know that's not the problem). One was a flat world, the other was normal. On the flat world I found a village rather quickly, but there were no villagers. In both worlds, whenever someone follows me, they instantly disappear. I also can't marry anyone together because whenever I try giving the second person an arranger's ring, they can't figure out where their spouse is, regardless of how close they are.

I haven't tested much yet, but it is worth noting that I was trying to marry them underground on the non-flatland so that they wouldn't wander into oblivion like my last survival world villagers did. The Flatland is, of course, very far down on the Y axis. I don't know if it makes a difference, but you might want to check it out. I am using some other mods, but none that should affect anything like that. (The mod list is ModLoader, I think ModLoaderMP, Timber, Biomes 'O Plenty, TMI, Optifine, and Ellian's Detector. Except for the biome mod adding some biomes that villages can spawn in, I don't think any of those should cause any problems, unless there's an issue with ModLoaderMP, which I'm not quite sure I have installed.)
"I realized I just liked making them move."
"Look at me still talking when there's science to do. When I look out there it makes me glad I'm not you."

#5108

al_jarwani
  • Location: oman
  • Minecraft: al_jarwani

Posted 30 September 2012 - 06:27 PM

Minecraft has crashed!      
      ----------------------      

Minecraft has stopped running because it encountered a problem; Unexpected error
This error has been saved to /Users/mazinjarwani/Library/Application Support/minecraft/crash-reports/crash-2012-09-30_22.26.55-client.txt for your convenience. Please include a copy of this file if you report this crash to anyone.



--- BEGIN ERROR REPORT 4d4d76ea --------
Generated 9/30/12 10:26 PM

- Minecraft Version: 1.3.2
- Operating System: Mac OS X (x86_64) version 10.7.3
- Java Version: 1.6.0_33, Apple Inc.
- Java VM Version: Java HotSpot™ 64-Bit Server VM (mixed mode), Apple Inc.
- Memory: 979149840 bytes (933 MB) / 1065025536 bytes (1015 MB) up to 1065025536 bytes (1015 MB)
- JVM Flags: 2 total; -Xms1024m -Xmx1024m
- ModLoader: Mods loaded: 9
ModLoader 1.3.2
mod_MineCapes 1.9
mod_Stackables 1.3.2
mod_bookRecipe 1.3.2
mod_Arrows 1.3.2
mod_ReiMinimap v3.2_05 [1.3.2]
mod_TooManyItems 1.3.2 2012-08-16
mod_ModLoaderMp 1.3.2v1
mod_MCA Minecraft Comes Alive v3.0 Beta

- LWJGL: 2.4.2
- OpenGL: Intel HD Graphics 4000 OpenGL Engine GL version 2.1 APPLE-7.22.24, Intel Inc.
- Is Modded: Very likely
- Type: Client
- Texture Pack: Mixcraft Basic
- Profiler Position: N/A (disabled)

java.lang.RuntimeException: java.lang.Exception: Image not found: /MCA/ItemBabyGirl.png
at ModLoader.registerAllTextureOverrides(ModLoader.java:1612)
at ModLoader.onTick(ModLoader.java:1186)
at EntityRendererProxy.b(EntityRendererProxy.java:21)
at net.minecraft.client.Minecraft.J(Minecraft.java:857)
at net.minecraft.client.Minecraft.run(Minecraft.java:751)
at java.lang.Thread.run(Thread.java:680)
Caused by: java.lang.Exception: Image not found: /MCA/ItemBabyGirl.png
at ModLoader.loadImage(ModLoader.java:1106)
at ModLoader.registerAllTextureOverrides(ModLoader.java:1604)
... 5 more
--- END ERROR REPORT c0e9f146 ----------

#5109

Hamster577

Posted 30 September 2012 - 06:53 PM

I keep having the same problem. I open minecraft, and once it starts loading the mojang logo comes up, then it crashes saying that modloader failed to initialize. Please help.

#5110

Blueflame451

Posted 30 September 2012 - 08:33 PM

ok upgraded to beta... and still crashing.

Spoiler:

edit: running no other mods, brand new world and only runs about 10 minutes before crashing. I've seen no village or villagers yet.

#5111

BlackAngelLN13

Posted 30 September 2012 - 08:36 PM

I am a forge user, and i am having problems spawning/finding villagers at all. Everytime i try to use an egg to spawn a villager, i get this crash.

Spoiler:

Then,when i try to find a village/use one of the seeds you have listed to spawn near a village, my game crashs producing this error.

Spoiler:

my mods are listed throughout the crash report, and after isolating and testing the other mods, i feel it is a compatibility problem with Forge and MCA. I cannot use the modloader patch in forge, or forge won't work. but then without the patch, it seems my game won't spawn villagers.

#5112

JoseCraftMCA

Posted 30 September 2012 - 09:11 PM

Minecraft Crashed Report:

Spoiler:


And, in the installation...
Image ERROR INSTALLATION (no crashed report!) :

Spoiler:

I was walking in the village when it chased Posted Image I wasn't making nothing.

Mods: ModLoader and Minecraft Comes Alive.

#5113

Ladyofthedrgns
  • Minecraft: Ladyofthedrgns

Posted 30 September 2012 - 09:38 PM

I am running Avira as my virus protection. It even flagged the website that the download came from as a high level threat.
That was just it, i did try that. As soon as my virus system was turned back on it immediately attacked and quarantined all the files. Claiming their were corrupted with a trojan virus.

#5114

LegoAgent12
  • Minecraft: LegoAgent12

Posted 01 October 2012 - 12:19 AM

I just now got a Curse Account, so now I can say: THIS IS THE BEST MOD EVER!
EVER!!!!!!!

#5115

Pulsater12
  • Location: In an Antarctic research facility.
  • Minecraft: Trozzikz
  • Xbox:Pulsater12

Posted 01 October 2012 - 12:46 AM

I built a machine to pick out a spouse, ( I'm a monster, i know.....) and as I hit the lever, i got this report:

[/spoiler]

---- Minecraft Crash Report ----
// This doesn't make any sense!

Time: 9/30/12 5:39 PM
Description: MCA: IOException occurred while saving world properties to file.

java.io.IOException: Stream Closed
at java.io.FileOutputStream.writeBytes(Native Method)
at java.io.FileOutputStream.write(Unknown Source)
at sun.nio.cs.StreamEncoder.writeBytes(Unknown Source)
at sun.nio.cs.StreamEncoder.implFlushBuffer(Unknown Source)
at sun.nio.cs.StreamEncoder.implFlush(Unknown Source)
at sun.nio.cs.StreamEncoder.flush(Unknown Source)
at java.io.OutputStreamWriter.flush(Unknown Source)
at java.io.BufferedWriter.flush(Unknown Source)
at java.util.Properties.store0(Unknown Source)
at java.util.Properties.store(Unknown Source)
at MCA_WorldPropertiesManager.saveWorldProperties(MCA_WorldPropertiesManager.java:113)
at MCA_EntityVillager.a(MCA_EntityVillager.java:291)
at jw.a(SourceFile:1279)
at asv.a(NetClientHandler.java:818)
at ch.a(SourceFile:31)
at ba.b(SourceFile:51)
at asv.d(NetClientHandler.java:89)
at atd.b(SourceFile:51)
at net.minecraft.client.Minecraft.l(SourceFile:1261)
at net.minecraft.client.Minecraft.J(SourceFile:583)
at net.minecraft.client.Minecraft.run(SourceFile:535)
at java.lang.Thread.run(Unknown Source)

Relevant Details:
- Minecraft Version: 1.3.2
- Operating System: Windows 7 (amd64) version 6.1
- Java Version: 1.7.0_05, Oracle Corporation
- Java VM Version: Java HotSpot™ 64-Bit Server VM (mixed mode), Oracle Corporation
- Memory: 368506592 bytes (351 MB) / 514523136 bytes (490 MB) up to 954466304 bytes (910 MB)
- JVM Flags: 2 total; -Xms512m -Xmx1024m
- ModLoader: Mods loaded: 3
ModLoader 1.3.2
mod_TooManyItems 1.3.2 2012-09-13
mod_MCA Minecraft Comes Alive v3.0 Beta
[/spoiler]
Posted Image

#5116

TankmanS5150

Posted 01 October 2012 - 01:01 AM

Buggin'! This one appeared (in beta!) shortly after commanding a villager to follow me. Still no other mods other then this puppy installed.

Spoiler:

That's another thing though, with the follow me command...the villagers teleport to the player after supposedly getting a certain distance away, yes? That distance seems to fluctuate on me...sometimes I'll be a good ways away from them, other times they keep on portin' right to my location several times in a row. What's more, the villagers also seem to have this nasty habit of teleporting into the -walls.- And then they suffocate! This happened back in Alpha, and it still seems to happen in Beta. But hey; not crashing! Except for now...with this one...and...yeah.

#5117

Kenscott_
  • Location: kentucky
  • Minecraft: kenscott

Posted 01 October 2012 - 01:31 AM

is this updated for 1.3.2???

#5118

Pulsater12
  • Location: In an Antarctic research facility.
  • Minecraft: Trozzikz
  • Xbox:Pulsater12

Posted 01 October 2012 - 01:46 AM

View PostKenscott_, on 01 October 2012 - 01:31 AM, said:

is this updated for 1.3.2???
Its in Beta. read the WHOLE OP, trust me, it helps.
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------On a different note, villagers still dont spawn in villages, so you have to spawn them in.
When I give my spouse a cake (item)  she doent take it, and the chat says: Spouse=null
Huh?
Posted Image

#5119

ClynicalDonut

Posted 01 October 2012 - 04:43 AM

I do run a MAC. I don't know if that is fixed or not. No other mods. Modloader, that stuff. all of it is good. But no matter what, after the Mojang sign is done displaying it just crashes! Please help!


--- BEGIN ERROR REPORT 7b155d5b --------
Generated 9/30/12 9:42 PM

- Minecraft Version: 1.3.2
- Operating System: Mac OS X (x86_64) version 10.6.8
- Java Version: 1.6.0_35, Apple Inc.
- Java VM Version: Java HotSpot™ 64-Bit Server VM (mixed mode), Apple Inc.
- Memory: 1031619840 bytes (983 MB) / 1071579136 bytes (1021 MB) up to 2143158272 bytes (2043 MB)
- JVM Flags: 3 total; -Xbootclasspath/a:/System/Library/PrivateFrameworks/JavaApplicationLauncher.framework/Resources/LauncherSupport.jar -Xms1024M -Xmx2048M
- ModLoader: Mods loaded: 2
ModLoader 1.3.2
mod_MCA Minecraft Comes Alive v3.0 Beta


java.lang.NullPointerException
at mod_MCA.loadSkins(mod_MCA.java:807)
at mod_MCA.load(mod_MCA.java:155)
at ModLoader.init(ModLoader.java:952)
at ModLoader.addAllRenderers(ModLoader.java:186)
at avy.<init>(RenderManager.java:87)
at avy.<clinit>(RenderManager.java:14)
at net.minecraft.client.Minecraft.a(SourceFile:260)
at net.minecraft.client.Minecraft.run(SourceFile:516)
at java.lang.Thread.run(Thread.java:680)
--- END ERROR REPORT 79cf279b ----------

#5120

MasterMattXIII

Posted 01 October 2012 - 03:31 PM

i was playing the mod when i realized all the villagers were gone i coudnt firgure out if they dissapered or despawned or whatevr may wanna look into it