Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[Mod Install] How to install the Aether Mod using MCPatcher [01/11/2012]


  • Please log in to reply
43 replies to this topic

#1

Lunaqua
    Lunaqua

    Stone Miner

  • Curse Premium
  • Curse Premium
  • 79 posts
  • Minecraft: Lunaqua

Posted 06 January 2012 - 06:16 AM

I made a video on how to install the Aether mod using MCPatcher.

Aether: 1.04_01
MCPatcher: 2.3.1
OS: Windows 7

Download pages:
Mac users:  To unzip files, download The Unarchiver from the Mac App Store.





Most Common Problems:
If something went wrong, you most likely...
  • did not install all required mods
  • installed the mods in the wrong order
  • installed a mod that was incompatible with the Aether
  • installed a compatible mod in the wrong order (usually before the Aether)
  • did not uncheck Custom Colors

Common Error Messages:

After installing Minecraft, hit Test Minecraft to make sure it will launch.  If it does not, one of these error messages may pop up.

Exception in thread "main" java.lang.NoSuchFieldError: N
	at com.pclewis.mcpatcher.mod.Colorizer.setupPotion(Colorizer.java:349)
	at abg.a(Potion.java:158)
	at abg.<clinit>(Potion.java:17)
	...
Uncheck Custom Colors at the bottom of the mods list in MCPatcher.  If you want Custom Colors installed, move it to the top of the list of mods in MCPatcher.


Installing Other Mods with the Aether:

Compatible Mods:


Armor Stand
Spoiler:
Custom Colors (packaged with MCPatcher)
Spoiler:
Death Chest
Spoiler:
Done Button Mover
Spoiler:
In-Game Texture Pack Changer
Spoiler:
MAtmos & MAtmos with Weapon Interactions
Spoiler:
Shelf
Spoiler:
Smart Moving
Spoiler:
Too Many Items
Spoiler:

How to install the Aether mod using MCPatcher For HD texture pack addicts... like me!

Register or log in to remove.

#2

Kensei
    Kensei

    Zombie Killer

  • Members
  • 172 posts

Posted 06 January 2012 - 08:05 PM

Thanks so much for this guide, it really helped, however, I still have a small problem. I followed your guide step by step, and while my HD texture pack (Dokucraft High) is working, and the water/lava is shown properly, none of the aether blocks have been changed by the texture pack, they all still have their original looks.

Did I miss something?

The odd thing is, the Aether's mobs are showing dokucraft textures, but the blocks arent.

EDIT: Just tested it by adding the mods in directly without MCPatcher, and the same thing happens, which leads me to believe it's the texture pack, not the patcher or the aether.

#3

Lunaqua
    Lunaqua

    Stone Miner

  • Curse Premium
  • Curse Premium
  • 79 posts
  • Minecraft: Lunaqua

Posted 06 January 2012 - 09:57 PM

View PostKensei, on 06 January 2012 - 08:05 PM, said:

Thanks so much for this guide, it really helped, however, I still have a small problem. I followed your guide step by step, and while my HD texture pack (Dokucraft High) is working, and the water/lava is shown properly, none of the aether blocks have been changed by the texture pack, they all still have their original looks.

Did I miss something?

The odd thing is, the Aether's mobs are showing dokucraft textures, but the blocks arent.

EDIT: Just tested it by adding the mods in directly without MCPatcher, and the same thing happens, which leads me to believe it's the texture pack, not the patcher or the aether.

Could you send me a link to which Dokucraft you are downloading?  It's more than likely it doesn't include Aether files, so Minecraft falls back on the Aether defaults.

EDIT: Look at me, not reading Dokucraft High.

I downloaded it and looked; Dokucraft hasn't been updated for Aether 1.04.
How to install the Aether mod using MCPatcher For HD texture pack addicts... like me!

#4

cocopuffs99

Posted 07 January 2012 - 06:15 AM

:Diamond:   :Diamond:   :Diamond:    Great job, Lunaqua! =)

#5

cocopuffs99

Posted 07 January 2012 - 08:43 AM

Anyone getting the error:

Exception in thread "Minecraft main thread" java.lang.VerifyError: (class: ModLoader, method: RegisterAllTextureOverrides signature: (Lzh;)V) Incompatible argument to function

when installing mods with the Aether also installed means that one of your mods (in this case, Minecolony rc 16b- which works without ModLoader 1.0.0 but is incompatibile with it, bugs are still being worked out) is incompatible with MInecraft 1.0.0.  So you'll just have to wait till a more compatible mod comes out- but be sure to post/pm the mod forum site so they know what the bug is and can fix it.

#6

DerekCreeperIsInSin

Posted 08 January 2012 - 03:16 PM

Lunaqua can you help me with this? I downloaded all the files that in the video that how to install the aether mod and i downloaded all the files that were included so i followed the video that its telling me what to do but when i did that , i start minecraft then i get a black screen at the very first of minecraft where it says: MoJang. Help me? I keep getting it.

Edited by DerekCreeperIsInSin, 08 January 2012 - 03:31 PM.


#7

Lunaqua
    Lunaqua

    Stone Miner

  • Curse Premium
  • Curse Premium
  • 79 posts
  • Minecraft: Lunaqua

Posted 08 January 2012 - 05:11 PM

View PostDerekCreeperIsInSin, on 08 January 2012 - 03:16 PM, said:

Lunaqua can you help me with this? I downloaded all the files that in the video that how to install the aether mod and i downloaded all the files that were included so i followed the video that its telling me what to do but when i did that , i start minecraft then i get a black screen at the very first of minecraft where it says: MoJang. Help me? I keep getting it.

Start off with a clean minecraft.jar.  If you have to, start up Minecraft, and before you log in, click Options and click Force Update!

Did you download Player API for the client?
Did you download ModLoaderMP for the client?

Did you install the mods in the correct order?
  • ModLoader
  • ModLoaderMP for Client
  • AudioMod
  • PlayerAPI for Client
  • ShockAhPI

Did you uncheck Custom Colors on the mod list in MCPatcher?

Did you install any other mods other than the ones required for Aether?  If you did, do not install them.

Are you getting any error messages?
How to install the Aether mod using MCPatcher For HD texture pack addicts... like me!

#8

ahumbleminer

Posted 08 January 2012 - 08:29 PM

wow, thank so much, i knew there was a way of getting it to work via the patcher but i had no clue about how to get about doing it =) cheers for the help on that one =D
Posted Image

#9

DerekCreeperIsInSin

Posted 08 January 2012 - 09:14 PM

View PostLunaqua, on 08 January 2012 - 05:11 PM, said:

Start off with a clean minecraft.jar.  If you have to, start up Minecraft, and before you log in, click Options and click Force Update!

Did you download Player API for the client?
Did you download ModLoaderMP for the client?

Did you install the mods in the correct order?
  • ModLoader
  • ModLoaderMP for Client
  • AudioMod
  • PlayerAPI for Client
  • ShockAhPI

Did you uncheck Custom Colors on the mod list in MCPatcher?

Did you install any other mods other than the ones required for Aether?  If you did, do not install them.

Are you getting any error messages?

Well , i got everything that i downloaded but i have a another minecraft.jar called: Minecraft.jar-1.0.0. can i delete it? and i installed other mods but i will delete them to not use them but i will keep TooManyItems. i might wanna use it for the aether , Oh and i have Shader Mod which installs it to make shades around something when i get too close at a block and i have SPC. i might wanna delete it. so that's all , Wait no i got one more thing. i unchecked Custom Colors even , Oh , one more thing. i did not get an error message.

Edited by DerekCreeperIsInSin, 08 January 2012 - 09:27 PM.


#10

thunder_creeps

Posted 08 January 2012 - 09:42 PM

thanks, this really helped me out!

#11

DerekCreeperIsInSin

Posted 08 January 2012 - 10:39 PM

Lunaqua can you help me with this problem? Whenever i put Aether 1.0.4 1. FINAL in 1.0.0 and AudioMod , and i open the + sign , my AudioMod and Aether doesn't show. Can you help me how to show it?

Edited by DerekCreeperIsInSin, 08 January 2012 - 10:40 PM.


#12

Lunaqua
    Lunaqua

    Stone Miner

  • Curse Premium
  • Curse Premium
  • 79 posts
  • Minecraft: Lunaqua

Posted 08 January 2012 - 11:40 PM

View PostDerekCreeperIsInSin, on 08 January 2012 - 09:14 PM, said:

Well , i got everything that i downloaded but i have a another minecraft.jar called: Minecraft.jar-1.0.0. can i delete it? and i installed other mods but i will delete them to not use them but i will keep TooManyItems. i might wanna use it for the aether , Oh and i have Shader Mod which installs it to make shades around something when i get too close at a block and i have SPC. i might wanna delete it. so that's all , Wait no i got one more thing. i unchecked Custom Colors even , Oh , one more thing. i did not get an error message.

Once you have the Aether and its required mod working, you can install other mods one at a time.  If you get an error, it's probably not compatible with the Aether.  If no errors, then that mod is probably good to go, and you can try patching in another mod.

Also, read any ReadMe files that come with a mod.
If it instructs you to place all files in a folder into minecraft.jar, put all the files in that folder into a zip, paste that zip into .minecraft\mods\1.0.0\, and load that into MCPatcher.
If it instructs you to place all files in a folder into the .minecraft folder, resources folder, xyz folder, anything other than into minecraft.jar, do what it asks.



View PostDerekCreeperIsInSin, on 08 January 2012 - 10:39 PM, said:

Lunaqua can you help me with this problem? Whenever i put Aether 1.0.4 1. FINAL in 1.0.0 and AudioMod , and i open the + sign , my AudioMod and Aether doesn't show. Can you help me how to show it?

They may not be zip folders.  Save them as .zip files.

Also, watch the video about the Aether mod.  You cannot load Aether 1.04_1 as is; you need to place all the files and folders in the Jar folder in the Aether zip into another zip folder (in the video, a Aether.zip) and load that zip.
Similar thing for ShockAhPI, except the bin folder instead of Jar folder.
How to install the Aether mod using MCPatcher For HD texture pack addicts... like me!

#13

Lunaqua
    Lunaqua

    Stone Miner

  • Curse Premium
  • Curse Premium
  • 79 posts
  • Minecraft: Lunaqua

Posted 09 January 2012 - 01:30 AM

View Postahumbleminer, on 08 January 2012 - 08:29 PM, said:

wow, thank so much, i knew there was a way of getting it to work via the patcher but i had no clue about how to get about doing it =) cheers for the help on that one =D

View Postthunder_creeps, on 08 January 2012 - 09:42 PM, said:

thanks, this really helped me out!

You are both welcome!
How to install the Aether mod using MCPatcher For HD texture pack addicts... like me!

#14

TNTQc
    TNTQc

    Redstone Miner

  • Members
  • 516 posts
  • Location: Electric Ladyland

Posted 10 January 2012 - 07:17 PM

I'm having trouble making my hd texture work properly (LB Photo Realism inside a modded Minecraft; SPC and Aether 1.04).

I instaled the mods manually... it worked,
but in my hd texture pack, the water and lava are bugging!!
(it used to work flawlessly in Minecraft 1.7.3 (and Aether 1.0.2)

I installed the stuff in this order:

1. fresh .minecraft
2. Patch with mcpatcher 2.3.1 for hd textures
3. Add my texture pack in .minecraft textures folder
4. install prerequisses (Audiomod, Modloader, ModloaderMP, PlayerAPI, ShockAhPI)-manually-
5. Install SPC 3.0.1-manually-
6. Install Aether 1.0.4-manually-
7. Install SPC-PlayerAPi patch (3.0.1)-manually-


Is there anyway to make this hd texture pack work with the Aether 1.04??

Thanks for helping

#15

cocopuffs99

Posted 11 January 2012 - 06:12 AM

hey luna, great job on adding the compatibility list!  i was working on a list before but couldn't find much, just mainly what was incompatible... =)
i cant wait to try out these mods now (i haven't used much from risugami before)

still keeping my fingers crossed for an industrialcraft 2/MCforge patch to work with the aether, so i can add other mods and more block IDs too...

#16

cocopuffs99

Posted 11 January 2012 - 06:21 AM

yes, follow the directions in the the post on this page...

1) dont install manually, use MCpatcher, and make sure to click the 'spoiler' for luna's tip on order for patching for each mod (on this page)
2) after installing/patching, put your HD texture pack in the texture packs folder of your .minecraft/minecraft folder
3) you are listing outdated mods, but minecraft is now 1.0.0- this tutorial is for the current minecraft version, 1.0.0- download the latest versions (i.e. SPC 1.0.0, Aether 1.04, etc) and use those to install- you don't need a patch for SPC 1.0.0

hope that helps! i'm using LP photorealism on 128 px and it works fine with all of the mods you listed following the directions on this page

View PostTNTQc, on 10 January 2012 - 07:17 PM, said:

I'm having trouble making my hd texture work properly (LB Photo Realism inside a modded Minecraft; SPC and Aether 1.04).

I instaled the mods manually... it worked,
but in my hd texture pack, the water and lava are bugging!!
(it used to work flawlessly in Minecraft 1.7.3 (and Aether 1.0.2)

I installed the stuff in this order:

1. fresh .minecraft
2. Patch with mcpatcher 2.3.1 for hd textures
3. Add my texture pack in .minecraft textures folder
4. install prerequisses (Audiomod, Modloader, ModloaderMP, PlayerAPI, ShockAhPI)-manually-
5. Install SPC 3.0.1-manually-
6. Install Aether 1.0.4-manually-
7. Install SPC-PlayerAPi patch (3.0.1)-manually-


Is there anyway to make this hd texture pack work with the Aether 1.04??

Thanks for helping


#17

cocopuffs99

Posted 11 January 2012 - 06:51 AM

Does anyone know if Mo' Health RPG v1.1 works with the Aether?  I'm testing out a new group of mods so I should have more info for your compatibility list sometime soon (if they work!)

EDIT:  I tested it- no class file compatibility issues on Windows IF you have Java 7
With Mac (which is what I use) it doesn't work because you get the

java.lang.UnsupportedClassVersionError: qd

error which is not because it isn't compatible with the Aether, but b/c of Java 6 running on the Mac...and there isn't a supported (working) java 7 out for mac yet.

#18

Lunaqua
    Lunaqua

    Stone Miner

  • Curse Premium
  • Curse Premium
  • 79 posts
  • Minecraft: Lunaqua

Posted 11 January 2012 - 05:48 PM

View PostTNTQc, on 10 January 2012 - 07:17 PM, said:

I'm having trouble making my hd texture work properly (LB Photo Realism inside a modded Minecraft; SPC and Aether 1.04).

I instaled the mods manually... it worked,
but in my hd texture pack, the water and lava are bugging!!
(it used to work flawlessly in Minecraft 1.7.3 (and Aether 1.0.2)

I installed the stuff in this order:

1. fresh .minecraft
2. Patch with mcpatcher 2.3.1 for hd textures
3. Add my texture pack in .minecraft textures folder
4. install prerequisses (Audiomod, Modloader, ModloaderMP, PlayerAPI, ShockAhPI)-manually-
5. Install SPC 3.0.1-manually-
6. Install Aether 1.0.4-manually-
7. Install SPC-PlayerAPi patch (3.0.1)-manually-


Is there anyway to make this hd texture pack work with the Aether 1.04??

Thanks for helping


Pretty much what cocopuffs99 said.  Install the mods using MCPatcher as the installer instead of manual install, and the custom animations should work fine.  I use a 32x texture pack, and the custom water and lava work.

I'll have to look into SPC with that PlayerAPI patch, since I assume it's working for you.
How to install the Aether mod using MCPatcher For HD texture pack addicts... like me!

#19

sangheili868

Posted 12 January 2012 - 02:52 AM

Does Aether work with Single player commands? When I clicked patch it said the di.class file conflicted in aether and spc.  Below is the error report that came up when i clicked test minecraft. For some reason the error didn't come up until aether tried to show the world in the title screen.

Is there some way to get around this conflict? I had Aether above spc in mcpatcher and I got this error.  When i put aether below spc minecraft worked but I couldn't use spc at all. If you can fix this you get :Diamond: :Diamond: :Diamond: :Diamond:    

--- BEGIN ERROR REPORT a0cd828f --------
Generated 1/11/12 8:50 PM

Minecraft: Minecraft 1.0.0
OS: Windows Vista (amd64) version 6.0
Java: 1.6.0_26, Sun Microsystems Inc.
VM: Java HotSpot™ 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
LWJGL: 2.4.2
OpenGL: GeForce 9800M GS/PCI/SSE2 version 3.0.0, NVIDIA Corporation

java.lang.NullPointerException
at mod_Aether.OnTickInGame(mod_Aether.java:436)
at ModLoader.OnTick(ModLoader.java:1073)
at EntityRendererProxy.b(EntityRendererProxy.java:26)
at net.minecraft.client.Minecraft.x(Minecraft.java:729)
at net.minecraft.client.Minecraft.run(Minecraft.java:627)
at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT 6a28556f ----------

#20

Sigma_Phi
  • Location: Amberground City, Spiritcraft Server
  • Minecraft: Llesmis

Posted 12 January 2012 - 06:23 AM

Does Optifine interfere with this mod somehow? I tried re-loading my mods one at a time and that was where it snagged. I figured I'd ask here, because Optifine adds HD texture files like the patcher, which can cause issues, right? I ask because I'd love to run the Aether, but my game runs terribly without Optifine. Thanks.
Sigma_Phi - home of the long-winded answers to questions nobody asked.
Posted Image