Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[1.6.4] Mystcraft (0.10.11)

mystcraft dimension terrain corruption ssp smp weather

  • Please log in to reply
12131 replies to this topic

#8301

sciguyryan
  • Location: Wales
  • Minecraft: sciguyryan

Posted 24 December 2012 - 10:15 AM

Anyone getting crashes of this kind: http://pastebin.com/cK4GAGzS


Simply update to the latest forge :)

Register or log in to remove.

#8302

Manuil
    Manuil

    Carpenter

  • Members
  • 44 posts
  • Minecraft: MightyManuil

Posted 24 December 2012 - 10:41 AM

View Postsciguyryan, on 24 December 2012 - 10:15 AM, said:

Anyone getting crashes of this kind: http://pastebin.com/cK4GAGzS


Simply update to the latest forge Posted Image

Thank you very much... semms i have to look after forge updates twice a day now, when i install new mods
Posted Image

#8303

Myschief

Posted 24 December 2012 - 11:17 AM

View Postsciguyryan, on 24 December 2012 - 10:15 AM, said:

Anyone getting crashes of this kind: http://pastebin.com/cK4GAGzS


Simply update to the latest forge Posted Image

What is considered the latest version of Forge?  I am already using the Recommended version and yet I am getting that error.  I double-checked and there isn't a specific Forge version mentioned that I could see.

#8304

sciguyryan
  • Location: Wales
  • Minecraft: sciguyryan

Posted 24 December 2012 - 11:19 AM

View PostMyschief, on 24 December 2012 - 11:17 AM, said:

What is considered the latest version of Forge?  I am already using the Recommended version and yet I am getting that error.  I double-checked and there isn't a specific Forge version mentioned that I could see.

Grab the latest from here :)

#8305

Jannis234
  • Location: Germany
  • Minecraft: Jannis234

Posted 24 December 2012 - 11:47 AM

I tkink I found a bug. I was teleporting a RailCraft tank cart from the nether to the overworld (botch chunkloaded) using MystCraft portals and my games crashed when the cart teleported:
Spoiler:
I was using MystCraft0.9.5.00 and Forge #480. I can still load the world but it still crashes when the cart teleports.

Also, I was standing in the nether and the cart teleported to the overworld but it got stuck in the nether (I couldn't hit or move it) and I saw this in my console:
2012-12-24 12:42:03 [INFO] [ForgeModLoader] Unloading dimension 1
It looks like Minecraft loaded the end. Maybe this has something to do with that crash?
Nothing to see here...

#8306

Pharabus

Posted 24 December 2012 - 12:36 PM

View PostJannis234, on 24 December 2012 - 11:47 AM, said:

I tkink I found a bug. I was teleporting a RailCraft tank cart from the nether to the overworld (botch chunkloaded) using MystCraft portals and my games crashed when the cart teleported:
Spoiler:
I was using MystCraft0.9.5.00 and Forge #480. I can still load the world but it still crashes when the cart teleports.

Also, I was standing in the nether and the cart teleported to the overworld but it got stuck in the nether (I couldn't hit or move it) and I saw this in my console:
2012-12-24 12:42:03 [INFO] [ForgeModLoader] Unloading dimension 1
It looks like Minecraft loaded the end. Maybe this has something to do with that crash?


I have the same issue, a tank cart moving from the nether to the end crashes with the indexoutofbound error, I stopped  the cart cycling and no more crashes, the cart seemed to be able to movve from the overwold to the nether ok

I am using ender pearl powered RC world anchors and the portals where in a 1.3.2 world that i upgraded when mystcraft upgraded to 146 (using forge 467 and the same happened when upgraded to 480)

#8307

Satscape
    Satscape

    Iron Miner

  • Curse Premium
  • Curse Premium
  • 306 posts
  • Location: Nottingham, UK
  • Minecraft: Satscape

Posted 24 December 2012 - 01:08 PM

Anyone know what's causing this crash:


2012-12-24 13:05:26 [SEVERE] [ForgeModLoader] The following problems were captured during this phase
2012-12-24 13:05:26 [SEVERE] [ForgeModLoader] Caught exception from Mystcraft
java.lang.NullPointerException
at xcompwiz.mystcraft.symbol.symbol_Biome.formatted(symbol_Biome.java:26)

Using Forge 6.5.0.480 (current latest) tried 472 as well.
Scott 'Satscape' Hather - Minecraft addict and mod-crafter.
Creator of 'Sim-U-Kraft' - available at My website -  Watch my youTube Videos too, youTube username: SatscapeMinecraft

#8308

airlag
    airlag

    Zombie Killer

  • Members
  • 153 posts
  • Location: germany

Posted 24 December 2012 - 02:21 PM

Thanks for that nice christmas present :)

#8309

Jannis234
  • Location: Germany
  • Minecraft: Jannis234

Posted 24 December 2012 - 03:35 PM

To anyone who gets the IndexOutOfBounds crash: I've created a bugfix for that.
You can download it here. Put it in your minecraft.jar after you've installed forge.

The problem seems to be that MystCraft removes the entity from loadedEntityList when it gets updated (teleported by MystCraft). After that, Minecraft trys to remove the entity from the list again (vanilla code) but it's already removed by MystCraft which causes the IndexOutOfBoundsException. I simply moved the code (from World.java) that removes the entitys into a second loop that runs after the loop that updates all entitys.
Nothing to see here...

#8310

Googlechrome

Posted 24 December 2012 - 04:01 PM

Going into any Mystcraft Age on my server gives me this error;
Spoiler:

I play with mods 24/7.
My Ingame username is Googlechrome. You'll probably find me on FTB and Tekkit servers.

#8311

Draco18s
    Draco18s

    Glowstone Miner

  • Members
  • 3398 posts

Posted 24 December 2012 - 05:10 PM

View PostGooglechrome, on 24 December 2012 - 04:01 PM, said:

Going into any Mystcraft Age on my server gives me this error;
Spoiler:

That error is not in Mystcraft, but in Enderstorage.  You'll have to take it to codechicken.

View PostTheSimpleMajority, on 24 December 2012 - 09:26 AM, said:

-deleted- seems to have fixed itself when I went from 473 to latest on forge.

And people wonder why 0.9.5.0 requires Forge 474...
Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

#8312

GamingNerddotCom

Posted 24 December 2012 - 05:50 PM

When I reload a game in one of my Mystcraft worlds, it starts to rain chickens O.o

Posted Image

They hit the ground with the explosion visual effect and disappear.

Possibly not a Mystcraft bug. I am unable to determine the cause as it now happens in every world, new and old, that I load.

#8313

Draco18s
    Draco18s

    Glowstone Miner

  • Members
  • 3398 posts

Posted 24 December 2012 - 06:16 PM

View PostGamingNerddotCom, on 24 December 2012 - 05:50 PM, said:

They hit the ground with the explosion visual effect and disappear.

Sounds like an Entity ID mismatch.

Load this up and take a look.
Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

#8314

Qwertygiy
    Qwertygiy

    Void Walker

  • Curse Premium
  • Curse Premium
  • 1692 posts
  • Location: That huge sandstone tower in that huge desert
  • Minecraft: Qwertygiy

Posted 24 December 2012 - 06:20 PM

View PostGamingNerddotCom, on 24 December 2012 - 05:50 PM, said:

When I reload a game in one of my Mystcraft worlds, it starts to rain chickens O.o

They hit the ground with the explosion visual effect and disappear.

Possibly not a Mystcraft bug. I am unable to determine the cause as it now happens in every world, new and old, that I load.

Why would you want to fix this?!

I want your mod setup. NOW! Posted Image
Upcoming TC4 Additional Aspects Addon -- give mod blocks aspect values! Want to help? Click and read!
KBI Enriched Gravel Mod -- sift out nuggets and chunks and make gravel useful! (Outdated)
Tinker's Construct Recovery Addon -- get back some of your half-used tool materials! (Outdated)

#8315

GamingNerddotCom

Posted 24 December 2012 - 06:35 PM

Uhmmmm... So, I think the falling chickens might be a Christmas joke or hoax from Mojang or a mod author. Changed my PC's date from the 25th, to the 27th. Chickens disappeared.

I live in Thailand. I saved and quit my game at 11 pm on the 24th, and 90 minutes later fire up Minecraft again and the chickens randomly happen. Didn't change a mod or add a thing.

lol

Edit: Just reconfirmed by turning back the clock to the 25th. lololol. Funny developer is funny, but I took about an hour investigating all my mods and making new worlds before posting it here.

#8316

Shadou81
    Shadou81

    Zombie Killer

  • Members
  • 184 posts
  • Minecraft: Shade_81

Posted 24 December 2012 - 06:48 PM

View PostJannis234, on 24 December 2012 - 03:35 PM, said:

To anyone who gets the IndexOutOfBounds crash: I've created a bugfix for that.
You can download it here. Put it in your minecraft.jar after you've installed forge.

The problem seems to be that MystCraft removes the entity from loadedEntityList when it gets updated (teleported by MystCraft). After that, Minecraft trys to remove the entity from the list again (vanilla code) but it's already removed by MystCraft which causes the IndexOutOfBoundsException. I simply moved the code (from World.java) that removes the entitys into a second loop that runs after the loop that updates all entitys.

That hotfix sounds REALLY unstable. If vanilla code is already removing the entity, why not just let the vanilla code do its job and just remove the entity removal code from Mystcraft?

#8317

Salaru
    Salaru

    Zombie Killer

  • Members
  • 173 posts
  • Location: Calgary
  • Minecraft: Salaru

Posted 24 December 2012 - 06:49 PM

Makes game crash upon startup if latest forge is used. Or NEI I think. Also, still lags.
Posted Image

#8318

Keyalha
    Keyalha

    Zombie Killer

  • Members
  • 230 posts
  • Minecraft: Keyalha

Posted 24 December 2012 - 06:59 PM

i get a freeze once i logout console keeps looping tons of stuff and filesize gets out of hand quite quickly
for now i turned logging off and removed mystcraft to save my stuff
Posted Image

#8319

laurazenc

Posted 24 December 2012 - 07:06 PM

Well i dont know if this bug has been reported but MineCraft crashes every time i send a TankCart through a Mystcraft portal from The Nether to the Overwold...anyone knows how to fix it?

#8320

Shadou81
    Shadou81

    Zombie Killer

  • Members
  • 184 posts
  • Minecraft: Shade_81

Posted 24 December 2012 - 07:41 PM

View Postlaurazenc, on 24 December 2012 - 07:06 PM, said:

Well i dont know if this bug has been reported but MineCraft crashes every time i send a TankCart through a Mystcraft portal from The Nether to the Overwold...anyone knows how to fix it?

Sounds like a railcraft problem to me. Mojang only fixed the ability for minecarts to go through nether portals in 1.4.6. I don't know if railcraft has fixed it for their additional carts. Have you tried sending a regular railcart or sent a tankcart through a standard nether portal?