Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Magic Aether Mod Installer


  • Please log in to reply
26 replies to this topic

Poll: Aether Mod Troubles? (162 member(s) have cast votes)

Are you having trouble installing the Aether Mod?

  1. Yes. (137 votes [84.57%])

    Percentage of vote: 84.57%

  2. No. (4 votes [2.47%])

    Percentage of vote: 2.47%

  3. I haven't tried. (21 votes [12.96%])

    Percentage of vote: 12.96%

Vote Guests cannot vote

#1

The_Only_Zac
  • Location: United States
  • Minecraft: The_Only_Zac

Posted 02 January 2012 - 06:33 PM

Wow. My mind is blown.
I had been trying for hours (literally) to install the Aether Mod in my Minecraft. I had been doing it for so long I thought my computer was going to overheat! Anyways, I suddenly got the idea to search on Google for an automatic installer. I did, and I found one that works perfectly. I was amazed when Minecraft didn't have a black screen at startup! Click here to get to the download page. If you want to install the Aether mod fast and easily, this is the way to go.
EDIT
There are a lot of comments saying that it doesn't work because that installer is for an older version of the mod made for Minecraft 1.0.0. There is a new update out for 1.2.5, though. The direct download link is: https://s3.amazonaws...d Installer.exe.
Posted Image

Register or log in to remove.

#2

adajak
    adajak

    Iron Miner

  • Curse Premium
  • Curse Premium
  • 278 posts
  • Minecraft: adajac
  • Xbox:adajak

Posted 02 January 2012 - 06:36 PM

NICE
Click my signature to see a huge version of it.
Posted Image

#3

Jake Sully
  • Location: Stockholm, Sweden
  • Minecraft: neytirijakesully

Posted 05 February 2012 - 05:41 PM

that mod installer doesent work :(


p.s nvm just found out i had this .dll file missing now it's working :D

Posted Image


#4

TFCxAddict
  • Location: Colorado, United States of America
  • Minecraft: TFCxAddict

Posted 05 February 2012 - 05:53 PM

Thanks for sharing to them :D

Posted Image


#5

minecraftgeek11

Posted 04 May 2012 - 10:56 PM

What version of minecraft is this?
The installer will not work
im using minecraft 1.2.5

#6

keatodylan

Posted 28 June 2012 - 04:40 PM

yah it doesnt work with 1.2.5 i tried multiple times

#7

xNyxShooterx
  • Location: The Nether
  • Minecraft: NyxShooter

Posted 02 July 2012 - 09:18 AM

View Postkeatodylan, on 28 June 2012 - 04:40 PM, said:

yah it doesnt work with 1.2.5 i tried multiple times

My friend, the mod creator did not update this mod to 1.2.5 you need to use MCNostalgia and downgrade yourself to 1.7.3
Posted Image

#8

XDVethos
    XDVethos

    Zombie Killer

  • Members
  • 151 posts
  • Location: In SpinelMan's Den!
  • Minecraft: V3thos

Posted 02 July 2012 - 01:31 PM

View PostxNyxShooterx, on 02 July 2012 - 09:18 AM, said:



My friend, the mod creator did not update this mod to 1.2.5 you need to use MCNostalgia and downgrade yourself to 1.7.3
Or Minecraft version changer i tried that and its quite good too
Posted Image
Please press the Green Button, Over there ---> If i have helped you once or more!

#9

Tomy1724
    Tomy1724

    Tree Puncher

  • Members
  • 10 posts

Posted 18 July 2012 - 08:34 PM

i need aether to 1.2.5

#10

Vectron_Force

Posted 07 August 2012 - 08:47 AM

Dang I can't find it on the page can anyone help me? plz

#11

aperturetester333

Posted 20 August 2012 - 04:38 AM

Could someone make this for Mac? If so, that would be awesome, as not everyone uses Windows
Posted Image

#12

Hdez
    Hdez

    Tree Puncher

  • Members
  • 13 posts
  • Minecraft: flamekiller123

Posted 20 August 2012 - 03:50 PM

i still dont get what version we need. I am assuming 1.0.0?

#13

Stygmax
    Stygmax

    Coal Miner

  • Members
  • 118 posts
  • Location: Bumanumuna, Australia
  • Minecraft: DoBarrelRoll1
  • Xbox:Rydengast

Posted 20 August 2012 - 04:47 PM

The Aether, until recently, was only for Beta 1.7.3 and Minecraft 1.0.0. Now it has been pre-released for 1.2.5, but that installer won't work for that. Just install it manually, merge the folders and replace the class files.

P. S. I am running Mac OS X Snow Leapord and have 86 mods.
Posted Image
I hope someone reads this and makes a "More Potions" mod.

#14

CYBORG_BEEMBOBBY

Posted 20 September 2012 - 09:07 PM

oh, directX. YOU NEED TO HAVE DIRECTX INSTALLED???
last time I tried to install it direct x downloader didnt work can someone help me?

View PostVectron_Force, on 07 August 2012 - 08:47 AM, said:

Dang I can't find it on the page can anyone help me? plz
there is a direct download

#15

derkwizzerds101
  • Location: The Time Vortex
  • Minecraft: derkwizzerds101

Posted 22 September 2012 - 10:48 AM

no this installer doesnt work.  i tried 1.7.3, 1.0, and 1.2.5 and none of them work! :(
[URL=http://doctorwho.ikingssgc.com/]Posted Image[/URL]

#16

CapChaos14

Posted 08 October 2012 - 03:10 PM

one word: amazingPosted Image

#17

skillet_master
  • Location: Colorado

Posted 14 January 2013 - 10:44 PM

I was easily able to get this to work on my PC for 1.2.5 MC, but how do I go about getting this to work for a mac when the installer is only for PC? (for 1.2.5)

#18

sluggertomcat7

Posted 14 January 2013 - 10:54 PM

I have seen the aether mod and i love it but i cant install it. PLZ HELP

#19

sluggertomcat7

Posted 14 January 2013 - 11:00 PM

quoteaperturetester333
Could someone make this for Mac? If so, that would be awesome, as not everyone uses Windows
i know i use mac too i've heard that its more easy if you run mods on windows but the only bad part is that i still don't know how to install mods!!!!!!!!!!!!!!!!!

P.S. Plus windows computers are way slower i have one and it took like 5 hours to boot up.

#20

matt_LOLZ

Posted 18 January 2013 - 10:24 PM

It's stuck on Done loading for me.

EDIT: i was using 1.0.0 instead of 1.2.5 -.-

Posted Image