Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Can't get friends to connect to my server.


  • Please log in to reply
10 replies to this topic

#1

whiteb0yred
  • Minecraft: whiteb0yred

Posted 12 December 2011 - 10:51 PM

I'm on Windows 7 using minecraft_server.jar

Alright. so when I start up the server, I get this:

[INFO] Starting minecraft server version 1.0.1
[INFO] Loading properties
[INFO] Starting Minecraft server on *:25565
[INFO] Preparing level "world"
[INFO] Default game type: 0
[INFO] Preparing start region for level 0
[INFO] Preparing spawn area: 89%
[INFO] Done (1180266518ns)! For help, type "help" or "?"

When I do this, I can only connect by using "localhost"

my external ip doesn't work, and neither does "externalip:25565". It keeps saying connection timed out!

I have 25565 forwarded through my router.

And, when I change server ip=*blank*   to    server ip=externalip, upon restarting the server it just tells me that the binding failed.

After seeing this, I went to task manager, quit all processes using java at all, and still got the same message.

So, I opened cmd.exe and typed in netstat -a, and 25565 doesn't show up. So, the port is free and my computer begs to differ.

When I change the server properties back to server ip=*blank*, I'm back to the first problem.


This is very frustrating to me, and I would appreciate any ideas or help. It must be something really subtle, because I've been trying to fix it for two days now.

Register or log in to remove.

#2

-OC-Pik4chu

Posted 12 December 2011 - 11:39 PM

Turn off your windows firewall or w/e firewall software you are using and try again.  Well serverip = *blank* is fine, it shouldnt be your external ip.  Do you have another computer that is local you can test with?

#3

whiteb0yred
  • Minecraft: whiteb0yred

Posted 13 December 2011 - 04:34 AM

View Post-OC-Pik4chu, on 12 December 2011 - 11:39 PM, said:

Turn off your windows firewall or w/e firewall software you are using and try again.  Well serverip = *blank* is fine, it shouldnt be your external ip.  Do you have another computer that is local you can test with?

I could, but not at this moment. :S Is there no way to do it without turning off the firewall?

#4

Lord_Ralex
    Lord_Ralex

    Typoing Absolmin

  • Forum Admin
  • Curse Premium
  • 5807 posts
  • Location: Route 120
  • Minecraft: Lord_Ralex

Posted 13 December 2011 - 04:36 AM

Sometimes you cannot use the external ip if you are on the network. And you just have to tell your firewall to allow that software, you do not have to turn it off. Lowering the firewall should only be done to see if it is causing a problem, and should only be down for less then a few minutes. Just get a friend to try to connect.

MCF Admin for Servers and Mapping and Modding

Posted Image


#5

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8076 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 13 December 2011 - 04:38 AM

have you double checked the port is open with a site like this? http://canyouseeme.org/
you are giving the external ip out, the same as is shown on the site i just linked?

the server-ip= should be blank unless you are running a lan server only, or hamachi server.

your firewall should have a setting in it to set up rules to allow/deny certain programs

#6

whiteb0yred
  • Minecraft: whiteb0yred

Posted 13 December 2011 - 04:48 AM

I have everything above done. 25565 isn't blocked, and I i set my firewall to allow it.

If I can't connect with my own external ip, that makes sense. Hopefully it works then. so I should just type in localhost (my computer can handle it) and they have to use the external ip, right? I wanna make sure I'm doing this right haha.  :Sheep:

#7

Lord_Ralex
    Lord_Ralex

    Typoing Absolmin

  • Forum Admin
  • Curse Premium
  • 5807 posts
  • Location: Route 120
  • Minecraft: Lord_Ralex

Posted 13 December 2011 - 04:50 AM

As long as the port is open, the firewall is not blocking it, and the server is running, it should be fine

MCF Admin for Servers and Mapping and Modding

Posted Image


#8

Mystara0001

Posted 13 December 2011 - 05:26 AM

View Postwhiteb0yred, on 13 December 2011 - 04:48 AM, said:

I have everything above done. 25565 isn't blocked, and I i set my firewall to allow it.

If I can't connect with my own external ip, that makes sense. Hopefully it works then. so I should just type in localhost (my computer can handle it) and they have to use the external ip, right? I wanna make sure I'm doing this right haha.  :Sheep:

If you are on a network you must set a port forward on the router to tell it which computer to send the connection request to or it will ignore it.

Simply opening the port will not work.

Example:

Three computers are on my network. A, B, and C
Server is running on B
A server request comes in on my external I.P. address.
The Router has no idea what to do with it and ignores it, no connection.

Set a port forward to computer B's internal (i.e. 192.168.*.*) I.P. address in the router setup and it will tell the router which computer to forward the server request to.



Example:

Three computers are on my network. A, B, and C
Server is running on B
A server request comes in on my external I.P. address.
The Router recognizes the port and uses the forward to send it to Computer B running the server, connection!

#9

whiteb0yred
  • Minecraft: whiteb0yred

Posted 13 December 2011 - 06:07 AM

View PostMystara0001, on 13 December 2011 - 05:26 AM, said:

If you are on a network you must set a port forward on the router to tell it which computer to send the connection request to or it will ignore it.

Simply opening the port will not work.

Example:

Three computers are on my network. A, B, and C
Server is running on B
A server request comes in on my external I.P. address.
The Router has no idea what to do with it and ignores it, no connection.

Set a port forward to computer B's internal (i.e. 192.168.*.*) I.P. address in the router setup and it will tell the router which computer to forward the server request to.



Example:

Three computers are on my network. A, B, and C
Server is running on B
A server request comes in on my external I.P. address.
The Router recognizes the port and uses the forward to send it to Computer B running the server, connection!

I'm using a 2WIRE 2701HG-B wireless router. I had already done this without knowing because I have to choose which computer is hosting the application before I get to set up any port forwarding.

Although, your post had me digging through cyberspace, and I learned a bit more about how port forwarding works. So, thanks!

My problem remains unsolved though, and I won't know if it works until tomorrow. Thanks for all of the help so far! I'll post tomorrow.

#10

-OC-Pik4chu

Posted 13 December 2011 - 05:27 PM

View Postwhiteb0yred, on 13 December 2011 - 04:34 AM, said:

I could, but not at this moment. :S Is there no way to do it without turning off the firewall?


The reason I suggested to turn off your firewall for the moment was for troubleshooting it.  Eliminating the chance that you just set it up wrong while you figure out where the problem is.  This is most easily accomplished by first disabling anything that could be blocking it until it starts working.  Then go back and re-enable things one at a time until you find out what is preventing access to your server and thus you know what to fix.

So the first step to figuring out why no one can connect to your server is

1) disable your windows firewall/firewall software, then try to connect via localhost from the same computer.

2) if that works, re-enable the firewall and try again, doesnt work? now you know the problem.

3) if that still works, then try from the outside, this way you know that any problem isnt with your server and its most likely your router/outside connection that is causing the issue and not the config on the server itself.

Its just your average troubleshooting steps,  start with least restrictive then continue to lock it down until you find what breaks it.

#11

whiteb0yred
  • Minecraft: whiteb0yred

Posted 13 December 2011 - 07:16 PM

View Post-OC-Pik4chu, on 13 December 2011 - 05:27 PM, said:

The reason I suggested to turn off your firewall for the moment was for troubleshooting it.  Eliminating the chance that you just set it up wrong while you figure out where the problem is.  This is most easily accomplished by first disabling anything that could be blocking it until it starts working.  Then go back and re-enable things one at a time until you find out what is preventing access to your server and thus you know what to fix.

So the first step to figuring out why no one can connect to your server is

1) disable your windows firewall/firewall software, then try to connect via localhost from the same computer.

2) if that works, re-enable the firewall and try again, doesnt work? now you know the problem.

3) if that still works, then try from the outside, this way you know that any problem isnt with your server and its most likely your router/outside connection that is causing the issue and not the config on the server itself.

Its just your average troubleshooting steps,  start with least restrictive then continue to lock it down until you find what breaks it.

Thanks for the troubleshooting tips. I'll give it a shot the next time I get a chance to mess with it!