Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Control: Button 1


  • This topic is locked This topic is locked
9 replies to this topic

#1

porkhock
    porkhock

    Out of the Water

  • Members
  • 4 posts

Posted 11 December 2011 - 12:18 AM

I need help! I was on my laptop (mac book pro). and i was messing around with the controls! I was clicking on some stuff, and randomly got 3 buttons saying ''button 1''. I'll upload a picture. I'm not exactly sure what to do!! Please, help me! I love minecraft, and when it doesn't work at my dad's i can only play at my moms computer (on the other side of town!!) here's a picture of what it looks like:

Posted Image
I've un-installed, and re- installed numerous times. please help!! ahh!!

Register or log in to remove.

#2

15avigil
    15avigil

    Redstone Miner

  • Members
  • 604 posts
  • Location: The magical land of off-topic.
  • Minecraft: 15avigil

Posted 11 December 2011 - 12:19 AM

Change it back...

#3

HiddenStrike
  • Minecraft: HiddenStrike

Posted 11 December 2011 - 12:19 AM

just click on them and press a different key
Frostheim Town
Posted Image
Halekine versprechen nichts.
~~~~
Verdammt durch das Fleisch. Gerettet durch das Blut.
~~~~
Skål, Kammerat; Prost, Kamerad; Ура, Товарищ
~~~~
Медвежья кавалерия
~~~~

#4

Mr 005
    Mr 005

    Lapis Lazuli Collector

  • Members
  • 934 posts
  • Location: The Milky Way
  • Minecraft: mr00five

Posted 11 December 2011 - 12:21 AM

ooh that is a very bad virus.  I'm afraid you can't play mine craft anymore.  

Spoiler:

Posted Image

#5

chokladjonte
  • Location: Under your bed....
  • Minecraft: chokladjonte

Posted 11 December 2011 - 12:22 AM

Just change two of the red ones to another key.
Do not pray to live easy lives. Pray to be stronger men.
                                     John F Kennedy

#6

robo111
    robo111

    Obsidian Miner

  • Members
  • 1265 posts
  • Location: Texas
  • Minecraft: robo111

Posted 11 December 2011 - 12:40 AM

Ignore the above players.

'Button 1' is your left mouse key. You must have clicked it twice. Click on the 'Pick Block' one and thing push the scroll key. That will make you scroll through your items. If you then click on the 'Use Block' and then click the right mouse button, it will be all better.
Posted Image

#7

BrennanZ
  • Location: United States
  • Minecraft: Baz621

Posted 11 December 2011 - 12:51 AM

Click on the one you want to change and hit the key you want it to be.

/close thread
Posted Image
"I can see a beautiful sunset rendering in the distance."

#8

Pxex
    Pxex

    Void Walker

  • Members
  • 1758 posts
  • Minecraft: Pxex

Posted 11 December 2011 - 01:52 AM

the reason there red is because they are the same button but does different things, confusing the game as for it cant do both at the same time

#9

Grigori0
    Grigori0

    Newly Spawned

  • Members
  • 1 posts

Posted 23 September 2012 - 09:26 PM

Dear Porkhock -

All the above posts are useless - because they have PC's and ignored that you have a Mac.  Here's what you have to do (because I had the same problem and Mojang has not made this easy to fix for Mac users):

1. Find a friend who has a PC and log in to your account.
2. Go to Options, and Controls, and be sure to reset or even reconfirm the default settings for your account on the PC (Attack = left click, Use Block = right click)
3. Log out and log on to your Mac - you will see your buttons are still the screwed up version.  Now, however, you can change them.  So, if the problem was the "Use Block" function, clear that function (and you get the ???) and then Control+click it and it should come up as Button 2.

I hope that helps you or some future user like me who did not find much useful info out there.  The posts above are really NOT helpful.

#10

Eclipse11
    Eclipse11

    Lapis Lazuli Collector

  • Members
  • 915 posts
  • Location: Somewhere

Posted 23 September 2012 - 09:32 PM

Buy a pc.