Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[SOLUTION] Internal Client Error: java.net.SocketException: Permission Denied: Connect


  • Please log in to reply
26 replies to this topic

#1

scyp10
    scyp10

    Iron Miner

  • Members
  • 260 posts
  • Location: Yo face
  • Minecraft: scyp10

Posted 08 December 2011 - 03:32 AM

I had a problem that whenever Minecraft would try to fetch news/go to a server, it would say this error:
Internal Client Error: java.net.SocketException: Permission Denied Connect
Now, here's the solution (if you run Windows 7)
Click on this link: https://www.java.com.../manual.jsp#win
Click on the 64-Bit Java link for Windows, and you'll install it. This will revert you to the newest stable java (which is Java 6 Update 29) but will fix your problem.

Thanks,
scyp10
Posted Image

Register or log in to remove.

#2

Steve_59
    Steve_59

    Zombie Killer

  • Members
  • 224 posts

Posted 08 December 2011 - 05:28 AM

View Postscyp10, on 08 December 2011 - 03:32 AM, said:

Hey guys,
I haven't been able to connect to any servers on Minecraft, or get the front page tumblr news, and I don't know what's causing it. Here is the error:
Internal Client Error: java.net.SocketException: Permission Denied: connect
When the problems started happening, these changes happened:
1. I updated to Java 7
2. My firewall settings might have been changed.

I have no idea what's causing this, and I've already tried updating to a fresh .jar (from a backup when 1.0.0 came out), and adding the java.exe in Program Files and System32 into my Firewall (along with minecraft.exe), but nothing has worked. Also, when I tried force updating, it didn't work, and gave a similar "Internal Client Error: java.net..." etc.
If anyone knows what's wrong please help!

Thanks,
scyp10


Add javaw.exe to the allowed applications in your firewall, that is what Minecraft uses.

#3

scyp10
    scyp10

    Iron Miner

  • Members
  • 260 posts
  • Location: Yo face
  • Minecraft: scyp10

Posted 08 December 2011 - 11:12 PM

View PostSteve_59, on 08 December 2011 - 05:28 AM, said:

Add javaw.exe to the allowed applications in your firewall, that is what Minecraft uses.

which javaw.exe are you referring to (what location)
Posted Image

#4

scyp10
    scyp10

    Iron Miner

  • Members
  • 260 posts
  • Location: Yo face
  • Minecraft: scyp10

Posted 10 December 2011 - 10:36 PM

bump
Posted Image

#5

scyp10
    scyp10

    Iron Miner

  • Members
  • 260 posts
  • Location: Yo face
  • Minecraft: scyp10

Posted 11 December 2011 - 06:14 AM

bump
Posted Image

#6

Steve_59
    Steve_59

    Zombie Killer

  • Members
  • 224 posts

Posted 11 December 2011 - 06:44 AM

View Postscyp10, on 11 December 2011 - 06:14 AM, said:

bump

Try removing all the java.exe and javaw.exe entries in your firewall exception list.
See if there is a popup requesting access when you start Minecraft.
If that does not work then it is probably your anti-virus causing the problem.
Try adding C:\Program Files\Java\jre6\bin\javaw.exe to your anti-virus firewall exclusion list.
If you have a Program Files (X86) version of java then you should remove it and install the 64bit version of java.

#7

scyp10
    scyp10

    Iron Miner

  • Members
  • 260 posts
  • Location: Yo face
  • Minecraft: scyp10

Posted 11 December 2011 - 08:18 PM

View PostSteve_59, on 11 December 2011 - 06:44 AM, said:

Try removing all the java.exe and javaw.exe entries in your firewall exception list.
See if there is a popup requesting access when you start Minecraft.
If that does not work then it is probably your anti-virus causing the problem.
Try adding C:\Program Files\Java\jre6\bin\javaw.exe to your anti-virus firewall exclusion list.
If you have a Program Files (X86) version of java then you should remove it and install the 64bit version of java.

I removed it (although it was jre7 instead of jre6) and, for some reason, it still showed that task running in task manager with the same error (no pop-up). Everything has gone wrong since I updated to Java 7, but for some reason I can't go back. When I update, it does the one in Program Files instead of Program Files(x86)
Posted Image

#8

sowel
    sowel

    Zombie Killer

  • Members
  • 205 posts

Posted 11 December 2011 - 08:26 PM

try going to control panel > programs and features and uninstall java™7 from there

infact try uninstalling all your java and reinstalling it to have a clean install

#9

scyp10
    scyp10

    Iron Miner

  • Members
  • 260 posts
  • Location: Yo face
  • Minecraft: scyp10

Posted 12 December 2011 - 01:33 AM

View Postsowel, on 11 December 2011 - 08:26 PM, said:

try going to control panel > programs and features and uninstall java™7 from there

infact try uninstalling all your java and reinstalling it to have a clean install

did it, still doesn't work.
where can I download the Program Files(x86) and the Program Files Java? I need to try re-installing both.
Posted Image

#10

gerbil
    gerbil

    Support Guru

  • Members
  • 4917 posts

Posted 12 December 2011 - 02:24 AM

View Postscyp10, on 12 December 2011 - 01:33 AM, said:

did it, still doesn't work.
where can I download the Program Files(x86) and the Program Files Java? I need to try re-installing both.

get them at java.com

#11

scyp10
    scyp10

    Iron Miner

  • Members
  • 260 posts
  • Location: Yo face
  • Minecraft: scyp10

Posted 12 December 2011 - 02:55 AM

View Postgerbil, on 12 December 2011 - 02:24 AM, said:

get them at java.com

no derp. I mean, the address.
Posted Image

#12

gerbil
    gerbil

    Support Guru

  • Members
  • 4917 posts

Posted 12 December 2011 - 03:54 AM

View Postscyp10, on 12 December 2011 - 02:55 AM, said:

no derp. I mean, the address.

clicky the linky.

#13

scyp10
    scyp10

    Iron Miner

  • Members
  • 260 posts
  • Location: Yo face
  • Minecraft: scyp10

Posted 12 December 2011 - 03:54 AM

ok, solution found. Check the OP!
Posted Image

#14

scyp10
    scyp10

    Iron Miner

  • Members
  • 260 posts
  • Location: Yo face
  • Minecraft: scyp10

Posted 12 December 2011 - 03:57 AM

View Postgerbil, on 12 December 2011 - 03:55 AM, said:

clicky the linky

triple post?
anyway, found and updated.
Posted Image

#15

gerbil
    gerbil

    Support Guru

  • Members
  • 4917 posts

Posted 12 December 2011 - 04:24 PM

Stupid forum didn't show my post,  I think it's because you were posting at the same time that I was. or something.

#16

Bloisjo013

Posted 14 January 2012 - 02:43 AM

I've done all this, I still get the same result...
Posted Image

#17

brobodude

Posted 21 January 2012 - 02:28 AM

I was having this exact same issue, which started unexpectedly and never stopped. FORTUNATELY, I FOUND A DEFINITE SOLUTION! I gave up and switched to MineOS Crux (which is truly awesome, I love it) and during setting it up I discovered that my server, in setting up a static IP, was using the same IP address as our printer. The problems started the same day we got the printer and ended as soon as I switched which IP address the server was using! Hopefully this is the same solution that everyone else can use. Just look and make sure the IP address you've given your server isn't the same as another device.

#18

arthion123
  • Location: florida
  • Minecraft: arthion123

Posted 22 March 2012 - 08:26 PM

I added javaw.exe to allowed setting and it still doesnt work

#19

arthion123
  • Location: florida
  • Minecraft: arthion123

Posted 22 March 2012 - 11:18 PM

neither one of your solutions works! Posted Image can someone tell me the RIGHT way to fix this?

#20

arthion123
  • Location: florida
  • Minecraft: arthion123

Posted 15 April 2012 - 06:06 PM

none of these solutions work!