Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[SOLVED] Minecraft on Fedora 13 (Crash)


  • Please log in to reply
1 reply to this topic

#1

Jailout2000

Posted 22 November 2010 - 09:01 AM

I downloaded Minecraft.jar (the Linux version) from http://www.minecraft.net and ran it.

The login box came up, I logged in using my account, it downloaded the packages, and then said "Done loading!" and went to the next screen. It stayed black for a few seconds, then gave me this error report:
------------------------------------------------------------------------------------------

      Minecraft has crashed!      
      ----------------------      

Minecraft has stopped running because it encountered a problem.

If you wish to report this, please copy this entire text and email it to [email protected].
Please include a description of what you did when the error occured.



--- BEGIN ERROR REPORT a1dce528 --------
Generated 11/22/10 2:53 AM

Minecraft: Minecraft Alpha v1.2.2
OS: Linux (i386) version 2.6.34.7-61.fc13.i686.PAE
Java: 1.6.0_22, Sun Microsystems Inc.
VM: Java HotSpot™ Client VM (mixed mode, sharing), Sun Microsystems Inc.
LWJGL: 2.4.2
[failed to get system properties (java.lang.NullPointerException)]

org.lwjgl.LWJGLException: X Error - disp: 0x98168a8 serial: 157 error: BadDrawable (invalid Pixmap or Window parameter) request_code: 14 minor_code: 0
at org.lwjgl.opengl.LinuxDisplay.globalErrorHandler(LinuxDisplay.java:268)
at org.lwjgl.opengl.LinuxContextImplementation.nMakeCurrent(Native Method)
at org.lwjgl.opengl.LinuxContextImplementation.makeCurrent(LinuxContextImplementation.java:117)
at org.lwjgl.opengl.Context.makeCurrent(Context.java:182)
at org.lwjgl.opengl.Display.makeCurrent(Display.java:730)
at org.lwjgl.opengl.Display.makeCurrentAndSetSwapInterval(Display.java:896)
at org.lwjgl.opengl.Display.create(Display.java:860)
at org.lwjgl.opengl.Display.create(Display.java:784)
at org.lwjgl.opengl.Display.create(Display.java:765)
at net.minecraft.client.Minecraft.a(SourceFile:201)
at net.minecraft.client.Minecraft.run(SourceFile:563)
at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT 8c2f19e7 ----------


------------------------------------------------------------------------------------------
And yes, I'm running the Sun JRE instead of OpenJDK, in case this error report doesn't make it obvious. I'm using Fedora 13 (Goddard) on an Intel Pentium 4 (i686) architecture.

Here's what I need: What can I do to get Minecraft playable?

Thanks,
- Jailout2000

Register or log in to remove.

#2

Jailout2000

Posted 02 December 2010 - 05:37 AM

I have fixed my problem.

At first, I tried adding myself to the group "video" by using $ usermod -a -G video . This did not help, but I am noting it here in case it may have helped with the next step I tried (I honestly don't know if adding myself to the video group helped or not). Also, you must be logged in as root ($ su) to execute usermod successfully.

All you need to do to fix this error is install your graphics drivers from your respective manufacturer.

For example, I was using NVIDIA. The default driver that ships with Linux is the Nouveau, an open-source alternative to the actual NVIDIA display driver. OpenGL will not work with this driver and must use the one created by NVIDIA.

To use NVIDIA's instead which OpenGL will work with, download the display driver from http://www.nvidia.com for your graphics card and architecture, and follow the README link under "Additional Information". See section 4 for installing your NVIDIA driver. Also, I want to note that it is crucial you read the "Before you begin" or otherwise you'll run into problems or errors.

I hope this helps anyone in the future.
- Jailout2000