Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Warning: Perhaps a server is already running on that port?


  • Please log in to reply
19 replies to this topic

#1

Crazylollipop123
  • Minecraft: crazylollipop

Posted 04 December 2011 - 09:35 PM

Okay, here's the deal: My local IP is 10.0.0.3, so I tried to run the server with that. It apparently didn't work. So somebody suggested using ipchicken.com to find my external/static IP address. That was 67.182.98.184. So I put it in the properties file, and when I began to start the server, the log said:


[INFO] Starting minecraft server version 1.0.0
[INFO] Loading properties
[INFO] Starting Minecraft server on 67.182.98.184:25565
[WARNING] **** FAILED TO BIND TO PORT!
[WARNING] The exception was: java.net.BindException: Cannot assign requested address: JVM_Bind
[WARNING] Perhaps a server is already running on that port?

And here's all the stuff from ipconfig/all:
IPv4: 10.0.0.3
Subnet Mask: 255.255.255.0
Default Gateway: 10.0.0.1
DNS Servers: 68.87.76.182
             68.87.78.134
Thats all I thought was important.
So yeah. PLease help. I'm trying to run the server on my laptop, which is using y'know, that general wi-fi thing. The router/modem or whatever. If there's nothing I can do, I'll just run the server on my actual computer downstairs. It just may not be online as long as I want it to be. PLEASE REPLY!!

Register or log in to remove.

#2

Crazylollipop123
  • Minecraft: crazylollipop

Posted 04 December 2011 - 09:56 PM

Hope they don't kill me for this bump, but I'm not promoting a server.

#3

paperCuT
    paperCuT

    Nether Resident

  • Members
  • 2039 posts
  • Location: A small town in California
  • Minecraft: _WhosDaMan_
  • Xbox:SlightThought

Posted 04 December 2011 - 09:58 PM

Try restarting your computer, then report what happens.
(Kickstarter) Bionic Fighters:Party Style Fighting - a video game in the vein of Super Smash Bros Melee

http://www.kickstart...ghters?ref=live

#4

Crazylollipop123
  • Minecraft: crazylollipop

Posted 04 December 2011 - 10:03 PM

View PostpaperCuT, on 04 December 2011 - 09:58 PM, said:

Try restarting your computer, then report what happens.
Just did. Checked ipconfig/all, and nothing had changed.

#5

nirvanaking95
  • Location: United States
  • Minecraft: nirvanaking95

Posted 23 December 2011 - 02:30 AM

Yes, I get the same error shown below.

Posted Image

THINGS I HAVE TRIED.
--------------------
1. Restart computer
2. Port forward
3. Run as administrator

Using hamachi works but I do not like to use hamachi.

Anyways this post was mainly for a bump, as I would like the solution to this problem aswell. It used to work! I don't know why it doesn't now.

EDIT:

I've also tried in the Command Prompt;

ipconfig /release
ipconfig /renew

but that does not work.

#6

MrTurtleCraft
  • Location: IP:66.38.4.226
  • Minecraft: IP:66.38.4.226

Posted 29 December 2011 - 12:15 AM

also having this problem it used to work but not now... does no one know how to fix this??...
Follow me on twitter @iturtleeee
Join my free build server IP:66.38.4.226 Donate:[email protected]

#7

MrTurtleCraft
  • Location: IP:66.38.4.226
  • Minecraft: IP:66.38.4.226

Posted 29 December 2011 - 12:43 AM

View Postnirvanaking95, on 23 December 2011 - 02:30 AM, said:

Yes, I get the same error shown below.

Posted Image

THINGS I HAVE TRIED.
--------------------
1. Restart computer
2. Port forward
3. Run as administrator

Using hamachi works but I do not like to use hamachi.

Anyways this post was mainly for a bump, as I would like the solution to this problem aswell. It used to work! I don't know why it doesn't now.

EDIT:

I've also tried in the Command Prompt;

ipconfig /release
ipconfig /renew

but that does not work.
Ok, i just had the same problem you did. I messed around and i fixed it. I found nothing online that helped everyone says restart your computer, but that didn't work for me.
SO
This is what i did.
I downloaded the latest bukkit build and remade the server. Then i went into the command prompt and typed ipconfig and somehow my ip changed so i deleted the port forward i had before and remade it with the new ip.

So, check your ip's and remake your server


Tell me if this worked for you.

Other things i've seen on the internet is. Maybe a plugin crashed ur server try to remove plugins by deleting them or taking them out for the time being like- Worledit, bigbrother, or logblock those are the most common
Follow me on twitter @iturtleeee
Join my free build server IP:66.38.4.226 Donate:[email protected]

#8

Boskow
    Boskow

    Out of the Water

  • Members
  • 4 posts

Posted 04 January 2012 - 01:03 PM

Same problem. Same as broking bedrock!









:opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock: :opblock:

#9

Boskow
    Boskow

    Out of the Water

  • Members
  • 4 posts

Posted 04 January 2012 - 11:11 PM

I think that this is the right website. http://wiki.bukkit.o...ing_up_a_server

#10

Kakadoo
    Kakadoo

    Tree Puncher

  • Curse Premium
  • Curse Premium
  • 20 posts

Posted 04 January 2012 - 11:58 PM

That Means You Dident Port Forward It Or Did it wrong or you have server runing on that port!
Posted Image

#11

AC_D3D
    AC_D3D

    Out of the Water

  • Members
  • 9 posts
  • Location: untitled folder, Desktop
  • Minecraft: AppleCactus

Posted 05 January 2012 - 11:57 PM

Same I Cant Do anything!
"may I request a brain massage?"

#12

noonzark
  • Minecraft: noonzark

Posted 08 January 2012 - 10:27 AM

are u runing mac if so go to this link it might help u

My link
Can some one buy me minecraft?

#13

azteknologya

Posted 08 January 2012 - 10:48 AM

i suggest just using a different port for when you port forward.....
Posted Image

#14

kittyXD
    kittyXD

    Out of the Water

  • Curse Premium
  • Curse Premium
  • 6 posts
  • Minecraft: hammy3502

Posted 09 September 2012 - 06:09 PM

If you are not required to use a .jar (running windows) try using another file type like a .exe.

#15

Polaris29
    Polaris29

    Not Retired Staff

  • Sectional Moderator
  • 4240 posts
  • Minecraft: Polaris29

Posted 09 September 2012 - 06:17 PM

You all obviously didn't port foward correctly

Learn how to portfoward here:
http://portforward.c...t/minecraft.htm
They have a guide for almost every single router

(And make sure you read all of it)
Also make sure you leave server-ip empty

#16

felinoel
    felinoel

    Nether Resident

  • Members
  • 2300 posts
  • Location: Somewhere, possibly?
  • Minecraft: felinoel

Posted 22 December 2012 - 05:05 AM

View PostPolaris29, on 09 September 2012 - 06:17 PM, said:

You all obviously didn't port foward correctly

Learn how to portfoward here:
http://portforward.c...t/minecraft.htm
They have a guide for almost every single router

(And make sure you read all of it)
Also make sure you leave server-ip empty
What if you did port forward, and your router has an automatic setting specific for Minecraft, and your ipv4 address doesn't work?

#17

Chibby
    Chibby

    Stone Miner

  • Members
  • 88 posts
  • Location: United States, OR
  • Minecraft: ydnar16

Posted 22 December 2012 - 08:05 AM

When I use to get that error I would do this

Task Manager > Processes > javaw.exe > End Process

That would always fix the problem for me!

Hope this helps other people

#18

felinoel
    felinoel

    Nether Resident

  • Members
  • 2300 posts
  • Location: Somewhere, possibly?
  • Minecraft: felinoel

Posted 22 December 2012 - 08:35 AM

View PostMinecraftDubstep0007, on 22 December 2012 - 08:05 AM, said:

When I use to get that error I would do this

Task Manager > Processes > javaw.exe > End Process

That would always fix the problem for me!

Hope this helps other people
I read that fix elsewhere, it didn't.

Well... I don't get that error anymore, but people still can't connect to my server.

#19

Lord_Lewes
    Lord_Lewes

    Diamond Miner

  • Curse Premium
  • Curse Premium
  • 728 posts
  • Location: United Kingdom
  • Minecraft: Lord_Lewes

Posted 22 December 2012 - 11:56 PM

Try using another port, and in server.properties set the IP as localhost or 127.0.0.1

For others, please stop suggesting port forwarding, you only use that if you want others to access the server, he can't even boot the server so port forwarding will have no effect.

Lord_Lewes

Web and java developer


#20

minernamewave

Posted 29 March 2013 - 08:08 AM

if you use mac this really help find the activate monitor or some thing...
then type in filter "java" then pres quit processing and then re open your server done..