Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Minecraft not running on graphics card :(


  • Please log in to reply
20 replies to this topic

#1

xJochim
    xJochim

    Carpenter

  • Members
  • 54 posts
  • Minecraft: drDday

Posted 29 November 2011 - 08:42 PM

Why is Minecraft not running on my graphics card?

hi,

I play Minecraft for a wild now and on my previous pc I had no problems with it lagging.
However on my new pc with way better specs(specs are below) it laggs a LOT! I tink I know what the problem is but I can't fix it. My Minecraft isn't running on my graphics card unlike other games like Team Fortess 2, BF3 and MW3. (Those games run SUPER smooth) I don't know how to run Minecraft on my AMD Radeon HD 6770M... Pls help!?

SPECS

- Intel Core i7 2670QM
- 8 GB RAM
- AMD Radeon HD 6770M (2 GB)
- (Windows 7 Home Premium)

Posted Image


Register or log in to remove.

#2

Wazupnow

Posted 29 November 2011 - 08:46 PM

That is very odd because with those specs you should be able to play it very easy. From what I have heard minecraft doesn't like some inter-graded graphics and mobile versions. I think I remember seeing a patch for it awhile back

#3

ads123
    ads123

    Iron Miner

  • Members
  • 331 posts
  • Minecraft: adsc123

Posted 29 November 2011 - 08:55 PM

View PostxJochim, on 29 November 2011 - 08:42 PM, said:

Why is Minecraft not running on my graphics card?

hi,

I play Minecraft for a wild now and on my previous pc I had no problems with it lagging.
However on my new pc with way better specs(specs are below) it laggs a LOT! I tink I know what the problem is but I can't fix it. My Minecraft isn't running on my graphics card unlike other games like Team Fortess 2, BF3 and MW3. (Those games run SUPER smooth) I don't know how to run Minecraft on my AMD Radeon HD 6770M... Pls help!?

SPECS

- Intel Core i7 2670QM
- 8 GB RAM
- AMD Radeon HD 6770M (2 GB)
- (Windows 7 Home Premium)
1.8 and 1.0.0 have got a lot more intensive try lowering the render distance.

#4

1Megaprime96
  • Location: Belgium

Posted 29 November 2011 - 09:05 PM

got one of the sticky threads:

OptiFog said:

Launch  Minecraft with less memory (yes, really). It needs maximum 256 MB and  runs fine on all settings with the default texture pack. By default java  allocates insane amounts of memory (1GB?) which then gets swapped to  disk and the overall performance suffers a lot.
Note  that launchers that use less memory should only be done with vanilla  Minecraft. Vanilla means no texture pack, mods, etc, just plain  Minecraft. If done with memory intense mods (humans+, mo' creatures) or a  texture pack that's bigger than 16x then the FPS may be hurt, or you  may run out of memory. DO NOT USE MORE MEMORY THAN YOU HAVE! If you have 1gb ram and use a 2gb launcher it will crash your game and computer.

256mb is recommended for vanilla.
512mb is recommended for mods that add a few new mobs, or use of a higher resolution texture pack.
1024mb is for many new mobs like mo creaturesif you play in browse, and super high res texture packs like x128.
2058 is A LOT of new mobs like mo creature, humans+, pokemobs, etc. Also if you have out of memory problems.
4096 is unnecessarily high, but it is possible.
These are in megabytes so 1024 is a gigabyte of ram. Adding more memory than default may help if you have a lot of spare RAM.

Posted Image


#5

xJochim
    xJochim

    Carpenter

  • Members
  • 54 posts
  • Minecraft: drDday

Posted 30 November 2011 - 12:53 PM

None of these worked :( Pls help...

Posted Image


#6

xJochim
    xJochim

    Carpenter

  • Members
  • 54 posts
  • Minecraft: drDday

Posted 30 November 2011 - 04:34 PM

If you know how to play Minecraft on my videocard or have the same problem as me pls reply! I realy want to play Minecraft without lag.

Posted Image


#7

xJochim
    xJochim

    Carpenter

  • Members
  • 54 posts
  • Minecraft: drDday

Posted 30 November 2011 - 09:40 PM

Realy?! No one knows the answer of my problem?;(

Posted Image


#8

rostafnk
    rostafnk

    Out of the Water

  • Members
  • 3 posts

Posted 01 December 2011 - 05:24 PM

I have the same problem!

I just bought an HP Pavillion DV6 with the same specs you've got. For whatever reason I can't get minecraft to run using the Radeon card. I've used the "catlyst control center" to place javaw.exe on "high performance." This doesn't instill the confidence that java is actually using my better card. I also did the .bat trick to increase the amount of RAM usage, despite the fact that I'm running the game w/o any add-ons.

I've never played minecraft before, but from what I've read my PC setup should run this game @ a Framerate higher than 7-10. I'd really appreciate it if someone could walk my noob ass through this.

P.S. Minecraft won't allow me to play online now.

#9

FlyingPenguinSki

Posted 17 December 2011 - 02:36 AM

I also have a Dv6, and i think it's because the i7 2670QM has intergrated graphics on it, and the game is using the graphics capabilities of the CPU, not the GPU. Also my laptop can run quite well with Fancy, all particles, and clouds turned on, but with normal render distance. If a world is generating i turn the settings down,  (say when you are travelling) to fast graphics with minimal particles and turn clouds off.

Also i want to say that when i checked whether my computer could run skyrim, one website analysis picked up the intel intergrated graphics, while the other picked up the 6770m GPU. I think it might be because of how the game searches for graphics cards?

#10

Defakto227

Posted 17 December 2011 - 02:36 AM

Couple of things could causing an issue.

1) It's a mobile chipset, some of these use a dual gpu that causes minecraft to run on a much lowered powerd GPU than the other.
2) You could be overheating, laptops auto throttle when they overheat, which reduces performance.

#11

usr1k
    usr1k

    Out of the Water

  • Members
  • 4 posts
  • Location: Slovakia
  • Minecraft: usr1k

Posted 18 January 2012 - 09:15 AM

Hello,

Sorry for my thread-necromancy, but I wanted to ask whether you have managed to resolve this issue.

My friend has the same problem - MC is using the internal Intel Chipset instead of his AMD Radeon 6370M and he has 5-20 FPS at fancy graphics and tiny-normal distance.

I believe there is a way how to set an appliction (javaw.exe) to prefer the proper card instead of the chipset?

Intel® Core™ i3-2330M
4GB RAM (1333)
ATI ROBSON XT DDR3 1G (written on the laptop's vendor's page, though the OS identifies it as AMD Radeon 6370M?)
Win7 x64


Thanks a bunch!

#12

CaptainGiblets
  • Location: Usa
  • Minecraft: CaptainGiblets

Posted 23 January 2012 - 01:05 AM

try geting the lastest Java updata, it helped me alot

#13

striikiito
  • Minecraft: striikiito

Posted 24 January 2012 - 10:27 PM

Hi,

You could edit alocate memory with my program, topic is here

I hope I can help you.

regards,
Striikiito.

#14

striikiito
  • Minecraft: striikiito

Posted 24 January 2012 - 10:35 PM

View Postusr1k, on 18 January 2012 - 09:15 AM, said:

Hello,

Sorry for my thread-necromancy, but I wanted to ask whether you have managed to resolve this issue.

My friend has the same problem - MC is using the internal Intel Chipset instead of his AMD Radeon 6370M and he has 5-20 FPS at fancy graphics and tiny-normal distance.

I believe there is a way how to set an appliction (javaw.exe) to prefer the proper card instead of the chipset?

Intel® Core™ i3-2330M
4GB RAM (1333)
ATI ROBSON XT DDR3 1G (written on the laptop's vendor's page, though the OS identifies it as AMD Radeon 6370M?)
Win7 x64


Thanks a bunch!

Infact minecraft use mostly your UC (processor) you graphic card is competent (I think) but your UC is lite ... try to use:
-Optimine (here)
-or Optifine (here) or (here)

#15

hunty512
    hunty512

    Lapis Lazuli Collector

  • Members
  • 981 posts

Posted 24 January 2012 - 10:41 PM

I recommend getting the mod "Optifine". It boosts your FPS pretty high.
Posted Image.
I made the link for the signature work unlike everyone else.

#16

peto2006
    peto2006

    Out of the Water

  • Members
  • 2 posts

Posted 18 April 2012 - 08:42 PM

I had problem with fps in minecraft on my hp pavilion dv6-6b90ec. I don't know, how to setup minecraft to use high-performance gpu, but i solved that problem. Go to bios. There are two modes for graphics card. I don't know exact names of possible options, but you can set that only one gpu will be used. Then you can setup in windows to use high-performance gpu and it will be used for whole system. Now I can play minecraft on best settings end extreme render distance with optifine.

#17

hedfun2
    hedfun2

    Out of the Water

  • Members
  • 5 posts

Posted 13 May 2012 - 08:11 PM

This has happened to me before but i have finally fixed it. You have to go the HP website and select drivers. Then find your laptop model and click on it. Then find Graphics card and BIOS and update those both. Then restart your computer and it should say like Press F10 for setup or something like that so press F10 (varies on computer) a couple of times and your system BIOS should come up. Navigate to System Configuration with the arrow keys and find Switchable Graphics. Change that from dynamic to Fixed. Now you can manually chose what graphics to use via the Catalyst Control Center.

#18

Superparker
  • Location: Aussie
  • Minecraft: superparker

Posted 20 May 2012 - 03:11 AM

I've had the same problem as you guys, the thing is that the computer has switchable graphics. If you run Skyrim it will switch to the HD6770. Now, minecraft is an openGL program and the graphic's card doesn't pick it up. You and I were getting low FPS because we were using the intel HD 3000. What hedfun said is true and should help you.
The main reason for the switchable graphics is to save battery. :)
Posted Image

#19

joannis11
  • Location: Eindhoven
  • Minecraft: joannis11

Posted 22 June 2012 - 10:27 PM

Most of this is off-topic. This problem - as the topic-opener said himself - doesn't have to do with RAM!!!
His computer doesn't use his GPU for rendering therefore using the CPU for rendering. This off course if f*cking slow.

#20

Superior_Reich

Posted 31 July 2012 - 09:58 PM

I am having the exact same problem. My specs are listed below:

AMD athlon 3.2 6x 1100 Thuban
8 Gigs of RAM running at 1600+
nvidia gforce GTX 580 1.5 VR
300 Gig velociraptor 10,000 RPM's
Crosshair IV motherboard

I am getting low fps for my computer. I should be getting way better frames then what I am. My frames are running between 3 to 30 to 60 at most. I am running around 24 mods, but still, I dont think I should be getting such crappy frames with my geforce GTX 580. I mean come on now. While I was playing minecraft I looked at my GPU usage and it was only at 16 to 17% and wasnt using any of the video ram. I am thinking that my processor is doing it all and my GPU is just sitting back. How the hell do I get my GPU more involved? Can someone please help?
Dont scream and shout!
Just help a noob out!