Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Minecraft too dark on mac


  • Please log in to reply
12 replies to this topic

#1

whitefedora

Posted 18 November 2010 - 10:44 AM

Sorry if this issue has already been brought up, I tried to search the support forum and it gave me an error.

I've been playing minecraft on my mac for 2 or 3 months now and it suddenly got too dark to play. I mean indoors (previously very well lit indoors, mind you) are now barely discernable, and outdoors is just pitch black at night.

This happened to me once before and I just rebooted and reset my PRAM/NVRAM -> Problem solved, but this time that didn't work.

I've also tried recalibrating my screen 3 times, but I'm pretty sure the problem is minecraft. If I look up a picture of the load screen on google it looks like it used to, implying that my screen is still functioning the same. The dirt on the forums looks normal, the dirt on the loading screen in minecraft looks more like darkened netherstone, just to give you an idea.

I've tried removing the bin file, and even completely reinstalled minecraft. I've tried running it without custom textures as well, no luck.

Specs:
OS X 10.6.5
2GHz Intel Core Duo
Graphics:
  Chipset Model: ATY,RadeonX1600
  Type: GPU
  Bus: PCIe
  PCIe Lane Width: x16
  VRAM (Total): 128 MB
  Vendor: ATI (0x1002)
  Device ID: 0x71c5
  Revision ID: 0x0000
  EFI Driver Version: 01.00.068
  Displays:
Color LCD:
  Resolution: 1440 x 900
  Pixel Depth: 32-Bit Color (ARGB8888)
  Main Display: Yes
  Mirror: Off
  Online: Yes
  Built-In: Yes
Display Connector:
  Status: No Display Connected

Register or log in to remove.

#2

whitefedora

Posted 18 November 2010 - 10:45 AM

Oh and Java is v. 1.6.0_22 from Apple, minecraft is 1.2.2.

The same problem occurs running in browser :/

#3

dadanman
    dadanman

    Tree Puncher

  • Members
  • 13 posts

Posted 18 November 2010 - 01:13 PM

Yeah I have this problem too. Is there anyway to fix it?

#4

whitefedora

Posted 18 November 2010 - 01:22 PM

I looked into rolling back the recent Java updates to see if that would solve the problem, but that would require a full system reinstall (I do not use time machine, so I cannot do a system restore). Naturally, I'm hesitant to do this, do you use time machine?

#5

dadanman
    dadanman

    Tree Puncher

  • Members
  • 13 posts

Posted 18 November 2010 - 05:41 PM

Yes, but I've never done a full system reinstall, but I dont really think its worth that much trouble to fix this little problem. Sorry

#6

whitefedora

Posted 18 November 2010 - 10:13 PM

You wouldn't need to do a reinstall, just a rollback to a version of your OS before the most recent java update. However, I did a full reinstall, and I still have the problem  :iapprove:.

any official word on this bug? Where's the best place to report it?

For the record, the bug has been reproduced in java version 1.6.0_17 and 1.6.0_22

#7

dylanweber
  • Location: Look behind you.

Posted 19 November 2010 - 12:08 AM

It's not a bug, as much of the failure to make brighter colors. The display on our Macs have the settings on to make all the colors we see much more elegant. Try going into the System Preferences and changing the gamma on the display's page to a different setting.

Welcome to the world of

Minecraft: BasicCraft


[24/7] [No PVP] [Anti-Creeper] [Whitelist] [Bukkit]


#8

whitefedora

Posted 19 November 2010 - 05:10 PM

I've already tried that, it still doesn't get anywhere near as bright as it used to be on my mac, and is still on my fiancee's mac. I've also tried recalibrating repeatedly, I'm convinced that this is minecraft mishandling something. Instead of 16 values of brightness I appear to have ~5. Things that should be in moonlight are instead exactly the same pitch black as inside a cave :/

#9

silvart
    silvart

    Out of the Water

  • Members
  • 6 posts

Posted 05 January 2011 - 07:32 PM

I'm still having this problem myself a while back the problem just vanished without any trace of having been anything i did in specific, but now it's back and will not go away. The game is not even that enjoyable this way, there really is nothing to do at night :\

any solutions yet?

#10

Kevinvdburg

Posted 31 January 2011 - 06:35 PM

Try Brightness Control
http://www.splasm.co...brightness.html
It's Free :)

#11

hagfish
    hagfish

    Out of the Water

  • Members
  • 5 posts

Posted 17 March 2011 - 07:22 PM

I was having the same problem. A new java update just came out so I applied it and way-hey - my mines are all beautifully lit just like in Ubuntu! It's made things much more playable. Well chuffed.

#12

CEOrko
    CEOrko

    Stone Miner

  • Members
  • 70 posts

Posted 17 March 2011 - 08:31 PM

Gamma Panel is another option.

At first, I was like
[Notch]
BUT THEN I PUT ON MY RAPE FACE
[SSSS]


#13

ryujin35
    ryujin35

    Tree Puncher

  • Members
  • 17 posts
  • Minecraft: Ryujin35

Posted 06 August 2012 - 12:47 PM

Go into System Preferences > Displays > Color. Change to one of the RGB profiles. Then go into Minecraft and turn the brightness up to max and turn off smooth lighting. The problem should be fixed. Good Luck!
Posted Image
Ryujin, as in the origami dragon. You guys know about that, right?