Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Anyone angry about the Pocket Edition for iOS?


  • This topic is locked This topic is locked
131 replies to this topic

#1

Dreamcast_Minecraft

Posted 17 November 2011 - 02:44 AM

Many of us iPod, iPhone, users may not really be able to get the Pocket Edition
I myself have an iPod Touch 2G. the highest firmware version it can get is 4.2.1
This aplies to the ipod touch 3g and iphone 3g as well
Probaby after many modifications it may become "playable" on the earlier ones
But if you have any iOS device that cant support iOs 4.3
No minecraft for you!

and yes, i know that it its because the devices are not powerful enough to support it

Register or log in to remove.

#2

mitch202
    mitch202

    Zombie Killer

  • Members
  • 167 posts
  • Minecraft: mitch323

Posted 17 November 2011 - 04:26 AM

I am angry about it. Mojang and Apple. And our devices CAN support it, its just the fact that Apple are being dicks to us and making us buy their new shit. I waited for this for SO LONG! and now they give us this shit. Thanks Apple and Mojang. Thanks.
Posted Image

#3

Cam5X5
    Cam5X5

    Stone Miner

  • Members
  • 85 posts

Posted 17 November 2011 - 04:41 AM

Only for apples?
Well no wonder it only going to have the crap version of minecraft.
To match it.

Troll be trolling >:P
Posted Image
Clicky Click ^^ XD

#4

Caleb
    Caleb

    Gold Miner

  • Members
  • 388 posts
  • Location: USA, GA
  • Minecraft: _Caleb

Posted 17 November 2011 - 07:14 AM

3rd gen iPods and the iPhone 3G can run MC: PE...

Posted Image


#5

Andrewkroger1
  • Minecraft: Andrewkroger1

Posted 17 November 2011 - 07:46 AM

View Postmitch202, on 17 November 2011 - 04:26 AM, said:

I am angry about it. Mojang and Apple. And our devices CAN support it, its just the fact that Apple are being dicks to us and making us buy their new shit. I waited for this for SO LONG! and now they give us this shit. Thanks Apple and Mojang. Thanks.

I'm sorry to say but, that's how the world works......

#6

0vonix0
    0vonix0

    Carpenter

  • Members
  • 60 posts

Posted 17 November 2011 - 08:00 AM

If you're on a 2nd gen iPod or first gen iPhone then I would hazard a guess that your warranty is up. If that is so go jailbreak that thing with Greenp0ison and fake your firmware version to 4.3 and much more. Then you can play pocket edition, but there could be a loss in frame rate. :L

#7

mitch202
    mitch202

    Zombie Killer

  • Members
  • 167 posts
  • Minecraft: mitch323

Posted 17 November 2011 - 08:28 AM

View Post0vonix0, on 17 November 2011 - 08:00 AM, said:

If you're on a 2nd gen iPod or first gen iPhone then I would hazard a guess that your warranty is up. If that is so go jailbreak that thing with Greenp0ison and fake your firmware version to 4.3 and much more. Then you can play pocket edition, but there could be a loss in frame rate. :L
Please tell me which Cydia app / tweak fakes your version.
Posted Image

#8

Mixmaster1190

Posted 17 November 2011 - 10:02 AM

View Postmitch202, on 17 November 2011 - 04:26 AM, said:

I am angry about it. Mojang and Apple. And our devices CAN support it, its just the fact that Apple are being dicks to us and making us buy their new shit. I waited for this for SO LONG! and now they give us this shit. Thanks Apple and Mojang. Thanks.
That's actually not their fault. Minecraft Pocket Edition just uses code that depends on 4.3.
A proud Minecrafter since August 2010.
Zombiecraft Maps!

#9

Mmarzex
    Mmarzex

    Tree Puncher

  • Members
  • 13 posts

Posted 17 November 2011 - 11:57 AM

I love how people complain about this like they're ten year olds who don't understand anything. It isn't going to work on anything less then 4.3 because then a lot of the objective C classes and such they probably used were not implemented in the sdk of the previous versions. And no the iPod touch 2g does not have the specs to be able to run PE at its intended state. That generation was released almost 4 years ago now. Accept that it is old and get a new one or don't, just don't complain on about it here.

#10

Xalusta
    Xalusta

    Diamond Miner

  • Members
  • 735 posts

Posted 17 November 2011 - 12:04 PM

How can anyone possibly be angry about it? Older technology isn't going to be able to run newer software, and it's really as simple as that. There's no way around it, nor is anyone doing anything wrong by creating better technology or making software that requires it. Unless you have a plan to stop the entire globe's technological advancements for the sake of being able to play games on old hardware, technology is going to become obsolete.

#11

Muffindog
  • Location: Up yours

Posted 17 November 2011 - 12:20 PM

The older devices don't have a enough RAM or processing power oh! And don't forget the Gpu power. So yeah that's why theres no Minecraft for 2g and lower. Because 3G can update to ios 5.0
Check out my YouTube channel, it has minecraft, PE and more:
http://www.youtube.c...er/Muffindog143

#12

Dr. Ian Itor
  • Location: Germany
  • Minecraft: Ian_Itor

Posted 17 November 2011 - 12:23 PM

the only thing i am angry about is that you can't really do anything except placing ~30 different blocks for a price of 5,49€.
imo they should have delayed the release (no one was expecting it right now anyways) until late december and added a lot more features. i am not willing to pay 5,49€ for a that, not yet at least, sorry :/


btw: don't complain about iOS version dependencies. update your firmware or bear with it that your device is way too old to support higher firmware, let out software.
i had an ipod 2nd gen and jailbroke it to iOS 4. even scrolling through my apps made it crash sometimes.
Posted ImagePosted ImagePosted Image    Posted Image    Posted Image    Posted Image

#13

TriFresh
    TriFresh

    Out of the Water

  • Members
  • 3 posts
  • Minecraft: TriFresh

Posted 17 November 2011 - 12:23 PM

View PostMmarzex, on 17 November 2011 - 11:57 AM, said:

I love how people complain about this like they're ten year olds who don't understand anything. It isn't going to work on anything less then 4.3 because then a lot of the objective C classes and such they probably used were not implemented in the sdk of the previous versions. And no the iPod touch 2g does not have the specs to be able to run PE at its intended state. That generation was released almost 4 years ago now. Accept that it is old and get a new one or don't, just don't complain on about it here.

I'm running MC PE off of fw 4.2.6(I'm jailbroken FYI) I just had to edit a simple file on my iPhone to make the App Store think I was on fw 4.3. The game runs absolutely fine on fw 4.2.6

#14

AndyThaBong
  • Location: Denmark
  • Minecraft: AndyThaBong

Posted 17 November 2011 - 02:34 PM

You shouldn't be angry! You're device wouldn't be able to run the game at all, it uses technoligies that wasn't there when you got you're iPod. I myself have one too, but i just got an iPhone 4S. But if i hadn't, i would still not be angry, it's like having a old computer with windows XP, and being angry about that it can't play Skyrim or whatever.. You could modify your iPod to think that it could run it, but it would lag like shit, and wouldn't be enjoyable at all.

#15

TheSinfoolGamer
  • Location: Down Under

Posted 17 November 2011 - 02:42 PM

Angry? No, slightly disgruntled? yes (but I would get "slightly disgruntled" if someone stabbed me in the eye too. I don't really get angry unless its about something absolutely serious that someone (mainly my husband) is being an idiot about)

Its just a game. Would I like it? yes, but I can't get it. Tough crap for me.

I'm on 4.1 point something, because its was easier to have my phone that way. I have not doubt with my luck, if I updated to 4.3 on my iphone 3gs, it would freeze and stuff itself, like many 3gs's do on 4.3.

I will just have to wait until I snag a broken Iphone 4 for cheap, rofl.

Posted Image

~ A friend told me I was delusional..... I almost fell off my unicorn ~ Fun Fact! Mosquitos don't just bite you. They also urinate on you after sucking your blood

RIP Henry the Ice-Cream Truck GTA4


#16

oleish
    oleish

    Coal Miner

  • Members
  • 101 posts
  • Location: trying to get in a door
  • Minecraft: oletube

Posted 17 November 2011 - 03:29 PM

View PostDreamcast_Minecraft, on 17 November 2011 - 02:44 AM, said:

Many of us iPod, iPhone, users may not really be able to get the Pocket Edition
I myself have an iPod Touch 2G. the highest firmware version it can get is 4.2.1
This aplies to the ipod touch 3g and iphone 3g as well
Probaby after many modifications it may become "playable" on the earlier ones
But if you have any iOS device that cant support iOs 4.3
No minecraft for you!

and yes, i know that it its because the devices are not powerful enough to support it
itouch 3g can run ios 5 perfectly thank you very much
#orangered

#17

Avantir_Yihn
  • Location: Earth, Heart and Soul.
  • Minecraft: Avantir_Yihn

Posted 17 November 2011 - 03:35 PM

I'm not angry. If you could get it, the game would be too slow to run anyways and would likely crash.

So be happy. Apple and Mojang just saved you from wasting 7 dollars.
Truly he is my rock and my salvation; he is my fortress, I will not be shaken. ~Psalms 62:6

#18

finkmac
    finkmac

    Zombie Killer

  • Members
  • 160 posts
  • Location: T_e___r _i_y
  • Minecraft: finkmac

Posted 17 November 2011 - 04:31 PM

As like 6 people have said on this thread, the Pre-A3 devices (pre 3GS) are not fast enough to run Minecraft…

The iPhone 2G and 3G have the same Memory and CPU, 128 MB and 412 MHz…
The iPod Touch 1G and 2G have the same memory, 128 MB but the 2G has a 532 MHz CPU, compared to the 412 MHz CPU in the 1G.

Hey, The Android version doesn't work on devices with the MSM7227 CPU…

If you have a iPod Touch 3G, you can install iOS 5 and enjoy Minecraft:PE…

#19

iFinity
    iFinity

    Zombie Killer

  • Members
  • 219 posts
  • Location: England, UK
  • Minecraft: iFinity

Posted 17 November 2011 - 04:47 PM

View Postfinkmac, on 17 November 2011 - 04:31 PM, said:

As like 6 people have said on this thread, the Pre-A3 devices (pre 3GS) are not fast enough to run Minecraft…

The iPhone 2G and 3G have the same Memory and CPU, 128 MB and 412 MHz…
The iPod Touch 1G and 2G have the same memory, 128 MB but the 2G has a 532 MHz CPU, compared to the 412 MHz CPU in the 1G.

Hey, The Android version doesn't work on devices with the MSM7227 CPU…

If you have a iPod Touch 3G, you can install iOS 5 and enjoy Minecraft:PE…
I have an iPod Touch 3rd Generation but it is the 8gb version which is basically the same as 2nd Generation.  If you've got more than 8gb then you're good to go.

#20

electonthefire

Posted 17 November 2011 - 06:24 PM

View PostDreamcast_Minecraft, on 17 November 2011 - 02:44 AM, said:

Many of us iPod, iPhone, users may not really be able to get the Pocket Edition
I myself have an iPod Touch 2G. the highest firmware version it can get is 4.2.1
This aplies to the ipod touch 3g and iphone 3g as well
Probaby after many modifications it may become "playable" on the earlier ones
But if you have any iOS device that cant support iOs 4.3
No minecraft for you!

and yes, i know that it its because the devices are not powerful enough to support it
yes, im annoyed with the pocket addition because

1. no crafting
2. only creative mode
3. no mobs, but with the data it uses, that isn't gonna happen anytime soon
4. crashes way too often
5. no redstone
6. no way to transport water if you're lucky enough to find it
7.the worlds are way too small
8. i could keep going, but i think you understand.
Posted Image Yeah. Derpy looking sig, huh?