Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

How to install Modloader AND Optifine


  • Please log in to reply
17 replies to this topic

#1

buddahcjcc

Posted 09 November 2011 - 07:46 PM

Im trying to install them both, they both say delete Meta-inf, but when I install modloader (it works afterwords), and delete the META-INF, and then install Optifine, theres no META-INF to delete, and I get the black screen o death

Register or log in to remove.

#2

rexo12(my ingame name)
  • Location: in front of my computer typing this out.
  • Minecraft: rexo12

Posted 09 November 2011 - 07:49 PM

you should only have to delete it once
Posted Image
Free + Crabs + Ability to trample/suffocate opponents in Cortex Command = Free Bombs.

#3

mahognyman

Posted 09 November 2011 - 07:51 PM

You can only delete it once and there might be other mods that are conflicting, why else would you need modloader?
¨http://media.tumblr.com/tumblr_lop4k17SUx1qk3k8x.jpg

#4

Terethien
  • Location: Canada
  • Minecraft: Terethien

Posted 09 November 2011 - 07:56 PM

Once you delete META-INF, you do not need to delete it again.

If those are the only two mods you are using, they should work absolutely fine together as long as you install Modloader and THEN Optifine. The other way around will cause crashes. If Optifine is the only mod other than Modloader you want to use, you don't actually need Modloader.

And remember, if you've used the HD Texture Patcher on your .jar file, you can't use Optifine on it as well. Only one or the other. If you have used it before, it's likely the reason you're getting the black screen.
Posted Image

#5

buddahcjcc

Posted 09 November 2011 - 08:04 PM

Its a clean install. No other mods involved here.
Ok, I install Modloader, Delete META-INF.
Load up Minecraft, it works.

I Install Optifine, theres no META-INF so I dont have to delete it
Load up Minecraft, Black screen of death.

What am I doing wrong here

The main reason Im trying this is (after being on this server a while with no issue) in the middle of a session, the games lagged to less than 1 fps. It cant even take commands at this point. I log out and back in and its a no-go. I log in and immediately hit F3 and its pegged the highest point in white on the graph.

The game eventually goes nonresponsive and dies. I thought it wasthe client, so I deleted it and got a new one, same results. Im getting Optifine to see if it helps with the issue

Hm... doesnt do it in single player, my internet is speed testing at 16 mbps (normal for mine), so its looking to be the server

#6

Mikeysax
    Mikeysax

    Tree Puncher

  • Members
  • 18 posts

Posted 06 December 2011 - 06:57 PM

View Postbuddahcjcc, on 09 November 2011 - 08:04 PM, said:

Its a clean install. No other mods involved here.
Ok, I install Modloader, Delete META-INF.
Load up Minecraft, it works.

I Install Optifine, theres no META-INF so I dont have to delete it
Load up Minecraft, Black screen of death.

What am I doing wrong here

The main reason Im trying this is (after being on this server a while with no issue) in the middle of a session, the games lagged to less than 1 fps. It cant even take commands at this point. I log out and back in and its a no-go. I log in and immediately hit F3 and its pegged the highest point in white on the graph.

The game eventually goes nonresponsive and dies. I thought it wasthe client, so I deleted it and got a new one, same results. Im getting Optifine to see if it helps with the issue

Hm... doesnt do it in single player, my internet is speed testing at 16 mbps (normal for mine), so its looking to be the server

I get a black screen too when I try to instal optifine, I've installed it manually and with mcpatcher but it doesnt seem to work. Says ACR.Class is conflicting when i instal it with mcpatcher.

#7

MSTwaterbug
  • Location: Sappin' your dispenser.
  • Minecraft: MSTwaterbug

Posted 15 May 2012 - 04:28 PM

View PostMikeysax, on 06 December 2011 - 06:57 PM, said:

I get a black screen too when I try to instal optifine, I've installed it manually and with mcpatcher but it doesnt seem to work. Says ACR.Class is conflicting when i instal it with mcpatcher.


Optifine has HD Texture support so it wont work with MCpatcher.
Sure, anyone can smash things into the ground like a hippo.

#8

ohsnap207
  • Minecraft: ohsnap207

Posted 09 June 2012 - 05:59 PM

View PostMSTwaterbug, on 15 May 2012 - 04:28 PM, said:

Optifine has HD Texture support so it wont work with MCpatcher.
It actually doesn't because when I try to use optifine with HD textures it makes some textures have nether portal and fire animations in them. I also need both so I can use 128X128 textures. I've been able to have both before but it no longer works.
<p> <object width="300" height="28" class="hark_player">
<param name="movie" value="

#9

blkjock
    blkjock

    Tree Puncher

  • Members
  • 29 posts

Posted 05 July 2012 - 04:53 AM

http://www.skydaz.co...-minecraft-1-2/ try with this site download the exe and run it

#10

DoomKnight_XD
  • Minecraft: DoomKnight_XD

Posted 09 July 2012 - 08:22 AM

Modloader and optifine conflict (MC patcher told me) i removed the MC patcher HD files to test but it should work because i didnt install the HD files from optifine. anyway it loads up goes black for a sec and then goes white even if i delete the conflicting file. any ideas?

EDIT: ok after some testing even without modloader its crashing and later i eventuly worked out it was crashing because i removed the HD classes from optifine so never mind but optifine conflicts with modloader and removing "vl.class" fixes it!!! hope this helps : )

#11

Elixan
    Elixan

    Out of the Water

  • Members
  • 3 posts

Posted 11 July 2012 - 03:52 PM

View PostDoomKnight_XD, on 09 July 2012 - 08:22 AM, said:

removing "vl.class" fixes it!!!

Came to the same conclusion before finding this thread. WD!

#12

tclementi1

Posted 13 July 2012 - 08:21 PM

hi is it possible to have nodus mod loader and optifine ?

#13

tclementi1

Posted 13 July 2012 - 09:35 PM

[bump]

#14

coreyvelazquez

Posted 20 July 2012 - 05:18 PM

The only mod i have is nodus, and when i go to put optifine in nodus and load mc, i get a black screen, it never did that in previous versions, any help???? pleaseee

#15

shadowriptide

Posted 20 August 2012 - 03:03 AM

use forge instead of modloader it worked 4 me but i need help on what the commands and controls r?

#16

Evenios
    Evenios

    Zombie Killer

  • Members
  • 150 posts
  • Minecraft: Evenios

Posted 06 December 2012 - 07:51 PM

Well i cant get it to work for 1.4.5 apparently Modloader and or forge with Optifine causes a crash. Gosh.

Cant wait till the mod api in 1.5 installing mods in Minecraft honestly is a pain in the butt.  If you ask me the mod api should have came out long ago and the other "fun features' should have been pushed back.  Some mods like optfine and others can work ok but others can be a royal PAIN to get to work right.  :-(

#17

Clockwork161
  • Location: On a Dalek Warship fighting to the death
  • Minecraft: Tree_Puncher9501

Posted 25 April 2013 - 05:59 PM

Im having the same issue. I cant use modloader with optifine, and forge never wants to work when i install it
Posted Image

#18

MaiK00L
    MaiK00L

    Newly Spawned

  • Members
  • 1 posts

Posted 16 July 2013 - 09:15 PM

.....