Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

JAVA Heap size & increase RAM WORKS!!


  • Please log in to reply
15 replies to this topic

#1

streetstar5
  • Location: Harlem, NY

Posted 03 November 2011 - 11:31 AM

im using 1.8.1 minecraft if it matters - i tried everything and this is what worked for me

1) Install the proper version of Java (64/32 bits OS) via java.com

2) Go to control panel -> System -> Advanced System Settings

3) Click Environmental Variables

4) Click New and type:

(EXACTLY everything after the : and Include dashes/underscores etc.)

1st box: _JAVA_OPTIONS

2nd box:  -Xmx1g -Xms1g

5) Click Ok, done

F3 in your game and memory should in top right screen is double!
Changing 1g to 2g or 3g the game wont run saying java has too much memory allocated or reached maxed. Just leave it at 1g and your memory for Java ingame will double. Im playing max settings with optifine and get 90-110 FPS. if you want a screen let me kno
Posted Image

Register or log in to remove.

#2

zerox56
    zerox56

    Diamond Miner

  • Members
  • 755 posts
  • Location: In the anime world :3
  • Minecraft: zerox56

Posted 03 November 2011 - 11:33 AM

Accidenly created a topic instead of replying?

I geuss so since this is the exact thing posted on the other topic
Did my post help? Click the Posted Image on my post. It's 100% optional. Still need me? Plz quote my post then
My Anime Planet

#3

jakobb987
  • Location: Denmark
  • Minecraft: Jill_Hester

Posted 03 November 2011 - 11:35 AM

View Postzerox56, on 03 November 2011 - 11:33 AM, said:

Accidenly created a topic instead of replying?

I geuss so since this is the exact thing posted on the other topic

I think its just to help other people, in need of help.

#4

ToadDude
    ToadDude

    Zombie Killer

  • Members
  • 160 posts
  • Location: 99% Earth, 1% Behind you.
  • Minecraft: ToadDude

Posted 03 November 2011 - 11:35 AM

Can someone confirm this?

View PostShannillaJackson, on 16 September 2011 - 08:01 PM, said:

why -101, my grammer not dat bad

#5

kheatsopon
  • Location: |Not This Time Stalker|
  • Minecraft: BigBlueDeadDots

Posted 03 November 2011 - 11:35 AM

Thx For Telling :)

#6

jakobb987
  • Location: Denmark
  • Minecraft: Jill_Hester

Posted 03 November 2011 - 11:40 AM

View PostToadDude, on 03 November 2011 - 11:35 AM, said:

Can someone confirm this?

Confirmed, it's almost the same as windows.

The weird:

-Xmx1g -Xms1g

are commands, the dash is like a slash in other programs, for example minecraft you would use
/kill
to die, and the slash shows its a command, not just chat.
The Xmx1g and Xms1g means how much ram is used, 1g being 1 gigabyte. Not completely sure what Xmx and Xms is though.

#7

minepro97
  • Location: Australia
  • Minecraft: minepro97

Posted 03 November 2011 - 11:46 AM

View Poststreetstar5, on 03 November 2011 - 11:31 AM, said:


2nd box:  -Xmx1g -Xms1g


Holy Crap! 1 Gigabyte! You do realise that the less memory allocated the faster the game runs!!! (to a certain point) Depending on your RAM there is a "magic number" in which minecraft runs fastest. This is usually VERY low. For example on most computers (about 4GB RAM or less) 256MB should do the trick. If you have 8GB RAM (like most modern computers) then  350-512MB should be fastest.

Also, this is a much harder way of changing the amount and it MAY also affect anything else that runs on Java. For the easiest way make a custom launcher. This page  should also help A LOT with speeding up minecraft performance.

Edited by minepro97, 03 November 2011 - 11:52 AM.


#8

streetstar5
  • Location: Harlem, NY

Posted 03 November 2011 - 02:46 PM

View Postminepro97, on 03 November 2011 - 11:46 AM, said:

Holy Crap! 1 Gigabyte! You do realise that the less memory allocated the faster the game runs!!! (to a certain point) Depending on your RAM there is a "magic number" in which minecraft runs fastest. This is usually VERY low. For example on most computers (about 4GB RAM or less) 256MB should do the trick. If you have 8GB RAM (like most modern computers) then  350-512MB should be fastest.

Also, this is a much harder way of changing the amount and it MAY also affect anything else that runs on Java. For the easiest way make a custom launcher. This page  should also help A LOT with speeding up minecraft performance.


umm actually it increased my fps for 45 fps so i dont understand...minecraft works faster with less mem allocated? yet many ppl included myself ran out of memory and get memory crashes. i have 8 gig ram 64 bit win 7 geforce 9800 gtx...theres no way minecraft should be giving me ANY problems. doing this helped and i have 0 crashes since and no lag and an extra 45+ fps...so whatever

I have 8 gig so putting it at 512mb (which it is at default) i would still have the same problems. let people try it 1st then see if the problem persist. I bet my method will help anyone running into memory crashes.
Posted Image

#9

tharglet
    tharglet

    Lapis Lazuli Collector

  • Members
  • 929 posts
  • Minecraft: tharglet

Posted 03 November 2011 - 02:53 PM

Xms = initial memory allocation
Xmx = maximum memory allocation


View Postminepro97, on 03 November 2011 - 11:46 AM, said:

256MB should do the trick. If you have 8GB RAM (like most modern computers) then  350-512MB should be fastest.
Or... if you're using a reasonable-sized texture pack, and travel around your world a lot, then you need a much bigger memory allocation :P.
I have an initial 1GB allocation, with a max of 2GB, don't notice any significant performance difference tbh, other than the fact I never get it running out of memory any more.
Posted Image
Here there be dragons. Please click to help it grow :) (If it's in fog, it's unwell and not in need of clicks)

#10

Painsucker
  • Location: Stealing your Nutella.
  • Minecraft: Psych0pus

Posted 03 November 2011 - 03:18 PM

Can anyone Confirm this on Vista?
Vista is crap.

You have somethin̸̸̸̸̸̸̸̸̨̨̨̨g on your screen.


#11

Painsucker
  • Location: Stealing your Nutella.
  • Minecraft: Psych0pus

Posted 03 November 2011 - 03:25 PM

Edit: For me it comes up with "Could not create Java Virtual machine"

You have somethin̸̸̸̸̸̸̸̸̨̨̨̨g on your screen.


#12

expend
    expend

    Diamond Miner

  • Members
  • 880 posts
  • Location: Under your bedrock.

Posted 03 November 2011 - 04:12 PM

View Postminepro97, on 03 November 2011 - 11:46 AM, said:

Holy Crap! 1 Gigabyte! You do realise that the less memory allocated the faster the game runs!!! (to a certain point) Depending on your RAM there is a "magic number" in which minecraft runs fastest. This is usually VERY low. For example on most computers (about 4GB RAM or less) 256MB should do the trick. If you have 8GB RAM (like most modern computers) then  350-512MB should be fastest.

Also, this is a much harder way of changing the amount and it MAY also affect anything else that runs on Java. For the easiest way make a custom launcher. This page  should also help A LOT with speeding up minecraft performance.

In what universe does this happen?
Toss creeper, run away.

#13

streetstar5
  • Location: Harlem, NY

Posted 04 November 2011 - 04:59 AM

View PostPainsucker, on 03 November 2011 - 03:25 PM, said:

Edit: For me it comes up with "Could not create Java Virtual machine"

im on win 7 so it should work..try the bat file method..OR

Create a Shortcut to fix Minecraft from crashing due to SE Binary Crash or Out of memory Crash

Step 1.
First find where you Java is located something like C:\Program Files\Java\jre6\bin\javaw.exe or C:\Program Files (x86)\Java\jre6\bin\javaw.exe

Step 2.
Paste in all the info into the short cut with your customized settings.

Step 3.
Replace Icon to look like Minecraft logo again.

Template:
"C:\Program Files\Java\jre6\bin\javaw.exe" -Xmx2048M -Xms2048M -jar "C:\Users\username\Desktop\Minecraft.exe"



If you get:

Unable to Create Java Virtual Machine

This is may be because you are trying to allocate more ram to Minecraft then your computer an handle. Or because you are running 32bit Java on a 64bit Machine.

Solutions to this:

Try less ram in the target example:

-Xmx2048M -Xms2048M or -Xmx1536M -Xms1536M

Uninstall 32bit Java and Install 64bit Java (for 64bit Operating systems only!)

Remember for 64bit Java you need both 32 & 64 bit. I think 64bit installs 32bit of Java upon installatioin. double check to make sure or just install both.
Posted Image

#14

minepro97
  • Location: Australia
  • Minecraft: minepro97

Posted 04 November 2011 - 11:01 PM

View Postexpend, on 03 November 2011 - 04:12 PM, said:

In what universe does this happen?

Again depending on what you are doing in game and your computers performance this varies a lot. I get MUCH, MUCH faster FPS with less memory on my dinosaur computer, however I do get memory crashes more often.

#15

under7dude

Posted 10 June 2012 - 05:41 AM

It dosn't work for me. It just says
"Error: Could not create the java virtual Machine
Error: A fatal exception has occoured. Program will exit."
Does it matter that im running on windows 7(32-bit)?

#16

Opposing Forces
  • Location: in your nether realm..
  • Minecraft: OpposingForces

Posted 03 July 2012 - 11:23 PM

works good. its nice since i have multiple minecraft installs and the bat file method only works on the exe.
Never dig straight down.
Posted Image