Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[V1.6.2] Risugami's Mods - Updated.


  • Please log in to reply
31850 replies to this topic

#28321

xXTerra_BranfordXx

Posted 29 November 2012 - 07:56 AM

View Postdavodiaz, on 29 November 2012 - 05:17 AM, said:

Minecraft has crashed!   
  ----------------------   

Minecraft has stopped running because it encountered a problem; Unexpected error

A full error report has been saved to /Users/jorgeandresdiaz/Library/Application Support/minecraft/crash-reports/crash-2012-11-28_21.37.58-client.txt - Please include a copy of that file (Not this screen!) if you report this crash to anyone; without it, they will not be able to help fix the crash Posted Image

Spoiler:

I was trying to use the Recipe Book and it just crashed
There's an ongoing issue between the Recipe Book mod and TMI, causing them both to start freaking out, and crash the client.

You'll likely have to choose between using TMI, or using Recipe Book. I don't know if anyone ever found a simple solution to stop the crashing, Sorry.

The only "solution" I've seen posted was to "try changing the ID number for the Recipe Book in the config"... but that was to solve the conflict between TMI and Recipe Book making all the heads look wrong.

Want Some Colored Glass for [1.6.4]?

Posted Image

Want to see my YouTube videos?


Register or log in to remove.

#28322

DarkStormDragon
  • Location: X: -256, Y:40, Z: 1024
  • Minecraft: DragonGilbert
  • Xbox:DarkDForce

Posted 29 November 2012 - 09:25 AM

View PostYutfgh, on 28 November 2012 - 05:38 AM, said:

Hey, the answer to this may already exist on one of the 1416 pages but, If I have another mod installed that edits world generation (either with structures or blocks etc) will they still spawn in the biospheres?
Thanks for your help.

No as of yet not buildings generate in the Biospheres you have to manually create the NPC villages and other buildings

Posted Image


#28323

Blaidd42
    Blaidd42

    Out of the Water

  • Members
  • 5 posts

Posted 29 November 2012 - 12:53 PM

Hi I have the ever popular black screen problem that i'm seeing a lot of in my search through the topic.
I've followed the instructions, applied the files with and without MCtexture patcher and deleted meta inf in the latter case.
I used the batch file for error reporting found earlier in the thread and got the following:
===Simple Minecraft Error Test===
Starting Minecraft...
MCPatcherUtils v2.4.3_04 initialized. Directory C:\Users\Gruffudd\AppData\Roamin
g\.minecraft
Exception in thread "main" java.lang.IncompatibleClassChangeError: Implementing
class
		at java.lang.ClassLoader.defineClass1(Native Method)
		at java.lang.ClassLoader.defineClassCond(Unknown Source)
		at java.lang.ClassLoader.defineClass(Unknown Source)
		at java.security.SecureClassLoader.defineClass(Unknown Source)
		at java.net.URLClassLoader.defineClass(Unknown Source)
		at java.net.URLClassLoader.access$000(Unknown Source)
		at java.net.URLClassLoader$1.run(Unknown Source)
		at java.security.AccessController.doPrivileged(Native Method)
		at java.net.URLClassLoader.findClass(Unknown Source)
		at java.lang.ClassLoader.loadClass(Unknown Source)
		at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
		at java.lang.ClassLoader.loadClass(Unknown Source)
		at amj.<clinit>(SourceFile:219)
		at bdb.<init>(SourceFile:14)
		at net.minecraft.client.Minecraft.<init>(SourceFile:126)
		at asi.<init>(SourceFile:36)
		at net.minecraft.client.MinecraftApplet.init(SourceFile:36)
		at net.minecraft.client.Minecraft.main(SourceFile:1670)
I've also tried the other OS minecraft option, and checked my java is up to date and has enough allocated memory.
Any ideas?
[url="http://www.minecraft...000-downloads/"][img]http://dl.dropbox.com/u/39169658/Pixelmon/Banners/pixelmon-charmander.png[/img][/url]

#28324

Dweller_Benthos
  • Minecraft: Dweller_Benthos

Posted 29 November 2012 - 12:56 PM

View PostBlaidd42, on 29 November 2012 - 12:53 PM, said:

Hi I have the ever popular black screen problem that i'm seeing a lot of in my search through the topic.
I've followed the instructions, applied the files with and without MCtexture patcher and deleted meta inf in the latter case.
I used the batch file for error reporting found earlier in the thread and got the following:
===Simple Minecraft Error Test===
Starting Minecraft...
MCPatcherUtils v2.4.3_04 initialized. Directory C:\Users\Gruffudd\AppData\Roamin
g\.minecraft
Exception in thread "main" java.lang.IncompatibleClassChangeError: Implementing
class
	 at java.lang.ClassLoader.defineClass1(Native Method)
	 at java.lang.ClassLoader.defineClassCond(Unknown Source)
	 at java.lang.ClassLoader.defineClass(Unknown Source)
	 at java.security.SecureClassLoader.defineClass(Unknown Source)
	 at java.net.URLClassLoader.defineClass(Unknown Source)
	 at java.net.URLClassLoader.access$000(Unknown Source)
	 at java.net.URLClassLoader$1.run(Unknown Source)
	 at java.security.AccessController.doPrivileged(Native Method)
	 at java.net.URLClassLoader.findClass(Unknown Source)
	 at java.lang.ClassLoader.loadClass(Unknown Source)
	 at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	 at java.lang.ClassLoader.loadClass(Unknown Source)
	 at amj.<clinit>(SourceFile:219)
	 at bdb.<init>(SourceFile:14)
	 at net.minecraft.client.Minecraft.<init>(SourceFile:126)
	 at asi.<init>(SourceFile:36)
	 at net.minecraft.client.MinecraftApplet.init(SourceFile:36)
	 at net.minecraft.client.Minecraft.main(SourceFile:1670)
I've also tried the other OS minecraft option, and checked my java is up to date and has enough allocated memory.
Any ideas?

Can't really tell from that error report, is there a modloader.txt in your minecraft folder? Post that. Or, use one of these and see if you get a different report:


http://dl.dropbox.co...fterrortest.bat
or this
http://www.minecraft...minecrafterror/

The second one is a bit easier to use and will run on any system.
D_B
To tell them how to live is to prevent them living.

#28325

Blaidd42
    Blaidd42

    Out of the Water

  • Members
  • 5 posts

Posted 29 November 2012 - 01:17 PM

The first link was what i used to get my original post.
The second produces:
Checking for Minecraft launcher (minecrafterr.jar) in C:\Users\Gruffudd\AppData\Roaming\.minecraft\minecrafterr.jar
Error: Could not find launcher!
Downloading from Minecraft.net...
Download failed...
Download successful!
Minecraft launcher found!
Starting launcher...
-------------Contents of mods folder:-------------
1.4.5/ModLoader.zip
--------------------------------------------------
Error: Could not find or load main class net.minecraft.LauncherFrame
Error report complete.
Here's my guess as to what went wrong:
Hm, I can't seem to figure it out. If your client failed to load press Paste Error and show that link to #Risucraft on esper.net
I've tried 'paste error' and 'paste modloader.txt' but neither produce a link nor a file i can find even after giving it several minutes
[url="http://www.minecraft...000-downloads/"][img]http://dl.dropbox.com/u/39169658/Pixelmon/Banners/pixelmon-charmander.png[/img][/url]

#28326

Dweller_Benthos
  • Minecraft: Dweller_Benthos

Posted 29 November 2012 - 01:23 PM

View PostBlaidd42, on 29 November 2012 - 01:17 PM, said:

The first link was what i used to get my original post.
The second produces:
Checking for Minecraft launcher (minecrafterr.jar) in C:\Users\Gruffudd\AppData\Roaming\.minecraft\minecrafterr.jar
Error: Could not find launcher!
Downloading from Minecraft.net...
Download failed...
Download successful!
Minecraft launcher found!
Starting launcher...
-------------Contents of mods folder:-------------
1.4.5/ModLoader.zip
--------------------------------------------------
Error: Could not find or load main class net.minecraft.LauncherFrame
Error report complete.
Here's my guess as to what went wrong:
Hm, I can't seem to figure it out. If your client failed to load press Paste Error and show that link to #Risucraft on esper.net
I've tried 'paste error' and 'paste modloader.txt' but neither produce a link nor a file i can find even after giving it several minutes

Well, it looks like you have a folder in your mods folder called 1.4.5 and in that is modloader.zip, which is incorrect. Delete everything in your mods folder, run minecraft and do a force update to get a clean jar, then use MC Patcher to install mods, be sure modloader is at the top of the list. If you don't want the patcher mods (for high res graphics and such) just uncheck those items in the list. There's a video in the patcher thread describing how to add mods with it.

Be sure also, you use the most recent version of the Minecraft error reporter, which is v31. When you hit the paste error button, the info display will show you a link at the very bottom like this:

http://pastebin.com/7bSZiXcD

You may have to scroll the window down to see it.
D_B
To tell them how to live is to prevent them living.

#28327

Blaidd42
    Blaidd42

    Out of the Water

  • Members
  • 5 posts

Posted 29 November 2012 - 01:36 PM

Cleared bin folder > forced update > MCPatcher patched with modloader and HDtextures, with modloader at the top of the list. > opened minecraft launcher, clicked login > black screen.

However one odity i have noticed since you mention minecraft.jar, is there is a minecraft.jar and a minecraft-1.4.5.jar both in the bin folder.
[url="http://www.minecraft...000-downloads/"][img]http://dl.dropbox.com/u/39169658/Pixelmon/Banners/pixelmon-charmander.png[/img][/url]

#28328

yardenma7

Posted 29 November 2012 - 02:37 PM

i want to downaldo a mod that is 1.4.2 how do i get a 1.4.2 modloader i didnt find it in the old veriosn please help

#28329

Blaidd42
    Blaidd42

    Out of the Water

  • Members
  • 5 posts

Posted 29 November 2012 - 04:21 PM

View PostDweller_Benthos, on 29 November 2012 - 01:23 PM, said:

Well, it looks like you have a folder in your mods folder called 1.4.5 and in that is modloader.zip, which is incorrect. Delete everything in your mods folder, run minecraft and do a force update to get a clean jar, then use MC Patcher to install mods, be sure modloader is at the top of the list. If you don't want the patcher mods (for high res graphics and such) just uncheck those items in the list. There's a video in the patcher thread describing how to add mods with it.

Be sure also, you use the most recent version of the Minecraft error reporter, which is v31. When you hit the paste error button, the info display will show you a link at the very bottom like this:

http://pastebin.com/7bSZiXcD

You may have to scroll the window down to see it.

View PostBlaidd42, on 29 November 2012 - 01:36 PM, said:

Cleared bin folder > forced update > MCPatcher patched with modloader and HDtextures, with modloader at the top of the list. > opened minecraft launcher, clicked login > black screen.

However one odity i have noticed since you mention minecraft.jar, is there is a minecraft.jar and a minecraft-1.4.5.jar both in the bin folder.
Ok, I removed the 1.4.5 folder when i did the previous posted (which was created by the modloader btw) I also removed the modloader file from the mods folder and pointed MC patcher to the file in my downloads instead. exactly as shown in the mcpatcher video. And black screen again.
I am definitly using the error reported V31, but it continues to be unable to find the minecraft launcher, mainly it seems because it's looking for a minecrafterr.jar which doesn't exist.

just in case it helps, here's the latest from the batch file error reporter from this attempt:
===Simple Minecraft Error Test===
Starting Minecraft...
Exception in thread "main" java.lang.NoSuchFieldError: b
		at ame.<init>(SourceFile:11)
		at amj.<clinit>(SourceFile:158)
		at bdb.<init>(SourceFile:14)
		at net.minecraft.client.Minecraft.<init>(SourceFile:126)
		at asi.<init>(SourceFile:36)
		at net.minecraft.client.MinecraftApplet.init(SourceFile:36)
		at net.minecraft.client.Minecraft.main(SourceFile:1670)

[url="http://www.minecraft...000-downloads/"][img]http://dl.dropbox.com/u/39169658/Pixelmon/Banners/pixelmon-charmander.png[/img][/url]

#28330

Blaidd42
    Blaidd42

    Out of the Water

  • Members
  • 5 posts

Posted 29 November 2012 - 04:55 PM

FIXED!
something had buggered up in the download file, redownloaded the modloader file and it works fine now :)
Thanks for the help anyway Dweller.
[url="http://www.minecraft...000-downloads/"][img]http://dl.dropbox.com/u/39169658/Pixelmon/Banners/pixelmon-charmander.png[/img][/url]

#28331

debabthecat

Posted 29 November 2012 - 05:06 PM

I have your recipe book mod. the first time i open it it works fine but the second time i open it my minecraft crashes. i have forge,gravity gun, balkon´s weapon mod, TMI. optifine, rei´s minimap, more explosives, modloader and then recipe book. is recipe book not compatible with one of these mods?

#28332

justDiar

Posted 29 November 2012 - 06:37 PM

I downloaded ModLoader along with Lan Bukkit, and now I'm getting a black screen when I try to play Minecraft. It crashed the first time, and said it was because of ModLoader. I put "_mod" in the main file and I'm unsure what to do. Are there any error messages I should give you, and where can I find them?

#28333

xXTerra_BranfordXx

Posted 29 November 2012 - 06:51 PM

View Postdebabthecat, on 29 November 2012 - 05:06 PM, said:

I have your recipe book mod. the first time i open it it works fine but the second time i open it my minecraft crashes. i have forge,gravity gun, balkon´s weapon mod, TMI. optifine, rei´s minimap, more explosives, modloader and then recipe book. is recipe book not compatible with one of these mods?
This is covered a little more in-depth on the previous page, but the TL;DR version is: "TMI and Recipe Book don't work together. Choose one, or the other.".

Want Some Colored Glass for [1.6.4]?

Posted Image

Want to see my YouTube videos?


#28334

justDiar

Posted 29 November 2012 - 07:40 PM

View PostxXTerra_BranfordXx, on 29 November 2012 - 06:51 PM, said:

This is covered a little more in-depth on the previous page, but the TL;DR version is: "TMI and Recipe Book don't work together. Choose one, or the other.".
Would It be possible for you to help me, please?

#28335

xXTerra_BranfordXx

Posted 29 November 2012 - 07:52 PM

View PostKRaidium, on 29 November 2012 - 07:40 PM, said:

Would It be possible for you to help me, please?
Well... I don't think it's possible to help with this issue. TMI and Recipe Book conflict with each other, for as yet, unknown reasons. As I'm not Risugami, I can't tell you what aspects of the configuration need/can be changed, to resolve the conflicting IDs, nor can I make a patch for you. I'm not a modder... I just remind people of content that was previously posted... be that actual solutions, or relaying bad news about mod conflicts.

Sorry. If it came down to it, I'd say keep TMI, and don't use Recipe Book. If you honestly can't ~live~ without Recipe Book, you might try gambling with using VoxelGet (requires Liteloader, which DOES work along-side ModLoader), instead... since it gives you a similar inventory interface as TMI. However, as I never used Recipe Book in the first place, I can't tell you if it'll work.

Edit: Actually... scratch the idea of using VoxelGet, instead of TMI. VoxelGet, while it will give you the complete item compendium, and let you give yourself all the items you want... it doesn't give you Enchantments, and doesn't feature all the extras that TMI has.

So now you're left with the choice of either using TMI, or using Recipe Book. But not both.

Want Some Colored Glass for [1.6.4]?

Posted Image

Want to see my YouTube videos?


#28336

justDiar

Posted 29 November 2012 - 08:15 PM

View PostxXTerra_BranfordXx, on 29 November 2012 - 07:52 PM, said:

Well... I don't think it's possible to help with this issue. TMI and Recipe Book conflict with each other, for as yet, unknown reasons. As I'm not Risugami, I can't tell you what aspects of the configuration need/can be changed, to resolve the conflicting IDs, nor can I make a patch for you. I'm not a modder... I just remind people of content that was previously posted... be that actual solutions, or relaying bad news about mod conflicts.

Sorry. If it came down to it, I'd say keep TMI, and don't use Recipe Book. If you honestly can't ~live~ without Recipe Book, you might try gambling with using VoxelGet (requires Liteloader, which DOES work along-side ModLoader), instead... since it gives you a similar inventory interface as TMI. However, as I never used Recipe Book in the first place, I can't tell you if it'll work.

Edit: Actually... scratch the idea of using VoxelGet, instead of TMI. VoxelGet, while it will give you the complete item compendium, and let you give yourself all the items you want... it doesn't give you Enchantments, and doesn't feature all the extras that TMI has.

So now you're left with the choice of either using TMI, or using Recipe Book. But not both.
Em... actually, my problem was this.

Quote

I downloaded ModLoader along with Lan Bukkit, and now I'm getting a black screen when I try to play Minecraft. It crashed the first time, and said it was because of ModLoader. I put "_mod" in the main file and I'm unsure what to do. Are there any error messages I should give you, and where can I find them?


#28337

LoRaM100
    LoRaM100

    Glowstone Miner

  • Members
  • 3482 posts
  • Location: Citizen of the world. We all share this one orb, let's take good care of it.

Posted 29 November 2012 - 08:17 PM

View PostKRaidium, on 29 November 2012 - 07:40 PM, said:

Would It be possible for you to help me, please?

View PostxXTerra_BranfordXx, on 29 November 2012 - 07:52 PM, said:

Well... I don't think it's possible to help with this issue. TMI and Recipe Book conflict with each other, for as yet, unknown reasons. As I'm not Risugami, I can't tell you what aspects of the configuration need/can be changed, to resolve the conflicting IDs, nor can I make a patch for you. I'm not a modder... I just remind people of content that was previously posted... be that actual solutions, or relaying bad news about mod conflicts.

Sorry. If it came down to it, I'd say keep TMI, and don't use Recipe Book. If you honestly can't ~live~ without Recipe Book, you might try gambling with using VoxelGet (requires Liteloader, which DOES work along-side ModLoader), instead... since it gives you a similar inventory interface as TMI. However, as I never used Recipe Book in the first place, I can't tell you if it'll work.

Edit: Actually... scratch the idea of using VoxelGet, instead of TMI. VoxelGet, while it will give you the complete item compendium, and let you give yourself all the items you want... it doesn't give you Enchantments, and doesn't feature all the extras that TMI has.

So now you're left with the choice of either using TMI, or using Recipe Book. But not both.
Apologies to Risu;
Have you seen the CraftGuide Mod?
Posted Image

#28338

xXTerra_BranfordXx

Posted 29 November 2012 - 08:32 PM

View PostKRaidium, on 29 November 2012 - 08:15 PM, said:

Em... actually, my problem was this.

<snip>

Ah. I've never used Lan Bukkit... this is actually only the second time I'm hearing about it. So I honestly couldn't tell you what's going wrong here.

And to be fair, the quote you used to ask for help, directly asked about making TMI and Recipe Mods work... hence the confusion.

View PostLoRaM100, on 29 November 2012 - 08:17 PM, said:

Apologies to Risu;
Have you seen the CraftGuide Mod?
*Apologizes to Risu*

Want Some Colored Glass for [1.6.4]?

Posted Image

Want to see my YouTube videos?


#28339

Graxwell
    Graxwell

    Out of the Water

  • Members
  • 9 posts

Posted 29 November 2012 - 08:35 PM

Help! I want to download modloader for 1.3.2 but I don't know what to click. in the "old versions" it doesent tell me wich version is for wich minecraft
  Help my pokemon!


                                                          Posted Image

#28340

xXTerra_BranfordXx

Posted 29 November 2012 - 08:44 PM

View PostGraxwell, on 29 November 2012 - 08:35 PM, said:

Help! I want to download modloader for 1.3.2 but I don't know what to click. in the "old versions" it doesent tell me wich version is for wich minecraft
Been a while since I've posted this, so, enjoy:
http://www.mediafire...6je53ynzap5a6t1

Though, for future reference, you can find pretty much ~every~ version of ModLoader by using this link form:
http://dl.dropbox.com/u/20629262/#.#.#/modloader.zip

You'll want to, of course, replace the #.#.# with the correct version of modloader you desire.

Want Some Colored Glass for [1.6.4]?

Posted Image

Want to see my YouTube videos?