Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Minecraft makes my computer overheat.


  • Please log in to reply
10 replies to this topic

#1

azeo
    azeo

    Out of the Water

  • Members
  • 6 posts

Posted 11 February 2010 - 10:36 PM

I can run mass effect, dragon age, crysis, stalker, bioshock and tons of other games fine. But when I ever I play minecraft for a significant amount of time, it causes my computer to over heat, whether or not I'm running a server. I'm getting sick of setting my laptop on top of books to keep it cool, any ideas for some way to fix this? As I said, it only happens when I'm playing minecraft.

Register or log in to remove.

#2

Varriount

Posted 12 February 2010 - 03:09 AM

Well, the overheating may be becouse minecraft is cpu and proccesor intensive, and performance fan vary wildly from cpu to cpu, and graphics card to graphics card. All I can say is to find a fan utilty ( PSU maybe?) and use it.
Remember that even old echoes can create new harmonies.
Who sits down and writes maniacle laughter?

#3

Razorlance
  • Location: UK

Posted 19 February 2010 - 01:14 PM

You can buy, or even make a laptop stand with built on fans to help cool it. Try a search for laptop cooling stand, seen them for around £20-25 here in th UK. A handbuilt one I've seen was a sheet of plexiglass with one edge bent to 90 degrees to form a slanted stand, with extra holes drilled into it to let the air through where the laptop venting was, then a standard PC case fan screwed to it underneath over the holes and the wires soldered (correctly) into a USB plug which you plugged into the laptop.
Posted Image

#4

Zuriki
    Zuriki

    Forum/Wiki Sponsor

  • Curse Premium
  • 5317 posts
  • Location: The Netherlands
  • Minecraft: gdscei

Posted 19 February 2010 - 02:59 PM

Download RivaTuner and stick your GPU fan on 90%
Download CPU-Z and GPU-Z to track your heat profiles whilst running Minecraft, if either one overheats then you probably need a new one

I have no idea how to mess with Intel fans.

#5

Varriount

Posted 19 February 2010 - 07:46 PM

For intel fans, go to pcworld and download speedfan, it can let you change the speed of the various fans in your computer.
Remember that even old echoes can create new harmonies.
Who sits down and writes maniacle laughter?

#6

Snowman
    Snowman

    Forum/Wiki Sponsor

  • Members
  • 2404 posts
  • Location: Antarctica

Posted 20 February 2010 - 10:58 AM

Press escape, go to options, make sure limit framerate is ON.
Posted Image

#7

TingoTheMiner

Posted 22 October 2010 - 09:04 PM

Snowman, thank you very much for your advice. I can confirm that turning the frame limiter on will actually decrease the temp your machine runs at.

My laptop was running at 72 degrees (centigrade!), after turning limiter on, it drops to about 57. Much better!

Adjusting fan speed is useless, mine were already maxed out and still really hot.

Thanks again Snowman buddy (lucky you weren't living in my laptop or you wouldve melted :iapprove: )

#8

Amarinth

Posted 22 October 2010 - 09:38 PM

Snowman said:

Press escape, go to options, make sure limit framerate is ON.

This is sooooo important, especially when running lower end games on higher end rigs.

It won't happen with all games and all hardware, but sometimes if you run an old game on a fast new computer the graphics card may go totally nuts and try to render a ridiculously high amount of framerates per second (like 200+ fps) and this can actually end up putting more strain on the graphics card than running a brandnew high-end game at  just 40-60 fps would!

"Limit framerate / sync to refresh / vsync"  is best turned on in these cases, as they'll all limit the framerates to either a set value or to your monitor's refresh rate (usually 60). If there's no ingame setting available for it in the game you're playing and assuming you have an ati/nvidia graphics card, then you can usually go into the settings panel for your graphics card (catalyst control center for ati and nvidia control panel for nvidia) and tell it to "force Vsync on" in that particular game.

Limit framerate was one of the first things I turned on as well in Minecraft as my graphics card fan was making a lot more noise than it should in a game like this. xD

#9

alterbridge

Posted 23 October 2010 - 10:09 PM

sorry to bump the topic, but I thought it might be worth mentioning to people who used the search and are looking at the topic:

Turning on limit framerate DOES work.. but for me, when I went fullscreen (even after turning limit framerate on) my computer overheated still.

But before I turned limit framerate on, my computer was reaching up to 91C, absolutely craziness!

Anyway, thanks Snowman for making things cooler! :(

#10

My_Fat_Dogz

Posted 18 December 2010 - 06:51 AM

Snowman said:

Press escape, go to options, make sure limit framerate is ON.
Thank you!

#11

DuoProd
    DuoProd

    Out of the Water

  • Members
  • 4 posts

Posted 15 May 2012 - 07:17 PM

This may be a stupid question but how do you put limit framerate on? :)