Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Damn HP double graphics cards...


  • Please log in to reply
12 replies to this topic

#1

S3l33ngrab
  • Minecraft: S3l33ngrab

Posted 10 August 2011 - 06:50 PM

Hi,

Some days ago, i've bought a brandnew HP Pavilion dv7 6101eg. It runs wonderful.
But it has some probs with minecraft: It gives me the Bad video card drivers error, when i try to launch it. And yes, my drivers are updated.
Built in are two cards: a ATI Radeon HD 6770 and a Intel ® HD Graphics. The intel is used for lower graphics, the ATI for better ones such as 3D-Games.
It looks like the automatic change between the two cards doesn't work correctly with Java, although i've changed the usage for Java from 'Low' to 'High'.
That means that my Laptop should use the better graphics card for anyting that has to do with Java. But, for some reason, it doesn't work.
All the drivers are installed correctly and are up to date.

I hope you can help mer or have some suggestions.
Oh Lord, I see stupid people! D:

Register or log in to remove.

#2

FireFtw
    FireFtw

    Redstone Miner

  • Members
  • 661 posts
  • Location: USA
  • Minecraft: FireFtw

Posted 10 August 2011 - 06:53 PM

Just disable the integrated graphics card, the Radeon will always preform better. I think you can disable it from the BIOS, if not just google it.

#3

S3l33ngrab
  • Minecraft: S3l33ngrab

Posted 11 August 2011 - 10:58 AM

I haven't found anything in the BIOS, and a 2 hour Google search didn't help me... Any other suggestions?
Oh Lord, I see stupid people! D:

#4

_j03_
    _j03_

    Ghast Hunter

  • Members
  • 2843 posts
  • Location: Finland

Posted 11 August 2011 - 12:10 PM

View PostS3l33ngrab, on 11 August 2011 - 10:58 AM, said:

I haven't found anything in the BIOS, and a 2 hour Google search didn't help me... Any other suggestions?
Googled the name of that laptop, first link, and there you have it...

Quote

For graphics switching to work at its best, the driver should be kept up-to-date. Unfortunately the dv7-6101eg did not reliably recognise every game we played, so at times we had to manually intervene and select the appropriate graphics card in the Catalyst Control Center.

Right click on your desktop, go to the catalyst center, select java and set it to use the dedicated gpu. It isn't that hard if you bother to search a little bit more...

#5

HonestFlames
  • Minecraft: HonestFlames

Posted 11 August 2011 - 05:06 PM

Instead of changing the profile for "java.exe", change it for "javaw.exe"

That, or seriously just go and disable the on-board Intel rubbish.

#6

Gringo_Starr

Posted 11 August 2011 - 05:14 PM

I wouldn't disable the Intel GOU entirely, it's there for a reason - to save power when all you're doing is surfing the web etc.

Lots of people have had this issue with Minecraft on multi-GPU laptops though - try searching the support section if you're still having no luck.

View PostPhoinex567, on 19 March 2012 - 01:45 PM, said:

Hm I Want To Make A Endless age like minecraft But I Want it to be diffrent I'm thinking And I know It's gonna Have Something from like A diffrent game But Kinda Has Like Other Stuff Completely Diffrent I Got To think.

#7

S3l33ngrab
  • Minecraft: S3l33ngrab

Posted 12 August 2011 - 09:13 AM

thx for the suggestions!

Just to say: I've changed the graphics card for ALL the items in the java folder. Also for javaw.exe and javasw.exe
And i couldn't find a way to disable the intel card, so i don't search further for one.

-s3l33ngrab
Oh Lord, I see stupid people! D:

#8

S3l33ngrab
  • Minecraft: S3l33ngrab

Posted 12 August 2011 - 06:54 PM

For some reason, it works now! Thanks for all the suggestions!
Oh Lord, I see stupid people! D:

#9

VergilPrime
  • Minecraft: VergilPrime

Posted 18 June 2012 - 05:19 PM

If this is STILL a problem for anyone, this is relevant.



#10

Radioaktiivinen
  • Location: Here

Posted 18 June 2012 - 05:35 PM

You could also try downloading 64 bit java if youre using 32 bit but could use 64 bit
*Insert fun quote*

*Insert random links*

*Insert bar saying that minecraft was bought googolplexian times*

#11

ConservativeParty

Posted 18 June 2012 - 06:03 PM

Put it on the good GPU manually?  I have a dv7 too (2010 model) and that's what I do.
The Commies count their quarters and the ArtSci wish they could, the Engs have the longest pole and slam it home for good, so big, so hard, so tall, it reaches all the way to heaven, so shut your hole, we climbed the pole, we're sci 1 ­ing 7!!!

#12

Razorne
    Razorne

    Zombie Killer

  • Members
  • 225 posts
  • Location: The Netherlands
  • Minecraft: Numilex

Posted 18 June 2012 - 08:52 PM

View PostRadioaktiivinen, on 18 June 2012 - 05:35 PM, said:

You could also try downloading 64 bit java if youre using 32 bit but could use 64 bit

What? Posted Image
People go into I.T expecting having to fix computers, but instead they have to deal with the people.

#13

cookiesui
  • Minecraft: cookiesui

Posted 18 June 2012 - 09:47 PM

View PostS3l33ngrab, on 10 August 2011 - 06:50 PM, said:

Hi,

Some days ago, i've bought a brandnew HP Pavilion dv7 6101eg. It runs wonderful.
But it has some probs with minecraft: It gives me the Bad video card drivers error, when i try to launch it. And yes, my drivers are updated.
Built in are two cards: a ATI Radeon HD 6770 and a Intel ® HD Graphics. The intel is used for lower graphics, the ATI for better ones such as 3D-Games.
It looks like the automatic change between the two cards doesn't work correctly with Java, although i've changed the usage for Java from 'Low' to 'High'.
That means that my Laptop should use the better graphics card for anyting that has to do with Java. But, for some reason, it doesn't work.
All the drivers are installed correctly and are up to date.

I hope you can help mer or have some suggestions.
You must go into your BIOS (spam Esc or Del or the F# keys when you see the HP logo at start-up), find the option labeled "Switchable Graphics", or something like that, and then set it to "Fixed Mode", and not "Dynamic Mode".

Then reboot, right-click on your desktop, and click the option about switchable graphics.
Posted Image

Then select "High-Performance GPU".
Posted Image

Posted Image