Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Help with Essentials Economy (Pay command)


  • Please log in to reply
4 replies to this topic

#1

SomeGarlicbread

Posted 23 July 2011 - 01:47 AM

Basically My users below admin, cannot use the pay command even though the node is clearly there, Looking for a solution to this +rep answers!
Here's my perms
groups:
	Default:
		default: true
		info:
			prefix: '&8[Unregistered]'
			suffix: ''
			build: true
		inheritance:
		permissions:
		- warpplugin.warp

		- localshops.user.*
		- lwc.protect
	Member:
		default: false
		info:
			prefix: '&3[Beta Member]: &f'
			suffix: ''
			build: true
		inheritance:
		- Default
		permissions:
		- warpplugin.warp
		- 'essentials.balance'
		- 'essentials.pay'
		- 'essentials.sell'
		- 'essentials.worth'
		- 'essentials.help'
		- 'essentials.info'
		- 'essentials.list'
		- 'essentials.mail'
		- 'essentials.mail.send'
		- 'essentials.me'
		- 'essentials.motd'
		- 'essentials.msg'
		- 'essentials.rules'
		- 'essentials.spawn'






	Prestige:
		default: false
		info:
			prefix: '&3[Prestige]: &f'
			suffix: ''
			build: true
		inheritance:
		- Member
		permissions:
		- warpplugin.warp

	Supernoob:
		default: false
		info:
			prefix: '&9[SuperNoob]: &f'
			suffix: ''
			build: true
		inheritance:
		- Member
		permissions:
		- warpplugin.warp
	Moderator:
		default: false
		info:
			prefix: '&9[Moderator]: &f'
			suffix: ''
			build: true
		inheritance:
		- Member
		permissions:
		- modplugin.ban
		- modplugin.kick
		- modplugin.unban
		- essentials.togglejail

	Police:
		default: false
		info:
			prefix: '&3[Police Officer]'
			suffix: ''
			build: true
		inheritance:
		- Member
		permissions:
		- modplugin.ban
		- modplugin.kick
		- modplugin.unban
	Admin:
		default: false
		info:
			prefix: '&5[Admin]'
			suffix: ''
			build: true
		inheritance:
		permissions:
		- '*'
	Admins:
		default: false
		info:
			prefix: '&6[God]: &f'
			suffix: ''
			build: true
		inheritance:
		permissions:
		- antiitems.ai
		- '*'

Posted Image

Register or log in to remove.

#2

Ultra695

Posted 23 July 2011 - 01:51 AM

Post this on the bukkit forums, not here.

But my 2 cents. (i'm assuming you already use an essentials-compatible plugin)

I belive you have to have the ' ~~~~~~ ' for the inheritance nodes.

#3

SomeGarlicbread

Posted 23 July 2011 - 01:52 AM

View PostUltra695, on 23 July 2011 - 01:51 AM, said:

Post this on the bukkit forums, not here.

But my 2 cents. (i'm assuming you already use an essentials-compatible plugin)

I belive you have to have the ' ~~~~~~ ' for the inheritance nodes.

I have posted multiple Help topics on the bukkit forums, Nobody answers anything.
Please elaborate on the Inheritance nodes
Posted Image

#4

Gabexav
    Gabexav

    Tree Puncher

  • Members
  • 22 posts
  • Minecraft: Gabexav

Posted 07 March 2014 - 01:23 AM

Not sure if you have solved this yet, But in case not, I'll leave my input. Try adding essentials.pay to there perms. If That dosent work just per - g:essentials.admin under inheritance. This will give them every command for essentials. Hope This Helped!
Posted Image

#5

DeltaCraft07

Posted 11 March 2014 - 07:29 AM

i think you have this thing (') that what make you the permission is disabled
If you dont bealive me.. you can do this /manuaddp [playername] essentials.pay
then ask them if them can use /pay or not ..

Hope this helps

Sorry for my bad English
Posted Image