Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Anti-aliasing In Minecraft for Nvidia users


  • Please log in to reply
54 replies to this topic

#1

burntcustard

Posted 13 July 2011 - 07:33 PM

Introduction
Anti-aliasing (or AA) is a graphical enhancement which smoothes or softens the edges of objects. It can be said that it is used to remove aliasing or "jaggies". Many modern games have built in options to turn anti-aliasing on, improving the image quality at the expense of a slightly lower frame-rate. Minecraft, however, does not.

If you have a high end Nvidia graphics card, and are running Microsoft Windows, (I know it doesn't work on Linux, tell me if I'm wrong MacMen) you can do some magic to get anti-aliasing working in Minecraft, YIPPIE!

Here are some examples of what AA can do
Here's a link to the whole main screenshot. View fullscreen, and zoom in if you have a small screen.

Some of these images have been zoomed in to make it more clear whats going on. The texture pack is an old version of my own (link).

Posted Image
The effect here is obvious. The window frames look much better when smoother.

Posted Image
AA can reduce the appearance of wrong or badly-rendered pixels like the black spots in the torch.

Posted Image
Textures with lots of straight lines like my wood (lol?) are heavily ridden with "jaggies" without AA.

Posted Image
Strange patterns are often produced by aliasing (for example the planks here). Mip-mapping is a variant of AA that fixes this problem, but the full supersampling AA in the technique here also works.

Posted Image
The effect of AA is clearly seen when you have dark coloured blocks against light coloured ones (like the grass and sand in this picture)


How to force anti-aliasing in Minecraft
First off, you need a modern Nvidia graphics card and recent Nvidia drivers and control panel installed for this to work. Try right clicking your desktop, is there an "NVIDIA Control Panel" option? If not, you can't do this, sorry. Another check to do is that your getting at least 100 frames per second when running Minecraft. You can check this by pressing F3 in-game. Full blown 8xAA will most likely half your FPS, but you can always try to optimize if you need to (explained later). If you're playing on a laptop, unless it is a real beast, this is also not for you.

Below here are some recommended desktop graphics cards for using this feature. I have experience with playing with the settings on 4 different Nvidia graphics cards so I know what I'm talking about.
Spoiler:

Step 1
Run Minecraft (you don't even need to log in). Press Ctrl+Shift+Esc (or Ctrl+Alt+Del if you're still using Vista or XP) to run task manager, then open the processes tab. Find "javaw.exe" then right click it and select "Properties"
Posted Image

Step 2
Highlight the location of javaw and Ctrl+C or right click -> copy to copy the text. Don't worry if yours isn't exactly the same as in the example.
Posted Image

Step 3
Open the Nvidia control panel by right clicking on your desktop and selecting it or finding it in your Windows start menu. Click on the "Manage 3D settings option", as is selected in the picture. Press the "Add" button that is circled in the picture.
Posted Image

Step 4
Click up in the location bar and paste (Ctrl+V or right click -> paste) the file location you copied earlier then press enter. Select (double click) javaw in that folder.
Posted Image

Step 5
Change the options that are in bold in the picture to.. what they are in the picture. They will not be bold until you change them.
Posted Image

Step 6
Make sure you "apply", then restart (or start) Minecraft. Oh look, even the yellow messages are anti-aliased and smooth!

Step 7
After you've realised your FPS has taken a big hit (F3 to check); go back into the control panel and change the settings that are set to "8x", to 4x or 2x. You should keep playing until you find the combination you like that balances FPS and visual awesomeness.
I recommend 4xAA and 4xSS for a good balance. Having supersampling the same as or the level below the AA value is recommended, supersampling is the main cause of the FPS drop.
You MUST use 2x, 4x, or 8x Supersampling, NOT multisampling, otherwise you WILL get horrendous visual artifacts

More detailed information for cool people:
Spoiler:


Er.. ending
I hope you enjoyed and managed to follow the guide. If you can't get AA working by using this technique, why not bug Notch and Jeb like angry stalkers until they promise to implement AA into Minecraft fully.

If a lot of people have questions and/or get stuck, I'll make a short Q&A under here.

One more thing, thanks to whichever moderator moved the thread without complaining :)
Posted Image

Register or log in to remove.

#2

DrRedstoner
  • Location: New Zealand
  • Minecraft: DrRedstoner

Posted 13 July 2011 - 07:34 PM

That is awesome1

Nice touch with the gifs.

Posted Image  
Build a noob a fire and he is warm for a day.

Set a noob on fire and you are warm for about five minutes, but it is much more satisfying


#3

xOldGhostx

Posted 13 July 2011 - 07:36 PM

Dangit, i got Nvidia GeForce 9400 GT :S

No AA for meh :(
Posted Image

#4

Dweller_Benthos
  • Minecraft: Dweller_Benthos

Posted 13 July 2011 - 07:36 PM

I have two 460's in SLI, I just might try this    B)
D_B
To tell them how to live is to prevent them living.

#5

Orfiel
    Orfiel

    Coal Miner

  • Members
  • 105 posts
  • Location: Finland
  • Minecraft: Orfiel

Posted 13 July 2011 - 07:37 PM

I want my cubes to have sharp edges!

How can I hurl cube with rounded edges to someone and hurt him in process?

TELL ME HOW! TELL ME NOW!


But for bringing this out:  :iapprove:
Stop taking yourself so seriously.

#6

xOldGhostx

Posted 13 July 2011 - 07:38 PM

Wait.. Where can i adjust the AA?
Posted Image

#7

jonny5300394
  • Location: The Nether
  • Minecraft: jonny5300394

Posted 13 July 2011 - 08:30 PM

Hmm, I kinda like no AA. After all this is a game of super pixelated blocks. AA is meant to make things less pixelated. Kind of a counter-intuitive thing to do isn't it?

Still for discovering this, you get an imaginary diamond that I'm too lazy to make the icon off. :P
Posted Image Clicking on her makes me happy, and keeps her alive.
You wouldn't want to kill a poor little dragon would you? You monster?

#8

burntcustard

Posted 13 July 2011 - 08:59 PM

View Postjonny5300394, on 13 July 2011 - 08:30 PM, said:

After all this is a game of super pixelated blocks. AA is meant to make things less pixelated.

Ah, but are your un-anti-aliased blocks really blocks? They look like they have jagged edges, dont they? Looking at it this way, anti-aliasing can actually make things look "more blocky".

I didn't actually "find this", I saw a thread about it ages ago. It just didn't have a clear method or write up and so disappeared into the abyss that is the Minecraft forum archive.

Also, I added an extra picture to persuade people.
Posted Image

#9

SoulzX
    SoulzX

    Stone Miner

  • Members
  • 91 posts
  • Location: Nether
  • Minecraft: SoulzX

Posted 13 July 2011 - 10:11 PM

I can understand why some people who have lived there entire life with AA, and high quality graphics might like this.

But im sticking to the classic feel of minecraft
Posted Image

#10

Disethas
    Disethas

    Ralphie you are so pretty

  • Retired Staff
  • Curse Premium
  • 2170 posts
  • Location: The next page.
  • Minecraft: Disethas

Posted 13 July 2011 - 10:44 PM

I tried this technique a few months ago and got horrible lines and artifacts. Same for just now.

Posted ImagePosted Image

Posted ImagePosted ImagePosted ImagePosted ImagePosted Image

#11

burntcustard

Posted 13 July 2011 - 10:48 PM

View PostDisethas, on 13 July 2011 - 10:44 PM, said:

got horrible lines and artifacts.

That's what happens when you use anti-aliasing which isn't purely supersampling+transparency. If you want some help, could you post your: operating system, graphics card, and what anti-aliasing settings your using?
Posted Image

#12

Disethas
    Disethas

    Ralphie you are so pretty

  • Retired Staff
  • Curse Premium
  • 2170 posts
  • Location: The next page.
  • Minecraft: Disethas

Posted 13 July 2011 - 11:51 PM

View Postburntcustard, on 13 July 2011 - 10:48 PM, said:

That's what happens when you use anti-aliasing which isn't purely supersampling+transparency. If you want some help, could you post your: operating system, graphics card, and what anti-aliasing settings your using?

Operating system is XP, SP3.
Graphics card is GeForce 9600 GT.
The settings were the same as yours, though the section for transparency differed from yours slightly. While yours was "8x (supersample)", mine was simply "supersampling".
The other difference was my minecraft application using java.exe rather than javaw.exe. Messing around a bit, javaw.exe did nothing for minecraft.

Posted ImagePosted Image

Posted ImagePosted ImagePosted ImagePosted ImagePosted Image

#13

burntcustard

Posted 14 July 2011 - 03:37 PM

View PostDisethas, on 13 July 2011 - 11:51 PM, said:

Operating system is XP, SP3.
Graphics card is GeForce 9600 GT.
The settings were the same as yours, though the section for transparency differed from yours slightly. While yours was "8x (supersample)", mine was simply "supersampling".
The other difference was my minecraft application using java.exe rather than javaw.exe. Messing around a bit, javaw.exe did nothing for minecraft.

I've been researching this as much as I can, from what I can tell your graphics card must not be doing "true" supersampling even though you've got that option selected. If you haven't updated your graphics drivers in a while, I recommend you give that a go but I can't promise anything (link). Sorry I can't be of more use :( It might turn out that only the 200 series and later can do this but I hope that's not the case, even though the 9-series is over 3 years old now.
Posted Image

#14

Spyduck
    Spyduck

    Tree Puncher

  • Members
  • 15 posts

Posted 14 July 2011 - 04:18 PM

Oh man this works wonderfully. It especially makes rendering objects at a distance look smoother and sort of "distance blurred." Thanks, man.

#15

Koogle
    Koogle

    Diamond Miner

  • Members
  • 723 posts

Posted 14 July 2011 - 08:53 PM

I remember trying to use AA ages back and got purple...

Turned out it was just the transparent supersampling that I hadn't set, but good guide for people who don't realize that its not minecraft.exe that needs to be added to the nvidia app control...

One other thing is that you don't need a high supersampling .. 2x is enough and won't hit performance needlessly, I found 4x, 8x to be just overkill for a supersampling settings as you won't see it as much as you would the difference between AA settings.
Server: mc.kraftzone.net Website:  kraftzone.net
Posted Image
Official Trailer: http://www.youtube.c...4vN366_94Y&hd=1

#16

burntcustard

Posted 19 July 2011 - 12:17 AM

View PostKoogle, on 14 July 2011 - 08:53 PM, said:

I remember trying to use AA ages back and got purple...

Turned out it was just the transparent supersampling that I hadn't set, but good guide for people who don't realize that its not minecraft.exe that needs to be added to the nvidia app control...

One other thing is that you don't need a high supersampling .. 2x is enough and won't hit performance needlessly, I found 4x, 8x to be just overkill for a supersampling settings as you won't see it as much as you would the difference between AA settings.

Glad it worked for you, and thanks :)

I fiddled around with supersampling settings again and although I definitely do notice a difference between them, it's not quite as significant visual improvement compared to the main AA setting as I first thought. I've altered my top post slightly due to this. Thanks.
Posted Image

#17

ANARKY
    ANARKY

    Obsidian Miner

  • Members
  • 1234 posts

Posted 19 August 2011 - 03:18 AM

Thanks for this. I'm running dual GTX 570's I know lol overkill and with one card I have it v-synced to 120hz and MC won't dip down with all of this stuff turned on like 8x ss and 16x Q CSAA but I set it to 32X Q CSAA SLI that way the fan on my gpu doesn't kick in so hard. Only can hear it if I run it on 16 X Q on one card but if I split that load onto the second card the whole system stays nice and quite.

#18

Daedalus1882

Posted 16 September 2011 - 01:53 PM

I've just read the opening post with interest as I have just bought a new computer with a GTS450 card.

Can I ask what values for anti-aliasing and supersampling would be recommended for my graphics card?
Check out my Minecraft YouTube Channel: http://www.youtube.com/user/CrouchyLP

#19

Daedalus1882

Posted 16 September 2011 - 01:54 PM

I should also add that, at present, I have a real problem with rendering objects at a distance. They always look awful, a bit like the example with the wooden planks in the opening post.

:(
Check out my Minecraft YouTube Channel: http://www.youtube.com/user/CrouchyLP

#20

burntcustard

Posted 18 September 2011 - 01:09 AM

View PostDaedalus1882, on 16 September 2011 - 01:54 PM, said:

I should also add that, at present, I have a real problem with rendering objects at a distance. They always look awful, a bit like the example with the wooden planks in the opening post.

Thanks for super necro-bumping this thread, I was hoping for more interest in it :) Could you give any more information about the awfulness your experiencing? Maybe a screenshot? Are you sure the anti-aliasing settings your changing are doing anything at all? (Hope that last one did't sound too silly.)

I'd recommend 4xAA along with 4xSS (Transparency), although you should try 2xSS as well, and if you don't notice a difference, use 2xAA.
Posted Image